Jean-Daniel Cryans has posted comments on this change.

Change subject: Add KuduTable.getFormattedRangePartitions method
......................................................................


Patch Set 2:

(8 comments)

http://gerrit.cloudera.org:8080/#/c/4934/2/java/kudu-client/src/main/java/org/apache/kudu/client/KeyEncoder.java
File java/kudu-client/src/main/java/org/apache/kudu/client/KeyEncoder.java:

PS2, Line 268: public
Does this need to be public?


http://gerrit.cloudera.org:8080/#/c/4934/2/java/kudu-client/src/main/java/org/apache/kudu/client/KuduTable.java
File java/kudu-client/src/main/java/org/apache/kudu/client/KuduTable.java:

PS2, Line 208: the tables
nit: this table's


Line 223:       if (!Iterators.all(partition.getHashBuckets().iterator(), 
Predicates.equalTo(0))) continue;
nit: I personally prefer if statements to not be on a single line, especially 
if sandwiched like this, for better readability.


http://gerrit.cloudera.org:8080/#/c/4934/2/java/kudu-client/src/main/java/org/apache/kudu/client/PartialRow.java
File java/kudu-client/src/main/java/org/apache/kudu/client/PartialRow.java:

PS2, Line 579: appendCellValueDebugString
nit: might as well put that in the enum itself.


PS2, Line 785: Returns {@code true} if the cell values for the given column are 
equal in the two rows.
nit: that text should be in @return. Write something here that's like "Checks 
if the specified cell is equal in both rows" or something similar.


PS2, Line 802: switch (type) {
Guess you could move that into the enum as well.


PS2, Line 839: Returns
Same comment as above.


Line 858:     switch (type) {
Same comment as above.


-- 
To view, visit http://gerrit.cloudera.org:8080/4934
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Ia9b263d2444314d46533191918833840e75b7ba7
Gerrit-PatchSet: 2
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Dan Burkert <danburk...@apache.org>
Gerrit-Reviewer: Adar Dembo <a...@cloudera.com>
Gerrit-Reviewer: Dan Burkert <danburk...@apache.org>
Gerrit-Reviewer: Dimitris Tsirogiannis <dtsirogian...@cloudera.com>
Gerrit-Reviewer: Jean-Daniel Cryans <jdcry...@apache.org>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Matthew Jacobs <m...@cloudera.com>
Gerrit-HasComments: Yes

Reply via email to