-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/58955/#review173814
-----------------------------------------------------------



LGTM. Minor points below.


src/tests/api_tests.cpp
Lines 741 (patched)
<https://reviews.apache.org/r/58955/#comment246854>

    s/launch nested container sessions/set the logging level/



src/tests/api_tests.cpp
Lines 742-744 (patched)
<https://reviews.apache.org/r/58955/#comment246855>

    Could fit on one line?



src/tests/api_tests.cpp
Lines 757-774 (original), 768-803 (patched)
<https://reviews.apache.org/r/58955/#comment246895>

    What do you think about placing each of these requests into an enclosing 
scope? It's a pattern we follow elsewhere, and I think it makes the code a bit 
more readable.
    
    i.e.
    ```
    {
      http::Headers headers = stuff;
      Future<Nothing> response = http::post( ... );
      AWAIT_READY(response);
    }
    
    {
      http::Headers headers = stuff;
      Future<Nothing> response = http::post( ... );
      AWAIT_READY(response);
      ASSERT_EQ( ... );
    }
    ```


- Greg Mann


On May 3, 2017, 9:26 a.m., Alexander Rojas wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/58955/
> -----------------------------------------------------------
> 
> (Updated May 3, 2017, 9:26 a.m.)
> 
> 
> Review request for mesos, Adam B and Greg Mann.
> 
> 
> Bugs: MESOS-7414
>     https://issues.apache.org/jira/browse/MESOS-7414
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Enables authorization in the v1 API call `SET_LOGGING_LEVEL` following
> the existing implementation for the agent call with the same name.
> Likewise it reuses the authorizer action `SET_LOG_LEVEL`.
> 
> 
> Diffs
> -----
> 
>   src/master/http.cpp 5aae52870451d883ef1ea1fda5a27764d7f318e8 
>   src/tests/api_tests.cpp faf3242f9c86d866c4bb5e457fcfe47c1063cc09 
> 
> 
> Diff: https://reviews.apache.org/r/58955/diff/1/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Alexander Rojas
> 
>

Reply via email to