> On March 20, 2019, 3:13 p.m., Benjamin Bannier wrote:
> > src/csi/v0_volume_manager.cpp
> > Lines 440 (patched)
> > <https://reviews.apache.org/r/70216/diff/2/?file=2132475#file2132475line440>
> >
> >     Should we have used an `Option` for this member?

I'm relying on the fact that the default capabilities are all off, and only 
turned on after recovery finishes, to avoid code like
```
if (pluginCapabilities.isSome() && pluginCapabilities->controllerService) {
  ...
}
```
That said, if this is more readable, I'm willing to change this and other 
capabilities variables to `Option`. WDYT?


> On March 20, 2019, 3:13 p.m., Benjamin Bannier wrote:
> > src/csi/v0_volume_manager.cpp
> > Lines 507 (patched)
> > <https://reviews.apache.org/r/70216/diff/2/?file=2132475#file2132475line507>
> >
> >     `Option`?

It's already an `Option`. Dropping.


- Chun-Hung


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/70216/#review213840
-----------------------------------------------------------


On March 15, 2019, 5:17 a.m., Chun-Hung Hsiao wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/70216/
> -----------------------------------------------------------
> 
> (Updated March 15, 2019, 5:17 a.m.)
> 
> 
> Review request for mesos, Benjamin Bannier, Jie Yu, and Jan Schlicht.
> 
> 
> Bugs: MESOS-9622
>     https://issues.apache.org/jira/browse/MESOS-9622
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> The recovery logic is similar to SLRP's `recoverVolumes` method. But
> `VolumeManager` no longer recovers all volumes to their steady states
> since this is not necessary. Together with the new `publishVolume`
> design, the recovery logic is now simpler.
> 
> 
> Diffs
> -----
> 
>   src/csi/v0_volume_manager.cpp PRE-CREATION 
>   src/csi/v0_volume_manager_process.hpp PRE-CREATION 
> 
> 
> Diff: https://reviews.apache.org/r/70216/diff/2/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Chun-Hung Hsiao
> 
>

Reply via email to