> The squiggly-heredoc operator can't be applied to an already existing string. 
> That is the only case were you still need strip_heredoc, so unless we add a 
> way to strip heredocs from an already existent string object to Ruby we can't 
> deprecated it.

How about we rename it to something like `strip_indent`?

As you should no longer be using it on a heredoc, the current name isn’t a 
great fit.

And then we can deprecate the old name, with a suggestion to use <<~ if 
possible, or strip_indent if not.



-- 
You received this message because you are subscribed to the Google Groups "Ruby 
on Rails: Core" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to rubyonrails-core+unsubscr...@googlegroups.com.
To post to this group, send email to rubyonrails-core@googlegroups.com.
Visit this group at https://groups.google.com/group/rubyonrails-core.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/rubyonrails-core/5B924D0D-9CD2-41BD-8485-5A07ED807022%40trebex.net.
For more options, visit https://groups.google.com/d/optout.

Reply via email to