On Fri, Dec 10, 2010 at 2:45 AM, daveloeffler <dave.loeff...@gmail.com> wrote:
>
>
> On Dec 10, 9:03 am, John Cremona <john.crem...@gmail.com> wrote:
>> On Fri, Dec 10, 2010 at 12:03 AM, Rob Beezer <goo...@beezer.cotse.net> wrote:
>> > Thanks, everybody, for the illuminating discussion.
>>
>> > Is there any objection to deprecating the current .adjoint() function
>> > (which returns a matrix of cofactors) and renaming it as the
>> > "adjugate"?  With all the usual procedures and warnings for the
>> > deprecation.  That would begin the process to free up "adjoint" for
>> > something else (ideally the conjugate-transpose).
>>
>> +1
>
> +1 from me as well.

+1

In addition to whatever gets done, it would be a good idea to add a
method called "conjugate_transpose()".

sage: A = random_matrix(CDF,2); A
[ 0.612527807778 + 0.44135771466*I 0.654609238114 + 0.769997550005*I]
[0.877761009274 - 0.771264650112*I 0.874089814928 + 0.123225733001*I]
sage: A.conjugate_transpose()
[ 0.612527807778 - 0.44135771466*I 0.877761009274 + 0.771264650112*I]
[0.654609238114 - 0.769997550005*I 0.874089814928 - 0.123225733001*I]

It's totally crystal clear what it means.   Adjoint is a little weird,
because to me it means "adjoint with respect to an inner product".
Since vector spaces in Sage can have arbitrary inner products, one
could at least imagine having

sage: A.adjoint()   # default inner product

sage: phi.adjoint()   # where phi is linear transformation of vector spaces

sage: A.adjoint(inner_product)    # where inner_product is an
as-yet-to-be-defined object

---

> 3*(A.T*B.T)*(2*(A.T-I))

I can't see the harm in adding properties in a very, very small number
of special cases.   Just please don't go crazy and have dozens of
them, since they are hard to document and can be confusing to read.

> In numpy, the conjugate transpose is A.H, the transpose is A.T, and the
> inverse is A.I.  I'd love if we adopted those shortcuts (as properties

A.H seems arbitrary?  Why "H"?    Consistency with numpy is a good
argument for supporting this though.

 -- William

William Stein
Professor of Mathematics
University of Washington
http://wstein.org

-- 
To post to this group, send an email to sage-devel@googlegroups.com
To unsubscribe from this group, send an email to 
sage-devel+unsubscr...@googlegroups.com
For more options, visit this group at http://groups.google.com/group/sage-devel
URL: http://www.sagemath.org

Reply via email to