VoIP+QoS+xDSL+H.323Gatekeeper [7:57104]

2002-11-08 Thread Mark S
Well, this should give you enough to chew on since voice is becoming a hot
topic.  I am trying to configure VoIP with QoS.  Why over IP and not over
ATM, you say?  I have to controll the call with a H.323 Gatekeeper, and that
is IP.

My problem appears to be that the call setup (or maybe signalling?) appears
to be delayed.  The test results are as follows:

If the WAN link is saturated with data packets PRIOR to establishing the
voice call, the first 10 to 15 (approximately) seconds of the call are
lost.  After the call is established, voice is rock solid and no voice
packets are delayed or lost.

If the voice call is established PRIOR to saturating the WAN link with data
packets, the voice call is rock solid and no voice packets are delayed or
lost.

Thoughts or configs would be appreciated.

--Mark


version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
logging buffered 4096 debugging
!
memory-size iomem 25
ip subnet-zero
!
no ip domain lookup
!
ip cef
!
voice call carrier capacity active
voice rtp send-recv
!
no voice hpi capture buffer
no voice hpi capture destination 
!
vc-class atm vip
  vbr-rt 256 256 10
  precedence 5 
  no bump traffic
  no protect vc
  no protect group
!
vc-class atm normal
  vbr-nrt 192 192
  precedence other
  no protect vc
  no protect group
!
interface ATM0/0
 ip address 1.1.1.254 255.255.255.0
 ip nat outside
 no atm ilmi-keepalive
 bundle-enable
 bundle qosmap
  protocol ip 1.1.1.1
  encapsulation aal5snap
  pvc-bundle data 0/37 
   class-vc normal
  pvc-bundle voice 0/36 
   class-vc vip
 !
 dsl equipment-type CPE
 dsl operating-mode GSHDSL symmetric annex A
 dsl linerate AUTO
 h323-gateway voip interface
 h323-gateway voip id Gatekeeper ipaddr x.x.x.x 1718
 h323-gateway voip h323-id Gateway
 ip rsvp bandwidth 64 64
 ip rsvp resource-provider wfq pvc
!
interface FastEthernet0/0
 ip address 10.200.100.1 255.255.255.0
 ip nat inside
 speed auto
!
ip nat inside source list 1 interface ATM0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 1.1.1.1
no ip http server
ip pim bidir-enable
!
access-list 1 permit 10.200.100.0 0.0.0.255
!
call rsvp-sync
!
voice-port 2/0
 station-id name StaID
 station-id number 111222
 caller-id enable
!
voice-port 2/1
 station-id name StaID
 station-id number 111222
 caller-id enable
!
dial-peer cor custom
!
dial-peer voice 1 voip
 destination-pattern T
 session target ras
!
gateway 
!
line con 0
line aux 0
line vty 0 4
 login
!
no scheduler allocate
end


Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=57104&t=57104
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



RE: how to configure WIC Fractional T1 with subint [7:57115]

2002-11-08 Thread Mark S
What you have is a good start.  The following is a sample of something I did
years ago and it works with NAT.

interface Serial0/0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 no ip mroute-cache
!
interface Serial0/0.102 multipoint
 ip address 192.168.1.21 255.255.255.252
 no ip directed-broadcast
 ip nat inside
 frame-relay interface-dlci 102
!
interface Serial0/0.103 multipoint
 ip address 192.168.1.5 255.255.255.252
 no ip directed-broadcast
 ip nat inside
 frame-relay interface-dlci 103

etc., etc., etc

--Mark


Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=57117&t=57115
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



VoIP+QoS+xDSL+H.323Gatekeeper [7:57121]

2002-11-08 Thread Mark S
For those of you trying to email me from the link in the message, here is
the updated post.  Sorry about the duplicate.

***
Well, this should give you enough to chew on since voice is becoming a hot
topic. I am trying to configure VoIP with QoS. Why over IP and not over ATM,
you say? I have to controll the call with a H.323 Gatekeeper, and that is IP.

My problem appears to be that the call setup (or maybe signalling?) appears
to be delayed. The test results are as follows:

If the WAN link is saturated with data packets PRIOR to establishing the
voice call, the first 10 to 15 (approximately) seconds of the call are lost.
After the call is established, voice is rock solid and no voice packets are
delayed or lost.

If the voice call is established PRIOR to saturating the WAN link with data
packets, the voice call is rock solid and no voice packets are delayed or
lost.

Thoughts or configs would be appreciated.

--Mark


version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
logging buffered 4096 debugging
!
memory-size iomem 25
ip subnet-zero
!
no ip domain lookup
!
ip cef
!
voice call carrier capacity active
voice rtp send-recv
!
no voice hpi capture buffer
no voice hpi capture destination
!
vc-class atm vip
vbr-rt 256 256 10
precedence 5
no bump traffic
no protect vc
no protect group
!
vc-class atm normal
vbr-nrt 192 192
precedence other
no protect vc
no protect group
!
interface ATM0/0
ip address 1.1.1.254 255.255.255.0
ip nat outside
no atm ilmi-keepalive
bundle-enable
bundle qosmap
protocol ip 1.1.1.1
encapsulation aal5snap
pvc-bundle data 0/37
class-vc normal
pvc-bundle voice 0/36
class-vc vip
!
dsl equipment-type CPE
dsl operating-mode GSHDSL symmetric annex A
dsl linerate AUTO
h323-gateway voip interface
h323-gateway voip id Gatekeeper ipaddr x.x.x.x 1718
h323-gateway voip h323-id Gateway
ip rsvp bandwidth 64 64
ip rsvp resource-provider wfq pvc
!
interface FastEthernet0/0
ip address 10.200.100.1 255.255.255.0
ip nat inside
speed auto
!
ip nat inside source list 1 interface ATM0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 1.1.1.1
no ip http server
ip pim bidir-enable
!
access-list 1 permit 10.200.100.0 0.0.0.255
!
call rsvp-sync
!
voice-port 2/0
station-id name StaID
station-id number 111222
caller-id enable
!
voice-port 2/1
station-id name StaID
station-id number 111222
caller-id enable
!
dial-peer cor custom
!
dial-peer voice 1 voip
destination-pattern T
session target ras
!
gateway
!
line con 0
line aux 0
line vty 0 4
login
!
no scheduler allocate
end


Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=57121&t=57121
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



RE: VoIP+QoS+xDSL+H.323Gatekeeper [7:57121]

2002-11-08 Thread Mark S
That is correct--I hear silence when the data pvc is saturated.  However,
further tests performed just recently indicate that the amount of data
saturating the link corresponds to the amount of lost voice packets.

That is why I thought this was a QoS issue.  It almost appears that some of
the call control packets are going down the data pvc instead of the voice
pvc.  But I don't want to comit to such a statement for fear of biasing
other opinions in the newsgroup, as others may have the "real" cause to the
problem already figured out.

I did explore an access-list config to match on port 1720 and there were
some hits, but again are there other voice payload and/or voice signaling
packets traversing the data pvc?  I don't know.

--Mark


Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=57133&t=57121
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



Re: VoIP+QoS+xDSL+H.323Gatekeeper [7:57121]

2002-11-08 Thread Mark S
Yeah, sorry about that.  I added the following:

 ip qos dscp cs5 media
 ip qos dscp cs5 signaling

to my dial-peer after the original post.  Unfortunately, same result.


Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=57141&t=57121
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



RE: VoIP+QoS+xDSL+H.323Gatekeeper [7:57121]

2002-11-08 Thread Mark S
Hamid,
Well there are two different ways that you can look at this.  From the telco
side one may conclude that the entire duration of the call is the actual
cost of the call, including call setup.  From the customer side, the
majority of customers would argue that call setup should not be billed, as
that is not part of the actual voice conversation.  However, ultimately, all
costs are eventually passed to the consumer.

Unfortunately, this doesn't directly answer your question but does explain
the two theories.  I don't get into call accounting too much.

--Mark



Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=57144&t=57121
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



Re: VoIP+QoS+xDSL+H.323Gatekeeper [7:57121]

2002-11-13 Thread Mark S
To paint you a better picture here is the scenerio...I am calling a number
that I know will respond initially with a voice annoincement (ie. Voice mail
system).  When data is not flooding the wan link the call is fine.  I get
the entire announcement beginning with "Thank you for calling xyz company,
the nations leading provider of..."

When data IS flooding the wan link, the call eventually goes through but I
hear the recording  starting in the middle of the stream... "leading
provider of..."

In the second case, why wouldn't I hear the entire message, just delayed
until the call set-up packets traversed the network?


""Mark S""  wrote in message
news:200211081804.SAA07463@;groupstudy.com...
For those of you trying to email me from the link in the message, here is
the updated post.  Sorry about the duplicate.

***
Well, this should give you enough to chew on since voice is becoming a hot
topic. I am trying to configure VoIP with QoS. Why over IP and not over ATM,
you say? I have to controll the call with a H.323 Gatekeeper, and that is
IP.

My problem appears to be that the call setup (or maybe signalling?) appears
to be delayed. The test results are as follows:

If the WAN link is saturated with data packets PRIOR to establishing the
voice call, the first 10 to 15 (approximately) seconds of the call are lost.
After the call is established, voice is rock solid and no voice packets are
delayed or lost.

If the voice call is established PRIOR to saturating the WAN link with data
packets, the voice call is rock solid and no voice packets are delayed or
lost.

Thoughts or configs would be appreciated.

--Mark


version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
logging buffered 4096 debugging
!
memory-size iomem 25
ip subnet-zero
!
no ip domain lookup
!
ip cef
!
voice call carrier capacity active
voice rtp send-recv
!
no voice hpi capture buffer
no voice hpi capture destination
!
vc-class atm vip
vbr-rt 256 256 10
precedence 5
no bump traffic
no protect vc
no protect group
!
vc-class atm normal
vbr-nrt 192 192
precedence other
no protect vc
no protect group
!
interface ATM0/0
ip address 1.1.1.254 255.255.255.0
ip nat outside
no atm ilmi-keepalive
bundle-enable
bundle qosmap
protocol ip 1.1.1.1
encapsulation aal5snap
pvc-bundle data 0/37
class-vc normal
pvc-bundle voice 0/36
class-vc vip
!
dsl equipment-type CPE
dsl operating-mode GSHDSL symmetric annex A
dsl linerate AUTO
h323-gateway voip interface
h323-gateway voip id Gatekeeper ipaddr x.x.x.x 1718
h323-gateway voip h323-id Gateway
ip rsvp bandwidth 64 64
ip rsvp resource-provider wfq pvc
!
interface FastEthernet0/0
ip address 10.200.100.1 255.255.255.0
ip nat inside
speed auto
!
ip nat inside source list 1 interface ATM0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 1.1.1.1
no ip http server
ip pim bidir-enable
!
access-list 1 permit 10.200.100.0 0.0.0.255
!
call rsvp-sync
!
voice-port 2/0
station-id name StaID
station-id number 111222
caller-id enable
!
voice-port 2/1
station-id name StaID
station-id number 111222
caller-id enable
!
dial-peer cor custom
!
dial-peer voice 1 voip
destination-pattern T
session target ras
!
gateway
!
line con 0
line aux 0
line vty 0 4
login
!
no scheduler allocate
end




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=57351&t=57121
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



Packets received on wrong pvc [7:57509]

2002-11-15 Thread Mark S
I turned on some debugging and I am seeing this message in my log files. 
Does anyone know the cause or how to correct?

IP precedence 0 received on voice but should have been on data

--Mark


Snips of the router config:

class-map match-all voip
  match access-group 100

policy-map llq
  class voip
priority 80
   set ip dscp cs5
  class class-default
   fair-queue
   set ip dscp default

vc-class atm vip
  vbr-rt 256 256 20
  precedence 5-7 
  no bump traffic
  no protect vc
  no protect group

vc-class atm normal
  vbr-nrt 192 192
  precedence 0-4 
  no protect vc
  no protect group
end

interface ATM0/0
 bandwidth 256
 ip address 1.1.1.254 255.255.255.0
 no atm ilmi-keepalive
 bundle-enable
 bundle qosmap
  protocol ip 1.1.1.1
  encapsulation aal5snap
  pvc-bundle voice 0/36 
   class-vc vip
   service-policy output llq
  pvc-bundle data 0/37 
   class-vc normal
   service-policy output llq
 !
 dsl equipment-type CPE
 dsl operating-mode GSHDSL symmetric annex A
 dsl linerate AUTO

access-list 100 permit ip any any dscp cs5
access-list 100 permit ip any any precedence critical
access-list 100 permit tcp any any eq 1720
access-list 100 permit udp any any range 16383 16384

dial-peer voice 1 voip
 destination-pattern T
 session target ras
 ip qos dscp cs5 media
 ip qos dscp cs5 signaling

Router#sh debug
Generic ATM:
  ATM VC Bundle Events debugging is on
  ATM VC Bundle Errors debugging is on
  ATM VC Bundle INARP Events debugging is on
  ATM VC Bundle Adjacency Events debugging is on


Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=57509&t=57509
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



RE: Port Address Translation [7:57485]

2002-11-15 Thread Mark S
HP uses ports starting at 9100 for their JetDirect product.  If you are
trying to translate through a NAT router, try the following:

ip nat inside source static tcp {inside IP} 9100 {outside IP} 9100 extendable

--Mark


Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=57516&t=57485
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



Re: full duplex or half duplex, how can you tell [7:57431]

2002-11-15 Thread Mark S
Wow!  Two ethernets!  Bonus!  I once worked on a 2501 and I only had one
ethernet...AND it was AUI!

--Mark


Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=57519&t=57431
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]