Re: IGRP Subnet mask issues [7:31349]

2002-01-09 Thread Engelhard M. Labiro

Hi Aamer,

This is another solution without static routes. The idea is still the same,
break 10.0.0.0/24 to smaller /30 networks to fit with the interface
of IGRP domain (10.3.255.8/30), using "summary-address" at OSPF.

r2#sh run
router ospf 1
 summary-address 10.0.0.0 255.255.255.252
 summary-address 10.0.1.0 255.255.255.252
 redistribute igrp 1 metric 10 subnets
 network 10.0.0.0 0.0.0.31 area 0
 network 10.0.1.0 0.0.0.255 area 1
 neighbor 10.0.0.6 priority 1
 neighbor 10.0.0.5 priority 1
!
router igrp 1
 redistribute ospf 1 route-map o2i
 passive-interface Serial0.24
 passive-interface Serial0.100
 network 10.0.0.0
 default-metric 1 100 255 1 1500
!
ip classless
no ip http server
!
access-list 101 permit ip host 10.0.0.0 host 255.255.255.252
access-list 101 permit ip host 10.0.1.0 host 255.255.255.252
route-map o2i permit 10
 match ip address 101
!

At r1 which receives the /30 networks

05:42:41: IGRP: broadcasting request on Serial0/0
05:42:41: IGRP: received update from 10.3.255.10 on Serial0/0
05:42:41:   subnet 10.0.0.0, metric 8576 (neighbor 1100)
05:42:41: RT: add 10.0.0.0/30 via 10.3.255.10, igrp metric [100/8576]
05:42:41:   subnet 10.0.1.0, metric 8576 (neighbor 1100)
05:42:41: RT: add 10.0.1.0/30 via 10.3.255.10, igrp metric [100/8576]
05:42:41: IGRP: Update contains 2 interior, 0 system, and 0 exterior routes.
05:42:41: IGRP: Total routes in update: 2
05:42:41: IGRP: edition is now 8

> want to do it without static routes.thats a restriction




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=31380&t=31349
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



Re: IGRP Subnet mask issues [7:31349]

2002-01-09 Thread Aamer Kaleem

want to do it without static routes.thats a restriction


Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=31366&t=31349
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



Re: IGRP Subnet mask issues [7:31349]

2002-01-09 Thread Engelhard M. Labiro

Without changing the interface subnetmask to /24,
break 10.0.0.0/24 to several /30 networks (10.0.0.0/30 to
10.0.0.252/30) , make a static route  for each /30 network to
the interface connecting 10.0.0.0/24, and redistribute those
static routes to IGRP domain.
This kind of solution is defined at CCO,
http://www.cisco.com/warp/public/105/52.html
I doubt that this solution will be allowed in the Lab, because
the requirement of static routes.

PS:  I think "ip subnet-zero" has to enable to allow
10.0.0.0 network.

> considering how often and to what depth this issue has been and continues
to
> be discussed here and elsewhere, it shouldn't be too hard to discover the
> answer.
>
> try changing your network on the R1-R2 link to a /24 and see what happens.
> then report back your findings along with your own speculation.
>
> HTH
>
> chuck
>
>
> ""Aamer Kaleem""  wrote in message
> [EMAIL PROTECTED]">news:[EMAIL PROTECTED]...
> > I have two routers. One of them is running IGRP,BGP and OSPF and other
is
> > running IGRP only.
> > The network between two IGRP routers is 30 bit mask.  Here is the
diagram:
> >
> > IGRP/BGP/OSPF IGRP
> >
> > R1-R2
> > 10.3.255.10/3010.3.255.9/30
> >
> > R1 has some 24 bit 10-netorks directly connected to it as well. I have
> > following IGRP configuration
> >
> > R1:
> > router igrp 1
> > redistribute ospf 1
> > redistribute bgp 65430
> > network 10.0.0.0
> > default-metric 10 100 255 255 1500
> >
> > R2:
> > router igrp 1
> > network 10.0.0.0
> >
> >
> > 10.0.0.0/24 networks won't show up in the routing table of R2.
> > Could someone explain why it is happening what is the fix.
> >
> > Thank you,
> > Aamer




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=31365&t=31349
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



Re: IGRP Subnet mask issues [7:31349]

2002-01-08 Thread Aamer Kaleem

Chuck,

Changing the IGRP interfaces to /24 bit solves the problem. IGRP matches the
incoming routes with its own interface Subnet mask and rejects the one which
does not match.

So, how to fix it without changing the IGRP interfaces mask.

Thanx,

Aamer


Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=31357&t=31349
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



Re: IGRP Subnet mask issues [7:31349]

2002-01-08 Thread Murtaza Syed

In general, you will not want to redistribute most BGP routes into your IGP.
A common design is to redistribute one or two routes and to make them
exterior routes
in IGRP, or have your BGP speaker generate a default route for your
autonomous system. When redistributing from BGP into IGP, only the routes
learned using
EBGP get redistributed. EBGP default administrative distance is 20 vs IGRP's
100.

Make sure you meant IGRP and not EIGRP, if it is EIGRP then run "no
auto-summary" to see the subnets.

Regards,

Murtaza

P.S.: some more info from cisco site
http://www.cisco.com/warp/public/105/21.html






- Original Message -
From: "Aamer Kaleem" 
To: 
Sent: Tuesday, January 08, 2002 8:10 PM
Subject: IGRP Subnet mask issues [7:31349]


> I have two routers. One of them is running IGRP,BGP and OSPF and other is
> running IGRP only.
> The network between two IGRP routers is 30 bit mask.  Here is the diagram:
>
> IGRP/BGP/OSPF IGRP
>
> R1-R2
> 10.3.255.10/3010.3.255.9/30
>
> R1 has some 24 bit 10-netorks directly connected to it as well. I have
> following IGRP configuration
>
> R1:
> router igrp 1
> redistribute ospf 1
> redistribute bgp 65430
> network 10.0.0.0
> default-metric 10 100 255 255 1500
>
> R2:
> router igrp 1
> network 10.0.0.0
>
>
> 10.0.0.0/24 networks won't show up in the routing table of R2.
> Could someone explain why it is happening what is the fix.
>
> Thank you,
> Aamer




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=31354&t=31349
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



Re: IGRP Subnet mask issues [7:31349]

2002-01-08 Thread Chuck Larrieu

considering how often and to what depth this issue has been and continues to
be discussed here and elsewhere, it shouldn't be too hard to discover the
answer.

try changing your network on the R1-R2 link to a /24 and see what happens.
then report back your findings along with your own speculation.

HTH

chuck


""Aamer Kaleem""  wrote in message
[EMAIL PROTECTED]">news:[EMAIL PROTECTED]...
> I have two routers. One of them is running IGRP,BGP and OSPF and other is
> running IGRP only.
> The network between two IGRP routers is 30 bit mask.  Here is the diagram:
>
> IGRP/BGP/OSPF IGRP
>
> R1-R2
> 10.3.255.10/3010.3.255.9/30
>
> R1 has some 24 bit 10-netorks directly connected to it as well. I have
> following IGRP configuration
>
> R1:
> router igrp 1
> redistribute ospf 1
> redistribute bgp 65430
> network 10.0.0.0
> default-metric 10 100 255 255 1500
>
> R2:
> router igrp 1
> network 10.0.0.0
>
>
> 10.0.0.0/24 networks won't show up in the routing table of R2.
> Could someone explain why it is happening what is the fix.
>
> Thank you,
> Aamer




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=31352&t=31349
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



IGRP Subnet mask issues [7:31349]

2002-01-08 Thread Aamer Kaleem

I have two routers. One of them is running IGRP,BGP and OSPF and other is
running IGRP only.
The network between two IGRP routers is 30 bit mask.  Here is the diagram:

IGRP/BGP/OSPF IGRP

R1-R2
10.3.255.10/3010.3.255.9/30

R1 has some 24 bit 10-netorks directly connected to it as well. I have
following IGRP configuration

R1:
router igrp 1
redistribute ospf 1 
redistribute bgp 65430
network 10.0.0.0
default-metric 10 100 255 255 1500

R2:
router igrp 1
network 10.0.0.0


10.0.0.0/24 networks won't show up in the routing table of R2. 
Could someone explain why it is happening what is the fix.

Thank you,
Aamer


Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=31349&t=31349
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]