PPP over Frame-Relay

2001-01-18 Thread AABAN34


   Hi

 I am trying to make this PPP over Frame-Relay with two Cisco 2501 
running 12.0.5(T) see below. For some reason this does not work? can someone 
please help me to get this to work, I have ran the debug commands and it 
seems like its working but I can not ping each other for some reason.

I have both my config's below...





Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname DCE
!
enable password brian
!
username brian password 0 brian
!
!
!
!
ip subnet-zero
!
virtual-profile virtual-template 1
frame-relay switching
cns event-service server
!
!
!
interface Ethernet0
 ip address 64.32.168.37 255.255.255.224
 no ip directed-broadcast
!
interface Virtual-Template1
 ip address 10.1.1.1 255.255.255.0
 no ip directed-broadcast
 no peer default ip address
 ppp authentication chap pap
!
interface Serial0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 clockrate 64000
 frame-relay lmi-type ansi
 frame-relay intf-type dce
!
interface Serial0.1 point-to-point
 no ip directed-broadcast
 frame-relay interface-dlci 32 ppp Virtual-Template1
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface TokenRing0
 no ip address
 no ip directed-broadcast
 shutdown
!
no ip classless
ip route 0.0.0.0 0.0.0.0 Virtual-Template1
no ip http server
!
access-list 1 permit 10.1.1.1
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password pp
 login
!
end

DCE#sho ver
Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-JS-L), Version 12.0(7)T,  RELEASE SOFTWARE (fc2)
Copyright (c) 1986-1999 by cisco Systems, Inc.
Compiled Mon 06-Dec-99 17:10 by phanguye
Image text-base: 0x0306C4E0, data-base: 0x1000

ROM: System Bootstrap, Version 5.2(8a), RELEASE SOFTWARE
BOOTFLASH: 3000 Bootstrap Software (IGS-RXBOOT), Version 10.2(8a), RELEASE 
SOFTW
ARE (fc1)

DCE uptime is 5 minutes
System returned to ROM by power-on
System image file is "flash:c2500-120T.bin"

cisco 2500 (68030) processor (revision E) with 8192K/2048K bytes of memory.
Processor board ID 03897480, with hardware revision 
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
TN3270 Emulation software.
1 Ethernet/IEEE 802.3 interface(s)
1 Token Ring/IEEE 802.5 interface(s)
2 Serial network interface(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read ONLY)

Configuration register is 0x2102

DCE#






DTE#sho run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname DTE
!
enable password pp
!
username brian password 0 brian
!
!
!
!
ip subnet-zero
!
virtual-profile virtual-template 1
cns event-service server
!
!
!
interface Ethernet0
 ip address 64.32.168.37 255.255.255.224
 no ip directed-broadcast
!
interface Virtual-Template1
 ip address 10.1.1.2 255.255.255.0
 no ip directed-broadcast
 ppp authentication chap pap
!
interface Serial0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
 no ip directed-broadcast
 frame-relay interface-dlci 32 ppp Virtual-Template1
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface TokenRing0
 no ip address
 no ip directed-broadcast
 shutdown
!
no ip classless
ip route 0.0.0.0 0.0.0.0 Virtual-Template1
no ip http server
!
access-list 1 permit 10.1.1.2
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password pp
 login
!
end

DTE#ping 10.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
..
Success rate is 0 percent (0/2)
DTE#sho ip int brief
Interface  IP-Address  OK? Method Status
Prot
ocol
Ethernet0  64.32.168.37YES NVRAM  up
down

Serial0unassigned  YES NVRAM  upup

Serial0.1  unassigned  YES unset  upup

Serial1unassigned  YES NVRAM  administratively down 
down

TokenRing0 unassigned  YES NVRAM  administratively down 
down

Virtual-Access110.1.1.2YES TFTP   up
down

Virtual-Template1  10.1.1.2YES NVRAM  down  
down

DTE#sho ver
Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-JS-L), Version 12.0(7)T,  RELEASE SOFTWARE (fc2)
Copyright (c) 1986-1999 by cisco Systems, Inc.
Compiled Mon 06-Dec-99 17:10 by phanguye
Image text-base: 0x0306C4E0, data-base: 0x1000

ROM: System Bootstrap, Version 5.2(8a), RELEASE SOFTWARE
BOOTFLASH: 3000 Boo

Re: PPP over Frame-Relay

2001-01-18 Thread Rahul Kachalia

can you attach debug ppp packet & debug vtemplate
rahul.

- Original Message -
From: <[EMAIL PROTECTED]>
To: <[EMAIL PROTECTED]>
Cc: <[EMAIL PROTECTED]>
Sent: Thursday, January 18, 2001 8:54 AM
Subject: PPP over Frame-Relay


>
>Hi
>
>  I am trying to make this PPP over Frame-Relay with two Cisco 2501
> running 12.0.5(T) see below. For some reason this does not work? can
someone
> please help me to get this to work, I have ran the debug commands and it
> seems like its working but I can not ping each other for some reason.
>
> I have both my config's below...
>
>
>
>
>
> Current configuration:
> !
> version 12.0
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> service udp-small-servers
> service tcp-small-servers
> !
> hostname DCE
> !
> enable password brian
> !
> username brian password 0 brian
> !
> !
> !
> !
> ip subnet-zero
> !
> virtual-profile virtual-template 1
> frame-relay switching
> cns event-service server
> !
> !
> !
> interface Ethernet0
>  ip address 64.32.168.37 255.255.255.224
>  no ip directed-broadcast
> !
> interface Virtual-Template1
>  ip address 10.1.1.1 255.255.255.0
>  no ip directed-broadcast
>  no peer default ip address
>  ppp authentication chap pap
> !
> interface Serial0
>  no ip address
>  no ip directed-broadcast
>  encapsulation frame-relay
>  clockrate 64000
>  frame-relay lmi-type ansi
>  frame-relay intf-type dce
> !
> interface Serial0.1 point-to-point
>  no ip directed-broadcast
>  frame-relay interface-dlci 32 ppp Virtual-Template1
> !
> interface Serial1
>  no ip address
>  no ip directed-broadcast
>  shutdown
> !
> interface TokenRing0
>  no ip address
>  no ip directed-broadcast
>  shutdown
> !
> no ip classless
> ip route 0.0.0.0 0.0.0.0 Virtual-Template1
> no ip http server
> !
> access-list 1 permit 10.1.1.1
> !
> !
> line con 0
>  transport input none
> line aux 0
> line vty 0 4
>  password pp
>  login
> !
> end
>
> DCE#sho ver
> Cisco Internetwork Operating System Software
> IOS (tm) 2500 Software (C2500-JS-L), Version 12.0(7)T,  RELEASE SOFTWARE
(fc2)
> Copyright (c) 1986-1999 by cisco Systems, Inc.
> Compiled Mon 06-Dec-99 17:10 by phanguye
> Image text-base: 0x0306C4E0, data-base: 0x1000
>
> ROM: System Bootstrap, Version 5.2(8a), RELEASE SOFTWARE
> BOOTFLASH: 3000 Bootstrap Software (IGS-RXBOOT), Version 10.2(8a), RELEASE
> SOFTW
> ARE (fc1)
>
> DCE uptime is 5 minutes
> System returned to ROM by power-on
> System image file is "flash:c2500-120T.bin"
>
> cisco 2500 (68030) processor (revision E) with 8192K/2048K bytes of
memory.
> Processor board ID 03897480, with hardware revision 
> Bridging software.
> X.25 software, Version 3.0.0.
> SuperLAT software (copyright 1990 by Meridian Technology Corp).
> TN3270 Emulation software.
> 1 Ethernet/IEEE 802.3 interface(s)
> 1 Token Ring/IEEE 802.5 interface(s)
> 2 Serial network interface(s)
> 32K bytes of non-volatile configuration memory.
> 16384K bytes of processor board System flash (Read ONLY)
>
> Configuration register is 0x2102
>
> DCE#
>
>
>
>
>
>
> DTE#sho run
> Building configuration...
>
> Current configuration:
> !
> version 12.0
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> service udp-small-servers
> service tcp-small-servers
> !
> hostname DTE
> !
> enable password pp
> !
> username brian password 0 brian
> !
> !
> !
> !
> ip subnet-zero
> !
> virtual-profile virtual-template 1
> cns event-service server
> !
> !
> !
> interface Ethernet0
>  ip address 64.32.168.37 255.255.255.224
>  no ip directed-broadcast
> !
> interface Virtual-Template1
>  ip address 10.1.1.2 255.255.255.0
>  no ip directed-broadcast
>  ppp authentication chap pap
> !
> interface Serial0
>  no ip address
>  no ip directed-broadcast
>  encapsulation frame-relay
>  frame-relay lmi-type ansi
> !
> interface Serial0.1 point-to-point
>  no ip directed-broadcast
>  frame-relay interface-dlci 32 ppp Virtual-Template1
> !
> interface Serial1
>  no ip address
>  no ip directed-broadcast
>  shutdown
> !
> interface TokenRing0
>  no ip address
>  no ip directed-broadcast
>  shutdown
> !
> no ip classless
> ip route 0.0.0.0 0.0.0.0 Virtual-Template1
> no ip http server
> !
> access-list 1 permit 10.1.1.2
> !
> !
> line con 0
>  transport input none
> line aux 0
> line vty 0 4
>  password pp
&

Re: PPP over Frame-Relay

2001-01-19 Thread AABAN34

I got it to work, all I needed to do was to remove the =A0 ppp authenticatio=
n=20
chap pap
 and it I could ping each other.


Thanks  Brian

_
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



PPP over Frame Relay [7:36300]

2002-02-22 Thread John Neiberger

I believe someone might have mentioned this recently but since 
I'm studying it right now I thought I'd ask again...

What the heck would be a real-world application of PPP over 
Frame Relay?  If you want it for the authentication this is a 
lot of work!

You need to setup a subinterface *and* a virtual template for 
every PVC!  What a pain Then again, if you're using 
multipoint interfaces you'd simply use ip unnumbered and a 
single virtual template.

Hmm  what might we actually do with this?  Interestingly, I 
just combined two features that I've never configured before:  
PPPoFR and FREEK.  It makes my config look fairly odd.  :-)

John


Get your own "800" number
Voicemail, fax, email, and a lot more
http://www.ureach.com/reg/tag




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=36300&t=36300
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



Re: PPP over Frame Relay [7:36300]

2002-02-23 Thread Rahul Kachalia

John,

PPPoFR solution is to maintain leased line PPP end to end over SP's FR
backbone..Following is the sample topology :

CPE--PPP/LL--SP--FR+PPP--SP--PPP/LL--CPE

But later started using in Broadband environment with following topology
:

CPE--PPPoFR/xDSL--DSLAM--PPPoFR--SP--PPPoFR--ISP/Wholesale provider

But now you will find PPPoE, oEoA, oA & oEoVLAN, as you can see several
L2 tech. is used but the goal is to maintain PPP end-to-end due to its
feature for AAA purpose..

thanks,
rahul.


""John Neiberger""  wrote in message
[EMAIL PROTECTED]">news:[EMAIL PROTECTED]...
> I believe someone might have mentioned this recently but since
> I'm studying it right now I thought I'd ask again...
>
> What the heck would be a real-world application of PPP over
> Frame Relay?  If you want it for the authentication this is a
> lot of work!
>
> You need to setup a subinterface *and* a virtual template for
> every PVC!  What a pain Then again, if you're using
> multipoint interfaces you'd simply use ip unnumbered and a
> single virtual template.
>
> Hmm  what might we actually do with this?  Interestingly, I
> just combined two features that I've never configured before:
> PPPoFR and FREEK.  It makes my config look fairly odd.  :-)
>
> John
>
> 
> Get your own "800" number
> Voicemail, fax, email, and a lot more
> http://www.ureach.com/reg/tag




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=36320&t=36300
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



Re: PPP over Frame Relay [7:36300]

2002-02-23 Thread nrf

The real purpose is just to make life more complicated.

Seriously, I cannot even think of a single reason why I would ever want to
use PPPoFR in real life.






""Rahul Kachalia""  wrote in message
[EMAIL PROTECTED]">news:[EMAIL PROTECTED]...
> John,
>
> PPPoFR solution is to maintain leased line PPP end to end over SP's FR
> backbone..Following is the sample topology :
>
> CPE--PPP/LL--SP--FR+PPP--SP--PPP/LL--CPE
>
> But later started using in Broadband environment with following
topology
> :
>
> CPE--PPPoFR/xDSL--DSLAM--PPPoFR--SP--PPPoFR--ISP/Wholesale provider
>
> But now you will find PPPoE, oEoA, oA & oEoVLAN, as you can see
several
> L2 tech. is used but the goal is to maintain PPP end-to-end due to its
> feature for AAA purpose..
>
> thanks,
> rahul.
>
>
> ""John Neiberger""  wrote in message
> [EMAIL PROTECTED]">news:[EMAIL PROTECTED]...
> > I believe someone might have mentioned this recently but since
> > I'm studying it right now I thought I'd ask again...
> >
> > What the heck would be a real-world application of PPP over
> > Frame Relay?  If you want it for the authentication this is a
> > lot of work!
> >
> > You need to setup a subinterface *and* a virtual template for
> > every PVC!  What a pain Then again, if you're using
> > multipoint interfaces you'd simply use ip unnumbered and a
> > single virtual template.
> >
> > Hmm  what might we actually do with this?  Interestingly, I
> > just combined two features that I've never configured before:
> > PPPoFR and FREEK.  It makes my config look fairly odd.  :-)
> >
> > John
> >
> > 
> > Get your own "800" number
> > Voicemail, fax, email, and a lot more
> > http://www.ureach.com/reg/tag




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=36337&t=36300
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



Re: PPP over Frame Relay [7:36300]

2002-02-24 Thread Howard C. Berkowitz

>The real purpose is just to make life more complicated.
>
>Seriously, I cannot even think of a single reason why I would ever want to
>use PPPoFR in real life.

Rahul is perfectly correct.

In the SP world, regulatory concerns may enter. For example, in the 
US, an ILEC can't terminate IP as part of its basic service. It can 
use IP in its infrastructure, as, for example, putting an L2TP proxy 
client in one of its POPs, extracting the PPP, and then sending the 
PPP to the ultimate server at the ISP. If the transport for that last 
leg happened to be FR, PPPoFR might be an alternative, although I 
tend to prefer L2TP.

>
>
>
>
>
>
>""Rahul Kachalia""  wrote in message
>[EMAIL PROTECTED]">news:[EMAIL PROTECTED]...
>>  John,
>>
>>  PPPoFR solution is to maintain leased line PPP end to end over SP's
FR
>>  backbone..Following is the sample topology :
>>
>>  CPE--PPP/LL--SP--FR+PPP--SP--PPP/LL--CPE
>>
>>  But later started using in Broadband environment with following
>topology
>>  :
>>
>>  CPE--PPPoFR/xDSL--DSLAM--PPPoFR--SP--PPPoFR--ISP/Wholesale provider
>>
>>  But now you will find PPPoE, oEoA, oA & oEoVLAN, as you can see
>several
>>  L2 tech. is used but the goal is to maintain PPP end-to-end due to its
>>  feature for AAA purpose..
>>
>>  thanks,
>>  rahul.
>>
>>
>>  ""John Neiberger""  wrote in message
>>  [EMAIL PROTECTED]">news:[EMAIL PROTECTED]...
>>  > I believe someone might have mentioned this recently but since
>>  > I'm studying it right now I thought I'd ask again...
>>  >
>>  > What the heck would be a real-world application of PPP over
>>  > Frame Relay?  If you want it for the authentication this is a
>>  > lot of work!
>>  >
>>  > You need to setup a subinterface *and* a virtual template for
>>  > every PVC!  What a pain Then again, if you're using
>>  > multipoint interfaces you'd simply use ip unnumbered and a
>>  > single virtual template.
>>  >
>>  > Hmm  what might we actually do with this?  Interestingly, I
>>  > just combined two features that I've never configured before:
>>  > PPPoFR and FREEK.  It makes my config look fairly odd.  :-)
>>  >
>  > > John

-- 
"What Problem are you trying to solve?"
***send Cisco questions to the list, so all can benefit -- not 
directly to me***

Howard C. Berkowitz  [EMAIL PROTECTED]
Chief Technology Officer, GettLab/Gett Communications
Technical Director, CertificationZone.com
"retired" Certified Cisco Systems Instructor (CID) #93005




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=36342&t=36300
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]