campus LAN design w/DHCP server [7:59578]

2002-12-19 Thread Priscilla Oppenheimer
Sorry if this is a dumb question! ;-) I want to make sure this design will
work before implementing it.

The customer has been using 192.168.168.0/24 in one small flat LAN. He has
run out of these addresses and is being hit by performance issues related to
broadcasts.

He wants to implement subnets and VLANs:

VLAN 100 192.168.168.0/24
VLAN 200 192.168.169.0/24

New design:

 Internet
 |
 s0
  2600 router e1 --- public servers
 e0
 | dot1q trunk
   switch
VLAN 200 VLAN 100

There is just one DHCP server. It will be in VLAN 100, address
192.168.168.10. The DHCP server will have 2 scopes for the 2 subnets.

We're going to do inter-VLAN routing on the 2600 router. 

Will this config work as far as DHCP is concerned?

interface ethernet 0
no ip address
interface ethernet 0.1
encapsulation dot1q  100
ip address 192.168.168.1  255.255.255.0
interface ethernet 0.2
encapsulation dot1q  200
ip address 192.168.169.1  255.255.255.0
ip helper-address 192.168.168.10

Devices in VLAN 100 will broadcast and get to the DHCP server directly. The
DHCP server is in their VLAN/subnet.

Devices in VLAN 200 will broadcast. The router will hopefully pick up the
broadcast, convert it to a unicast to the DHCP server and send it back out
e0, with the GIADDR address filled in so the server will use the right scope.

Sounds like it should work, but for some unknown reason, I couldn't find an
example that showed this.

Thanks so much for your help. You could save my Christmas by helping me
verify (or poke holes) in this design! I just wanted to check on the DHCP
aspect at this point. I can fix up the NAT and routing. My brain stopped
working after the last egg nog, so help is needed! :-)

Priscilla


Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=59578&t=59578
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



RE: campus LAN design w/DHCP server [7:59578]

2002-12-19 Thread s vermill
Priscilla,

I'm sure someone can verify this with a 2600 specifically.  As far as DHCP
in general, yes.  We just did this with a much larger 6509-based network. 
No problems.  The only difference, of course, is that the MSFC has virtual
router interfaces per VLAN - not subinterfaces on a router on a stick. 
Can't see why DHCP itself would know or care.  But I guess you can't know
for sure what that subinterface on the 2600 will do until someone
specifically verifies it.  If you don't get such a response, I've got a 2600
laying around at the moment.  I'll dig up a switch, set up a DHCP server,
and mock 'er up for ya.  Won't take long at all.

Regards,

Scott




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=59580&t=59578
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



Re: campus LAN design w/DHCP server [7:59578]

2002-12-19 Thread Larry Letterman
No more drinks for you, pris
Design seems like it will work...till an intern puts up a nother dhcp
server on the same vlan and people get wrong address's

:-P

Priscilla Oppenheimer wrote:

>Sorry if this is a dumb question! ;-) I want to make sure this design will
>work before implementing it.
>
>The customer has been using 192.168.168.0/24 in one small flat LAN. He has
>run out of these addresses and is being hit by performance issues related to
>broadcasts.
>
>He wants to implement subnets and VLANs:
>
>VLAN 100 192.168.168.0/24
>VLAN 200 192.168.169.0/24
>
>New design:
>
> Internet
> |
> s0
>  2600 router e1 --- public servers
> e0
> | dot1q trunk
>   switch
>VLAN 200 VLAN 100
>
>There is just one DHCP server. It will be in VLAN 100, address
>192.168.168.10. The DHCP server will have 2 scopes for the 2 subnets.
>
>We're going to do inter-VLAN routing on the 2600 router. 
>
>Will this config work as far as DHCP is concerned?
>
>interface ethernet 0
>no ip address
>interface ethernet 0.1
>encapsulation dot1q  100
>ip address 192.168.168.1  255.255.255.0
>interface ethernet 0.2
>encapsulation dot1q  200
>ip address 192.168.169.1  255.255.255.0
>ip helper-address 192.168.168.10
>
>Devices in VLAN 100 will broadcast and get to the DHCP server directly. The
>DHCP server is in their VLAN/subnet.
>
>Devices in VLAN 200 will broadcast. The router will hopefully pick up the
>broadcast, convert it to a unicast to the DHCP server and send it back out
>e0, with the GIADDR address filled in so the server will use the right
scope.
>
>Sounds like it should work, but for some unknown reason, I couldn't find an
>example that showed this.
>
>Thanks so much for your help. You could save my Christmas by helping me
>verify (or poke holes) in this design! I just wanted to check on the DHCP
>aspect at this point. I can fix up the NAT and routing. My brain stopped
>working after the last egg nog, so help is needed! :-)
>
>Priscilla




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=59586&t=59578
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



RE: campus LAN design w/DHCP server [7:59578]

2002-12-19 Thread Priscilla Oppenheimer
Maybe what I really need for Christmas is a new router. ;-) My routers are
too old to do this sort of stuff. It would be terrific if you could mock it
up.

I'm just not totally conviced the router will behave the way it obviously
should. Could be the egg nog though.

Thank-you. I am indebted to you!

Priscilla

s vermill wrote:
> 
> Priscilla,
> 
> I'm sure someone can verify this with a 2600 specifically.  As
> far as DHCP in general, yes.  We just did this with a much
> larger 6509-based network.  No problems.  The only difference,
> of course, is that the MSFC has virtual router interfaces per
> VLAN - not subinterfaces on a router on a stick.  Can't see why
> DHCP itself would know or care.  But I guess you can't know for
> sure what that subinterface on the 2600 will do until someone
> specifically verifies it.  If you don't get such a response,
> I've got a 2600 laying around at the moment.  I'll dig up a
> switch, set up a DHCP server, and mock 'er up for ya.  Won't
> take long at all.
> 
> Regards,
> 
> Scott
> 
> 




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=59587&t=59578
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



RE: campus LAN design w/DHCP server [7:59578]

2002-12-20 Thread Frank Jimenez
There are no dumb questions.  Lots of dumb answers, though ;-)

We do this all the time when setting up Voice Vlans for AVVID.  The
configuration below details the operation of DHCP and the configuration
required.  You should be fine with the example you gave.

http://www.cisco.com/en/US/tech/tk648/tk362/technologies_tech_note09186a
0080114aee.shtml


Frank Jimenez, CCIE #5738
Systems Engineer
Dallas Commercial
Cisco Systems, Inc.
[EMAIL PROTECTED]

-Original Message-
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]
Sent: Thursday, December 19, 2002 7:18 PM
To: [EMAIL PROTECTED]
Subject: campus LAN design w/DHCP server [7:59578]


Sorry if this is a dumb question! ;-) I want to make sure this design
will work before implementing it.

The customer has been using 192.168.168.0/24 in one small flat LAN. He
has run out of these addresses and is being hit by performance issues
related to broadcasts.

He wants to implement subnets and VLANs:

VLAN 100 192.168.168.0/24
VLAN 200 192.168.169.0/24

New design:

 Internet
 |
 s0
  2600 router e1 --- public servers
 e0
 | dot1q trunk
   switch
VLAN 200 VLAN 100

There is just one DHCP server. It will be in VLAN 100, address
192.168.168.10. The DHCP server will have 2 scopes for the 2 subnets.

We're going to do inter-VLAN routing on the 2600 router.

Will this config work as far as DHCP is concerned?

interface ethernet 0
no ip address
interface ethernet 0.1
encapsulation dot1q  100
ip address 192.168.168.1  255.255.255.0
interface ethernet 0.2
encapsulation dot1q  200
ip address 192.168.169.1  255.255.255.0
ip helper-address 192.168.168.10

Devices in VLAN 100 will broadcast and get to the DHCP server directly.
The DHCP server is in their VLAN/subnet.

Devices in VLAN 200 will broadcast. The router will hopefully pick up
the broadcast, convert it to a unicast to the DHCP server and send it
back out e0, with the GIADDR address filled in so the server will use
the right scope.

Sounds like it should work, but for some unknown reason, I couldn't find
an example that showed this.

Thanks so much for your help. You could save my Christmas by helping me
verify (or poke holes) in this design! I just wanted to check on the
DHCP aspect at this point. I can fix up the NAT and routing. My brain
stopped working after the last egg nog, so help is needed! :-)

Priscilla




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=59616&t=59578
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



RE: campus LAN design w/DHCP server [7:59578]

2002-12-21 Thread s vermill
Priscilla,

I haven’t forsaken you (yet).  But here’s the deal:  

My 2610 only has 24M of memory.  I ignored the recommendation for at least
40M to run 12.1 IP Plus only to meet with disastrous results.  I need IP
Plus on this old clunker to enable dot1q (and I’m pretty sure at least 12.1
also).  So...I found what appears to be a 2620 in one of our labs.  There’s
a 2900XL nearby.  I suspect I can fire the two up and get ‘em going. 
However, the only module in the 2900 uplink slot is GigE.  So does anyone
know if I can configure one of the 24 access ports to trunk?  I have minimal
experience with the 2900XL and that was over a year ago.

The real problem is that I don’t have any servers in that lab at the
moment.  Does anyone know of a simple stand-alone DHCP application that will
run on a Windows machine?  If not, the best I can do at the moment using a
2600 would be to put a sniffer on 192.168.1.0 and a client on 192.168.2.0. 
The captured DHCP client requests should show whether or not the pertinent
subinterface address is being plugged into giaddr.
 
Regards,

Scott   



s vermill wrote:
> 
> Priscilla,
> 
> I'm sure someone can verify this with a 2600 specifically.  As
> far as DHCP in general, yes.  We just did this with a much
> larger 6509-based network.  No problems.  The only difference,
> of course, is that the MSFC has virtual router interfaces per
> VLAN - not subinterfaces on a router on a stick.  Can't see why
> DHCP itself would know or care.  But I guess you can't know for
> sure what that subinterface on the 2600 will do until someone
> specifically verifies it.  If you don't get such a response,
> I've got a 2600 laying around at the moment.  I'll dig up a
> switch, set up a DHCP server, and mock 'er up for ya.  Won't
> take long at all.
> 
> Regards,
> 
> Scott
> 
> 




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=59684&t=59578
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]