Re: routing protocols over a serial link

2001-04-03 Thread John Neiberger

Luckily, the network command works similarly for both EIGRP and OSPF:  they
specify which interfaces are participating in the routing process.  However,
with OSPF I've noticed that if there is an interface that I don't want to
run OSPF on, I still have to have a network statement for it or other
routers won't be able to see that network.  To stop the updates, I just add
a passive interface command.

This goes against what I understood about the network command in OSPF.  In
this case, it is also acting to specify which networks I want to advertise,
and I thought it didn't act that way.  Perhaps someone else will clear that
up for us.

Now, with BGP, the network statement definitely specifies which networks to
advertise and has nothing to do with your interface IP addresses.  But
that's another story... 

John

>  Ya know, that fixed it right up. For some reason I was thinking it would 
>  cause troubles if I advertised the same network out but now that I read
into 
>  it, thats not the context at all. Strange.. now for ospf :) 
>  
>  Look to the south for a large mushroom cloud in the sky.
>  Thanks again,
>  Dave
>  
>  On Wednesday 04 April 2001 00:45, John Neiberger wrote:
>  > In EIGRP, the network statement specifies which interfaces are going to
>  > participate in the routing process.  So, for every separate major
network
>  > on the router, you need a different network statement.
>  >
>  > For example, on Router eo1 the only interface that will run EIGRP is
e0. 
>  > To have EIGRP run on all interfaces on that router, add "network
10.0.0.0".
>  >
>  > Do that for the necessary networks on each router and you should be
good to
>  > go!
>  >
>  > HTH,
>  > John
>  >
>  > >  Okey dokey :)
>  > >
>  > >  3 routers:
>  > >
>  > >  eo1 Cisco 2516 2 Serials s0 and s1, 1 ethernet (hub).
>  > >  e0: 172.16.1.40/16
>  > >  s0: 10.10.10.10/24 (creative huh?) s0.1
>  > >  s1: 10.10.30.1/24 s1.1
>  > >
>  > >
>  > >  eo2 Cisco 1602r 2 Serials (56K 4 wire dsu), 1 ethernet
>  > >  e0: 192.168.1.1/24
>  > >  s0: 10.10.30.2/24 s0.1
>  > >  s1: 10.10.20.2/24 s1.1
>  > >
>  > >
>  > >  eo3 Cisco 2610 2 Serials (1 56K 4 wire dsu) , 1 WIC-T1, 1 ethernet
>  > >  e0: 192.168.200.1/24
>  > >  s0: 10.10.10.11/24 s0/0.1
>  > >  s1: 10.10.20.1/24 s0/1.1
>  > >
>  > >  just a basic run down.
>  > >
>  > >
>  > >  eo1's config.
>  > >  !
>  > >  version 12.0
>  > >  service timestamps debug uptime
>  > >  service timestamps log uptime
>  > >  no service password-encryption
>  > >  !
>  > >  hostname eo1
>  > >  !
>  > >  enable secret 5 $k3jl23.3kj2lk3jn4k3l233.
>  > >  !
>  > >  ip subnet-zero
>  > >  !
>  > >  !
>  > >  !
>  > >  
>  > >  !
>  > >  !
>  > >  interface Ethernet0
>  > >   ip address 172.16.1.40 255.255.0.0
>  > >   no ip directed-broadcast
>  > >  !
>  > >  interface Serial0
>  > >   no ip address
>  > >   no ip directed-broadcast
>  > >   encapsulation frame-relay
>  > >   no ip mroute-cache
>  > >   logging event subif-link-status
>  > >   logging event dlci-status-change
>  > >   no keepalive
>  > >   clockrate 200
>  > >  !
>  > >  interface Serial0.1 point-to-point
>  > >   ip address 10.10.10.10 255.255.255.0
>  > >   no ip directed-broadcast
>  > >   frame-relay interface-dlci 100
>  > >  !
>  > >  interface Serial1
>  > >   no ip address
>  > >   no ip directed-broadcast
>  > >   encapsulation frame-relay
>  > >   logging event subif-link-status
>  > >   logging event dlci-status-change
>  > >   no keepalive
>  > >  !
>  > >  interface Serial1.1 point-to-point
>  > >   ip address 10.10.30.1 255.255.255.0
>  > >   no ip directed-broadcast
>  > >   frame-relay interface-dlci 200
>  > >  !
>  > >  interface BRI0
>  > >   no ip address
>  > >   no ip directed-broadcast
>  > >   shutdown
>  > >  !
>  > >  router eigrp 1
>  > >   network 172.16.0.0
>  > >  !
>  > >  ip classless
>  > >  ip route 0.0.0.0 0.0.0.0 172.16.1.16
>  > >  !
>  > >  !
>  > >  line con 0
>  > >   exec-timeout 540 0
>  > >   password eh?
>  > >   login
>  > >   transport input none
>  > >  line aux 0
>  > >  line vty 0 4
>  > >   exec-timeout 540 0
>  > >   password wee
>  > >   login
>  > >  !
>  > >  end
>  > >
>  > >
>  > >
>  > >  eo2's config
>  > >  !
>  > >  version 11.2
>  > >  no service password-encryption
>  > >  service udp-small-servers
>  > >  service tcp-small-servers
>  > >  !
>  > >  hostname eo2
>  > >  !
>  > >  enable secret 5 $1$klwke..ekrjekwejr3lk3js.
>  > >  !
>  > >  interface Ethernet0
>  > >   ip address 192.168.1.1 255.255.255.0
>  > >   no ip route-cache
>  > >   no ip mroute-cache
>  > >   logging event subif-link-status
>  > >  !
>  > >  interface Serial0
>  > >   no ip address
>  > >   encapsulation frame-relay
>  > >   no ip route-cache
>  > >   no ip mroute-cache
>  > >   logging event subif-link-status
>  > >   logging event dlci-status-change
>  > >   no keepalive
>  > >   service-module 56k clock source internal
>  > >   service-module 56k network-type dds
>  > >  !
>  > >  interface Serial0.1 

Re: routing protocols over a serial link

2001-04-03 Thread David Cooper

Ya know, that fixed it right up. For some reason I was thinking it would 
cause troubles if I advertised the same network out but now that I read into 
it, thats not the context at all. Strange.. now for ospf :) 

Look to the south for a large mushroom cloud in the sky.
Thanks again,
Dave

On Wednesday 04 April 2001 00:45, John Neiberger wrote:
> In EIGRP, the network statement specifies which interfaces are going to
> participate in the routing process.  So, for every separate major network
> on the router, you need a different network statement.
>
> For example, on Router eo1 the only interface that will run EIGRP is e0. 
> To have EIGRP run on all interfaces on that router, add "network 10.0.0.0".
>
> Do that for the necessary networks on each router and you should be good to
> go!
>
> HTH,
> John
>
> >  Okey dokey :)
> >
> >  3 routers:
> >
> >  eo1 Cisco 2516 2 Serials s0 and s1, 1 ethernet (hub).
> >  e0: 172.16.1.40/16
> >  s0: 10.10.10.10/24 (creative huh?) s0.1
> >  s1: 10.10.30.1/24 s1.1
> >
> >
> >  eo2 Cisco 1602r 2 Serials (56K 4 wire dsu), 1 ethernet
> >  e0: 192.168.1.1/24
> >  s0: 10.10.30.2/24 s0.1
> >  s1: 10.10.20.2/24 s1.1
> >
> >
> >  eo3 Cisco 2610 2 Serials (1 56K 4 wire dsu) , 1 WIC-T1, 1 ethernet
> >  e0: 192.168.200.1/24
> >  s0: 10.10.10.11/24 s0/0.1
> >  s1: 10.10.20.1/24 s0/1.1
> >
> >  just a basic run down.
> >
> >
> >  eo1's config.
> >  !
> >  version 12.0
> >  service timestamps debug uptime
> >  service timestamps log uptime
> >  no service password-encryption
> >  !
> >  hostname eo1
> >  !
> >  enable secret 5 $k3jl23.3kj2lk3jn4k3l233.
> >  !
> >  ip subnet-zero
> >  !
> >  !
> >  !
> >  
> >  !
> >  !
> >  interface Ethernet0
> >   ip address 172.16.1.40 255.255.0.0
> >   no ip directed-broadcast
> >  !
> >  interface Serial0
> >   no ip address
> >   no ip directed-broadcast
> >   encapsulation frame-relay
> >   no ip mroute-cache
> >   logging event subif-link-status
> >   logging event dlci-status-change
> >   no keepalive
> >   clockrate 200
> >  !
> >  interface Serial0.1 point-to-point
> >   ip address 10.10.10.10 255.255.255.0
> >   no ip directed-broadcast
> >   frame-relay interface-dlci 100
> >  !
> >  interface Serial1
> >   no ip address
> >   no ip directed-broadcast
> >   encapsulation frame-relay
> >   logging event subif-link-status
> >   logging event dlci-status-change
> >   no keepalive
> >  !
> >  interface Serial1.1 point-to-point
> >   ip address 10.10.30.1 255.255.255.0
> >   no ip directed-broadcast
> >   frame-relay interface-dlci 200
> >  !
> >  interface BRI0
> >   no ip address
> >   no ip directed-broadcast
> >   shutdown
> >  !
> >  router eigrp 1
> >   network 172.16.0.0
> >  !
> >  ip classless
> >  ip route 0.0.0.0 0.0.0.0 172.16.1.16
> >  !
> >  !
> >  line con 0
> >   exec-timeout 540 0
> >   password eh?
> >   login
> >   transport input none
> >  line aux 0
> >  line vty 0 4
> >   exec-timeout 540 0
> >   password wee
> >   login
> >  !
> >  end
> >
> >
> >
> >  eo2's config
> >  !
> >  version 11.2
> >  no service password-encryption
> >  service udp-small-servers
> >  service tcp-small-servers
> >  !
> >  hostname eo2
> >  !
> >  enable secret 5 $1$klwke..ekrjekwejr3lk3js.
> >  !
> >  interface Ethernet0
> >   ip address 192.168.1.1 255.255.255.0
> >   no ip route-cache
> >   no ip mroute-cache
> >   logging event subif-link-status
> >  !
> >  interface Serial0
> >   no ip address
> >   encapsulation frame-relay
> >   no ip route-cache
> >   no ip mroute-cache
> >   logging event subif-link-status
> >   logging event dlci-status-change
> >   no keepalive
> >   service-module 56k clock source internal
> >   service-module 56k network-type dds
> >  !
> >  interface Serial0.1 point-to-point
> >   ip address 10.10.30.2 255.255.255.0
> >   no ip route-cache
> >   no ip mroute-cache
> >   no arp frame-relay
> >   frame-relay interface-dlci 200
> >  !
> >  interface Serial1
> >   no ip address
> >   encapsulation frame-relay
> >   logging event subif-link-status
> >   logging event dlci-status-change
> >   no keepalive
> >  !
> >  interface Serial1.1 point-to-point
> >   ip address 10.10.20.2 255.255.255.0
> >   frame-relay interface-dlci 150
> >  !
> >  router eigrp 1
> >   network 192.168.1.0
> >  !
> >  ip classless
> >  logging buffered 4096 debugging
> >  !
> >  line con 0
> >   exec-timeout 540 0
> >   password cheeze
> >   login authentication conmethod
> >  line vty 0 4
> >   exec-timeout 540 0
> >   password milk
> >   login authentication vtymethod
> >  !
> >  end
> >
> >
> >  eo3's config
> >
> >  !
> >
> >  version 12.0
> >
> >  service timestamps debug uptime
> >
> >  service timestamps log uptime
> >  no service password-encryption
> >  !
> >  hostname eo3
> >
> >  !
> >
> >  enable secret 5 $1$T1Rz$TPvI656j4h4
> >  !
> >  memory-size iomem 20
> >  ip subnet-zero
> >  !
> >  !
> >  !
> >  !
> >
> >  !
> >  interface Ethernet0/0
> >  ip address 192.168.200.1 255.255.255.0
> >
> >  no ip directed-broadcast
> >
> >  !
> >

Re: routing protocols over a serial link

2001-04-03 Thread John Neiberger

In EIGRP, the network statement specifies which interfaces are going to
participate in the routing process.  So, for every separate major network on
the router, you need a different network statement.

For example, on Router eo1 the only interface that will run EIGRP is e0.  To
have EIGRP run on all interfaces on that router, add "network 10.0.0.0".  

Do that for the necessary networks on each router and you should be good to
go!

HTH,
John

>  Okey dokey :)
>  
>  3 routers:
>  
>  eo1 Cisco 2516 2 Serials s0 and s1, 1 ethernet (hub).
>  e0: 172.16.1.40/16
>  s0: 10.10.10.10/24 (creative huh?) s0.1
>  s1: 10.10.30.1/24 s1.1
>  
>  
>  eo2 Cisco 1602r 2 Serials (56K 4 wire dsu), 1 ethernet
>  e0: 192.168.1.1/24
>  s0: 10.10.30.2/24 s0.1
>  s1: 10.10.20.2/24 s1.1
>  
>  
>  eo3 Cisco 2610 2 Serials (1 56K 4 wire dsu) , 1 WIC-T1, 1 ethernet
>  e0: 192.168.200.1/24
>  s0: 10.10.10.11/24 s0/0.1
>  s1: 10.10.20.1/24 s0/1.1
>  
>  just a basic run down.
>  
>  
>  eo1's config. 
>  !
>  version 12.0
>  service timestamps debug uptime
>  service timestamps log uptime
>  no service password-encryption
>  !
>  hostname eo1
>  !
>  enable secret 5 $k3jl23.3kj2lk3jn4k3l233.
>  !
>  ip subnet-zero
>  !
>  !
>  !
>  
>  !
>  !
>  interface Ethernet0
>   ip address 172.16.1.40 255.255.0.0
>   no ip directed-broadcast
>  !
>  interface Serial0
>   no ip address
>   no ip directed-broadcast
>   encapsulation frame-relay
>   no ip mroute-cache
>   logging event subif-link-status
>   logging event dlci-status-change
>   no keepalive
>   clockrate 200
>  !
>  interface Serial0.1 point-to-point
>   ip address 10.10.10.10 255.255.255.0
>   no ip directed-broadcast
>   frame-relay interface-dlci 100   
>  !
>  interface Serial1
>   no ip address
>   no ip directed-broadcast
>   encapsulation frame-relay
>   logging event subif-link-status
>   logging event dlci-status-change
>   no keepalive
>  !
>  interface Serial1.1 point-to-point
>   ip address 10.10.30.1 255.255.255.0
>   no ip directed-broadcast
>   frame-relay interface-dlci 200   
>  !
>  interface BRI0
>   no ip address
>   no ip directed-broadcast
>   shutdown
>  !
>  router eigrp 1
>   network 172.16.0.0
>  !
>  ip classless
>  ip route 0.0.0.0 0.0.0.0 172.16.1.16
>  ! 
>  !
>  line con 0
>   exec-timeout 540 0
>   password eh?
>   login
>   transport input none
>  line aux 0
>  line vty 0 4
>   exec-timeout 540 0
>   password wee
>   login
>  !
>  end
>  
>  
>  
>  eo2's config
>  !
>  version 11.2
>  no service password-encryption
>  service udp-small-servers
>  service tcp-small-servers
>  !
>  hostname eo2
>  !
>  enable secret 5 $1$klwke..ekrjekwejr3lk3js.
>  !
>  interface Ethernet0
>   ip address 192.168.1.1 255.255.255.0
>   no ip route-cache
>   no ip mroute-cache
>   logging event subif-link-status
>  !
>  interface Serial0
>   no ip address
>   encapsulation frame-relay
>   no ip route-cache
>   no ip mroute-cache
>   logging event subif-link-status
>   logging event dlci-status-change
>   no keepalive
>   service-module 56k clock source internal
>   service-module 56k network-type dds
>  !
>  interface Serial0.1 point-to-point
>   ip address 10.10.30.2 255.255.255.0
>   no ip route-cache
>   no ip mroute-cache
>   no arp frame-relay
>   frame-relay interface-dlci 200   
>  !
>  interface Serial1
>   no ip address
>   encapsulation frame-relay
>   logging event subif-link-status
>   logging event dlci-status-change
>   no keepalive
>  !
>  interface Serial1.1 point-to-point
>   ip address 10.10.20.2 255.255.255.0
>   frame-relay interface-dlci 150   
>  !
>  router eigrp 1
>   network 192.168.1.0
>  !
>  ip classless
>  logging buffered 4096 debugging
>  !
>  line con 0
>   exec-timeout 540 0
>   password cheeze
>   login authentication conmethod
>  line vty 0 4
>   exec-timeout 540 0
>   password milk
>   login authentication vtymethod
>  !
>  end
>  
>  
>  eo3's config
>  
>  !

>  version 12.0 

>  service timestamps debug uptime  

>  service timestamps log uptime   
>  no service password-encryption
>  !
>  hostname eo3 

>  !

>  enable secret 5 $1$T1Rz$TPvI656j4h4  
>  !  
>  memory-size iomem 20 
>  ip subnet-zero 
>  !
>  !  
>  ! 

Re: routing protocols over a serial link

2001-04-03 Thread David Cooper

Okey dokey :)

3 routers:

eo1 Cisco 2516 2 Serials s0 and s1, 1 ethernet (hub).
e0: 172.16.1.40/16
s0: 10.10.10.10/24 (creative huh?) s0.1
s1: 10.10.30.1/24 s1.1


eo2 Cisco 1602r 2 Serials (56K 4 wire dsu), 1 ethernet
e0: 192.168.1.1/24
s0: 10.10.30.2/24 s0.1
s1: 10.10.20.2/24 s1.1


eo3 Cisco 2610 2 Serials (1 56K 4 wire dsu) , 1 WIC-T1, 1 ethernet
e0: 192.168.200.1/24
s0: 10.10.10.11/24 s0/0.1
s1: 10.10.20.1/24 s0/1.1

just a basic run down.


eo1's config. 
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname eo1
!
enable secret 5 $k3jl23.3kj2lk3jn4k3l233.
!
ip subnet-zero
!
!
!

!
!
interface Ethernet0
 ip address 172.16.1.40 255.255.0.0
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 no ip mroute-cache
 logging event subif-link-status
 logging event dlci-status-change
 no keepalive
 clockrate 200
!
interface Serial0.1 point-to-point
 ip address 10.10.10.10 255.255.255.0
 no ip directed-broadcast
 frame-relay interface-dlci 100   
!
interface Serial1
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 logging event subif-link-status
 logging event dlci-status-change
 no keepalive
!
interface Serial1.1 point-to-point
 ip address 10.10.30.1 255.255.255.0
 no ip directed-broadcast
 frame-relay interface-dlci 200   
!
interface BRI0
 no ip address
 no ip directed-broadcast
 shutdown
!
router eigrp 1
 network 172.16.0.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.1.16
! 
!
line con 0
 exec-timeout 540 0
 password eh?
 login
 transport input none
line aux 0
line vty 0 4
 exec-timeout 540 0
 password wee
 login
!
end



eo2's config
!
version 11.2
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname eo2
!
enable secret 5 $1$klwke..ekrjekwejr3lk3js.
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 logging event subif-link-status
!
interface Serial0
 no ip address
 encapsulation frame-relay
 no ip route-cache
 no ip mroute-cache
 logging event subif-link-status
 logging event dlci-status-change
 no keepalive
 service-module 56k clock source internal
 service-module 56k network-type dds
!
interface Serial0.1 point-to-point
 ip address 10.10.30.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 no arp frame-relay
 frame-relay interface-dlci 200   
!
interface Serial1
 no ip address
 encapsulation frame-relay
 logging event subif-link-status
 logging event dlci-status-change
 no keepalive
!
interface Serial1.1 point-to-point
 ip address 10.10.20.2 255.255.255.0
 frame-relay interface-dlci 150   
!
router eigrp 1
 network 192.168.1.0
!
ip classless
logging buffered 4096 debugging
!
line con 0
 exec-timeout 540 0
 password cheeze
 login authentication conmethod
line vty 0 4
 exec-timeout 540 0
 password milk
 login authentication vtymethod
!
end


eo3's config

! 
version 12.0
service timestamps debug uptime   
service timestamps log uptime   
no service password-encryption
!
hostname eo3 
!  
enable secret 5 $1$T1Rz$TPvI656j4h4  
!  
memory-size iomem 20 
ip subnet-zero 
!
!  
!
! 
!   
interface Ethernet0/0   
ip address 192.168.200.1 255.255.255.0
no ip directed-broadcast  
! 
!   
interface Serial0/0   
no ip address 
no ip directed-broadcast
encapsulation frame-relay 
no ip mroute-cache  
no keepalive  
!
interface Serial0/0.1 po

Re: routing protocols over a serial link

2001-04-03 Thread John Neiberger

Hmm... off the top of my head the only reason for that behavior that I can
think of is a passive-interface statement in your eigrp config, which you'd
probably notice.Perhaps posting the configs is a good idea.

John

>  Hey again,
>  
>   I've run into a wall here trying to configure a small test lab. The
problem 
>  is, In my network of three routers, No routing protocol will traverse one

>  serial link. The serial link in question is up/up and ip traffic will
pass 
>  across it. static routes work, dynamic routes aren't ever learned. The
serial 
>  interfaces are all frame relay and are tested fully for ip functionality.

>  
>  
>  All 3 routers have 2 serial interfaces apeice. They are linked in a
triangle 
>  mesh on separate subnets for each link. They are running encapsulation 
>  frame-relay, with no keepalives. subinterfaces are point-to-point. On
both 
>  the offending routers a show ip eigrp interfaces return showing just the 
>  ethernet ports of the routers as the only interfaces used in the routing 
>  process. 
>  
>  Im just wondering if there is something crucial that I am totally missing

>  here. If required I will paste out the configs in another email. I just
don't 
>  like to write long emails with all the details if I don't have to. 
>  
>  Sorry if I leave some holes. Any advice would be appreciated.
>  
>  Thanks in advance,
>  Dave
___
Send a cool gift with your E-Card
http://www.bluemountain.com/giftcenter/
_
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



routing protocols over a serial link

2001-04-03 Thread David Cooper

Hey again,

I've run into a wall here trying to configure a small test lab. The problem 
is, In my network of three routers, No routing protocol will traverse one 
serial link. The serial link in question is up/up and ip traffic will pass 
across it. static routes work, dynamic routes aren't ever learned. The serial 
interfaces are all frame relay and are tested fully for ip functionality. 


All 3 routers have 2 serial interfaces apeice. They are linked in a triangle 
mesh on separate subnets for each link. They are running encapsulation 
frame-relay, with no keepalives. subinterfaces are point-to-point. On both 
the offending routers a show ip eigrp interfaces return showing just the 
ethernet ports of the routers as the only interfaces used in the routing 
process. 

Im just wondering if there is something crucial that I am totally missing 
here. If required I will paste out the configs in another email. I just don't 
like to write long emails with all the details if I don't have to. 

Sorry if I leave some holes. Any advice would be appreciated.

Thanks in advance,
Dave
_
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]