Re: Review Request 17442: Added 'active_tasks' stat to master stats endpoint.

2014-01-28 Thread Vinod Kone

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/17442/
---

(Updated Jan. 28, 2014, 6:05 p.m.)


Review request for mesos, Benjamin Hindman, Ben Mahler, David Robinson, and 
Niklas Nielsen.


Changes
---

decided to add _gauge suffix after all to make @drob happy.


Bugs: MESOS-772
https://issues.apache.org/jira/browse/MESOS-772


Repository: mesos-git


Description
---

See summary.

I opted for active tasks instead of running tasks because I didn't want the 
stats endpoint to loop through all tasks to figure out if a task is in RUNNING 
state. I think active is useful for most debugging purposes.


Diffs (updated)
-

  src/master/http.cpp 546e91dbb9c8ee1014bb4f0b3be2714ad6a2d520 

Diff: https://reviews.apache.org/r/17442/diff/


Testing
---

make check


Thanks,

Vinod Kone



Review Request 17442: Added 'active_tasks' stat to master stats endpoint.

2014-01-27 Thread Vinod Kone

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/17442/
---

Review request for mesos, Benjamin Hindman, Ben Mahler, David Robinson, and 
Niklas Nielsen.


Bugs: MESOS-772
https://issues.apache.org/jira/browse/MESOS-772


Repository: mesos-git


Description
---

See summary.

I opted for active tasks instead of running tasks because I didn't want the 
stats endpoint to loop through all tasks to figure out if a task is in RUNNING 
state. I think active is useful for most debugging purposes.


Diffs
-

  src/master/http.cpp 546e91dbb9c8ee1014bb4f0b3be2714ad6a2d520 

Diff: https://reviews.apache.org/r/17442/diff/


Testing
---

make check


Thanks,

Vinod Kone



Re: Review Request 17442: Added 'active_tasks' stat to master stats endpoint.

2014-01-27 Thread Adam B

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/17442/#review32942
---

Ship it!


Looks great! Thanks


src/master/http.cpp
https://reviews.apache.org/r/17442/#comment61977

What are the active states besides RUNNING? STAGING and STARTING? Those 
should be fine to count too. Maybe add them to the comment to clarify.


- Adam B


On Jan. 27, 2014, 6:17 p.m., Vinod Kone wrote:
 
 ---
 This is an automatically generated e-mail. To reply, visit:
 https://reviews.apache.org/r/17442/
 ---
 
 (Updated Jan. 27, 2014, 6:17 p.m.)
 
 
 Review request for mesos, Benjamin Hindman, Ben Mahler, David Robinson, and 
 Niklas Nielsen.
 
 
 Bugs: MESOS-772
 https://issues.apache.org/jira/browse/MESOS-772
 
 
 Repository: mesos-git
 
 
 Description
 ---
 
 See summary.
 
 I opted for active tasks instead of running tasks because I didn't want 
 the stats endpoint to loop through all tasks to figure out if a task is in 
 RUNNING state. I think active is useful for most debugging purposes.
 
 
 Diffs
 -
 
   src/master/http.cpp 546e91dbb9c8ee1014bb4f0b3be2714ad6a2d520 
 
 Diff: https://reviews.apache.org/r/17442/diff/
 
 
 Testing
 ---
 
 make check
 
 
 Thanks,
 
 Vinod Kone
 




Re: Review Request 17442: Added 'active_tasks' stat to master stats endpoint.

2014-01-27 Thread Vinod Kone

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/17442/
---

(Updated Jan. 28, 2014, 2:59 a.m.)


Review request for mesos, Benjamin Hindman, Ben Mahler, David Robinson, and 
Niklas Nielsen.


Changes
---

adam's comments.


Bugs: MESOS-772
https://issues.apache.org/jira/browse/MESOS-772


Repository: mesos-git


Description
---

See summary.

I opted for active tasks instead of running tasks because I didn't want the 
stats endpoint to loop through all tasks to figure out if a task is in RUNNING 
state. I think active is useful for most debugging purposes.


Diffs (updated)
-

  src/master/http.cpp 546e91dbb9c8ee1014bb4f0b3be2714ad6a2d520 

Diff: https://reviews.apache.org/r/17442/diff/


Testing
---

make check


Thanks,

Vinod Kone



Re: Review Request 17442: Added 'active_tasks' stat to master stats endpoint.

2014-01-27 Thread Ben Mahler

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/17442/#review32952
---

Ship it!


I hope the past vs present tense will be enough to not make the monotonic vs 
instantaneous stats confusing for those consuming this data.


src/master/http.cpp
https://reviews.apache.org/r/17442/#comment62012

s/launched/active/ ?


- Ben Mahler


On Jan. 28, 2014, 2:59 a.m., Vinod Kone wrote:
 
 ---
 This is an automatically generated e-mail. To reply, visit:
 https://reviews.apache.org/r/17442/
 ---
 
 (Updated Jan. 28, 2014, 2:59 a.m.)
 
 
 Review request for mesos, Benjamin Hindman, Ben Mahler, David Robinson, and 
 Niklas Nielsen.
 
 
 Bugs: MESOS-772
 https://issues.apache.org/jira/browse/MESOS-772
 
 
 Repository: mesos-git
 
 
 Description
 ---
 
 See summary.
 
 I opted for active tasks instead of running tasks because I didn't want 
 the stats endpoint to loop through all tasks to figure out if a task is in 
 RUNNING state. I think active is useful for most debugging purposes.
 
 
 Diffs
 -
 
   src/master/http.cpp 546e91dbb9c8ee1014bb4f0b3be2714ad6a2d520 
 
 Diff: https://reviews.apache.org/r/17442/diff/
 
 
 Testing
 ---
 
 make check
 
 
 Thanks,
 
 Vinod Kone
 




Re: Review Request 17442: Added 'active_tasks' stat to master stats endpoint.

2014-01-27 Thread David Robinson

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/17442/#review32962
---

Ship it!



src/master/http.cpp
https://reviews.apache.org/r/17442/#comment62039

s/launched_tasks/launched_tasks_gauge/ ? (or active_tasks_gauge, please 
yourself)

All the other *_tasks are counters, which, but calling this something_tasks 
also implies it is. This isn't a counter so it's better to explicitly call it 
something else, such as something_tasks_gauge.


- David Robinson


On Jan. 28, 2014, 2:59 a.m., Vinod Kone wrote:
 
 ---
 This is an automatically generated e-mail. To reply, visit:
 https://reviews.apache.org/r/17442/
 ---
 
 (Updated Jan. 28, 2014, 2:59 a.m.)
 
 
 Review request for mesos, Benjamin Hindman, Ben Mahler, David Robinson, and 
 Niklas Nielsen.
 
 
 Bugs: MESOS-772
 https://issues.apache.org/jira/browse/MESOS-772
 
 
 Repository: mesos-git
 
 
 Description
 ---
 
 See summary.
 
 I opted for active tasks instead of running tasks because I didn't want 
 the stats endpoint to loop through all tasks to figure out if a task is in 
 RUNNING state. I think active is useful for most debugging purposes.
 
 
 Diffs
 -
 
   src/master/http.cpp 546e91dbb9c8ee1014bb4f0b3be2714ad6a2d520 
 
 Diff: https://reviews.apache.org/r/17442/diff/
 
 
 Testing
 ---
 
 make check
 
 
 Thanks,
 
 Vinod Kone
 




Re: Review Request 17442: Added 'active_tasks' stat to master stats endpoint.

2014-01-27 Thread David Robinson


 On Jan. 28, 2014, 4:55 a.m., Ben Mahler wrote:
  I hope the past vs present tense will be enough to not make the monotonic 
  vs instantaneous stats confusing for those consuming this data.

I'd find it confusing. active_tasks_gauge is preferrable.


- David


---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/17442/#review32952
---


On Jan. 28, 2014, 2:59 a.m., Vinod Kone wrote:
 
 ---
 This is an automatically generated e-mail. To reply, visit:
 https://reviews.apache.org/r/17442/
 ---
 
 (Updated Jan. 28, 2014, 2:59 a.m.)
 
 
 Review request for mesos, Benjamin Hindman, Ben Mahler, David Robinson, and 
 Niklas Nielsen.
 
 
 Bugs: MESOS-772
 https://issues.apache.org/jira/browse/MESOS-772
 
 
 Repository: mesos-git
 
 
 Description
 ---
 
 See summary.
 
 I opted for active tasks instead of running tasks because I didn't want 
 the stats endpoint to loop through all tasks to figure out if a task is in 
 RUNNING state. I think active is useful for most debugging purposes.
 
 
 Diffs
 -
 
   src/master/http.cpp 546e91dbb9c8ee1014bb4f0b3be2714ad6a2d520 
 
 Diff: https://reviews.apache.org/r/17442/diff/
 
 
 Testing
 ---
 
 make check
 
 
 Thanks,
 
 Vinod Kone
 




Re: Review Request 17442: Added 'active_tasks' stat to master stats endpoint.

2014-01-27 Thread Vinod Kone


 On Jan. 28, 2014, 6:31 a.m., David Robinson wrote:
  src/master/http.cpp, line 349
  https://reviews.apache.org/r/17442/diff/2/?file=452628#file452628line349
 
  s/launched_tasks/launched_tasks_gauge/ ? (or active_tasks_gauge, please 
  yourself)
  
  All the other *_tasks are counters, which, but calling this 
  something_tasks also implies it is. This isn't a counter so it's better to 
  explicitly call it something else, such as something_tasks_gauge.

There are lots of stats that we currently expose that are gauges but we don't 
explicitly call them that way. I agree adding a suffix like _gauge is more 
explicit but maybe we should do that across all gauge stats in one fell swoop 
to avoid confusion? What do you think?


- Vinod


---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/17442/#review32962
---


On Jan. 28, 2014, 2:59 a.m., Vinod Kone wrote:
 
 ---
 This is an automatically generated e-mail. To reply, visit:
 https://reviews.apache.org/r/17442/
 ---
 
 (Updated Jan. 28, 2014, 2:59 a.m.)
 
 
 Review request for mesos, Benjamin Hindman, Ben Mahler, David Robinson, and 
 Niklas Nielsen.
 
 
 Bugs: MESOS-772
 https://issues.apache.org/jira/browse/MESOS-772
 
 
 Repository: mesos-git
 
 
 Description
 ---
 
 See summary.
 
 I opted for active tasks instead of running tasks because I didn't want 
 the stats endpoint to loop through all tasks to figure out if a task is in 
 RUNNING state. I think active is useful for most debugging purposes.
 
 
 Diffs
 -
 
   src/master/http.cpp 546e91dbb9c8ee1014bb4f0b3be2714ad6a2d520 
 
 Diff: https://reviews.apache.org/r/17442/diff/
 
 
 Testing
 ---
 
 make check
 
 
 Thanks,
 
 Vinod Kone
 




Re: Review Request 17442: Added 'active_tasks' stat to master stats endpoint.

2014-01-27 Thread Vinod Kone

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/17442/
---

(Updated Jan. 28, 2014, 6:57 a.m.)


Review request for mesos, Benjamin Hindman, Ben Mahler, David Robinson, and 
Niklas Nielsen.


Changes
---

benm's.


Bugs: MESOS-772
https://issues.apache.org/jira/browse/MESOS-772


Repository: mesos-git


Description
---

See summary.

I opted for active tasks instead of running tasks because I didn't want the 
stats endpoint to loop through all tasks to figure out if a task is in RUNNING 
state. I think active is useful for most debugging purposes.


Diffs (updated)
-

  src/master/http.cpp 546e91dbb9c8ee1014bb4f0b3be2714ad6a2d520 

Diff: https://reviews.apache.org/r/17442/diff/


Testing
---

make check


Thanks,

Vinod Kone