Re: Review Request: Adds method to KBookmarkManager disable showing dialogs on errors.

2010-12-06 Thread David Faure

---
This is an automatically generated e-mail. To reply, visit:
http://svn.reviewboard.kde.org/r/6004/#review9157
---



/trunk/KDE/kdelibs/kio/bookmarks/kbookmarkmanager.h


I would prefer if it was named like the similar method in KDirLister:

  /**
   * Check whether auto error handling is enabled.
   * If enabled, it will show an error dialog to the user when an
   * error occurs. It is turned on by default.
   * @return true if auto error handling is enabled, false otherwise
   * @see setAutoErrorHandlingEnabled()
   */
  bool autoErrorHandlingEnabled() const;

  /**
   * Enable or disable auto error handling is enabled.
   * If enabled, it will show an error dialog to the user when an
   * error occurs. It is turned on by default.
   * If disabled, the application should react on the error() signal.
   * @param enable true to enable auto error handling, false to disable
   * @param parent the parent widget for the error dialogs, can be 0 for
   *   top-level
   * @see autoErrorHandlingEnabled()
   */
  void setAutoErrorHandlingEnabled( bool enable, QWidget *parent );

(the QWidget* would also allow to give a proper parent widget for the 
dialog box instead of the current activeWindow() hack)




/trunk/KDE/kdelibs/kio/bookmarks/kbookmarkmanager.h


const QString &


- David


On 2010-11-30 20:57:03, Matthias Fuchs wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> http://svn.reviewboard.kde.org/r/6004/
> ---
> 
> (Updated 2010-11-30 20:57:03)
> 
> 
> Review request for kdelibs and David Faure.
> 
> 
> Summary
> ---
> 
> Adds method to KBookmarkManager disable showing dialogs on errors.
> This way it is possible to deactivate those messages if KBoomarkManager is 
> not run in the gui thread.
> BUG:207592
> 
> 
> This addresses bug 207592.
> https://bugs.kde.org/show_bug.cgi?id=207592
> 
> 
> Diffs
> -
> 
>   /trunk/KDE/kdelibs/kio/bookmarks/kbookmarkmanager.h 1202414 
>   /trunk/KDE/kdelibs/kio/bookmarks/kbookmarkmanager.cc 1202414 
> 
> Diff: http://svn.reviewboard.kde.org/r/6004/diff
> 
> 
> Testing
> ---
> 
> 
> Thanks,
> 
> Matthias
> 
>



Re: Review Request: Adds method to KBookmarkManager disable showing dialogs on errors.

2010-11-30 Thread Matthias Fuchs

---
This is an automatically generated e-mail. To reply, visit:
http://svn.reviewboard.kde.org/r/6004/
---

(Updated 2010-11-30 20:57:03.986026)


Review request for kdelibs and David Faure.


Changes
---

Messed up the last diff, this one is correct now.


Summary
---

Adds method to KBookmarkManager disable showing dialogs on errors.
This way it is possible to deactivate those messages if KBoomarkManager is not 
run in the gui thread.
BUG:207592


This addresses bug 207592.
https://bugs.kde.org/show_bug.cgi?id=207592


Diffs (updated)
-

  /trunk/KDE/kdelibs/kio/bookmarks/kbookmarkmanager.h 1202414 
  /trunk/KDE/kdelibs/kio/bookmarks/kbookmarkmanager.cc 1202414 

Diff: http://svn.reviewboard.kde.org/r/6004/diff


Testing
---


Thanks,

Matthias



Re: Review Request: Adds method to KBookmarkManager disable showing dialogs on errors.

2010-11-30 Thread Matthias Fuchs

---
This is an automatically generated e-mail. To reply, visit:
http://svn.reviewboard.kde.org/r/6004/
---

(Updated 2010-11-30 20:55:09.801653)


Review request for kdelibs and David Faure.


Changes
---

Adds a error signal that contains the translated error message.
To be able to emit it a const_cast is needed in saveAs, which we -- Albert and 
me -- are not that happy about.  :)


Summary
---

Adds method to KBookmarkManager disable showing dialogs on errors.
This way it is possible to deactivate those messages if KBoomarkManager is not 
run in the gui thread.
BUG:207592


Diffs (updated)
-

  /trunk/KDE/kdelibs/kate/plugins/autobrace/ktexteditor_autobrace.desktop 
1201809 
  /trunk/KDE/kdelibs/kate/syntax/katehighlight.cpp 1201809 
  /trunk/KDE/kdelibs/kdecore/io/kzip.cpp 1201809 
  /trunk/KDE/kdelibs/kdecore/kernel/kglobal.h 1201809 
  /trunk/KDE/kdelibs/kdecore/kernel/kglobal.cpp 1201809 
  /trunk/KDE/kdelibs/kdecore/kernel/kstandarddirs.cpp 1201809 
  /trunk/KDE/kdelibs/kdecore/localization/all_languages.desktop 1201809 
  /trunk/KDE/kdelibs/kdecore/tests/kstandarddirstest.cpp 1201809 
  /trunk/KDE/kdelibs/kdeui/dialogs/kaboutapplicationpersonlistdelegate_p.h 
1201809 
  /trunk/KDE/kdelibs/kdeui/dialogs/kaboutapplicationpersonlistdelegate_p.cpp 
1201809 
  /trunk/KDE/kdelibs/kdeui/shortcuts/kglobalaccel.cpp 1201809 
  /trunk/KDE/kdelibs/kdeui/util/kpixmapsequence.h 1201809 
  /trunk/KDE/kdelibs/kdeui/util/kpixmapsequence.cpp 1201809 
  /trunk/KDE/kdelibs/kdeui/widgets/kmultitabbar.cpp 1201809 
  /trunk/KDE/kdelibs/kdewebkit/kwebpage.cpp 1201809 
  /trunk/KDE/kdelibs/kio/bookmarks/kbookmarkmanager.h 1201809 
  /trunk/KDE/kdelibs/kio/bookmarks/kbookmarkmanager.cc 1201809 
  /trunk/KDE/kdelibs/kio/kfile/kfilemetadatawidget.h 1201809 
  /trunk/KDE/kdelibs/kio/kfile/kfilemetadatawidget.cpp 1201809 
  /trunk/KDE/kdelibs/kio/kio/accessmanager.cpp 1201809 
  /trunk/KDE/kdelibs/kio/kio/accessmanagerreply_p.cpp 1201809 
  /trunk/KDE/kdelibs/kio/kio/kfilemetainfo.cpp 1201809 
  /trunk/KDE/kdelibs/nepomuk/query/query.cpp 1201809 
  /trunk/KDE/kdelibs/nepomuk/utils/utils.cpp 1201809 
  /trunk/KDE/kdelibs/plasma/widgets/label.cpp 1201809 
  /trunk/KDE/kdelibs/plasma/widgets/pushbutton.cpp 1201809 
  /trunk/KDE/kdelibs/plasma/widgets/scrollwidget.cpp 1201809 
  /trunk/KDE/kdelibs/plasma/widgets/tabbar.cpp 1201809 
  /trunk/KDE/kdelibs/solid/solid/CMakeLists.txt 1201809 
  /trunk/KDE/kdelibs/solid/solid/backends/udev/udevblock.h PRE-CREATION 
  /trunk/KDE/kdelibs/solid/solid/backends/udev/udevblock.cpp PRE-CREATION 
  /trunk/KDE/kdelibs/solid/solid/backends/udev/udevdevice.cpp 1201809 
  /trunk/KDE/kdelibs/solid/solid/backends/udev/udevmanager.cpp 1201809 

Diff: http://svn.reviewboard.kde.org/r/6004/diff


Testing
---


Thanks,

Matthias



Re: Review Request: Adds method to KBookmarkManager disable showing dialogs on errors.

2010-11-30 Thread Matthias Fuchs


> On 2010-11-29 00:08:22, Albert Astals Cid wrote:
> > Why did you change the if/else logic? Also you added another kError when 
> > there was an existing one already.
> > 
> > Also as commented on IRC maybe it would make sense to emit a signal to warn 
> > whoever might be interested that an error happened
> 
> Matthias Fuchs wrote:
> I changed that to always have a useful debug output. The second one is 
> there to make it easier if there are bug reports, as it is hard to work with 
> translated messages, especially if they are quite important. So not the whole 
> message is translated, probably I should us an error code there, as 
> file.errorString() is translated.

Btw. on the signal.

Should it just be an "void error()" signal or a "void 
error(translatedErrorMessage)" one?


- Matthias


---
This is an automatically generated e-mail. To reply, visit:
http://svn.reviewboard.kde.org/r/6004/#review9034
---


On 2010-11-28 21:00:30, Matthias Fuchs wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> http://svn.reviewboard.kde.org/r/6004/
> ---
> 
> (Updated 2010-11-28 21:00:30)
> 
> 
> Review request for kdelibs and David Faure.
> 
> 
> Summary
> ---
> 
> Adds method to KBookmarkManager disable showing dialogs on errors.
> This way it is possible to deactivate those messages if KBoomarkManager is 
> not run in the gui thread.
> BUG:207592
> 
> 
> Diffs
> -
> 
>   /trunk/KDE/kdelibs/kio/bookmarks/kbookmarkmanager.h 1201809 
>   /trunk/KDE/kdelibs/kio/bookmarks/kbookmarkmanager.cc 1201809 
> 
> Diff: http://svn.reviewboard.kde.org/r/6004/diff
> 
> 
> Testing
> ---
> 
> 
> Thanks,
> 
> Matthias
> 
>



Re: Review Request: Adds method to KBookmarkManager disable showing dialogs on errors.

2010-11-29 Thread Matthias Fuchs


> On 2010-11-29 00:08:22, Albert Astals Cid wrote:
> > Why did you change the if/else logic? Also you added another kError when 
> > there was an existing one already.
> > 
> > Also as commented on IRC maybe it would make sense to emit a signal to warn 
> > whoever might be interested that an error happened

I changed that to always have a useful debug output. The second one is there to 
make it easier if there are bug reports, as it is hard to work with translated 
messages, especially if they are quite important. So not the whole message is 
translated, probably I should us an error code there, as file.errorString() is 
translated.


- Matthias


---
This is an automatically generated e-mail. To reply, visit:
http://svn.reviewboard.kde.org/r/6004/#review9034
---


On 2010-11-28 21:00:30, Matthias Fuchs wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> http://svn.reviewboard.kde.org/r/6004/
> ---
> 
> (Updated 2010-11-28 21:00:30)
> 
> 
> Review request for kdelibs and David Faure.
> 
> 
> Summary
> ---
> 
> Adds method to KBookmarkManager disable showing dialogs on errors.
> This way it is possible to deactivate those messages if KBoomarkManager is 
> not run in the gui thread.
> BUG:207592
> 
> 
> Diffs
> -
> 
>   /trunk/KDE/kdelibs/kio/bookmarks/kbookmarkmanager.h 1201809 
>   /trunk/KDE/kdelibs/kio/bookmarks/kbookmarkmanager.cc 1201809 
> 
> Diff: http://svn.reviewboard.kde.org/r/6004/diff
> 
> 
> Testing
> ---
> 
> 
> Thanks,
> 
> Matthias
> 
>



Re: Review Request: Adds method to KBookmarkManager disable showing dialogs on errors.

2010-11-28 Thread Albert Astals Cid

---
This is an automatically generated e-mail. To reply, visit:
http://svn.reviewboard.kde.org/r/6004/#review9034
---


Why did you change the if/else logic? Also you added another kError when there 
was an existing one already.

Also as commented on IRC maybe it would make sense to emit a signal to warn 
whoever might be interested that an error happened

- Albert


On 2010-11-28 21:00:30, Matthias Fuchs wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> http://svn.reviewboard.kde.org/r/6004/
> ---
> 
> (Updated 2010-11-28 21:00:30)
> 
> 
> Review request for kdelibs and David Faure.
> 
> 
> Summary
> ---
> 
> Adds method to KBookmarkManager disable showing dialogs on errors.
> This way it is possible to deactivate those messages if KBoomarkManager is 
> not run in the gui thread.
> BUG:207592
> 
> 
> Diffs
> -
> 
>   /trunk/KDE/kdelibs/kio/bookmarks/kbookmarkmanager.h 1201809 
>   /trunk/KDE/kdelibs/kio/bookmarks/kbookmarkmanager.cc 1201809 
> 
> Diff: http://svn.reviewboard.kde.org/r/6004/diff
> 
> 
> Testing
> ---
> 
> 
> Thanks,
> 
> Matthias
> 
>



Re: Review Request: Adds method to KBookmarkManager disable showing dialogs on errors.

2010-11-28 Thread Matthias Fuchs

---
This is an automatically generated e-mail. To reply, visit:
http://svn.reviewboard.kde.org/r/6004/
---

(Updated 2010-11-28 21:00:30.131444)


Review request for kdelibs and David Faure.


Changes
---

Changed the name of the method to setDialogsAllowed.


Summary
---

Adds method to KBookmarkManager disable showing dialogs on errors.
This way it is possible to deactivate those messages if KBoomarkManager is not 
run in the gui thread.
BUG:207592


Diffs (updated)
-

  /trunk/KDE/kdelibs/kio/bookmarks/kbookmarkmanager.h 1201809 
  /trunk/KDE/kdelibs/kio/bookmarks/kbookmarkmanager.cc 1201809 

Diff: http://svn.reviewboard.kde.org/r/6004/diff


Testing
---


Thanks,

Matthias



Re: Review Request: Adds method to KBookmarkManager disable showing dialogs on errors.

2010-11-28 Thread Chani Armitage

---
This is an automatically generated e-mail. To reply, visit:
http://svn.reviewboard.kde.org/r/6004/#review9021
---


one tiny thing: calling it setDialogsAllowed would be clearer than 
setDialogsActive.

I'd check 'ship it' but this isn't my code at all :)

- Chani


On 2010-11-28 19:53:45, Matthias Fuchs wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> http://svn.reviewboard.kde.org/r/6004/
> ---
> 
> (Updated 2010-11-28 19:53:45)
> 
> 
> Review request for kdelibs and David Faure.
> 
> 
> Summary
> ---
> 
> Adds method to KBookmarkManager disable showing dialogs on errors.
> This way it is possible to deactivate those messages if KBoomarkManager is 
> not run in the gui thread.
> BUG:207592
> 
> 
> Diffs
> -
> 
>   /trunk/KDE/kdelibs/kio/bookmarks/kbookmarkmanager.h 1201809 
>   /trunk/KDE/kdelibs/kio/bookmarks/kbookmarkmanager.cc 1201809 
> 
> Diff: http://svn.reviewboard.kde.org/r/6004/diff
> 
> 
> Testing
> ---
> 
> 
> Thanks,
> 
> Matthias
> 
>



Review Request: Adds method to KBookmarkManager disable showing dialogs on errors.

2010-11-28 Thread Matthias Fuchs

---
This is an automatically generated e-mail. To reply, visit:
http://svn.reviewboard.kde.org/r/6004/
---

Review request for kdelibs and David Faure.


Summary
---

Adds method to KBookmarkManager disable showing dialogs on errors.
This way it is possible to deactivate those messages if KBoomarkManager is not 
run in the gui thread.
BUG:207592


Diffs
-

  /trunk/KDE/kdelibs/kio/bookmarks/kbookmarkmanager.h 1201809 
  /trunk/KDE/kdelibs/kio/bookmarks/kbookmarkmanager.cc 1201809 

Diff: http://svn.reviewboard.kde.org/r/6004/diff


Testing
---


Thanks,

Matthias