Re: [WISPA] Hotel Redirect

2011-01-07 Thread Nick Olsen
Blake, This worked perfect. Anything using dst-nat was un-reliable as the 
browser would cache the page, So even since they were past the redirect 
part, The local machine would still load the same page for whatever site 
the person requested originally. However, using web-proxy it redirects the 
request perfectly.

I appreciate all the help I got on this one. Thanks to everyone.

Nick Olsen
Network Operations
(855) FLSPEED  x106



From: Blake Covarrubias bl...@beamspeed.com
Sent: Thursday, January 06, 2011 5:09 PM
To: WISPA General List wireless@wispa.org
Subject: Re: [WISPA] Hotel Redirect

How about this?

/ip firewall nat
add chain=dstnat in-interface=ether2 protocol=tcp dst-port=80 action=accept 
src-address-list=proxy-bypass
add chain=dstnat in-interface=ether2 protocol=tcp dst-port=80 
action=add-src-to-address-list address-list=proxy-bypass 
address-list-timeout=1d 
add chain=dstnat in-interface=ether2 protocol=tcp dst-port=80 
action=redirect to-ports=8080

/ip proxy
set enabled=yes port=8080

/ip proxy access
add dst-port=80 action=allow dst-host=www.hotel.tld
add dst-port=80 action=deny redirect-to=www.hotel.tld

If you're not using proxy for anything else then it works great. Although, 
it does not allow them to simply reload the page to reach the URL they 
initially intended. The user would have to issue a totally new request to 
see the content they desire.

--
Blake Covarrubias
Network Manager / IT Consultant
Beamspeed, LLC

On Jan 6, 2011, at 1:41 PM, David E. Smith wrote:

 
 
 On Thu, Jan 6, 2011 at 14:20, Nick Olsen n...@flhsi.com wrote:
 Normally Hotspot works with a I accept button on a page, As thats what 
we have done in the past. I don't mind getting a call when a user has a 
tivo/gamesystem/* that can't login as they can read me the mac and I can 
bypass it.
 The point with this is it goes to a page we don't control, And can't 
really change at all.
 
 Could you do something crazy like put their site in an iframe? Have the 
parent page include their mandatory page, and a bit of JavaScript. That 
JavaScript has their MAC embedded in a link, using the same sort of link as 
the click to accept TOS link, which auto-refreshes after one second (thus 
logging them in as though they'd clicked that link themselves). Then add 
their page (and whatever other things it uses) to the walled-garden.
 
 Yes, this fails if they disable JavaScript, but it's a reasonable price 
to pay.
 
 David Smith
 MVN.net
 
 
 
 


 WISPA Wants You! Join today!
 http://signup.wispa.org/
 


 
 WISPA Wireless List: wireless@wispa.org
 
 Subscribe/Unsubscribe:
 http://lists.wispa.org/mailman/listinfo/wireless
 
 Archives: http://lists.wispa.org/pipermail/wireless/



WISPA Wants You! Join today!
http://signup.wispa.org/



WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/




WISPA Wants You! Join today!
http://signup.wispa.org/

 
WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/

[WISPA] Hotel Redirect

2011-01-06 Thread Nick Olsen
We are looking for a way to redirect hotel guests to the hotels home page 
on the first page load.
We are looking for something that does this in mikrotik because thats what 
we have on location already.
The idea is that the user connects up, Hits the internet and is redirected 
to a page. And then, On the next page load without hitting login or 
something they go to the page they requested. We use hotspot for our own 
stuff, And have used hotspot on this before using the trial function but 
this time around we don't control the page that the user is brought to. So 
we couldn't add some form of login button to it.
I've tried this with dst-nat rules and browser caching always gets in the 
way.
What is everyone else doing?

Nick Olsen
Network Operations
(855) FLSPEED  x106






WISPA Wants You! Join today!
http://signup.wispa.org/

 
WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/

Re: [WISPA] Hotel Redirect

2011-01-06 Thread Robert West
I was doing the same thing but after so many calls about whatever device
someone was trying to use that wouldn't go through the redirect, I turned it
off.  The final straw was some IBM people were having a meeting at the hotel
and were trying to use the wireless access for every big shot wireless
device one could think of.  Some would go but the ones that had to work in
secure mode wouldn't allow the redirect.  Bogus.  Turned it off and the
calls went away.

 

 

 

From: wireless-boun...@wispa.org [mailto:wireless-boun...@wispa.org] On
Behalf Of Nick Olsen
Sent: Thursday, January 06, 2011 1:46 PM
To: WISPA General List
Subject: [WISPA] Hotel Redirect

 

We are looking for a way to redirect hotel guests to the hotels home page on
the first page load.
We are looking for something that does this in mikrotik because thats what
we have on location already.
The idea is that the user connects up, Hits the internet and is redirected
to a page. And then, On the next page load without hitting login or
something they go to the page they requested. We use hotspot for our own
stuff, And have used hotspot on this before using the trial function but
this time around we don't control the page that the user is brought to. So
we couldn't add some form of login button to it.
I've tried this with dst-nat rules and browser caching always gets in the
way.
What is everyone else doing?

Nick Olsen
Network Operations 

(855) FLSPEED  x106

  http://www.flhsi.com/files/emaillogo.jpg 




WISPA Wants You! Join today!
http://signup.wispa.org/

 
WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/

Re: [WISPA] Hotel Redirect

2011-01-06 Thread Cameron Crum
What is the purpose? Is it just advertising for the hotel? If so, why not
just creat a page that looks like their page. It doesn't have to have all
the functionality of the real page, just a brochure page or something to
say thanks for staying with us. Then you could add a button that logs them
in (really just adds them as a generic user to the hotspot) so they can
continue on to their regular home page. Just an idea.

Cameron

On Thu, Jan 6, 2011 at 12:55 PM, Robert West robert.w...@just-micro.comwrote:

 I was doing the same thing but after so many calls about whatever device
 someone was trying to use that wouldn’t go through the redirect, I turned it
 off.  The final straw was some IBM people were having a meeting at the hotel
 and were trying to use the wireless access for every big shot wireless
 device one could think of.  Some would go but the ones that had to work in
 secure mode wouldn’t allow the redirect.  Bogus.  Turned it off and the
 calls went away.







 *From:* wireless-boun...@wispa.org [mailto:wireless-boun...@wispa.org] *On
 Behalf Of *Nick Olsen
 *Sent:* Thursday, January 06, 2011 1:46 PM
 *To:* WISPA General List
 *Subject:* [WISPA] Hotel Redirect



 We are looking for a way to redirect hotel guests to the hotels home page
 on the first page load.
 We are looking for something that does this in mikrotik because thats what
 we have on location already.
 The idea is that the user connects up, Hits the internet and is redirected
 to a page. And then, On the next page load without hitting login or
 something they go to the page they requested. We use hotspot for our own
 stuff, And have used hotspot on this before using the trial function but
 this time around we don't control the page that the user is brought to. So
 we couldn't add some form of login button to it.
 I've tried this with dst-nat rules and browser caching always gets in the
 way.
 What is everyone else doing?

 Nick Olsen
 Network Operations

 (855) FLSPEED  x106





 
 WISPA Wants You! Join today!
 http://signup.wispa.org/

 

 WISPA Wireless List: wireless@wispa.org

 Subscribe/Unsubscribe:
 http://lists.wispa.org/mailman/listinfo/wireless

 Archives: http://lists.wispa.org/pipermail/wireless/




WISPA Wants You! Join today!
http://signup.wispa.org/

 
WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/

Re: [WISPA] Hotel Redirect

2011-01-06 Thread Cameron Crum
You could also put in a link to the real hotel page and put that url in the
walled garden so they can hit it no matter what, even on the first try.

Cameron

On Thu, Jan 6, 2011 at 1:05 PM, Cameron Crum cc...@wispmon.com wrote:

 What is the purpose? Is it just advertising for the hotel? If so, why not
 just creat a page that looks like their page. It doesn't have to have all
 the functionality of the real page, just a brochure page or something to
 say thanks for staying with us. Then you could add a button that logs them
 in (really just adds them as a generic user to the hotspot) so they can
 continue on to their regular home page. Just an idea.

 Cameron

 On Thu, Jan 6, 2011 at 12:55 PM, Robert West 
 robert.w...@just-micro.comwrote:

 I was doing the same thing but after so many calls about whatever device
 someone was trying to use that wouldn’t go through the redirect, I turned it
 off.  The final straw was some IBM people were having a meeting at the hotel
 and were trying to use the wireless access for every big shot wireless
 device one could think of.  Some would go but the ones that had to work in
 secure mode wouldn’t allow the redirect.  Bogus.  Turned it off and the
 calls went away.







 *From:* wireless-boun...@wispa.org [mailto:wireless-boun...@wispa.org] *On
 Behalf Of *Nick Olsen
 *Sent:* Thursday, January 06, 2011 1:46 PM
 *To:* WISPA General List
 *Subject:* [WISPA] Hotel Redirect



 We are looking for a way to redirect hotel guests to the hotels home page
 on the first page load.
 We are looking for something that does this in mikrotik because thats what
 we have on location already.
 The idea is that the user connects up, Hits the internet and is redirected
 to a page. And then, On the next page load without hitting login or
 something they go to the page they requested. We use hotspot for our own
 stuff, And have used hotspot on this before using the trial function but
 this time around we don't control the page that the user is brought to. So
 we couldn't add some form of login button to it.
 I've tried this with dst-nat rules and browser caching always gets in the
 way.
 What is everyone else doing?

 Nick Olsen
 Network Operations

 (855) FLSPEED  x106





 
 WISPA Wants You! Join today!
 http://signup.wispa.org/

 

 WISPA Wireless List: wireless@wispa.org

 Subscribe/Unsubscribe:
 http://lists.wispa.org/mailman/listinfo/wireless

 Archives: http://lists.wispa.org/pipermail/wireless/






WISPA Wants You! Join today!
http://signup.wispa.org/

 
WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/

Re: [WISPA] Hotel Redirect

2011-01-06 Thread Nick Olsen
That would work for some of them, In this case, The hotel management company 
has a page that the hotel must redirect to. They get fined if it doesn't 
redirect to the companies specific page.
I'm thinking maybe load it in a frame, or something. And have a login button 
above it or something. Was hoping someone had a cleaner way.

Nick Olsen
Network Operations
(855) FLSPEED  x106



From: Cameron Crum cc...@wispmon.com
Sent: Thursday, January 06, 2011 2:04 PM
To: WISPA General List wireless@wispa.org
Subject: Re: [WISPA] Hotel Redirect

What is the purpose? Is it just advertising for the hotel? If so, why not just 
creat a page that looks like their page. It doesn't have to have all the 
functionality of the real page, just a brochure page or something to say 
thanks for staying with us. Then you could add a button that logs them in 
(really just adds them as a generic user to the hotspot) so they can continue 
on to their regular home page. Just an idea.

Cameron

On Thu, Jan 6, 2011 at 12:55 PM, Robert West robert.w...@just-micro.com wrote:



I was doing the same thing but after so many calls about whatever device 
someone was trying to use that wouldn't go through the redirect, I turned it 
off.  The final straw was some IBM people were having a meeting at the hotel 
and were trying to use the wireless access for every big shot wireless device 
one could think of.  Some would go but the ones that had to work in secure mode 
wouldn't allow the redirect.  Bogus.  Turned it off and the calls went away.




From: wireless-boun...@wispa.org [mailto:wireless-boun...@wispa.org] On Behalf 
Of Nick Olsen
Sent: Thursday, January 06, 2011 1:46 PM
To: WISPA General List
Subject: [WISPA] Hotel Redirect






We are looking for a way to redirect hotel guests to the hotels home page on 
the first page load.
We are looking for something that does this in mikrotik because thats what we 
have on location already.
The idea is that the user connects up, Hits the internet and is redirected to a 
page. And then, On the next page load without hitting login or something they 
go to the page they requested. We use hotspot for our own stuff, And have used 
hotspot on this before using the trial function but this time around we don't 
control the page that the user is brought to. So we couldn't add some form of 
login button to it.
I've tried this with dst-nat rules and browser caching always gets in the way.
What is everyone else doing?

Nick Olsen
Network Operations

(855) FLSPEED  x106


WISPA Wants You! Join today!
http://signup.wispa.org/


WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/





WISPA Wants You! Join today!
http://signup.wispa.org/

 
WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/

Re: [WISPA] Hotel Redirect

2011-01-06 Thread Robert West
At the beginning it was a disclaimer page that the hotel operator wanted to
have at the suggestion of his lawyer.  Basically it would say It's free but
everyone else is also on it and don't come crying to me if your computer or
finances get all jacked up.

 

The Patel wanted to try to make a buck and sell ad's on the splash page.  

 

But it's gone now.  Thankfully.

 

 

 

From: wireless-boun...@wispa.org [mailto:wireless-boun...@wispa.org] On
Behalf Of Cameron Crum
Sent: Thursday, January 06, 2011 2:05 PM
To: WISPA General List
Subject: Re: [WISPA] Hotel Redirect

 

What is the purpose? Is it just advertising for the hotel? If so, why not
just creat a page that looks like their page. It doesn't have to have all
the functionality of the real page, just a brochure page or something to
say thanks for staying with us. Then you could add a button that logs them
in (really just adds them as a generic user to the hotspot) so they can
continue on to their regular home page. Just an idea.

Cameron

On Thu, Jan 6, 2011 at 12:55 PM, Robert West robert.w...@just-micro.com
wrote:

I was doing the same thing but after so many calls about whatever device
someone was trying to use that wouldn't go through the redirect, I turned it
off.  The final straw was some IBM people were having a meeting at the hotel
and were trying to use the wireless access for every big shot wireless
device one could think of.  Some would go but the ones that had to work in
secure mode wouldn't allow the redirect.  Bogus.  Turned it off and the
calls went away.

 

 

 

From: wireless-boun...@wispa.org [mailto:wireless-boun...@wispa.org] On
Behalf Of Nick Olsen
Sent: Thursday, January 06, 2011 1:46 PM
To: WISPA General List
Subject: [WISPA] Hotel Redirect

 

We are looking for a way to redirect hotel guests to the hotels home page on
the first page load.
We are looking for something that does this in mikrotik because thats what
we have on location already.
The idea is that the user connects up, Hits the internet and is redirected
to a page. And then, On the next page load without hitting login or
something they go to the page they requested. We use hotspot for our own
stuff, And have used hotspot on this before using the trial function but
this time around we don't control the page that the user is brought to. So
we couldn't add some form of login button to it.
I've tried this with dst-nat rules and browser caching always gets in the
way.
What is everyone else doing?

Nick Olsen
Network Operations 

(855) FLSPEED  x106

Error! Filename not specified.






WISPA Wants You! Join today!
http://signup.wispa.org/



WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/

 




WISPA Wants You! Join today!
http://signup.wispa.org/

 
WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/

Re: [WISPA] Hotel Redirect

2011-01-06 Thread David E. Smith
On Thu, Jan 6, 2011 at 13:31, Nick Olsen n...@flhsi.com wrote:

 That would work for some of them, In this case, The hotel management
 company has a page that the hotel must redirect to. They get fined if it
 doesn't redirect to the companies specific page.
 I'm thinking maybe load it in a frame, or something. And have a login
 button above it or something. Was hoping someone had a cleaner way.



I'm doing something very similar to this. I just put the whole mandatory
page on the Mikrotik box itself, and made the I agree to the TOS link into
a silently log this MAC into the hotspot for 24 hours link.

David Smith
MVN.net



WISPA Wants You! Join today!
http://signup.wispa.org/

 
WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/

Re: [WISPA] Hotel Redirect

2011-01-06 Thread Robert West
The problem that I was seeing was that there are many wireless devices now
that don't have any screen to see a login button.  Game systems being the
first on my mind.  In hotels, some guests bring their kids game system to
keep them from running the halls..  How can you get these basically blind
systems to punch through a page like that?

 

I never had the time to get the workaround.

 

 

From: wireless-boun...@wispa.org [mailto:wireless-boun...@wispa.org] On
Behalf Of Nick Olsen
Sent: Thursday, January 06, 2011 2:31 PM
To: WISPA General List
Subject: Re: [WISPA] Hotel Redirect

 

That would work for some of them, In this case, The hotel management company
has a page that the hotel must redirect to. They get fined if it doesn't
redirect to the companies specific page.
I'm thinking maybe load it in a frame, or something. And have a login button
above it or something. Was hoping someone had a cleaner way.

Nick Olsen
Network Operations 

(855) FLSPEED  x106

  http://www.flhsi.com/files/emaillogo.jpg 

 

  _  

From: Cameron Crum cc...@wispmon.com
Sent: Thursday, January 06, 2011 2:04 PM
To: WISPA General List wireless@wispa.org
Subject: Re: [WISPA] Hotel Redirect

What is the purpose? Is it just advertising for the hotel? If so, why not
just creat a page that looks like their page. It doesn't have to have all
the functionality of the real page, just a brochure page or something to
say thanks for staying with us. Then you could add a button that logs them
in (really just adds them as a generic user to the hotspot) so they can
continue on to their regular home page. Just an idea.

Cameron

On Thu, Jan 6, 2011 at 12:55 PM, Robert West robert.w...@just-micro.com
wrote:

I was doing the same thing but after so many calls about whatever device
someone was trying to use that wouldn't go through the redirect, I turned it
off.  The final straw was some IBM people were having a meeting at the hotel
and were trying to use the wireless access for every big shot wireless
device one could think of.  Some would go but the ones that had to work in
secure mode wouldn't allow the redirect.  Bogus.  Turned it off and the
calls went away.

 

 

 

From: wireless-boun...@wispa.org [mailto:wireless-boun...@wispa.org] On
Behalf Of Nick Olsen
Sent: Thursday, January 06, 2011 1:46 PM
To: WISPA General List
Subject: [WISPA] Hotel Redirect

 

We are looking for a way to redirect hotel guests to the hotels home page on
the first page load.
We are looking for something that does this in mikrotik because thats what
we have on location already.
The idea is that the user connects up, Hits the internet and is redirected
to a page. And then, On the next page load without hitting login or
something they go to the page they requested. We use hotspot for our own
stuff, And have used hotspot on this before using the trial function but
this time around we don't control the page that the user is brought to. So
we couldn't add some form of login button to it.
I've tried this with dst-nat rules and browser caching always gets in the
way.
What is everyone else doing?

Nick Olsen
Network Operations 

(855) FLSPEED  x106

Error! Filename not specified.






WISPA Wants You! Join today!
http://signup.wispa.org/



WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/

 




WISPA Wants You! Join today!
http://signup.wispa.org/

 
WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/

Re: [WISPA] Hotel Redirect

2011-01-06 Thread David E. Smith
On Thu, Jan 6, 2011 at 13:45, Robert West robert.w...@just-micro.comwrote:

 The problem that I was seeing was that there are many wireless devices now
 that don’t have any “screen” to see a login button.  Game systems being the
 first on my mind.  In hotels, some guests bring their kids game system to
 keep them from running the halls……  How can you get these basically blind
 systems to punch through a page like that?


I suppose, in that case, you could keep a few wireless bridges around to
lend to guests, with crossover cables, with their MACs already
pre-authorized. (Might have to have it do NAT, so the AP only sees its MAC
and not the MAC of the Xbox or whatever. Depends on the device.)

Or get the system's MAC, but that adds a lot of extra complications (your
hotel clerks now need to know how to get that information from every device
ever made, and how to add the MAC to an ACL somewhere).

David Smith
MVN.net



WISPA Wants You! Join today!
http://signup.wispa.org/

 
WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/

Re: [WISPA] Hotel Redirect

2011-01-06 Thread Robert West
Possibly a simple screen the desk people can use to see what MAC ID is
attempting to login and do a manual authorize?  

 

It's in my mind now  That's a relief.  Finally not thinking about where
baby oil comes from..

 

 

 

From: wireless-boun...@wispa.org [mailto:wireless-boun...@wispa.org] On
Behalf Of Robert West
Sent: Thursday, January 06, 2011 2:46 PM
To: n...@flhsi.com; 'WISPA General List'
Subject: Re: [WISPA] Hotel Redirect

 

The problem that I was seeing was that there are many wireless devices now
that don't have any screen to see a login button.  Game systems being the
first on my mind.  In hotels, some guests bring their kids game system to
keep them from running the halls..  How can you get these basically blind
systems to punch through a page like that?

 

I never had the time to get the workaround.

 

 

From: wireless-boun...@wispa.org [mailto:wireless-boun...@wispa.org] On
Behalf Of Nick Olsen
Sent: Thursday, January 06, 2011 2:31 PM
To: WISPA General List
Subject: Re: [WISPA] Hotel Redirect

 

That would work for some of them, In this case, The hotel management company
has a page that the hotel must redirect to. They get fined if it doesn't
redirect to the companies specific page.
I'm thinking maybe load it in a frame, or something. And have a login button
above it or something. Was hoping someone had a cleaner way.

Nick Olsen
Network Operations 

(855) FLSPEED  x106

  http://www.flhsi.com/files/emaillogo.jpg 

 

  _  

From: Cameron Crum cc...@wispmon.com
Sent: Thursday, January 06, 2011 2:04 PM
To: WISPA General List wireless@wispa.org
Subject: Re: [WISPA] Hotel Redirect

What is the purpose? Is it just advertising for the hotel? If so, why not
just creat a page that looks like their page. It doesn't have to have all
the functionality of the real page, just a brochure page or something to
say thanks for staying with us. Then you could add a button that logs them
in (really just adds them as a generic user to the hotspot) so they can
continue on to their regular home page. Just an idea.

Cameron

On Thu, Jan 6, 2011 at 12:55 PM, Robert West robert.w...@just-micro.com
wrote:

I was doing the same thing but after so many calls about whatever device
someone was trying to use that wouldn't go through the redirect, I turned it
off.  The final straw was some IBM people were having a meeting at the hotel
and were trying to use the wireless access for every big shot wireless
device one could think of.  Some would go but the ones that had to work in
secure mode wouldn't allow the redirect.  Bogus.  Turned it off and the
calls went away.

 

 

 

From: wireless-boun...@wispa.org [mailto:wireless-boun...@wispa.org] On
Behalf Of Nick Olsen
Sent: Thursday, January 06, 2011 1:46 PM
To: WISPA General List
Subject: [WISPA] Hotel Redirect

 

We are looking for a way to redirect hotel guests to the hotels home page on
the first page load.
We are looking for something that does this in mikrotik because thats what
we have on location already.
The idea is that the user connects up, Hits the internet and is redirected
to a page. And then, On the next page load without hitting login or
something they go to the page they requested. We use hotspot for our own
stuff, And have used hotspot on this before using the trial function but
this time around we don't control the page that the user is brought to. So
we couldn't add some form of login button to it.
I've tried this with dst-nat rules and browser caching always gets in the
way.
What is everyone else doing?

Nick Olsen
Network Operations 

(855) FLSPEED  x106

Error! Filename not specified.






WISPA Wants You! Join today!
http://signup.wispa.org/



WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/

 




WISPA Wants You! Join today!
http://signup.wispa.org/

 
WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/

Re: [WISPA] Hotel Redirect

2011-01-06 Thread Nick Olsen
Normally Hotspot works with a I accept button on a page, As thats what we 
have done in the past. I don't mind getting a call when a user has a 
tivo/gamesystem/* that can't login as they can read me the mac and I can bypass 
it.
The point with this is it goes to a page we don't control, And can't really 
change at all.

Nick Olsen
Network Operations
(855) FLSPEED  x106



From: Robert West robert.w...@just-micro.com
Sent: Thursday, January 06, 2011 2:49 PM
To: WISPA General List wireless@wispa.org
Subject: Re: [WISPA] Hotel Redirect



Possibly a simple screen the desk people can use to see what MAC ID is 
attempting to login and do a manual authorize?

It's in my mind now  That's a relief.  Finally not thinking about where 
baby oil comes from..





From: wireless-boun...@wispa.org [mailto:wireless-boun...@wispa.org] On Behalf 
Of Robert West
Sent: Thursday, January 06, 2011 2:46 PM
To: n...@flhsi.com; 'WISPA General List'
Subject: Re: [WISPA] Hotel Redirect



The problem that I was seeing was that there are many wireless devices now that 
don't have any screen to see a login button.  Game systems being the first on 
my mind.  In hotels, some guests bring their kids game system to keep them from 
running the halls..  How can you get these basically blind systems to punch 
through a page like that?

I never had the time to get the workaround.



From: wireless-boun...@wispa.org [mailto:wireless-boun...@wispa.org] On Behalf 
Of Nick Olsen
Sent: Thursday, January 06, 2011 2:31 PM
To: WISPA General List
Subject: Re: [WISPA] Hotel Redirect


That would work for some of them, In this case, The hotel management company 
has a page that the hotel must redirect to. They get fined if it doesn't 
redirect to the companies specific page.
I'm thinking maybe load it in a frame, or something. And have a login button 
above it or something. Was hoping someone had a cleaner way.

Nick Olsen
Network Operations

(855) FLSPEED  x106









From: Cameron Crum cc...@wispmon.com
Sent: Thursday, January 06, 2011 2:04 PM
To: WISPA General List wireless@wispa.org
Subject: Re: [WISPA] Hotel Redirect

What is the purpose? Is it just advertising for the hotel? If so, why not just 
creat a page that looks like their page. It doesn't have to have all the 
functionality of the real page, just a brochure page or something to say 
thanks for staying with us. Then you could add a button that logs them in 
(really just adds them as a generic user to the hotspot) so they can continue 
on to their regular home page. Just an idea.

Cameron

On Thu, Jan 6, 2011 at 12:55 PM, Robert West robert.w...@just-micro.com wrote:


I was doing the same thing but after so many calls about whatever device 
someone was trying to use that wouldn't go through the redirect, I turned it 
off.  The final straw was some IBM people were having a meeting at the hotel 
and were trying to use the wireless access for every big shot wireless device 
one could think of.  Some would go but the ones that had to work in secure mode 
wouldn't allow the redirect.  Bogus.  Turned it off and the calls went away.




From: wireless-boun...@wispa.org [mailto:wireless-boun...@wispa.org] On Behalf 
Of Nick Olsen
Sent: Thursday, January 06, 2011 1:46 PM
To: WISPA General List
Subject: [WISPA] Hotel Redirect




We are looking for a way to redirect hotel guests to the hotels home page on 
the first page load.
We are looking for something that does this in mikrotik because thats what we 
have on location already.
The idea is that the user connects up, Hits the internet and is redirected to a 
page. And then, On the next page load without hitting login or something they 
go to the page they requested. We use hotspot for our own stuff, And have used 
hotspot on this before using the trial function but this time around we don't 
control the page that the user is brought to. So we couldn't add some form of 
login button to it.
I've tried this with dst-nat rules and browser caching always gets in the way.
What is everyone else doing?

Nick Olsen
Network Operations

(855) FLSPEED  x106

Error! Filename not specified.









WISPA Wants You! Join today!
http://signup.wispa.org/


WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/






WISPA Wants You! Join today!
http://signup.wispa.org/

 
WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/

Re: [WISPA] Hotel Redirect

2011-01-06 Thread Robert West
I hear ya, brother.  I hear ya.  These hotel higher ups need to get with the
Now on this wireless.  

 

 

 

From: wireless-boun...@wispa.org [mailto:wireless-boun...@wispa.org] On
Behalf Of Nick Olsen
Sent: Thursday, January 06, 2011 3:21 PM
To: WISPA General List
Subject: Re: [WISPA] Hotel Redirect

 

Normally Hotspot works with a I accept button on a page, As thats what we
have done in the past. I don't mind getting a call when a user has a
tivo/gamesystem/* that can't login as they can read me the mac and I can
bypass it.
The point with this is it goes to a page we don't control, And can't really
change at all.

Nick Olsen
Network Operations 

(855) FLSPEED  x106

  http://www.flhsi.com/files/emaillogo.jpg 

 

  _  

From: Robert West robert.w...@just-micro.com
Sent: Thursday, January 06, 2011 2:49 PM
To: WISPA General List wireless@wispa.org
Subject: Re: [WISPA] Hotel Redirect

Possibly a simple screen the desk people can use to see what MAC ID is
attempting to login and do a manual authorize?  

 

It's in my mind now  That's a relief.  Finally not thinking about where
baby oil comes from..

 

 

 

From: wireless-boun...@wispa.org [mailto:wireless-boun...@wispa.org] On
Behalf Of Robert West
Sent: Thursday, January 06, 2011 2:46 PM
To: n...@flhsi.com; 'WISPA General List'
Subject: Re: [WISPA] Hotel Redirect

 

The problem that I was seeing was that there are many wireless devices now
that don't have any screen to see a login button.  Game systems being the
first on my mind.  In hotels, some guests bring their kids game system to
keep them from running the halls..  How can you get these basically blind
systems to punch through a page like that?

 

I never had the time to get the workaround.

 

 

From: wireless-boun...@wispa.org [mailto:wireless-boun...@wispa.org] On
Behalf Of Nick Olsen
Sent: Thursday, January 06, 2011 2:31 PM
To: WISPA General List
Subject: Re: [WISPA] Hotel Redirect

 

That would work for some of them, In this case, The hotel management company
has a page that the hotel must redirect to. They get fined if it doesn't
redirect to the companies specific page.
I'm thinking maybe load it in a frame, or something. And have a login button
above it or something. Was hoping someone had a cleaner way.

Nick Olsen
Network Operations 

(855) FLSPEED  x106

  http://www.flhsi.com/files/emaillogo.jpg 

 

  _  

From: Cameron Crum cc...@wispmon.com
Sent: Thursday, January 06, 2011 2:04 PM
To: WISPA General List wireless@wispa.org
Subject: Re: [WISPA] Hotel Redirect

What is the purpose? Is it just advertising for the hotel? If so, why not
just creat a page that looks like their page. It doesn't have to have all
the functionality of the real page, just a brochure page or something to
say thanks for staying with us. Then you could add a button that logs them
in (really just adds them as a generic user to the hotspot) so they can
continue on to their regular home page. Just an idea.

Cameron

On Thu, Jan 6, 2011 at 12:55 PM, Robert West robert.w...@just-micro.com
wrote:

I was doing the same thing but after so many calls about whatever device
someone was trying to use that wouldn't go through the redirect, I turned it
off.  The final straw was some IBM people were having a meeting at the hotel
and were trying to use the wireless access for every big shot wireless
device one could think of.  Some would go but the ones that had to work in
secure mode wouldn't allow the redirect.  Bogus.  Turned it off and the
calls went away.

 

 

 

From: wireless-boun...@wispa.org [mailto:wireless-boun...@wispa.org] On
Behalf Of Nick Olsen
Sent: Thursday, January 06, 2011 1:46 PM
To: WISPA General List
Subject: [WISPA] Hotel Redirect

 

We are looking for a way to redirect hotel guests to the hotels home page on
the first page load.
We are looking for something that does this in mikrotik because thats what
we have on location already.
The idea is that the user connects up, Hits the internet and is redirected
to a page. And then, On the next page load without hitting login or
something they go to the page they requested. We use hotspot for our own
stuff, And have used hotspot on this before using the trial function but
this time around we don't control the page that the user is brought to. So
we couldn't add some form of login button to it.
I've tried this with dst-nat rules and browser caching always gets in the
way.
What is everyone else doing?

Nick Olsen
Network Operations 

(855) FLSPEED  x106

Error! Filename not specified.






WISPA Wants You! Join today!
http://signup.wispa.org/



WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless

Re: [WISPA] Hotel Redirect

2011-01-06 Thread David E. Smith
On Thu, Jan 6, 2011 at 14:20, Nick Olsen n...@flhsi.com wrote:

 Normally Hotspot works with a I accept button on a page, As thats what we
 have done in the past. I don't mind getting a call when a user has a
 tivo/gamesystem/* that can't login as they can read me the mac and I can
 bypass it.
 The point with this is it goes to a page we don't control, And can't really
 change at all.


Could you do something crazy like put their site in an iframe? Have the
parent page include their mandatory page, and a bit of JavaScript. That
JavaScript has their MAC embedded in a link, using the same sort of link as
the click to accept TOS link, which auto-refreshes after one second (thus
logging them in as though they'd clicked that link themselves). Then add
their page (and whatever other things it uses) to the walled-garden.

Yes, this fails if they disable JavaScript, but it's a reasonable price to
pay.

David Smith
MVN.net



WISPA Wants You! Join today!
http://signup.wispa.org/

 
WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/

Re: [WISPA] Hotel Redirect

2011-01-06 Thread Blake Covarrubias
How about this?

/ip firewall nat
add chain=dstnat in-interface=ether2 protocol=tcp dst-port=80 action=accept 
src-address-list=proxy-bypass
add chain=dstnat in-interface=ether2 protocol=tcp dst-port=80 
action=add-src-to-address-list address-list=proxy-bypass 
address-list-timeout=1d 
add chain=dstnat in-interface=ether2 protocol=tcp dst-port=80 action=redirect 
to-ports=8080

/ip proxy
set enabled=yes port=8080

/ip proxy access
add dst-port=80 action=allow dst-host=www.hotel.tld
add dst-port=80 action=deny redirect-to=www.hotel.tld

If you're not using proxy for anything else then it works great. Although, it 
does not allow them to simply reload the page to reach the URL they initially 
intended. The user would have to issue a totally new request to see the content 
they desire.

--
Blake Covarrubias
Network Manager / IT Consultant
Beamspeed, LLC

On Jan 6, 2011, at 1:41 PM, David E. Smith wrote:

 
 
 On Thu, Jan 6, 2011 at 14:20, Nick Olsen n...@flhsi.com wrote:
 Normally Hotspot works with a I accept button on a page, As thats what we 
 have done in the past. I don't mind getting a call when a user has a 
 tivo/gamesystem/* that can't login as they can read me the mac and I can 
 bypass it.
 The point with this is it goes to a page we don't control, And can't really 
 change at all.
 
 Could you do something crazy like put their site in an iframe? Have the 
 parent page include their mandatory page, and a bit of JavaScript. That 
 JavaScript has their MAC embedded in a link, using the same sort of link as 
 the click to accept TOS link, which auto-refreshes after one second (thus 
 logging them in as though they'd clicked that link themselves). Then add 
 their page (and whatever other things it uses) to the walled-garden.
 
 Yes, this fails if they disable JavaScript, but it's a reasonable price to 
 pay.
 
 David Smith
 MVN.net
 
 
 
 
 WISPA Wants You! Join today!
 http://signup.wispa.org/
 
 
 WISPA Wireless List: wireless@wispa.org
 
 Subscribe/Unsubscribe:
 http://lists.wispa.org/mailman/listinfo/wireless
 
 Archives: http://lists.wispa.org/pipermail/wireless/




WISPA Wants You! Join today!
http://signup.wispa.org/

 
WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/


Re: [WISPA] Hotel Redirect

2011-01-06 Thread Sam Tetherow

Would something like this work?

If you used a large enough pool of IPs.
DHCP with a 24 hour expire time.
Then basically:


1) src-address-list=SEEN and out-interface=INTERNET passthrough=no 
action=accept


2) action=add-to-address-list address-list=SEEN address-list-timeout=24h 
passthrough=yes


3) redirect

So the first time through it doesn't match the accept in rule 1), 
instead it gets added to the address list (rule 2) and redirected (rule 
3).  Then all subsequent traffic for the next 24hours matches the first 
rule and is accepted by rule 1.


Sam Tetherow
Sandhills Wireless

On 1/6/11 2:41 PM, David E. Smith wrote:



On Thu, Jan 6, 2011 at 14:20, Nick Olsen n...@flhsi.com 
mailto:n...@flhsi.com wrote:


Normally Hotspot works with a I accept button on a page, As
thats what we have done in the past. I don't mind getting a call
when a user has a tivo/gamesystem/* that can't login as they can
read me the mac and I can bypass it.
The point with this is it goes to a page we don't control, And
can't really change at all.


Could you do something crazy like put their site in an iframe? Have 
the parent page include their mandatory page, and a bit of 
JavaScript. That JavaScript has their MAC embedded in a link, using 
the same sort of link as the click to accept TOS link, which 
auto-refreshes after one second (thus logging them in as though they'd 
clicked that link themselves). Then add their page (and whatever other 
things it uses) to the walled-garden.


Yes, this fails if they disable JavaScript, but it's a reasonable 
price to pay.


David Smith
MVN.net





WISPA Wants You! Join today!
http://signup.wispa.org/


WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/





WISPA Wants You! Join today!
http://signup.wispa.org/

 
WISPA Wireless List: wireless@wispa.org

Subscribe/Unsubscribe:
http://lists.wispa.org/mailman/listinfo/wireless

Archives: http://lists.wispa.org/pipermail/wireless/