Re: Base64OutputStream needs a cleanup

2006-11-14 Thread Arjuna Wijeyekoon
/stream in the chain. Why was it that the test failed? let me take a look at the test. --arjuna On 11/9/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: thanks guys. http://issues.apache.org/jira/browse/ADFFACES-283 On 11/8/06, Simon Lessard [EMAIL PROTECTED] wrote: Yeah that would be a good

Re: [Question] trinidad-skins.xml in a jar

2006-11-13 Thread Arjuna Wijeyekoon
If you think the 'right' way is to have skin/customSkin.css work instead +1 for having skin/customSkin.css to work. then I could do this: when I get each trinidad-skins.xml in a jar, I get a path like this: /C:/TestJarTwo/forthebirds.jar!META-INF/trinidad-skins.xml I could strip out the part

Re: [Question] trinidad-skins.xml in a jar

2006-11-13 Thread Arjuna Wijeyekoon
also use URL(URL base, String cssFileName) to construct the path rather than parsing the string yourself. On 11/13/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: If you think the 'right' way is to have skin/customSkin.css work instead +1 for having skin/customSkin.css to work. then I

Re: [Question] trinidad-skins.xml in a jar

2006-11-13 Thread Arjuna Wijeyekoon
the other alternative is to declare the css file name to be globally unique like a java class name. On 11/13/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: also use URL(URL base, String cssFileName) to construct the path rather than parsing the string yourself. On 11/13/06, Arjuna Wijeyekoon

Re: Re: Re: make ValueMap public

2006-11-09 Thread Arjuna Wijeyekoon
PROTECTED] wrote: Shouldn't it be BidiMap? Not BidiHashMap? -- Adam On 11/8/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: http://issues.apache.org/jira/browse/ADFFACES-282 --arjuna On 11/8/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: Also, can I call this method getInvertedMap? MapV,K

Re: Base64OutputStream needs a cleanup

2006-11-09 Thread Arjuna Wijeyekoon
thanks guys. http://issues.apache.org/jira/browse/ADFFACES-283 On 11/8/06, Simon Lessard [EMAIL PROTECTED] wrote: Yeah that would be a good idea. On 11/9/06, Adam Winer [EMAIL PROTECTED] wrote: I agree, it'd be good to fix all those. -- Adam On 11/8/06, Arjuna Wijeyekoon [EMAIL

Re: Re: make ValueMap public

2006-11-08 Thread Arjuna Wijeyekoon
the public API dependency, but adds an implementation dependency. I don't know, though, if it's worth adding the dependency on commons-collections for this one feature. -- Adam On 10/27/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: underlying storage is HashMap. I just found

Re: Re: make ValueMap public

2006-11-08 Thread Arjuna Wijeyekoon
Also, can I call this method getInvertedMap? MapV,K BidiHashMapK,V.getInvertedMap() ? On 11/8/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: ok, since we can't use the commons-collections, let's make ValueMap public. I was going to call it ReverseHashMap, but since BidiMap seems to be more

Re: Re: make ValueMap public

2006-11-08 Thread Arjuna Wijeyekoon
http://issues.apache.org/jira/browse/ADFFACES-282 --arjuna On 11/8/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: Also, can I call this method getInvertedMap? MapV,K BidiHashMapK,V.getInvertedMap() ? On 11/8/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: ok, since we can't use the commons

Re: api cleanup for UIXCollection

2006-11-08 Thread Arjuna Wijeyekoon
/jira/browse/ADFFACES-270 On 10/30/06, Matthias Wessendorf [EMAIL PROTECTED] wrote: just saw that. thx! On 10/29/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: uploaded a patch http://issues.apache.org/jira/browse/ADFFACES-270 On 10/25/06, Simon Lessard [EMAIL PROTECTED] wrote: +1

Base64OutputStream needs a cleanup

2006-11-08 Thread Arjuna Wijeyekoon
The public class: org.apache.myfaces.trinidad.util.Base64OutputStream is annoying me. 1. it has a finish() method instead of a close() method. 2. it doesn't have a close() method at all. It should have one that delegates to the underlying Writer 3. it doesn't have a flush() method that

When notSerializableException is thrown it is hard to find the problem

2006-11-08 Thread Arjuna Wijeyekoon
Sometimes, when people use complete client-side state saving, or they passivate the HttpSession, they get a NotSerializableException thrown while Serializing the component state tree. Usually the cause is user error - the user did not use a ValueBinding to bind to some unSerializable object. It

deprecating methods

2006-11-08 Thread Arjuna Wijeyekoon
Usually method deprecation is done like: /** * @deprecated use the foobar method instead */ public void foo() In addition , do we have to do: /** * @deprecated use the foobar method instead */ @Deprecated public void foo() ??

Re: Re: Re: TreeTable focusRowKey

2006-10-31 Thread Arjuna Wijeyekoon
code in UIXTreeTable and utilities such as HierarchyUtils to handle a null focusRowKey (long-term) On 10/30/06, Adam Winer [EMAIL PROTECTED] wrote: On 10/30/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: +1 to moving the defaulting code to the renderer. However

Re: Re: TreeTable focusRowKey

2006-10-30 Thread Arjuna Wijeyekoon
+1 to moving the defaulting code to the renderer. However, the renderer must call setFocusRowKey on the component with the default value, so that decode/validate/update will work correctly. if the focusRowKey is null upon postback, it could cause errors during decode. --arjuna On 10/30/06, Adam

Re: Re: make ValueMap public

2006-10-27 Thread Arjuna Wijeyekoon
already has such a dependency. I don't know, though, if it's worth adding the dependency on commons-collections for this one feature. Does it make a difference if the trinidad-impl package already depends on this? --arjuna -- Adam On 10/27/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote

Re: Re: make ValueMap public

2006-10-27 Thread Arjuna Wijeyekoon
actually, i take that back. It appears that trinidad-impl does not use commons-collections any more. --arjuna On 10/27/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: On 10/27/06, Adam Winer [EMAIL PROTECTED] wrote: While I've no problem with using commons-collections internally, I'm very

Re: [ADFFACES-253] Make trinidad-config.xml location configurable in web.xml

2006-10-26 Thread Arjuna Wijeyekoon
-1 from me too. --arjuna On 10/26/06, Simon Lessard [EMAIL PROTECTED] wrote: Well, as far as I know, you cannot move web.xml so you can add a specification to that list and there's also the service provider standard that requires META-INF/services if I'm not mistaken. Trinidad cannot be used

Re: new validator: dateRestrictionValidator

2006-10-26 Thread Arjuna Wijeyekoon
I like the name DateRestrictionValidator --arjuna On 10/26/06, Adam Winer [EMAIL PROTECTED] wrote: +1 to the validator. Would definitely hope for client-side validation too! A tricky question from an API standpoint, though: for an inputText, you'd just add this validator. But for

Re: new validator: dateRestrictionValidator

2006-10-26 Thread Arjuna Wijeyekoon
Can you describe what type the three invalid attributes are? --arjuna On 10/25/06, Gabrielle Crawford [EMAIL PROTECTED] wrote: Hi, I'd like to add a new validator. My proposed name is DateRestrictionValidator, other suggestions welcome. This would support attributes like: invalidMonths -

Re: Re: Formatting locale vs. translation locale

2006-10-24 Thread Arjuna Wijeyekoon
I like #2 because: 1. no new public apis. 2. correct behaviour out-of-the-box 3. we won't get into a weird state where locale is english_uk, but someone programmatically sets formatting locale to english_us. --arjuna On 10/23/06, Adam Winer [EMAIL PROTECTED] wrote: Arash,

Re: Re: Re: Formatting locale vs. translation locale

2006-10-24 Thread Arjuna Wijeyekoon
On 10/24/06, Adam Winer [EMAIL PROTECTED] wrote: On 10/24/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: I like #2 because: 1. no new public apis. Maybe I didn't explain #2: in either case, we have a new public API. There's no way to add this feature without adding a public API

Re: move token map from UIXCollection to corresponding renderer

2006-10-18 Thread Arjuna Wijeyekoon
indefinitely (note that it grew indefinitely for these components, even before issue 210 was fixed). --arjuna On 10/16/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: I made a few minor changes to this as reported on http://issues.apache.org/jira/browse/ADFFACES-210 On 10/15/06, Arjuna Wijeyekoon [EMAIL

Re: move token map from UIXCollection to corresponding renderer

2006-10-16 Thread Arjuna Wijeyekoon
I made a few minor changes to this as reported on http://issues.apache.org/jira/browse/ADFFACES-210 On 10/15/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: I've updated http://issues.apache.org/jira/browse/ADFFACES-210 with this discussion and a patch. let me know what you think. On 10/9/06

Re: commandNavigationItem - recommend changing 2 properties

2006-10-16 Thread Arjuna Wijeyekoon
+1 to use just disabled and to drop readOnly On 10/16/06, Gabrielle Crawford [EMAIL PROTECTED] wrote: Hi, I have 3 thoughts about this. 1] I think navPane and breadcrumbs clearly only need 1 attribute. I actually thought they basically treat readOnly and disabled the same. 2] I can't think

Re: [Proposal] Always render navigation controls in tr:table if rows attribute 0

2006-10-13 Thread Arjuna Wijeyekoon
the number of rows to display per page, and whether or not you want the paging controls all the time are two separate things that should not be bundled into one attribute. I like Adam's proposal for a skinning property to control the latter. --arjuna On 10/13/06, Adam Winer [EMAIL PROTECTED]

Re: security issue w/ UIXEditableValue ?

2006-10-13 Thread Arjuna Wijeyekoon
I think you're right. I could have sworn that we were special-casing the required-validator; I even looked at the code in the old corporate repository, but this bug exists there. --arjuna On 10/13/06, Matthias Wessendorf [EMAIL PROTECTED] wrote: Hi please take a look at MYFACES-1467 which is

Re: move token map from UIXCollection to corresponding renderer

2006-10-09 Thread Arjuna Wijeyekoon
table, String clientRowKey); and UIXCollection has: public String getClientRowKey() public void setClientRowKey(String clientKey) protected final ClientRowKeyManager getClientRowKeyManager() Let me know your thoughts and I can start on this implementation. --arjuna On 10/7/06, Arjuna Wijeyekoon

Re: move token map from UIXCollection to corresponding renderer

2006-10-09 Thread Arjuna Wijeyekoon
sorry, that last method has to be public (Renderer needs access to it during encodeBegin to do pruning). so UIXCollection has: public String getClientRowKey() public void setClientRowKey(String clientKey) public final ClientRowKeyManager getClientRowKeyManager() On 10/9/06, Arjuna Wijeyekoon

Re: move token map from UIXCollection to corresponding renderer

2006-10-07 Thread Arjuna Wijeyekoon
I decided to call this ClientRowKeyManager: public String getClientRowKey(FacesContext, UIComponent table, Object rowKey); public Object getRowKey(FacesContext, UIComponent table, String clientRowKey); what d'ya think? On 10/4/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: If you're having

Re: move token map from UIXCollection to corresponding renderer

2006-10-07 Thread Arjuna Wijeyekoon
after this is checked in, I want to start a new thread to rename UIXCollection.get/setCurrencyString to UIXCollection.get/setClientRowKey does this make sense? On 10/7/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: I decided to call this ClientRowKeyManager: public String getClientRowKey

Re: ADFFACES-214: EditableValueRenderer does not handle EvaluationException in method getReadOnly

2006-10-06 Thread Arjuna Wijeyekoon
I agree with Adam, I think an Exception while calling any of the methods on ValueBinding (except for the setValue method) should be considered a bug in the application and logged at level WARNING. And in this case, we should return true to indicate that the binding is readOnly (opt for the more

Re: move token map from UIXCollection to corresponding renderer

2006-10-04 Thread Arjuna Wijeyekoon
getRowKeyManagingRenderer() hook up on UIXCollection that provides this? But after reading that second paragraph, I'm starting to doubt my first - maybe renderers won't always be the only way to hook this in, so it shouldn't have Renderer in the name? -- Adam On 9/29/06, Arjuna Wijeyekoon [EMAIL PROTECTED

Re: Possible bug in StateManager

2006-09-30 Thread Arjuna Wijeyekoon
in place. --arjuna On 9/29/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: http://issues.apache.org/jira/browse/ADFFACES-209 On 9/26/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: ok, I will file a JIRA issue for this and fix it this weekend. On 9/25/06, Alexander Smirnov [EMAIL PROTECTED

Re: move token map from UIXCollection to corresponding renderer

2006-09-29 Thread Arjuna Wijeyekoon
. The customized treeTable support might be much much more important, when all of the renderer api overhauls are done. can you nail this issue into Jira? Thanks! Matthias On 9/22/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: Folks, Currently the UIXCollection class (which is the super class

Re: move token map from UIXCollection to corresponding renderer

2006-09-29 Thread Arjuna Wijeyekoon
model. which do you think we should do? --arjuna On 9/29/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: http://issues.apache.org/jira/browse/ADFFACES-210 On 9/26/06, Matthias Wessendorf [EMAIL PROTECTED] wrote: sorry for the delay. Not sure if I got it completely, but your suggestion to move

Re: [Proposal] ProcessModel changes

2006-09-27 Thread Arjuna Wijeyekoon
dataModelClass) --arjuna On 9/27/06, Simon Lessard [EMAIL PROTECTED] wrote: Added some comments inline On 9/27/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: Hi, So I feel a little unhappy with putting things like label/readOnly (which are UI properties), visited/selected/disabled/outcome (which

Re: [Proposal] ProcessModel changes

2006-09-27 Thread Arjuna Wijeyekoon
or corresponding renderer? --arjuna However it would indeed requires some changes for UIComponent attribute autobinding. On 9/27/06, Simon Lessard [EMAIL PROTECTED] wrote: Hello Arjuna, On 9/27/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: Hi Simon, thanks for your reply. Could

Re: Possible bug in StateManager

2006-09-26 Thread Arjuna Wijeyekoon
ah, I see. makes sense, --arjuna On 9/25/06, Adam Winer [EMAIL PROTECTED] wrote: On 9/25/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: The preferred solution is making sure that we can simply cache the original UIViewRoot itself. But simply saving and restoring sufficient state

Re: Possible bug in StateManager

2006-09-26 Thread Arjuna Wijeyekoon
ok, I will file a JIRA issue for this and fix it this weekend. On 9/25/06, Alexander Smirnov [EMAIL PROTECTED] wrote: Two solutions for same problem breacks togewer :-) I have overriede UIViewRoot due to same problem, for keep evens queue ( also as uniqueId counter etc ) in own request-scope

Re: move token map from UIXCollection to corresponding renderer

2006-09-26 Thread Arjuna Wijeyekoon
ok, I will file a jira.

Re: Differences between read-only inputText and read-only selectOneChoice

2006-09-26 Thread Arjuna Wijeyekoon
inputText should act as outputText and produce same output. And if not there must be a good reason for this. Btw. tomahawk uses behavioral interface DisplayValueOnlyCapable for this. Martin Arjuna Wijeyekoon píše v Po 25. 09. 2006 v 18:02 -0700: Martin, why does it matter that these components

Re: move token map from UIXCollection to corresponding renderer

2006-09-24 Thread Arjuna Wijeyekoon
hi, anyone like to comment on this? feel free :) --arjuna On 9/22/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: Folks, Currently the UIXCollection class (which is the super class for table/tree/treeTable) maintains a mapping between Object rowkeys and String tokens. see private

Re: Process train and IE

2006-09-24 Thread Arjuna Wijeyekoon
is this IE 6 or IE 7? On 9/23/06, Simon Lessard [EMAIL PROTECTED] wrote: Hello all, As you might know, IE has some problems with composite selectors (.something.somethingElse for example, but more commonly .af_train_stop.p_AFVisited). With process train the most important issue it yield is

make UIXComponentBase.__broadcast a protected method

2006-09-22 Thread Arjuna Wijeyekoon
Does anyone mind if I make the following method in UIXComponentBase protected? It is a method that component extensions (and components in other packages) would find very useful. It is used to deliver a faces event to a method binding listener, as in the following: tr:commandButton

Re: make UIXComponentBase.__broadcast a protected method

2006-09-22 Thread Arjuna Wijeyekoon
? -- Adam On 9/22/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: Does anyone mind if I make the following method in UIXComponentBase protected? It is a method that component extensions (and components in other packages) would find very useful. It is used to deliver a faces event to a method

Re: make UIXComponentBase.__broadcast a protected method

2006-09-22 Thread Arjuna Wijeyekoon
http://issues.apache.org/jira/browse/ADFFACES-190 On 9/22/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: fine with me. I'll file a jira On 9/22/06, Adam Winer [EMAIL PROTECTED] wrote: Hrm, but it's event-specific (takes a FacesEvent, deals with AbortProcessingException) so something like

Re: Suggested LifecycleRenderer improvement

2006-09-22 Thread Arjuna Wijeyekoon
+1 will help solve problems with trees,tables and other stamping components, since now the same logic that walks the tree on encode can do the same walk for decode,validate and update. --arjuna On 9/22/06, Gabrielle Crawford [EMAIL PROTECTED] wrote: Adam Winer wrote: Trinidad has a

Re: Marker interface for components that do not render anything

2006-09-17 Thread Arjuna Wijeyekoon
filed issue and uploaded patch. http://issues.apache.org/jira/browse/ADFFACES-179 On 9/15/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: I really like the idea of testing for a null rendererType. My vote would be to just do that and add no public api. I think that the self-rendering

Re: Marker interface for components that do not render anything

2006-09-15 Thread Arjuna Wijeyekoon
. Can you nail this issue / improvement to jira, that it doesn't get lost? -Matthias On 9/15/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: Hi,. Some components, like switcher and iterator, do not (or need not) render any content themselves. This causes problems when

Re: [Vote] missing name for the ADF donation

2006-06-09 Thread Arjuna Wijeyekoon
+1 Trinidad