"David Abrahams" <[EMAIL PROTECTED]> wrote in message
[EMAIL PROTECTED]">news:[EMAIL PROTECTED]...
> [...]
> Reminder: If you haven't done one yet, please take a moment to review
> one of the licenses at
>
>
http://www.crystalclearsoftware.com/cgi-bin/boost_wiki/wiki.pl?Boost_License
I finally k
- Original Message -
From: "Beman Dawes" <[EMAIL PROTECTED]>
> At 09:30 AM 12/4/2002, David Abrahams wrote:
> >Once a library is accepted, it is up to the library author if, and on
> >what schedule, review remarks are addressed. My advice is to check
> >Spirit into the Boost CVS tree
Does this mean a view is mutable? For example, using Boost.View,
can I write a bounded that automatically drops the
last element on push_front if size() is at some upper limit value
before adding the new element? This is the sort of thing I
No. A view is not mutable; sometimes the underlying
"Rozental, Gennadiy" <[EMAIL PROTECTED]> writes:
>> #File: ..\libs\test\src\execution_monitor.cpp
>> # ---
>> # 157: case _CRT_ASSERT:
>> # Error: ^^^
>> # undefined identifier '_CRT_ASSERT'
>> ### mwcc Compiler:
>> #
Gennadiy,
My posting was not meant to start a discussion thread here, and I was
not trying to solicit individual opinions like those you posted below.
Those interested in the development of this library should regroup and
tackle these questions and others of concern to the group together.
I will
At 02:58 PM 12/9/2002, you wrote:
>At 03:53 PM 12/8/2002, Gennaro Prota wrote:
>
>>On Sun, 08 Dec 2002 13:16:24 -0700, Greg Colvin
>><[EMAIL PROTECTED]> wrote:
>>
>>>It may be time to post a question to [EMAIL PROTECTED]
>>
>>Thank you very much. What is that? An internal list for the C++
>>committ
"David B. Held" <[EMAIL PROTECTED]> writes:
[...]
| 2) Under what circumstances is the following equivalent to the
| above:
|
| reinterpret_cast(p);
One of the issues that distinguishly arose during this disucssion is
whether
reinterpret_cast(ptr)
is well-formed. (My compilers don't reje
> 2. Careful description of scope. Answer questions like:
> * Is this a persistence or serialization library?
serialization
> * Is it important to be able to plug in arbitrary archive
>formats?
Yes
> * Is it important to be able to use the same UDT serialization
>cod
> #File: ..\libs\test\src\execution_monitor.cpp
> # ---
> # 157: case _CRT_ASSERT:
> # Error: ^^^
> # undefined identifier '_CRT_ASSERT'
> ### mwcc Compiler:
> # 161: case _CRT_ERROR:
> # Error:
Fernando Cacciola said:
> "William E. Kempf" <[EMAIL PROTECTED]> wrote in message
>> * I believe there should be an "optional& operator=(T const& v)".
>>
> This would break the pointer-semantics:
>
> optional opt ;
>
> opt = 3 ;
>
> instead of
>
> *opt = 3 ;
>
> as it is currently the required syn
David Abrahams wrote:
> > Second, with VC++ large numbers of warnings are now
> > appearing for many type traits headers.
>
> Which version? I can't reproduce these problems with 6, 7, or 7.1.
I can't either, but I fixed it anyway :).
Aleksey
___
Un
"Beman Dawes" <[EMAIL PROTECTED]> wrote in message
[EMAIL PROTECTED]">news:[EMAIL PROTECTED]...
> [...]
> Several committee members (Gaby, Dave Abrahams, Greg, me,
> etc.) will be happy to post something on that list if the question is
> well-formed and is one that only committee members can answer
- Original Message -
From: "Dirk Gerrits" <[EMAIL PROTECTED]>
To: <[EMAIL PROTECTED]>
Sent: Monday, December 09, 2002 6:14 PM
Subject: [boost] Re: Formal review: Optional library
> Fernando Cacciola wrote:
> > I'm actually trying to vouch for my peek/acquire idiom here.
> > Essentially,
- Original Message -
From: "Glen Knowles" <[EMAIL PROTECTED]>
To: "'Boost mailing list'" <[EMAIL PROTECTED]>
Sent: Monday, December 09, 2002 6:42 PM
Subject: RE: [boost] Formal review: Optional library
> From: Fernando Cacciola [mailto:[EMAIL PROTECTED]]
> >>
> >> * I'm unsure about the
"Rozental, Gennadiy" <[EMAIL PROTECTED]> writes:
>> First, the regression tests are broken; the message is:
>>
>> unknown dependent target
>> libboost_prg_exec_monitor.lib
>
> 1. I do not get it. boost_prg_exec_monitor is the new name of the library.
> bjam could not find it?
I think he mis
Beman Dawes <[EMAIL PROTECTED]> writes:
> First, the regression tests are broken; the message is:
>
> unknown dependent target libboost_prg_exec_monitor.lib
>
> I assume this is the result of a change Glennadiy made last night in
> the test library build Jamfile, but reverting it to the prior
At 03:53 PM 12/8/2002, Gennaro Prota wrote:
>On Sun, 08 Dec 2002 13:16:24 -0700, Greg Colvin
><[EMAIL PROTECTED]> wrote:
>
>>It may be time to post a question to [EMAIL PROTECTED]
>
>Thank you very much. What is that? An internal list for the C++
>committee? Is it open to everybody, or you meant t
At 09:30 AM 12/4/2002, David Abrahams wrote:
>"Joel de Guzman" <[EMAIL PROTECTED]> writes:
>> As soon as the review requests are fulfilled... I do not have a
>> definite time when that will be. Most of the items in the to do
>> list are easy. However, there are some quite sticky items
>> such as t
> First, the regression tests are broken; the message is:
>
> unknown dependent target
> libboost_prg_exec_monitor.lib
1. I do not get it. boost_prg_exec_monitor is the new name of the library.
bjam could not find it?
2. Where did you get these errors?
3. I though that in most cases minimal
Title: RE: [boost] Formal review: Optional library
From: Fernando Cacciola [mailto:[EMAIL PROTECTED]]
>>
>> * I'm unsure about the presence of "initialized()". On the one hand, the
>> duplication in features (compared to "get/peek() == 0") is something I
>> think designs should generally avoi
Fernando Cacciola wrote:
I'm actually trying to vouch for my peek/acquire idiom here.
Essentially, the name 'peek()' is intended to convey the fact that the
pointer
points to a managed object and that the ownership is not being transfered
along with the pointer (as oposed to acquire()).
If I manag
David Abrahams <[EMAIL PROTECTED]> writes:
> At one point during the review process, Robert wrote to me privately,
> expressing the opinion that
Ugh, sorry. This was left over from an earlier draft. It has nothing
to do with anything, and you can just ignore it.
-Dave
--
The Serialization library submission by Robert Ramey is not
accepted into Boost at this time.
First of all, I'd like to acknowledge that this was a *very* difficult
review for all concerned. It was tough for the reviewers, for me as
review manager, and especially for Robert Ramey, the libra
First, the regression tests are broken; the message is:
unknown dependent target libboost_prg_exec_monitor.lib
I assume this is the result of a change Glennadiy made last night in the
test library build Jamfile, but reverting it to the prior version doesn't
clear the problem. Sigh. I've emai
"William E. Kempf" <[EMAIL PROTECTED]> wrote in message
[EMAIL PROTECTED]">news:[EMAIL PROTECTED]...
>
> Douglas Gregor said:
> > The formal review of Fernando Cacciola's Optional library begins today
> > and runs until the end of Wednesday, December 18.
> >
> > The Optional library provides a cla
I notice that a shared_ptr can be constructed directly from an
intrusive_ptr, but a weak_ptr cannot. Is there some reason why we wouldn't
want to add the appropriate constructor to weak_ptr?
-Greg Hickman
___
Unsubscribe & other changes: http://lists.bo
On Mon, 09 Dec 2002 08:49:01 -0500, David Abrahams
<[EMAIL PROTECTED]> wrote:
>No, I just meant that a falsely succeeding test is very _unlucky_.
Yeah. The reason why I said it was a lucky case is that I was thinking
to real code, not to the test: in real code where you want
#if BOOST_WORKAROU
On Sunday, December 8, 2002, at 04:44 PM, Thomas Witt wrote:
On Sunday 08 December 2002 09:41, Daryle Walker wrote:
Did the people who arrange formal reviews see this?
Yes, this time. Sorry for missing your first post. Can you give me a
short
summary of what this stuff is about and whether i
I use the header file instead of
by mistake. Thanks for your help.
On Mon, 9 Dec 2002 13:16:38 -0500 (EST)
Jaakko Jarvi <[EMAIL PROTECTED]> wrote:
> The algorithm.hpp header is badly broken in 1.29 (wrong file
> in the wrong place at the wrong time). This is fixed in the cvs main
> trunk.
>
Fernando Cacciola wrote:
- Original Message -
From: "David A. Greene" <[EMAIL PROTECTED]>
To: <[EMAIL PROTECTED]>
Sent: Tuesday, November 05, 2002 5:10 PM
Subject: [boost] Compile-time print
Hi gang,
Has anyone come across a compile-time print metafunction?
Yep. Look at the attached
/X Net License is done.
Summary: appears to be suitable except that there is no distinction between
binaries and source.
Mike
"David Abrahams" <[EMAIL PROTECTED]> wrote in message
[EMAIL PROTECTED]">news:[EMAIL PROTECTED]...
>
> This is a formal call for volunteers to fill out a few of the
> op
From: "vladimir josef sykora" <[EMAIL PROTECTED]>
> template
> struct foo {
> };
>
> // usage example :
> typedef boost::mpl::vector<...> types;
> typedef foo foo_types;
> std::vector std_vect_foos;
> std_vect_foos.push_back(
Roland Richter wrote:
I would like to announce that I finally imported the first set
of Boost.View classes to the Boost-Sandbox CVS.
> + What is it?
> A view is a light-weight, immutable decorator to some existing data.
> Usually, it will provide the same interface as a STL container.
Does th
Douglas Gregor said:
> The formal review of Fernando Cacciola's Optional library begins today
> and runs until the end of Wednesday, December 18.
>
> The Optional library provides a class template "optional" that either
> contains a value of type "T" or contains no value (i.e., having a value
>
Greetings boosters,
I have a class like this one
template
struct foo {
};
// usage example :
typedef boost::mpl::vector<...> types;
typedef foo foo_types;
std::vector std_vect_foos;
std_vect_foos.push_back(foo());
When mpl
The algorithm.hpp header is badly broken in 1.29 (wrong file
in the wrong place at the wrong time). This is fixed in the cvs main
trunk.
The following program compiles and runs fine (with gcc3.2).
Cheers, Jaakko
// --
#include
#include
#include
#include
#include
using
"Joel de Guzman" <[EMAIL PROTECTED]> writes:
> Hi Dave,
>
> Did the Zope public license.
Thanks Joel!
Keep it up, everyone. We have real momentum, now.
--
David Abrahams
[EMAIL PROTECTED] * http://www.boost-consulting.com
Boost support, enhancements, training, and com
Hi Boosters:
In the document of boost::lambda (ar01s05.html#sect:nested_stl_algorithms),
it says:
-->cited begin<---
Some aid for common special cases can be provided though. The BLL defines two
helper function object classes, call_begin and call_end, whi
Hi Dave,
Did the Zope public license.
Joel de Guzman
[EMAIL PROTECTED]
http://www.boost-consulting.com
___
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
The formal review of Fernando Cacciola's Optional library begins today and
runs until the end of Wednesday, December 18.
The Optional library provides a class template "optional" that either
contains a value of type "T" or contains no value (i.e., having a value is
optional). It is useful, for
"Virgilio, Vincent" <[EMAIL PROTECTED]> wrote in message
[EMAIL PROTECTED]">news:[EMAIL PROTECTED]...
> This went faster than I expected, and from a most unexpected source
> of support.
>
> I added 'using boost::mpl::_' at file scope just before the below
> mentioned template, STT_row_impl; the com
I apologize for the incompleteness of my last message:
In addition to a successful compile of the fsm generator, the 'player'
example works as well.
Thank you for such high quality software,
Vince Virgilio
> -Original Message-
> From: Virgilio, Vincent
> Sent: Monday, December 09, 2002
This went faster than I expected, and from a most unexpected source of
support.
I added 'using boost::mpl::_' at file scope just before the below mentioned
template, STT_row_impl; the compile succeeded.
Should this have been necessary?
Regards,
Vince Virgilio
> -Original Message-
> Fro
Hello,
Has anybody successfully compiled Aleksey Gurtovoy's state machine generator
with gcc 3.2 over Boost 1.29 (which includes the mpl)?
My efforts are failing in STT_impl_gen.hpp, line 137. gcc is failing on the
lambda-like expressions given as template parameters, i.e. . . .
STT_row_impl<_,_
Hello,
I'm using Comeau 4.3.0.1 together with Dinkum Unabridged Library V4.0 on
Debian GNU/Linux 3.0. My question is: does anybody compile boost
succesfull while using this configuration? I.e. it seems that boost
doesn't support this configuration directly by providing appropriate
toolset.
Thank
David Abrahams <[EMAIL PROTECTED]> writes:
> or
>
>#if BOOST_WORKAROUND(__BORLANDC__, +0x569)
>// not sure about overflow issues, so maybe not
or
#if BOOST_WORKAROUND(__BORLANDC__, |0x569)
--
David Abrahams
[EMAIL PROTECTED] * http://www.boost-consulting.co
Toon Knapen <[EMAIL PROTECTED]> writes:
> On Monday 09 December 2002 15:32, Samuel Krempp wrote:
>> On the opposite hand, using the same kind of naming scheme,
>> #ifdef BOOST_NEED_UNREACHABLE_RETURN
>> return whatever;
>> #endif
>
> Well all the time I got really confused in this discussion
On Monday 09 December 2002 15:32, Samuel Krempp wrote:
> On the opposite hand, using the same kind of naming scheme,
> #ifdef BOOST_NEED_UNREACHABLE_RETURN
> return whatever;
> #endif
Well all the time I got really confused in this discussion but this proposal
is very clear to me. I definitl
"Jeff Garland" <[EMAIL PROTECTED]> writes:
> Ok Dave you wore me down. I did the W3C license. Executive
> summary is that it passes all but one and has in interesting
> disclaimer about patents, copyrights, and trademarks.
>
>
>http://www.crystalclearsoftware.com/cgi-bin/boost_wiki/wiki.pl?Boos
"John Maddock" <[EMAIL PROTECTED]> writes:
>> This is bad [but read to the end because I might change my
>> mind]. Suppose someone is working with a pre-release of MSVC 8.0. She
>> knows it has several problems, so adds appropriate workarounds to the
>> code. How can someone over at Microsoft is t
le Samedi 7 Décembre 2002 23:24, [EMAIL PROTECTED] écrivit :
>> What about having
>>
>> BOOST_UNREACHABLE_RETURN(0)
>> or
>> BOOST_UNREACHABLE_RETURN("")
>
> I like it!
>
>> I think we need to "return" values for types other than int.
>
> Of course. My suggestion would have just been used th
Ok Dave you wore me down. I did the W3C license. Executive
summary is that it passes all but one and has in interesting
disclaimer about patents, copyrights, and trademarks.
http://www.crystalclearsoftware.com/cgi-bin/boost_wiki/wiki.pl?Boost_License/W3C_License
Jeff
__
Gennaro Prota <[EMAIL PROTECTED]> writes:
> I apologize for the tardy reply but, as it often happens, it was late
> night here when I received your post.
>
> On Sun, 08 Dec 2002 18:20:27 -0500, David Abrahams
> <[EMAIL PROTECTED]> wrote:
>
>>Gennaro Prota <[EMAIL PROTECTED]> writes:
>>> Actually,
"Gennadiy Rozental" <[EMAIL PROTECTED]> writes:
> * Added building dynamic libraries into Jamfile
>Unfortunately it does not work as expected on windows platform. I would
> greatly appreciate any input. See:
>http://groups.yahoo.com/group/jamboost/message/2248
Vladimir followed up to that
Herve Bronnimann <[EMAIL PROTECTED]> writes:
> On Tue, Dec 03, 2002 at 08:01:10PM -0500, David Abrahams wrote:
>> This is a formal call for volunteers to fill out a few of the
>> open-source license evaluations at
>> http://www.crystalclearsoftware.com/cgi-bin/boost_wiki/wiki.pl?Boost_License
>
>
Roland,
Roland Richter wrote:
Rumors have it that iterator_adaptors is redesigned from scratch.
I'd like to hear any news...
You can find what will become the new iterator_adaptors in the sandbox.
The code currently needs a pretty capable compiler, I hope to improve on
that during this week
I apologize for the tardy reply but, as it often happens, it was late
night here when I received your post.
On Sun, 08 Dec 2002 18:20:27 -0500, David Abrahams
<[EMAIL PROTECTED]> wrote:
>Gennaro Prota <[EMAIL PROTECTED]> writes:
>> Actually, you "fall" into using
>> SOME_COMPILER_MACRO1 but, luc
> This is bad [but read to the end because I might change my
> mind]. Suppose someone is working with a pre-release of MSVC 8.0. She
> knows it has several problems, so adds appropriate workarounds to the
> code. How can someone over at Microsoft is test their compiler against
> the Boost CVS with
> > BOOST_UNREACHABLE_RETURN(0)
> > or
> > BOOST_UNREACHABLE_RETURN("")
>
> I like it!
Ditto, added: can you add a define for BOOST_NO_UNREACHABLE_RETURN_DETECTION
to the compiler configs for any compilers that require the
BOOST_UNREACHABLE_RETURN workaround to be activated (none of those I ha
I have recently implemented a set of custom output iterators that allow
you to very trivially do escaping and quoting on data from any kind of
iterator source. Example usage would be
std::string input = "a bdsf 'foo bar baz'";
input.append( 1, '\0' );
std::string expectedOutput
Gennaro Prota writes:
> On 08 Dec 2002 15:09:32 +0100, Gabriel Dos Reis
> <[EMAIL PROTECTED]> wrote:
>
> >Gennaro Prota <[EMAIL PROTECTED]> writes:
> >
> >[...]
> >
> >| If void* is not a "pointer to an object" then reinterpret_cast
> >| is invalid. Otherwise it just yields an undefined r
David A. Greene wrote:
> Aleksey Gurtovoy wrote:
> > It _is_ possible to implement a single template along the
> > lines of the SHAZAM template you've mentioned early in the
> > thread:
> >
> > template
> > struct my_type { ... } // Note: no ::type member
> >
> > typedef SHAZAM > g
Dear all,
I would like to announce that I finally imported the first set
of Boost.View classes to the Boost-Sandbox CVS.
+ What is it?
A view is a light-weight, immutable decorator to some existing data.
Usually, it will provide the same interface as a STL container.
In much the same way as an
Eric Woodruff writes:
> Is my previous statement
> > Precisely, T1 is Foo in this case as you have already pointed out. This is
> > simply the identity conversion T1 -> T2 -> T1, which is pretty much the
> only
> > thing reinterpret_cast can do portably.
>only valid if placement new used a
Gabriel Dos Reis writes:
>
> Hi,
>
> Anthony Williams <[EMAIL PROTECTED]> writes:
>
> [...]
>
> | > You made youself clear.
> | >
> | > However, there are two running issues originating from a claim of Dave
> | > that dangerous_cast<> might be better than reinterpret_cast<> in
65 matches
Mail list logo