[boost] RE: Re: Filesystem: create_directories

2003-08-03 Thread Vladimir Prus
Reid Sweatman wrote: >> > Another option might be: "create_directory_and_parents" >> > That name is longer than "create_directories" although it better >> > describes the function. >> >> I like "create_directory_path" > That one's good, and captures the essential distinction well. Other > possib

[boost] Re: Sudden VC6 ICEs in BGL code

2003-08-03 Thread Vladimir Prus
David Abrahams wrote: > David Abrahams <[EMAIL PROTECTED]> writes: > >> Jeremy Siek <[EMAIL PROTECTED]> writes: >> >>> I seem to remember the named parameters mechanism being fragile >>> under VC6. >> >> After a painstaking binary search in recent CVS states for the ICE, I >> narrowed it down to:

[boost] Re: Filesystem: create_directories

2003-08-03 Thread Vladimir Prus
David Abrahams wrote: > The documentation for create_directories makes no sense. It says > only: > > void create_directories( const path & ph ); > > Precondition: ph.empty() || > forall p: p == ph || is_parent(p, ph): is_directory(p) || !exists( p ) > > Postcondition: exists(ph

[boost] C++ Builder 6 and Boost Generic Graph Library

2003-08-03 Thread Rizky Herucakra
awhile ago I tried to compile this simple program:   #include   int main (){      return 0; }     and Borland C++ Builder 6 refuse to compile. I have track the problem and it seemed that Borland C++ builder has problem with template partial specialization with constant. The program below also refus

[boost] Re: Re: Re: Re: Re: Re: Re: Re: Re: GUI/GDI template library

2003-08-03 Thread Philippe A. Bouchard
brock wrote: [...] >> Is it possible to associate widget instances with functions? > > Like with boost::bind? > >button b; >edit e; > >button.set_on_pushed(boost::bind(&edit::disable_window, &e)); > > (This is not how my library class names looks now, but how they will > when rewritte

Re: [boost] Re: Re: Re: Re: Re: Re: Re: Re: GUI/GDI template library

2003-08-03 Thread brock
- Original Message - From: "Philippe A. Bouchard" <[EMAIL PROTECTED]> To: <[EMAIL PROTECTED]> Sent: Sunday, August 03, 2003 9:33 PM Subject: [boost] Re: Re: Re: Re: Re: Re: Re: Re: GUI/GDI template library > brock wrote: > > [...] > > > What do you mean by "official macros"? The only ma

[boost] Re: Re: Re: Re: Re: Re: Re: Re: GUI/GDI template library

2003-08-03 Thread Philippe A. Bouchard
brock wrote: [...] > What do you mean by "official macros"? The only macros in my code > are in > the implementation, you shouldn't see any in user code. Sorry I guess I have misinterpreted BEGIN_MESSAGE_MAP() in boost_gui_test.cpp. > I'm pretty > sure > they use macros in similar situations i

Re: [boost] Re: Re: Re: Re: Re: Re: Re: GUI/GDI template library

2003-08-03 Thread brock
- Original Message - From: "Philippe A. Bouchard" <[EMAIL PROTECTED]> To: <[EMAIL PROTECTED]> Sent: Sunday, August 03, 2003 8:40 PM Subject: [boost] Re: Re: Re: Re: Re: Re: Re: GUI/GDI template library [...] > Find a way not to rely on "official macros". Those are false hopes. What do

[boost] Re: Re: Re: Re: Re: Re: Re: GUI/GDI template library

2003-08-03 Thread Philippe A. Bouchard
brock wrote: [...] >> - "boost_gui_test/dialog.cpp" is pretty cool... I like it for its >> simplicity but the syntax could be even more elegant. Try some >> operator << instead > of >> a macro defined number of parameters. Nobody likes this idea. > > Probably true, I think I was just looking fo

[boost] Re: Filesystem: create_directories

2003-08-03 Thread David Abrahams
Thomas Witt <[EMAIL PROTECTED]> writes: > I'de like to get away from create. As I understand it, what we really > want is to make sure a directory path actually exists without > necessarily creating any directories. To me calling a create function > for something that already exists should be an e

Re: [boost] Re: Re: Re: Re: Re: Re: GUI/GDI template library

2003-08-03 Thread brock
- Original Message - From: "Philippe A. Bouchard" <[EMAIL PROTECTED]> To: <[EMAIL PROTECTED]> Sent: Sunday, August 03, 2003 8:04 PM Subject: [boost] Re: Re: Re: Re: Re: Re: GUI/GDI template library > brock wrote: > > [...] > > > Having a library with an interface that > > leverages the a

[boost] Re: Re: Re: Re: Re: Re: GUI/GDI template library

2003-08-03 Thread Philippe A. Bouchard
brock wrote: [...] > Having a library with an interface that > leverages the advantages of modern C++ saves me a lot more time than > what I spent making the library. That is true. Maintenance is important also. [...] > I've been proposing, something like: > >gui_manager app = row( "name"

[boost] Re: Re: Re: Re: Re: GUI/GDI template library

2003-08-03 Thread Philippe A. Bouchard
Philippe A. Bouchard wrote: [...] > emit (a.sigdone)(99); Let's call it the placement "emit" operator ;) Just joking... Philippe ___ Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost

Re: [boost] Re: Re: Re: Re: Re: GUI/GDI template library

2003-08-03 Thread brock
Personally I would much rather start from scratch. I want something that is boost from the ground up, not a project that has a code so old it supports MSVC 4.0. Who knows if the folks at wxWindows or elsewhere have the same goals as boost. Don't they have an open source license? Developing a GU

[boost] Re: Re: Re: Re: Re: GUI/GDI template library

2003-08-03 Thread Philippe A. Bouchard
Rene Rivera wrote: > [2003-08-03] Philippe A. Bouchard wrote: > >> WxWindows don't have any intermediate compiler but the end user >> syntax is not attractive for the signal / slot mechanism (macros). > > Yes, and no. You can use the macros if you like that sort of stuff. > But the signal/slot meca

[boost] Re: GUI/GDI template library

2003-08-03 Thread Bohdan
Trying to continue GUI libraries review ( FLTK, WxWin ) Any ideas about VCF ( visual component framework ) sourceforge project ? Its original idea was taken from Borland C++ Builder. Unfortunately, this IDE and VCL (pascal GUI library used by Delphi and c++ builder) doesn't allow to use c++ fe

[boost] Re: Re: Re: Re: Re: GUI/GDI template library

2003-08-03 Thread Philippe A. Bouchard
How about this one: #include #include #include using namespace std; struct Object { }; template struct signal : vector< pair > { typedef typename vector< pair >::value_type value_type; template void connect(Object & o, T U::* s) { push_back(value_type(& o, static_cast(s)

Re: [boost] Re: Filesystem: create_directories

2003-08-03 Thread Thomas Witt
David Abrahams wrote: Dave Gomboc <[EMAIL PROTECTED]> writes: Ah, naming again. My favourite. :-) It's not my favourite, but it matters. I like create_path_and_directory. I prefer this order of the two terms because logically the path exists before the directory itself does. create_full_path

[boost] Re: Re: Re: Re: Re: GUI/GDI template library

2003-08-03 Thread Philippe A. Bouchard
... or the following with the "emit" keyword defined as the only macro. The function connect() could be simplified but I won't go further because it is not pure C++. You take the decisions from here: #include #include #include using namespace std; struct Object { }; template struct si

[boost] Re: Re: Re: Re: Re: GUI/GDI template library

2003-08-03 Thread Philippe A. Bouchard
Here is a better example. I am breaking standards when upcasting a pointer to member though ((void (B::*)(int) -> (void (Object::*)(int))). This is why I never proposed it ;) #include #include #include using namespace std; struct Object { }; template struct signal : list< pair > {

[boost] Re: Re: Re: Re: Re: GUI/GDI template library

2003-08-03 Thread Philippe A. Bouchard
Terje Slettebø wrote: [...] > It's also possible to do the signal/slot without macros on wxWindows. > See here (http://www.wxwindows.org/hworld2.txt) for an example. It's > all done in standard C++, without any macros. It is a lot better this way, I was not aware of this new syntax. But it seem

Re: [boost] Re: Re: Re: Re: GUI/GDI template library

2003-08-03 Thread Terje Slettebø
>From: "Philippe A. Bouchard" <[EMAIL PROTECTED]> > WxWindows don't have any intermediate compiler but the end user syntax is > not attractive for the signal / slot mechanism (macros). It's also possible to do the signal/slot without macros on wxWindows. See here (http://www.wxwindows.org/hworld2

Re: [boost] Re: Re: Re: Re: GUI/GDI template library

2003-08-03 Thread Rene Rivera
[2003-08-03] Philippe A. Bouchard wrote: >WxWindows don't have any intermediate compiler but the end user syntax is >not attractive for the signal / slot mechanism (macros). Yes, and no. You can use the macros if you like that sort of stuff. But the signal/slot mecahnism is just as easilly avai

[boost] Re: Re: GUI/GDI template library

2003-08-03 Thread Rainer Deyke
E. Gladyshev wrote: > --- Rainer Deyke <[EMAIL PROTECTED]> wrote: >> For a GUI library to be useful to me, it would need >> to support custom >> physical GUI layers. I would then write my own > [...] >> full-screen multimedia. I >> realize that my needs are unusual, and boost::gui >> may be unabl

[boost] Re: Re: Re: Re: GUI/GDI template library

2003-08-03 Thread Philippe A. Bouchard
Pavel Vozenilek wrote: [...] > Here is interesting review of five GUI toolkits, including wxWindows: > http://freshmeat.net/articles/view/928/ For the Qt toolkit, they kinda forgot to mention that they work in parallel with the KDE project (http://kde.org) so they have a huge open source suppor

[boost] Re: Filesystem: create_directories

2003-08-03 Thread David Abrahams
Dave Gomboc <[EMAIL PROTECTED]> writes: > Ah, naming again. My favourite. :-) > > I like create_path_and_directory. I prefer this order of the two terms > because logically the path exists before the directory itself does. create_full_path(path, 'd') create_full_path(path, 'f') ?? -- Dave Ab

Re: [boost] Re: Preparing 1.30.1 Release

2003-08-03 Thread John Maddock
>I've applied the first two; I'm not comfortable applying the regex >patches myself; it takes someone who knows the library to verify that >they're OK. John can do it, though, as far as I'm concerned. done, John. ___ Unsubscribe & other changes: http

[boost] Re: plans for a bugfix release ?

2003-08-03 Thread David Abrahams
Misha Bergal <[EMAIL PROTECTED]> writes: > "Misha Bergal" <[EMAIL PROTECTED]> writes: > >> "David Abrahams" <[EMAIL PROTECTED]> wrote in message >> news:[EMAIL PROTECTED] >> > >> > Thanks. The hyperlinks to test failure logs don't ever scroll to the >> > appropriate section of the output on IE6.

[boost] Re: Re: Re: Re: GUI/GDI template library

2003-08-03 Thread Pavel Vozenilek
"Terje Slettebø" <[EMAIL PROTECTED]> wrote in message news:[EMAIL PROTECTED] > Make no mistake - this is a lot of work, too. However, it may be much less > work than creating one from scratch. What do we want - vaporware of a Boost > GUI library coming "real soon now", perhaps not appearing for ma

[boost] RE: Re: Filesystem: create_directories

2003-08-03 Thread Dave Gomboc
> > > > create_directory > > > > and > > > > create_directories > > > > > > Another option might be: "create_directory_and_parents" > > > That name is longer than "create_directories" although it better > > > describes the function. > > > > I like "create_directory_path" > > That one's good, and c

Re: [boost] Re: Re: Re: GUI/GDI template library

2003-08-03 Thread Terje Slettebø
>From: "Rob & Lori" <[EMAIL PROTECTED]> > E. Gladyshev wrote: > > >--- Edward Diener <[EMAIL PROTECTED]> wrote: > > > >>As you have pointed out in the rest of your post, it > >>may prove more > >>worthwhile to work with the developers which already > >>exist for a free > >>cross-platform framework

Re: [boost] Re: Re: Re: GUI/GDI template library

2003-08-03 Thread Terje Slettebø
>From: "Edward Diener" <[EMAIL PROTECTED]> > Terje Slettebø wrote: > >> From: "Edward Diener" <[EMAIL PROTECTED]> > > > >> Add to this the fact that nearly every C++ programmer already works > >> with a framework library depending on his implementation of choice. > >> On Windows alone I know of WT

[boost] Re: plans for a bugfix release ?

2003-08-03 Thread Misha Bergal
David Abrahams <[EMAIL PROTECTED]> writes: > I am slightly concerned about the number of unexpected failures with > intel7.1-stlport. Is there a configuration problem? Yes, there is. The main trunks intel-win32-tools.jam,1.28 enables wchar_t for our configuration but RC_1_30_0 intel-win32-tools

[boost] Re: plans for a bugfix release ?

2003-08-03 Thread Misha Bergal
"Misha Bergal" <[EMAIL PROTECTED]> writes: > "David Abrahams" <[EMAIL PROTECTED]> wrote in message > news:[EMAIL PROTECTED] > > > > Thanks. The hyperlinks to test failure logs don't ever scroll to the > > appropriate section of the output on IE6. Fixed > The compiler_status changes from main tru