ppening.
> >
> > Stephen
> >
> > - Original Message -
> > From: "Gary Gregory" <[EMAIL PROTECTED]>
> > To: "'Jakarta Commons Developers List'" <[EMAIL PROTECTED]>
> > Sent: Friday, October 10, 2003 9:54 PM
> &g
wards compatibility in
mind with the functionality I desire, what would it look like?
Thanks,
Gary
> -Original Message-
> From: Stephen Colebourne [mailto:[EMAIL PROTECTED]
> Sent: Friday, October 10, 2003 14:28
> To: Jakarta Commons Developers List
> Subject: Re: [lang] ArrayUtils
#x27;Jakarta Commons Developers List'" <[EMAIL PROTECTED]>
Sent: Friday, October 10, 2003 9:54 PM
Subject: RE: [lang] ArrayUtils.reverse
> I've not heard back on this last post.
>
> So... is my idea below not acceptable because it breaks the API signature
> for
ary Gregory [mailto:[EMAIL PROTECTED]
> Sent: Wednesday, October 08, 2003 15:10
> To: 'Jakarta Commons Developers List'
> Subject: RE: [lang] ArrayUtils.reverse
>
> Hmm... my main proposal seems to have gotten lost in the shuffle (sorry,
> couldn't resist).
&
m not feeling the requirement to have reverseCopy() ATM
Stephen
> Thoughts?
>
> Gary
>
> > -Original Message-
> > From: Stephen Colebourne [mailto:[EMAIL PROTECTED]
> > Sent: Wednesday, October 08, 2003 13:20
> > To: Jakarta Commons Developers List
> > S
cutTheDeck(ArrayUtils.shuffleHere(ArrayUtils.shuffleThere(deck)))
;
Etc.
Gary
> -Original Message-
> From: __matthewHawthorne [mailto:[EMAIL PROTECTED]
> Sent: Wednesday, October 08, 2003 14:58
> To: Jakarta Commons Developers List
> Subject: Re: [lang] ArrayUtils.reverse
>
> I do
returns its arg.
3) do not add reverseAsCopy until someone asks for it.
Thoughts?
Gary
-Original Message-
From: Stephen Colebourne [mailto:[EMAIL PROTECTED]
Sent: Wednesday, October 08, 2003 13:20
To: Jakarta Commons Developers List
Subject: Re: [lang] ArrayUtils.reverse
I would agree that re
[EMAIL PROTECTED]
> Sent: Wednesday, October 08, 2003 13:20
> To: Jakarta Commons Developers List
> Subject: Re: [lang] ArrayUtils.reverse
>
> I would agree that reverse() should probably return the array, however
> this
> is a nasty backwards compatable change, seems harmless but
t; > -Original Message-
> > From: __matthewHawthorne [mailto:[EMAIL PROTECTED]
> > Sent: Wednesday, October 08, 2003 12:09
> > To: Jakarta Commons Developers List
> > Subject: Re: [lang] ArrayUtils.reverse
> >
> > I think it's a good idea, but I lik
pe array[])
Makes copying the most prominent verb, not quite right IMHO.
(2.3) reverse(type array[], boolean copyFirst)
Barf.
Gary
-Original Message-
From: __matthewHawthorne [mailto:[EMAIL PROTECTED]
Sent: Wednesday, October 08, 2003 12:09
To: Jakarta Commons Developer
ist
> Subject: Re: [lang] ArrayUtils.reverse
>
> I think it's a good idea, but I like method that returns void also,
> because it may save memory by modifying the input array.
>
> Maybe your suggested method should be renamed to:
>
> Object[] copyReverse(final Object[]
I think it's a good idea, but I like method that returns void also,
because it may save memory by modifying the input array.
Maybe your suggested method should be renamed to:
Object[] copyReverse(final Object[] array)
and be modified to not operate on the argument, but instead create a
copy of
12 matches
Mail list logo