Re: RFR: 8017513: Support for closeable streams

2013-08-28 Thread Alan Bateman
On 28/08/2013 22:10, Henry Jen wrote: Hi, Please review the webrev at http://cr.openjdk.java.net/~henryjen/ccc/8017513/1/webrev/ Based on the feedback/discussion from last time, the EG decided to weaken AutoCloseable contract(see RFR 8022176[1]), and have Stream extend AutoCloseable. A quick b

Re: RFR: JDK-4792059 -- test/java/io/pathNames/GeneralSolaris.java fails on symbolic links

2013-08-28 Thread Alan Bateman
On 28/08/2013 23:18, Dan Xu wrote: Thank you, Alan. I have updated my webrev to http://cr.openjdk.java.net/~dxu/4792059/webrev.01/. -Dan Looks fine. -Alan

Re: RFR: 5047859 : (reflect) Class.getField can't find String[].length

2013-08-28 Thread David Holmes
On 29/08/2013 6:26 AM, Joel Borggrén-Franck wrote: Hi David, On Aug 27, 2013, at 5:21 AM, David Holmes wrote: Hi Joel, On 26/08/2013 10:39 PM, Joel Borggren-Franck wrote: Hi, Please review doc fix and test for http://bugs.sun.com/view_bug.do?bug_id=5047859 http://cr.openjdk.java.net/~jfr

Re: Java 8 RFR 8010430: Math.round has surprising behavior for odd values of ulp 1

2013-08-28 Thread Brian Burkhalter
I will update the javadoc in the webrev and repost tomorrow. Brian On Aug 28, 2013, at 7:03 PM, Guy Steele wrote: > In any case, I think everyone is now agreed on "the right thing" for going > forward.

Re: RFR: 7057785 : (xs) Add note to hashCode() that support for self referential is optional

2013-08-28 Thread Guy Steele
What Mike said. It's basically the same problem as for serialization, so you keep a hashtable of all objects traversed---but you need not record objects that have no subobjects and have "simple" or "short" printed representations (such as numbers and maybe short strings). In full generality it r

Re: Java 8 RFR 8010430: Math.round has surprising behavior for odd values of ulp 1

2013-08-28 Thread Guy Steele
Thanks for this context, Joe. And, truth be told, the fact there was a discrepancy between the textual and code descriptions of the operation may well have been my error. (I don't have a clear memory either way, but it's the sort of text I would have worked on rather than Bill.) In any case, I

Re: RFR: 5047859 : (reflect) Class.getField can't find String[].length

2013-08-28 Thread Mandy Chung
On 8/28/2013 6:39 AM, Joel Borggrén-Franck wrote: Hi Mandy, Thanks for your comments, On 2013-08-26, Mandy Chung wrote: Joel, The spec of the getFields and getDeclaredFields() methods both states this: This method returns an array of length 0 if the class or interface declares no fiel

Re: Java 8 RFR 8010430: Math.round has surprising behavior for odd values of ulp 1

2013-08-28 Thread Joseph Darcy
Hello, On 8/23/2013 1:36 PM, Guy Steele wrote: The specification of java.lang.Math.round in the first edition of the Java Language Specification is quite clear: public static int round(float a) The result is rounded to an integer by adding 1/2, taking the floor of the result, and casting

Re: RFR: JDK-8023765 -- Improve MaxPathLength.java testcase and reduce its test load

2013-08-28 Thread Dan Xu
On 08/27/2013 07:15 AM, Dan Xu wrote: On 08/27/2013 12:12 AM, Alan Bateman wrote: On 27/08/2013 01:18, Dan Xu wrote: Hi All, MaxPathLength.javais a troublesome testcase, and fails intermittently in the nightly test. And it also runs for a long time, especially on Windows platforms. Inorder

Re: RFR: 7057785 : (xs) Add note to hashCode() that support for self referential is optional

2013-08-28 Thread Mike Duigou
On Aug 28 2013, at 15:54 , Alan Eliasen wrote: > On 08/28/2013 04:47 PM, Guy Steele wrote: >> *ahem* Y'know, Common Lisp had a good solution for >> printing self-referential structures (by a user-extensible print >> function) back in 1984. >> >> It leaned on the solution that had been provided

Re: RFR: 7057785 : (xs) Add note to hashCode() that support for self referential is optional

2013-08-28 Thread Alan Eliasen
On 08/28/2013 04:47 PM, Guy Steele wrote: > *ahem* Y'know, Common Lisp had a good solution for > printing self-referential structures (by a user-extensible print > function) back in 1984. > > It leaned on the solution that had been provided in Interlisp in > 1974. On a machine with one megabyte

Re: RFR: 7057785 : (xs) Add note to hashCode() that support for self referential is optional

2013-08-28 Thread Guy Steele
On Aug 28, 2013, at 6:13 PM, Mike Duigou wrote: > > On Aug 28 2013, at 11:48 , Martin Buchholz wrote: > >> This isn't just about hashCode - I'm not sure why you are singling it out. >> What about toString? > > A reasonable point. The bug reports are just about as common for toString() > be

hg: jdk8/tl/langtools: 8010310: [javadoc] Error processing sources with -private

2013-08-28 Thread jonathan . gibbons
Changeset: 189942cdf585 Author:jjg Date: 2013-08-28 15:40 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/langtools/rev/189942cdf585 8010310: [javadoc] Error processing sources with -private Reviewed-by: vromero, mcimadamore ! src/share/classes/com/sun/tools/javac/code/Symbol.java !

Re: RFR: JDK-4792059 -- test/java/io/pathNames/GeneralSolaris.java fails on symbolic links

2013-08-28 Thread Dan Xu
Thank you, Alan. I have updated my webrev to http://cr.openjdk.java.net/~dxu/4792059/webrev.01/. -Dan On 08/28/2013 04:05 AM, Alan Bateman wrote: On 28/08/2013 00:20, Dan Xu wrote: Hi, When GeneralSolaris testcase follows symbolic link to pick up an existing file or directory for testing

Re: RFR: 7057785 : (xs) Add note to hashCode() that support for self referential is optional

2013-08-28 Thread Mike Duigou
On Aug 28 2013, at 11:48 , Martin Buchholz wrote: > This isn't just about hashCode - I'm not sure why you are singling it out. > What about toString? A reasonable point. The bug reports are just about as common for toString() being "broken" for self-referential collections. > Or really, any

RFR: JDK-6341345: (spec) Console.reader() should make it clear that the reader requires line termination

2013-08-28 Thread Xueming Shen
Alan, My mailbox suggests that you have already reviewed this one back to the past May, somehow I dropped the ball some where. Here is the webrev and CCC again (the change is a trivial spec clarification, which I should have done 8 years ago). http://cr.openjdk.java.net/~sherman/6341345 http://c

Re: RFR: 8022176: Weaken contract of java.lang.AutoCloseable

2013-08-28 Thread Henry Jen
On 08/24/2013 01:40 PM, Alan Bateman wrote: > On 24/08/2013 14:09, Doug Lea wrote: >> >> "resource specification", while accurate, looked confusing here. >> But we could include both terms, which seems like an improvement. >> See below. > This looks better to me, thanks. > Updated webrev as concl

RFR: 8017513: Support for closeable streams

2013-08-28 Thread Henry Jen
Hi, Please review the webrev at http://cr.openjdk.java.net/~henryjen/ccc/8017513/1/webrev/ Based on the feedback/discussion from last time, the EG decided to weaken AutoCloseable contract(see RFR 8022176[1]), and have Stream extend AutoCloseable. A quick briefing of the webrev, - Remove Closeabl

Re: java.util.Locale changes

2013-08-28 Thread Alan Bateman
On 28/08/2013 14:25, Masayoshi Okutsu wrote: (adding core-libs-dev) Hi Christian, RFC 4647 defines The Language Priority List [1]. The use of java.util.List would be a natural fit, which is the reason why List is used. But use of Iterable does work (as API design). The parameter name `priori

Re: RFR: 5047859 : (reflect) Class.getField can't find String[].length

2013-08-28 Thread Joel Borggrén-Franck
Hi David, On Aug 27, 2013, at 5:21 AM, David Holmes wrote: > Hi Joel, > > On 26/08/2013 10:39 PM, Joel Borggren-Franck wrote: >> Hi, >> >> Please review doc fix and test for >> http://bugs.sun.com/view_bug.do?bug_id=5047859 >> >> http://cr.openjdk.java.net/~jfranck/5047859/webrev.00/ >> >>

hg: jdk8/tl/jdk: 8023155: Ensure functional consistency across Random, ThreadLocalRandom, SplittableRandom

2013-08-28 Thread paul . sandoz
Changeset: b1f41565b806 Author:psandoz Date: 2013-08-28 22:11 +0200 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/b1f41565b806 8023155: Ensure functional consistency across Random, ThreadLocalRandom, SplittableRandom Reviewed-by: mduigou Contributed-by: Doug Lea , Paul Sandoz

hg: jdk8/tl/langtools: 8014566: Remove @ignore tags from MethodReference66 and InInterface when 8013875 is fixed

2013-08-28 Thread henry . jen
Changeset: 7de7100c30ce Author:henryjen Date: 2013-08-28 10:17 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/langtools/rev/7de7100c30ce 8014566: Remove @ignore tags from MethodReference66 and InInterface when 8013875 is fixed Reviewed-by: briangoetz, jjg ! test/tools/javac/lambda/

Re: Java 8 RFR 8010430: Math.round has surprising behavior for odd values of ulp 1

2013-08-28 Thread Dmitry Nadezhin
TLS 1 specification contained verbal statement "The result is rounded to an integer by adding , taking the floor of the result, and casting the result to type int". and Java code Math.floor(f + 0.5). It seems to me that the verbal statement says about mathematical "+" . It maps a pair of reals to

Re: Java 8 RFR 8010430: Math.round has surprising behavior for odd values of ulp 1

2013-08-28 Thread Brian Burkhalter
On Aug 28, 2013, at 10:55 AM, Dmitry Nadezhin wrote: > TLS 1 specification contained verbal statement > "The result is rounded to an integer by adding , taking the floor of the > result, and casting the result to typeint". > and Java code > Math.floor(f + 0.5). > > It seems to me that the verbal

Re: RFR JDK-8023713: ZipFileSystem has compatiable issue to handle old zip file.

2013-08-28 Thread Xueming Shen
On 08/28/2013 10:45 AM, Martin Buchholz wrote: get16 can not return negative values, right? correct. will remove it in a separate push. thanks! So elide the sz < 0 below 666 if (sz < 0 || (off + 4 + sz) > len) { 667 break; 668 } Otherwise, looks good

hg: jdk8/tl/jdk: 8023713: ZipFileSystem crashes on old zip file

2013-08-28 Thread xueming . shen
Changeset: 690b2931baef Author:sherman Date: 2013-08-28 09:46 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/690b2931baef 8023713: ZipFileSystem crashes on old zip file Summary: to handle extra data field copy correctly even the extra data does not follow the spec Reviewed-b

Re: RFR JDK-8023713: ZipFileSystem has compatiable issue to handle old zip file.

2013-08-28 Thread Xueming Shen
On 08/28/2013 03:56 AM, Alan Bateman wrote: On 28/08/2013 00:09, Xueming Shen wrote: On 08/27/2013 03:07 PM, Martin Buchholz wrote: It does seem vaguely reasonable to support any extra data. Don't you want to also handle arbitrary byte arrays, if e.g. one the 16-bit size fields overflows the

Re: RFR: 7057785 : (xs) Add note to hashCode() that support for self referential is optional

2013-08-28 Thread Mike Duigou
Thanks Stephen, I am fine with your wording. Any other votes or suggested wordings? Mike On Aug 28 2013, at 02:55 , Stephen Colebourne wrote: > I lke the idea, but the wording feels a little opaque as the result is > typically StackOverflow. > > Also, I prefer a style with the @apiNote on a li

Re: Java 8 RFR 8010430: Math.round has surprising behavior for odd values of ulp 1

2013-08-28 Thread Brian Burkhalter
On Aug 27, 2013, at 7:44 PM, Dmitry Nadezhin wrote: > Is it reasonable to make specification clearer ? > > Either to return JLS 1 specification: > <<< > The result is rounded to an integer by adding , taking the floor of the > result, and casting the result to type long. > >>> This verbiage wou

hg: jdk8/tl/jdk: 8022594: Potential deadlock in of sun.nio.ch.Util/IOUtil

2013-08-28 Thread alan . bateman
Changeset: 378acd4d03c8 Author:alanb Date: 2013-08-28 15:50 +0100 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/378acd4d03c8 8022594: Potential deadlock in of sun.nio.ch.Util/IOUtil Reviewed-by: chegar ! src/macosx/classes/sun/nio/ch/KQueueArrayWrapper.java ! src/macosx/classes/

hg: jdk8/tl/jdk: 8023717: (process) ProcessBuilder should catch SecurityException rather than AccessControlException

2013-08-28 Thread alan . bateman
Changeset: 2efa310226f7 Author:alanb Date: 2013-08-28 14:07 +0100 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/2efa310226f7 8023717: (process) ProcessBuilder should catch SecurityException rather than AccessControlException Reviewed-by: wetmore, alanb Contributed-by: marti...@go

Re: RFR: 5047859 : (reflect) Class.getField can't find String[].length

2013-08-28 Thread Joel Borggrén-Franck
Hi Mandy, Thanks for your comments, On 2013-08-26, Mandy Chung wrote: > Joel, > > The spec of the getFields and getDeclaredFields() methods both states this: > > This method returns an array of length 0 if the class > or interface declares no fields, or if this|Class| object > represents

Re: java.util.Locale changes

2013-08-28 Thread Masayoshi Okutsu
(adding core-libs-dev) Hi Christian, RFC 4647 defines The Language Priority List [1]. The use of java.util.List would be a natural fit, which is the reason why List is used. But use of Iterable does work (as API design). The parameter name `priorityIterable' sounds a bit odd, though. Does u

Re: Additional source to guess the local timezone ID on linux

2013-08-28 Thread Andrew Hughes
- Original Message - > On 08/27/2013 03:00 AM, Masayoshi Okutsu wrote: > > /etc/sysconfig/clock used to be supported, but it was removed in JDK 7. > > The problem is discussed in bug #6456628. > > > > http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6456628 > > Thanks for that link. I d

Re: Potential issue with CHM.toArray

2013-08-28 Thread Peter Levart
On 08/28/2013 12:10 PM, Paul Sandoz wrote: Hi, Intermittent failures were reported with the CHM toArray test in the JDK. I updated the tests to increase the number of runs and the number of workers and i can reliably reproduce on my laptop, see below. The test presumes the size should always

Re: Potential issue with CHM.toArray

2013-08-28 Thread Doug Lea
On 08/28/2013 06:10 AM, Paul Sandoz wrote: Hi, Intermittent failures were reported with the CHM toArray test in the JDK. I updated the tests to increase the number of runs and the number of workers and i can reliably reproduce on my laptop, see below. The test presumes the size should always

Re: RFR: 8015068 : (m) Use jtreg -exclude for problemlist.txt processing

2013-08-28 Thread Alan Bateman
On 28/08/2013 00:17, Mike Duigou wrote: Hello all; I have updated the changeset for this issue based upon feedback from the earlier version. As a result of intervening work this version contains even more cleanup. http://cr.openjdk.java.net/~mduigou/JDK-8015068/1/webrev/ Since the last revis

Re: RFR: JDK-4792059 -- test/java/io/pathNames/GeneralSolaris.java fails on symbolic links

2013-08-28 Thread Alan Bateman
On 28/08/2013 00:20, Dan Xu wrote: Hi, When GeneralSolaris testcase follows symbolic link to pick up an existing file or directory for testing, it will fail the assertion in check()method because the file path canonicalization process will result in the real path not a path containing symboli

Re: RFR JDK-8023713: ZipFileSystem has compatiable issue to handle old zip file.

2013-08-28 Thread Alan Bateman
On 28/08/2013 00:09, Xueming Shen wrote: On 08/27/2013 03:07 PM, Martin Buchholz wrote: It does seem vaguely reasonable to support any extra data. Don't you want to also handle arbitrary byte arrays, if e.g. one the 16-bit size fields overflows the extra data? It looks to me like getExtraLen

Re: Take 2 Re: RFR 8023155: Ensure functional consistency across Random, ThreadLocalRandom, SplittableRandom

2013-08-28 Thread Paul Sandoz
On Aug 27, 2013, at 11:47 PM, Mike Duigou wrote: > ThreadLocalRandom:: > > - I don't understand the point of having a writeObject() if the readResolve() > ignores the result. My expectation for a serialized TLR might be that upon > de-serialization the seeding state is restored. If that isn't p

Potential issue with CHM.toArray

2013-08-28 Thread Paul Sandoz
Hi, Intermittent failures were reported with the CHM toArray test in the JDK. I updated the tests to increase the number of runs and the number of workers and i can reliably reproduce on my laptop, see below. The test presumes the size should always increase but fails when it observes a new ne

Re: Simple RFR: 8203311 Clean up profile-includes.txt

2013-08-28 Thread David Holmes
Sorry about that. I thought the two fixes were travelling together else I would have taken steps to put them together. :( David On 28/08/2013 8:04 PM, Dawid Weiss wrote: Thanks Andreas, I'll switch to that revision. On Wed, Aug 28, 2013 at 12:00 PM, Andreas Rieber wrote: Hi Dawid, the fix

Re: Simple RFR: 8203311 Clean up profile-includes.txt

2013-08-28 Thread Dawid Weiss
Thanks Andreas, I'll switch to that revision. On Wed, Aug 28, 2013 at 12:00 PM, Andreas Rieber wrote: > Hi Dawid, > > the fix is in jdk8tl already, just missed to come into jdk8. It's only a few > lines. > > Andreas > > Here the changeset: > > Changeset: 3b8fed46b2a8 > Author:dholmes > Date:

Re: Simple RFR: 8203311 Clean up profile-includes.txt

2013-08-28 Thread Andreas Rieber
Hi Dawid, the fix is in jdk8tl already, just missed to come into jdk8. It's only a few lines. Andreas Here the changeset: Changeset: 3b8fed46b2a8 Author:dholmes Date: 2013-08-21 05:56 -0400 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/3b8fed46b2a8 8023460: OPENJDK build fa

Re: RFR: 7057785 : (xs) Add note to hashCode() that support for self referential is optional

2013-08-28 Thread Stephen Colebourne
I lke the idea, but the wording feels a little opaque as the result is typically StackOverflow. Also, I prefer a style with the @apiNote on a line of its own, rather like a heading. It makes the documentation easier to read in source code, and has no effect on the output Javadoc. @apiNote If the

Re: Simple RFR: 8203311 Clean up profile-includes.txt

2013-08-28 Thread Dawid Weiss
David, Is the fix for this committed anywhere? I've just tried building from scratch and I'm getting the same error. Dawid On Wed, Aug 21, 2013 at 10:55 AM, David Holmes wrote: > Fix on the way. This exposed another piece that was missing from the > original change. But mea culpa for not doing

Re: RFR JDK-8023713: ZipFileSystem has compatiable issue to handle old zip file.

2013-08-28 Thread Chris Hegarty
On 28/08/2013 00:09, Xueming Shen wrote: On 08/27/2013 03:07 PM, Martin Buchholz wrote: It does seem vaguely reasonable to support any extra data. Don't you want to also handle arbitrary byte arrays, if e.g. one the 16-bit size fields overflows the extra data? It looks to me like getExtraLen co