The DBI already has a cancel method. Not many drivers do though.
Tim.
On Tue, Jul 09, 2002 at 10:56:58PM -0700, Dean Arnold wrote:
> Been thinking about this recently...
>
> While I still think a 'close()' semantic is needed, maybe
> a 'cancel()' is also needed if/when some asynch execution,
>
Been thinking about this recently...
While I still think a 'close()' semantic is needed, maybe
a 'cancel()' is also needed if/when some asynch execution,
or more likely multithreaded, support is implemented ?
I.e., close() means I've got a big resultset that I only want to see
a few rows of, the
> On Tue, Jul 02, 2002 at 04:44:59PM +0200, Waldemar Zurowski wrote:
> > On Mon, 1 Jul 2002 21:34:50 +0100
> > Tim Bunce <[EMAIL PROTECTED]> wrote:
> >
> > > > Yet is't a horribly long name. Why don't you change "connect" into
> > > > "connect_to_database", "prepare" into "prepare_statement" and "
On 7/2/02 1:56 PM, "Tim Bunce" <[EMAIL PROTECTED]> claimed:
> I hope you don't think I'd actually make a change to the DBI that
> would break much old code.
>
> I'd naturally leave finish as a deprecated alias.
Okay. Sanity check. Sorry.
Regards,
David
--
David Wheeler
On Tue, Jul 02, 2002 at 09:57:42AM -0700, David Wheeler wrote:
> On 7/2/02 9:43 AM, "Tim Bunce" <[EMAIL PROTECTED]> claimed:
>
> > Trouble is, thousands of people (literally) think it finishes/deallocates
> > the statement handle and/or that they need to call it after fetch loops.
>
> Hmmm...if
On 7/2/02 9:43 AM, "Tim Bunce" <[EMAIL PROTECTED]> claimed:
> Trouble is, thousands of people (literally) think it finishes/deallocates
> the statement handle and/or that they need to call it after fetch loops.
Hmmm...if you're changing the name, you probably ought to know that, thanks
to an old
On Tue, Jul 02, 2002 at 04:44:59PM +0200, Waldemar Zurowski wrote:
> On Mon, 1 Jul 2002 21:34:50 +0100
> Tim Bunce <[EMAIL PROTECTED]> wrote:
>
> > > Yet is't a horribly long name. Why don't you change "connect" into
> > > "connect_to_database", "prepare" into "prepare_statement" and "do" into
>
On Mon, 1 Jul 2002 21:34:50 +0100
Tim Bunce <[EMAIL PROTECTED]> wrote:
> > Yet is't a horribly long name. Why don't you change "connect" into
> > "connect_to_database", "prepare" into "prepare_statement" and "do" into
> > "prepare_and_execute_statement"?
>
> Huffman coding.
Well - I personally
- Original Message -
From: "Tim Bunce" <[EMAIL PROTECTED]>
> Can you point me to a reference that shows close() doing exactly
> what finish() does?
I can't say for sure its exactly the same, but it does remind me of Informix
where
you might say:
open some_cursor using some_bind_variabl
On Mon, 1 Jul 2002 21:34:50 +0100 Tim Bunce <[EMAIL PROTECTED]> wrote:
> On Mon, Jul 01, 2002 at 02:51:11PM +0200, Bart Lateur wrote:
> > On Mon, 1 Jul 2002 12:18:31 +0100, Tim Bunce wrote:
> >
> > >> >I'll probably rename finish() to something like
> discard_unfetched_rows().
> > >> >(Keeping a
The one I'm most familiar with is the JDBC
spec, specifically ResultSet.close()
(and I guess Statement.close() is similar as
well).
And of course, one could argue that, after
execute() completes,
$sth is just a cursor handle,
and "CLOSE "
has been the standard SQL way to close a
cur
On Mon, Jul 01, 2002 at 02:51:11PM +0200, Bart Lateur wrote:
> On Mon, 1 Jul 2002 12:18:31 +0100, Tim Bunce wrote:
>
> >> >I'll probably rename finish() to something like discard_unfetched_rows().
> >> >(Keeping an alias for old code of course.)
> >>
> >> I guess I got the idea from this sentenc
Can you point me to a reference that shows close() doing exactly
what finish() does?
Tim.
On Mon, Jul 01, 2002 at 07:28:15AM -0700, Dean Arnold wrote:
> Perhaps just $sth->close() is sufficient ? This would mimic
> most other API's syntax...
>
> Dean Arnold
>
> > > >
> > > >I'll probably renam
Perhaps just $sth->close() is sufficient ? This would mimic
most other API's syntax...
Dean Arnold
> > >
> > >I'll probably rename finish() to something like
discard_unfetched_rows().
> > >(Keeping an alias for old code of course.)
> >
> > I guess I got the idea from this sentence in perldoc DBI
On Mon, 1 Jul 2002 12:18:31 +0100, Tim Bunce wrote:
>> >I'll probably rename finish() to something like discard_unfetched_rows().
>> >(Keeping an alias for old code of course.)
>>
>> I guess I got the idea from this sentence in perldoc DBI:
>>
>> The `finish' method should have been cal
On Sun, Jun 30, 2002 at 08:30:31PM -0500, Paul DuBois wrote:
> At 23:32 +0100 6/30/02, Tim Bunce wrote:
> >On Sun, Jun 30, 2002 at 10:43:19AM -0700, Michael A Chase wrote:
> >> On Sun, 30 Jun 2002 11:48:49 -0500 Paul DuBois <[EMAIL PROTECTED]> wrote:
> >>
> >> > At 16:23 +0100 6/30/02, Tim Bunce
At 23:32 +0100 6/30/02, Tim Bunce wrote:
>On Sun, Jun 30, 2002 at 10:43:19AM -0700, Michael A Chase wrote:
>> On Sun, 30 Jun 2002 11:48:49 -0500 Paul DuBois <[EMAIL PROTECTED]> wrote:
>>
>> > At 16:23 +0100 6/30/02, Tim Bunce wrote:
>> > >Support for cancel was added in DBD::Oracle 1.09 thanks
On Sun, Jun 30, 2002 at 10:43:19AM -0700, Michael A Chase wrote:
> On Sun, 30 Jun 2002 11:48:49 -0500 Paul DuBois <[EMAIL PROTECTED]> wrote:
>
> > At 16:23 +0100 6/30/02, Tim Bunce wrote:
> > >Support for cancel was added in DBD::Oracle 1.09 thanks to a patch
> > >from Fredrik Sjoholm.
> >
> > W
On Sun, 30 Jun 2002 11:48:49 -0500 Paul DuBois <[EMAIL PROTECTED]> wrote:
> At 16:23 +0100 6/30/02, Tim Bunce wrote:
> >Support for cancel was added in DBD::Oracle 1.09 thanks to a patch
> >from Fredrik Sjoholm.
>
> Will cancel eventually become the general preferred replacement for
> finish for
test script with it:
>
>#!/usr/bin/perl
>use DBI;
>use strict;
># test $sth->cancel() implementation
>my $db = DBI->connect ('dbi:Oracle:', "ez", "ez", { RaiseError=>1,
>AutoCommit=>0 });
>my $q = $db->prepare ("begin loop null;
Support for cancel was added in DBD::Oracle 1.09 thanks to a patch
from Fredrik Sjoholm.
He sent this test script with it:
#!/usr/bin/perl
use DBI;
use strict;
# test $sth->cancel() implementation
my $db = DBI->connect ('dbi:Oracle:', "ez", "ez", { RaiseErr
21 matches
Mail list logo