[PATCH] staging: iio: ad2s1210: fix 'assignment operator' style checks

2018-10-05 Thread Matheus Tavares Bernardino
This patch fixes all "Assignment operator '=' should be on the previous line" checks found in ad2s1210.c by checkpatch.pl. Signed-off-by: Matheus Tavares --- drivers/staging/iio/resolver/ad2s1210.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git

Re: [PATCH] staging/rtlwifi: Fixing formatting warnings from checkpatch.pl.

2018-10-05 Thread Scott Tracy
On Fri, Oct 5, 2018 at 6:37 PM Joe Perches wrote: > > On Fri, 2018-10-05 at 16:58 -0600, Scott Tracy wrote: > > Fixing formatting warnings in rtlwifi found by checkpatch.pl > > Changes include breaking up functions calls into multi line calls. > > No functional/logical changes. > > I believe the

[no subject]

2018-10-05 Thread Scott Tracy
linux-ker...@vger.kernel.org Cc: Bcc: Subject: [PATCH] staging/rtlwifi: Fixing formatting warnings from checkpatch.pl. Reply-To: On Fri, 10/5/18 at 6:37PM Joe Perches wrote: >On Fri, 2018-10-05 at 16:58 -0600, Scott Tracy wrote: >> Fixing formatting warnings in rtlwifi found by checkpatch.pl

Re: [PATCH] staging: erofs: fix indenting to conform to kernel coding style

2018-10-05 Thread Gao Xiang
Hi Ioannis, Thanks for your patch. Could you please resend this patch to the staging-devel/erofs-devel mailing list? Since we are in the China National Day holiday and I can only send email in the corporation by the HUAWEI mailbox, I cannot reply emails in time... It could be better to Cc

[PATCH] staging/rtlwifi: Fixing formatting warnings from checkpatch.pl.

2018-10-05 Thread Scott Tracy
Fixing formatting warnings in rtlwifi found by checkpatch.pl Changes include breaking up functions calls into multi line calls. No functional/logical changes. Signed-off-by: Scott Tracy --- drivers/staging/rtlwifi/core.c | 5 +++-- drivers/staging/rtlwifi/efuse.c | 5 +++-- 2 files changed, 6

Re: [PATCH] STAGING/EMXX_UDC: emxx_udc.c: Fixed all meaningful sparse errors: 1. Added static to udc_controller 2. Added mising __iomem modifier to handle p_regs 3. Added missing le16_to_cpu

2018-10-05 Thread Greg KH
On Fri, Oct 05, 2018 at 01:04:27PM -0400, Carmeli Tamir wrote: > Signed-off-by: Tamir Carmeli > --- > drivers/staging/emxx_udc/Makefile | 2 +- > drivers/staging/emxx_udc/emxx_udc.c | 69 > +++-- > drivers/staging/emxx_udc/emxx_udc.h | 2 +- > 3 files

Re: [PATCH] staging/rtlwifi: Fixing formatting warnings.

2018-10-05 Thread Greg Kroah-Hartman
On Fri, Oct 05, 2018 at 02:58:15PM -0600, Scott Tracy wrote: > Signed-off-by: Scott Tracy > --- > drivers/staging/rtlwifi/core.c | 5 +++-- > drivers/staging/rtlwifi/efuse.c | 5 +++-- > 2 files changed, 6 insertions(+), 4 deletions(-) Hi, This is the friendly patch-bot of Greg Kroah-Hartman.

Re: [patch 00/11] x86/vdso: Cleanups, simmplifications and CLOCK_TAI support

2018-10-05 Thread Marcelo Tosatti
On Thu, Oct 04, 2018 at 09:54:45AM +0200, Vitaly Kuznetsov wrote: > Marcelo Tosatti writes: > > > On Wed, Oct 03, 2018 at 11:22:58AM +0200, Vitaly Kuznetsov wrote: > >> > >> There is a very long history of different (hardware) issues Marcelo was > >> fighting with and the current code is the

Re: [PATCH] staging/rtlwifi: Fixing formatting warnings.

2018-10-05 Thread Gustavo A. R. Silva
On 10/5/18 10:58 PM, Scott Tracy wrote: > Signed-off-by: Scott Tracy > --- > drivers/staging/rtlwifi/core.c | 5 +++-- > drivers/staging/rtlwifi/efuse.c | 5 +++-- > 2 files changed, 6 insertions(+), 4 deletions(-) > > diff --git a/drivers/staging/rtlwifi/core.c

[PATCH] staging/rtlwifi: Fixing formatting warnings.

2018-10-05 Thread Scott Tracy
Signed-off-by: Scott Tracy --- drivers/staging/rtlwifi/core.c | 5 +++-- drivers/staging/rtlwifi/efuse.c | 5 +++-- 2 files changed, 6 insertions(+), 4 deletions(-) diff --git a/drivers/staging/rtlwifi/core.c b/drivers/staging/rtlwifi/core.c index ca37f7511c4d..a36cb44a5388 100644 ---

[PATCH] STAGING/EMXX_UDC: emxx_udc.c: Fixed all meaningful sparse errors: 1. Added static to udc_controller 2. Added mising __iomem modifier to handle p_regs 3. Added missing le16_to_cpu

2018-10-05 Thread Carmeli Tamir
Signed-off-by: Tamir Carmeli --- drivers/staging/emxx_udc/Makefile | 2 +- drivers/staging/emxx_udc/emxx_udc.c | 69 +++-- drivers/staging/emxx_udc/emxx_udc.h | 2 +- 3 files changed, 38 insertions(+), 35 deletions(-) diff --git

Re: [PATCH resend 00/15] staging: vboxvideo: Convert to atomic modesetting API

2018-10-05 Thread Daniel Vetter
On Mon, Oct 01, 2018 at 11:20:04AM +0200, Hans de Goede wrote: > Hi, > > On 01-10-18 09:25, Dan Carpenter wrote: > > Why are you resending this? It's because you added some more patches > > on the end? Just send those as a new series... > > I accidentally numbered the cover-letter of the

[PATCH 3/3] staging: greybus: loopback.c: simplify prototype of gb_loopback_bus_id_compare

2018-10-05 Thread Rasmus Villemoes
gb_loopback_bus_id_compare only has a single caller, and it no longer needs to have a prototype compatible with being a callback for list_sort. Signed-off-by: Rasmus Villemoes --- drivers/staging/greybus/loopback.c | 7 ++- 1 file changed, 2 insertions(+), 5 deletions(-) diff --git

[PATCH 1/3] staging: greybus: loopback.c: remove unused gb_loopback::lbid

2018-10-05 Thread Rasmus Villemoes
It's not obvious how the code prevents adding more than 31 elements to the list and thus invoking undefined behaviour in the 1 << new_lbid expression, and in practice causing ->lbid values to repeat every 32 elements. But the definition of struct gb_loopback is local to loopback.c, and the lbid

[PATCH 2/3] staging: greybus: loopback.c: do insertion in O(n) instead of O(n lg n)

2018-10-05 Thread Rasmus Villemoes
"Append to the list and do a merge sort" is not really an insertion sort. While a few more lines of code, we can keep the list sorted doing at most n comparisons by iterating until we find the first element strictly greater than gb. Signed-off-by: Rasmus Villemoes --- I have no idea if the

[PATCH -next] staging: axis-fifo: remove duplicated include from axis-fifo.c

2018-10-05 Thread YueHaibing
Remove duplicated include. Signed-off-by: YueHaibing --- drivers/staging/axis-fifo/axis-fifo.c | 2 -- 1 file changed, 2 deletions(-) diff --git a/drivers/staging/axis-fifo/axis-fifo.c b/drivers/staging/axis-fifo/axis-fifo.c index 63c8efd..48a9877 100644 ---

[PATCH -next] [media] media: drop pointless static qualifier in vpfe_ipipeif_init()

2018-10-05 Thread YueHaibing
There is no need to have the 'resource_size_t res_len' variable static since new value always be assigned before use it. Signed-off-by: YueHaibing --- drivers/staging/media/davinci_vpfe/dm365_ipipeif.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

[PATCH -next] [media] media: drop pointless static qualifier in vpfe_resizer_init()

2018-10-05 Thread YueHaibing
There is no need to have the 'resource_size_t res_len' variable static since new value always be assigned before use it. Signed-off-by: YueHaibing --- drivers/staging/media/davinci_vpfe/dm365_resizer.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

Re: [PATCH v4 10/11] media: imx: Allow interweave with top/bottom lines swapped

2018-10-05 Thread Philipp Zabel
Hi Steve, On Thu, 2018-10-04 at 11:54 -0700, Steve Longerbeam wrote: > Allow sequential->interlaced interweaving but with top/bottom > lines swapped to the output buffer. > > This can be accomplished by adding one line length to IDMAC output > channel address, with a negative line length for the

Re: [PATCH v4 09/11] media: imx-csi: Move crop/compose reset after filling default mbus fields

2018-10-05 Thread Philipp Zabel
On Thu, 2018-10-04 at 11:53 -0700, Steve Longerbeam wrote: > If caller passes un-initialized field type V4L2_FIELD_ANY to CSI > sink pad, the reset CSI crop window would not be correct, because > the crop window depends on a valid input field type. To fix move > the reset of crop and compose

Re: [PATCH v4 06/11] media: imx: interweave and odd-chroma-row skip are incompatible

2018-10-05 Thread Philipp Zabel
On Thu, 2018-10-04 at 11:53 -0700, Steve Longerbeam wrote: > If IDMAC interweaving is enabled in a write channel, the channel must > write the odd chroma rows for 4:2:0 formats. Skipping writing the odd > chroma rows produces corrupted captured 4:2:0 images when interweave > is enabled. > >

Re: [PATCH v4 07/11] media: imx-csi: Allow skipping odd chroma rows for YVU420

2018-10-05 Thread Philipp Zabel
On Thu, 2018-10-04 at 11:53 -0700, Steve Longerbeam wrote: > Skip writing U/V components to odd rows for YVU420 in addition to > YUV420 and NV12. > > Signed-off-by: Steve Longerbeam > Reviewed-by: Philipp Zabel > --- > drivers/staging/media/imx/imx-media-csi.c | 1 + > 1 file changed, 1

Re: [PATCH v4 05/11] media: imx-csi: Double crop height for alternate fields at sink

2018-10-05 Thread Philipp Zabel
On Thu, 2018-10-04 at 11:53 -0700, Steve Longerbeam wrote: > If the incoming sink field type is alternate, the reset crop height > and crop height bounds must be set to twice the incoming height, > because in alternate field mode, upstream will report only the > lines for a single field, and the

Re: [PATCH v4 04/11] media: imx: Fix field negotiation

2018-10-05 Thread Philipp Zabel
On Thu, 2018-10-04 at 11:53 -0700, Steve Longerbeam wrote: > IDMAC interlaced scan, a.k.a. interweave, should be enabled in the > IDMAC output channels only if the IDMAC output pad field type is > 'seq-bt' or 'seq-tb', and field type at the capture interface is > 'interlaced*'. > >

Re: [PATCH v4 02/11] gpu: ipu-csi: Swap fields according to input/output field types

2018-10-05 Thread Philipp Zabel
Hi Steve, On Thu, 2018-10-04 at 11:53 -0700, Steve Longerbeam wrote: [...] > int ipu_csi_init_interface(struct ipu_csi *csi, > struct v4l2_mbus_config *mbus_cfg, > -struct v4l2_mbus_framefmt *mbus_fmt) > +struct

Re: [PATCH v4 03/11] gpu: ipu-v3: Add planar support to interlaced scan

2018-10-05 Thread Philipp Zabel
On Thu, 2018-10-04 at 11:53 -0700, Steve Longerbeam wrote: > To support interlaced scan with planar formats, cpmem SLUV must > be programmed with the correct chroma line stride. For full and > partial planar 4:2:2 (YUV422P, NV16), chroma line stride must > be doubled. For full and partial planar

[PATCH v5 1/2] memory_hotplug: Free pages as higher order

2018-10-05 Thread Arun KS
When free pages are done with higher order, time spend on coalescing pages by buddy allocator can be reduced. With section size of 256MB, hot add latency of a single section shows improvement from 50-60 ms to less than 1 ms, hence improving the hot add latency by 60%. Modify external providers of

[PATCH v5 2/2] mm/page_alloc: remove software prefetching in __free_pages_core

2018-10-05 Thread Arun KS
They not only increase the code footprint, they actually make things slower rather than faster. Remove them as contemporary hardware doesn't need any hint. Suggested-by: Dan Williams Signed-off-by: Arun KS --- mm/page_alloc.c | 6 +- 1 file changed, 1 insertion(+), 5 deletions(-) diff

[PATCH v2 1/2] staging: iio: cdc: ad7150: use value copy to shorten the line length

2018-10-05 Thread Slawomir Stepien
By using the copy of channel attribute, we can now make the lines short enough to eliminate the checkpatch.pl problem: CHECK: Alignment should match open parenthesis Signed-off-by: Slawomir Stepien --- drivers/staging/iio/cdc/ad7150.c | 5 +++-- 1 file changed, 3 insertions(+), 2

[PATCH v2 2/2] staging: iio: cdc: ad7150: fix misaligned lines

2018-10-05 Thread Slawomir Stepien
These lines were misaligned, but the checkpatch.pl didn't indicate them as such. Signed-off-by: Slawomir Stepien --- drivers/staging/iio/cdc/ad7150.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/iio/cdc/ad7150.c b/drivers/staging/iio/cdc/ad7150.c index

[PATCH v2 0/2] Fix style problems in ad7150 driver

2018-10-05 Thread Slawomir Stepien
This series will fix simple style problems inside the ad7150 driver. --- Changes since v1: - Use channel value copy rather than pointer - for better readability - Change "problem" -> "problems" in cover letter description --- Slawomir Stepien (2): staging: iio: cdc: ad7150: use value copy to

Re: [PATCH RFC] mm/memory_hotplug: Introduce memory block types

2018-10-05 Thread David Hildenbrand
On 04/10/2018 19:50, Michal Suchánek wrote: > On Thu, 4 Oct 2018 17:45:13 +0200 > David Hildenbrand wrote: > >> On 04/10/2018 17:28, Michal Suchánek wrote: > >>> >>> The state of the art is to determine what to do with hotplugged >>> memory in userspace based on platform and virtualization

Re: [PATCH v4] memory_hotplug: Free pages as higher order

2018-10-05 Thread Arun KS
On 2018-10-04 20:21, Michal Hocko wrote: On Wed 03-10-18 19:09:39, Arun KS wrote: [...] +static int online_pages_blocks(unsigned long start, unsigned long nr_pages) +{ + unsigned long end = start + nr_pages; + int order, ret, onlined_pages = 0; + + while (start < end) { +

Re: [PATCH v3 2/6] mm/memory_hotplug: make add_memory() take the device_hotplug_lock

2018-10-05 Thread Oscar Salvador
On Thu, Sep 27, 2018 at 11:25:50AM +0200, David Hildenbrand wrote: > Reviewed-by: Pavel Tatashin > Reviewed-by: Rafael J. Wysocki > Reviewed-by: Rashmica Gupta > Signed-off-by: David Hildenbrand Reviewed-by: Oscar Salvador -- Oscar Salvador SUSE L3

Re: [PATCH v3 1/6] mm/memory_hotplug: make remove_memory() take the device_hotplug_lock

2018-10-05 Thread Oscar Salvador
On Thu, Sep 27, 2018 at 11:25:49AM +0200, David Hildenbrand wrote: > Reviewed-by: Pavel Tatashin > Reviewed-by: Rafael J. Wysocki > Reviewed-by: Rashmica Gupta > Signed-off-by: David Hildenbrand Reviewed-by: Oscar Salvador -- Oscar Salvador SUSE L3

Re: [PATCH v3 6/6] memory-hotplug.txt: Add some details about locking internals

2018-10-05 Thread Oscar Salvador
On Thu, Sep 27, 2018 at 11:25:54AM +0200, David Hildenbrand wrote: > Cc: Jonathan Corbet > Cc: Michal Hocko > Cc: Andrew Morton > Reviewed-by: Pavel Tatashin > Reviewed-by: Rashmica Gupta > Signed-off-by: David Hildenbrand Reviewed-by: Oscar Salvador -- Oscar Salvador SUSE L3

Re: [PATCH v3 3/6] mm/memory_hotplug: fix online/offline_pages called w.o. mem_hotplug_lock

2018-10-05 Thread Oscar Salvador
On Thu, Sep 27, 2018 at 11:25:51AM +0200, David Hildenbrand wrote: > Reviewed-by: Pavel Tatashin > Reviewed-by: Rashmica Gupta > Signed-off-by: David Hildenbrand Reviewed-by: Oscar Salvador -- Oscar Salvador SUSE L3 ___ devel mailing list