Re: [PATCH 0/5] staging: rtl8712: Fixed Multiple FSF address checkpatch warnings

2016-03-20 Thread Joshua Clayton
On Sunday, March 20, 2016 11:12:32 PM Parth Sane wrote: > > Fixed Multiple FSF address checkpatch warnings to conform to kernel coding > > style. > > > > Parth Sane (5): > > staging: rtl8712: Fixed FSF address warning in basic_types.h > > staging: rtl8712: Fixed FSF address warning in

Re: [PATCH v3 1/9] Staging: rts5208: rtsx_transport.c: Cleanup comments

2016-02-09 Thread Joshua Clayton
Hi Shaun. These comments now reflect common kernel style. Thanks for addressing my comments. Just one minor note below. It seems the word SCSI SCSI got duplicated in one comment. (Noted below). The rest look great to me. On Tuesday, February 09, 2016 06:45:20 PM Shaun Ren wrote: > This patch

Re: [PATCH v2 1/9] Staging: rts5208: rtsx_transport.c: Fix comment style warnings

2016-02-08 Thread Joshua Clayton
Hello Shaun, /* * Multiline comments (except in the net subsystem) should * start with "/*" on a separate line. see Documentation/CodingStyle */ If you are going to fix the comments you should get both the beginning and the end. More comments inline. On Monday, February 08, 2016 05:31:17 PM

Re: [patch] staging: rtl8712: memory corruption in wpa_set_encryption()

2016-01-30 Thread Joshua Clayton
On Saturday, January 30, 2016 05:41:10 PM Dan Carpenter wrote: > ->KeyMaterial is declared as a 16 byte array, but we only ever allocate > either 5 or 13 bytes of it. The problem is that we memset() all 16 > bytes to zero so we're memsetting past the end of the allocated memory. > > I fixed this

[PATCH] mm: fix noisy sparse warning in LIBCFS_ALLOC_PRE()

2015-12-26 Thread Joshua Clayton
running sparse on drivers/staging/lustre results in dozens of warnings: include/linux/gfp.h:281:41: warning: odd constant _Bool cast (40 becomes 1) Use "!!" to explicitly convert the result to bool range. --- include/linux/gfp.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff

[PATCH v2] staging: lustre: fix lock imbalance

2015-12-26 Thread Joshua Clayton
in 'nrs_resource_put_safe' - different lock contexts for basic block Signed-off-by: Joshua Clayton <stillcompil...@gmail.com> --- changed for v2: - remove unused nrs variable drivers/staging/lustre/lustre/ptlrpc/nrs.c | 14 ++ 1 file changed, 2 insertions(+), 12 deletions(-) diff

Re: [PATCH] staging: rtl8712: remove dead code

2015-09-29 Thread Joshua Clayton
On Monday, September 28, 2015 10:52:33 PM Luis de Bethencourt wrote: > The while() loop will only exit in a return or a goto ask_for_joinbss, > which means it will never break and execute the return after it. > Removing return _FAIL since it is dead code. > > Signed-off-by: Luis de Bethencourt

Re: [PATCH] Staging: rtl8712: rtl871x_ioctl_linux.c Move constant to right side of the comparision

2015-09-26 Thread Joshua Clayton
On Saturday, September 26, 2015 11:24:06 PM punit vara wrote: > On Sat, Sep 26, 2015 at 11:15 PM, Larry Finger > wrote: > > On 09/26/2015 11:49 AM, Punit Vara wrote: > >> > >> This patch is to the rtl871x_ioctl_linux.c that fixes up following > >> warning reported by

[PATCH v4 REPOST 0/8] clean up wlan_bssdef.h

2015-08-05 Thread Joshua Clayton
of lines that fit within 80 characters, removing superfluous == true expressions that would otherwise keep the lines overlong. Joshua Clayton (8): staging: rtl8712: fix buggy size calculation staging: rtl8712: simplify size calculation staging: rtl8712: fix comment staging: rtl8712

[PATCH v4 REPOST 2/8] staging: rtl8712: simplify size calculation

2015-08-05 Thread Joshua Clayton
replace item-by-item size calculation of a struct with the size of the struct. This gets rid of a use of typedef NDIS_802_11_RATES_EX Signed-off-by: Joshua Clayton stillcompil...@gmail.com --- drivers/staging/rtl8712/rtl871x_cmd.c | 11 +-- 1 file changed, 1 insertion(+), 10 deletions

[PATCH v4 REPOST 5/8] staging: rtl8712: remove duplicate struct

2015-08-05 Thread Joshua Clayton
struct ndis_wlan_bssid_ex is a doppelganger of struct wlan_bssid_ex, and is used about a third as often. Switch all instances to wlan_bssid_ex, and remove ndis_wlan_bssid_ex This also gets rid of a use of typedef NDIS_802_11_RATES_EX Signed-off-by: Joshua Clayton stillcompil...@gmail.com

[PATCH v4 REPOST 3/8] staging: rtl8712: fix comment

2015-08-05 Thread Joshua Clayton
to the current size. Signed-off-by: Joshua Clayton stillcompil...@gmail.com --- drivers/staging/rtl8712/wlan_bssdef.h | 12 +--- 1 file changed, 1 insertion(+), 11 deletions(-) diff --git a/drivers/staging/rtl8712/wlan_bssdef.h b/drivers/staging/rtl8712/wlan_bssdef.h index 2ea8a3d

[PATCH v4 REPOST 1/8] staging: rtl8712: fix buggy size calculation

2015-08-05 Thread Joshua Clayton
r8712_get_ndis_wlan_bssid_ex_sz has a 6 * sizeof(unsigned long) where the underlying struct has a 6 * unsigned char. Simplify the calculation by just subtracting the variable part from the size of the struct. This also gets rid of a use of typedef NDIS_802_11_RATES_EX Signed-off-by: Joshua

[PATCH v4 REPOST 7/8] staging: rtl8712: remove typedefs

2015-08-05 Thread Joshua Clayton
Coding style fix. Get rid of typedefs NDIS_802_11_RATES and NDIS_802_11_RATES_EX Undo any casting that was done as a result of the typedef. Signed-off-by: Joshua Clayton stillcompil...@gmail.com --- drivers/staging/rtl8712/rtl871x_ioctl_linux.c | 12 ++-- drivers/staging/rtl8712

[PATCH v4 REPOST 8/8] staging: rtl8712: change SupportedRates to rates

2015-08-05 Thread Joshua Clayton
Change the value to a name that conforms to Linux coding style. rates is equally expressive in this context, and I have left alone a comment and function name that describe the rates as supported rates. Signed-off-by: Joshua Clayton stillcompil...@gmail.com --- drivers/staging/rtl8712/ieee80211

[PATCH v4 REPOST 4/8] staging: rtl8712: removed unused wrapper structs

2015-08-05 Thread Joshua Clayton
Remove wrapper structs that just wrap struct ndis_wlan_bssid_ex, and are unused. Signed-off-by: Joshua Clayton stillcompil...@gmail.com --- drivers/staging/rtl8712/rtl871x_cmd.h | 18 -- 1 file changed, 18 deletions(-) diff --git a/drivers/staging/rtl8712/rtl871x_cmd.h b

[PATCH v4 REPOST 6/8] staging: rtl8712: rename function

2015-08-05 Thread Joshua Clayton
Rename r8712_get_ndis_wlan_bssid_ex_sz() to r8712_get_wlan_bssid_ex_sz(), which corresponds to the struct whose size it measures. Signed-off-by: Joshua Clayton stillcompil...@gmail.com --- drivers/staging/rtl8712/rtl871x_cmd.c | 8 drivers/staging/rtl8712/rtl871x_mlme.c | 16

[PATCH V4 1/8] staging: rtl8712: fix buggy size calculation

2015-07-29 Thread Joshua Clayton
r8712_get_ndis_wlan_bssid_ex_sz has a 6 * sizeof(unsigned long) where the underlying struct has a 6 * unsigned char. Simplify the calculation by just subtracting the variable part from the size of the struct. This also gets rid of a use of typedef NDIS_802_11_RATES_EX Signed-off-by: Joshua

[PATCH V4 5/8] staging: rtl8712: remove duplicate struct

2015-07-29 Thread Joshua Clayton
struct ndis_wlan_bssid_ex is a doppelganger of struct wlan_bssid_ex, and is used about a third as often. Switch all instances to wlan_bssid_ex, and remove ndis_wlan_bssid_ex This also gets rid of a use of typedef NDIS_802_11_RATES_EX Signed-off-by: Joshua Clayton stillcompil...@gmail.com

[PATCH V4 6/8] staging: rtl8712: rename function

2015-07-29 Thread Joshua Clayton
Rename r8712_get_ndis_wlan_bssid_ex_sz() to r8712_get_wlan_bssid_ex_sz(), which corresponds to the struct whose size it measures. Signed-off-by: Joshua Clayton stillcompil...@gmail.com --- drivers/staging/rtl8712/rtl871x_cmd.c | 8 drivers/staging/rtl8712/rtl871x_mlme.c | 16

[PATCH V4 3/8] staging: rtl8712: fix comment

2015-07-29 Thread Joshua Clayton
to the current size. Signed-off-by: Joshua Clayton stillcompil...@gmail.com --- drivers/staging/rtl8712/wlan_bssdef.h | 12 +--- 1 file changed, 1 insertion(+), 11 deletions(-) diff --git a/drivers/staging/rtl8712/wlan_bssdef.h b/drivers/staging/rtl8712/wlan_bssdef.h index 2ea8a3d

[PATCH V4 8/8] staging: rtl8712: change SupportedRates to rates

2015-07-29 Thread Joshua Clayton
Change the value to a name that conforms to Linux coding style. rates is equally expressive in this context, and I have left alone a comment and function name that describe the rates as supported rates. Signed-off-by: Joshua Clayton stillcompil...@gmail.com --- drivers/staging/rtl8712/ieee80211

[PATCH V4 2/8] staging: rtl8712: simplify size calculation

2015-07-29 Thread Joshua Clayton
replace item-by-item size calculation of a struct with the size of the struct. This gets rid of a use of typedef NDIS_802_11_RATES_EX Signed-off-by: Joshua Clayton stillcompil...@gmail.com --- drivers/staging/rtl8712/rtl871x_cmd.c | 11 +-- 1 file changed, 1 insertion(+), 10 deletions

[PATCH V4 4/8] staging: rtl8712: removed unused wrapper structs

2015-07-29 Thread Joshua Clayton
Remove wrapper structs that just wrap struct ndis_wlan_bssid_ex, and are unused. Signed-off-by: Joshua Clayton stillcompil...@gmail.com --- drivers/staging/rtl8712/rtl871x_cmd.h | 18 -- 1 file changed, 18 deletions(-) diff --git a/drivers/staging/rtl8712/rtl871x_cmd.h b

[PATCH V4 7/8] staging: rtl8712: remove typedefs

2015-07-29 Thread Joshua Clayton
Coding style fix. Get rid of typedefs NDIS_802_11_RATES and NDIS_802_11_RATES_EX Undo any casting that was done as a result of the typedef. Signed-off-by: Joshua Clayton stillcompil...@gmail.com --- drivers/staging/rtl8712/rtl871x_ioctl_linux.c | 12 ++-- drivers/staging/rtl8712

Re: [PATCH V3 0/8] clean up wlan_bssdef.h

2015-07-28 Thread Joshua Clayton
On Tuesday, July 28, 2015 07:27:53 AM Julia Lawall wrote: Something horrible seems to have happened in your patch sending process, and you have the same message over and over. I see that now. :( This was a failed work-around to git-send-email I forgot I had done early in the day. I'll fix it

[PATCH V3 RESEND 2/8] staging: rtl8712: simplify size calculation

2015-07-28 Thread Joshua Clayton
replace item-by-item size calculation of a struct with the size of the struct. This gets rid of a use of typedef NDIS_802_11_RATES_EX Signed-off-by: Joshua Clayton stillcompil...@gmail.com --- drivers/staging/rtl8712/rtl871x_cmd.c | 11 +-- 1 file changed, 1 insertion(+), 10 deletions

[PATCH V3 RESEND 8/8] staging: rtl8712: change SupportedRates to rates

2015-07-28 Thread Joshua Clayton
Change the value to a name that conforms to Linux coding style. rates is equally expressive in this context, and I have left alone a comment and function name that describe the rates as supported rates. Signed-off-by: Joshua Clayton stillcompil...@gmail.com --- drivers/staging/rtl8712/ieee80211

[PATCH V3 RESEND 7/8] staging: rtl8712: remove typedefs

2015-07-28 Thread Joshua Clayton
Coding style fix. Get rid of typedefs NDIS_802_11_RATES and NDIS_802_11_RATES_EX Undo any casting that was done as a result of the typedef. Signed-off-by: Joshua Clayton stillcompil...@gmail.com --- drivers/staging/rtl8712/rtl871x_ioctl_linux.c | 12 ++-- drivers/staging/rtl8712

Re: [PATCH V3 RESEND 8/8] staging: rtl8712: change SupportedRates to rates

2015-07-28 Thread Joshua Clayton
be some other cases in the patch where the line breaks could be adjusted to improve readability. julia I agree. Dan Carpenter earlier complained about me fixing up the lines while changing the variable name. Should that be a separate patch? -- ~Joshua Clayton

Re: [PATCH V3 1/8] staging: rtl8712: fix buggy size calculation

2015-07-28 Thread Joshua Clayton
On Tuesday, July 28, 2015 05:16:56 PM Sudip Mukherjee wrote: On Mon, Jul 27, 2015 at 09:41:10PM -0700, Joshua Clayton wrote: r8712_get_ndis_wlan_bssid_ex_sz has a 6 * sizeof(unsigned long) where the underlying struct has a 6 * unsigned char. Simplify the calculation by just subtracting

Re: [PATCH V3 RESEND 8/8] staging: rtl8712: change SupportedRates to rates

2015-07-28 Thread Joshua Clayton
On Tuesday, July 28, 2015 06:56:38 PM Dan Carpenter wrote: On Tue, Jul 28, 2015 at 08:50:04AM -0700, Joshua Clayton wrote: On Tuesday, July 28, 2015 05:37:16 PM Julia Lawall wrote: diff --git a/drivers/staging/rtl8712/rtl871x_ioctl_linux.c b/drivers/staging/rtl8712

[PATCH V2 2/6] staging: rtl8712: simplify size calculation

2015-07-27 Thread Joshua Clayton
replace item-by-item size calculation of a struct with the size of the struct. This gets rid of a use of typedef NDIS_802_11_RATES_EX Signed-off-by: Joshua Clayton stillcompil...@gmail.com diff --git a/drivers/staging/rtl8712/rtl871x_cmd.c b/drivers/staging/rtl8712/rtl871x_cmd.c index e35854d

[PATCH V2 0/6] clean up wlan_bssdef.h

2015-07-27 Thread Joshua Clayton
to the typedef Joshua Clayton (6): staging: rtl8712: fix buggy size calculation staging: rtl8712: simplify size calculation staging: rtl8712: fix comment staging: rtl8712: remove duplicate struct staging: rtl8712: remove typedefs staging: rtl8712: change SupportedRates to rates drivers/staging

[PATCH V2 1/6] staging: rtl8712: fix buggy size calculation

2015-07-27 Thread Joshua Clayton
r8712_get_ndis_wlan_bssid_ex_sz has a 6 * sizeof(unsigned long) where the underlying struct has a 6 * unsigned char. Simplify the calculation by just subtracting the variable part from the size of the struct. This also gets rid of a use of typedef NDIS_802_11_RATES_EX Signed-off-by: Joshua

[PATCH V2 0/6] clean up wlan_bssdef.h

2015-07-27 Thread Joshua Clayton
to the typedef Joshua Clayton (6): staging: rtl8712: fix buggy size calculation staging: rtl8712: simplify size calculation staging: rtl8712: fix comment staging: rtl8712: remove duplicate struct staging: rtl8712: remove typedefs staging: rtl8712: change SupportedRates to rates drivers/staging

[PATCH V2 3/6] staging: rtl8712: fix comment

2015-07-27 Thread Joshua Clayton
to the current size. Signed-off-by: Joshua Clayton stillcompil...@gmail.com diff --git a/drivers/staging/rtl8712/wlan_bssdef.h b/drivers/staging/rtl8712/wlan_bssdef.h index 2ea8a3d..8c5d6e7 100644 --- a/drivers/staging/rtl8712/wlan_bssdef.h +++ b/drivers/staging/rtl8712/wlan_bssdef.h @@ -83,17

[PATCH V2 2/6] staging: rtl8712: simplify size calculation

2015-07-27 Thread Joshua Clayton
replace item-by-item size calculation of a struct with the size of the struct. This gets rid of a use of typedef NDIS_802_11_RATES_EX Signed-off-by: Joshua Clayton stillcompil...@gmail.com diff --git a/drivers/staging/rtl8712/rtl871x_cmd.c b/drivers/staging/rtl8712/rtl871x_cmd.c index e35854d

[PATCH V3 1/8] staging: rtl8712: fix buggy size calculation

2015-07-27 Thread Joshua Clayton
) + - sizeof(NDIS_802_11_RATES_EX) + - sizeof(u32) + bss-IELength; - return t_len; + return sizeof(*bss) + bss-IELength - MAX_IE_SZ; } u8 *r8712_get_capability_from_ie(u8 *ie) -- 2.4.6 From: Joshua Clayton stillcompil...@gmail.com To: Larry Finger

[PATCH V3 3/8] staging: rtl8712: fix comment

2015-07-27 Thread Joshua Clayton
to the current size. Signed-off-by: Joshua Clayton stillcompil...@gmail.com --- drivers/staging/rtl8712/wlan_bssdef.h | 12 +--- 1 file changed, 1 insertion(+), 11 deletions(-) diff --git a/drivers/staging/rtl8712/wlan_bssdef.h b/drivers/staging/rtl8712/wlan_bssdef.h index 2ea8a3d

[PATCH V3 4/8] staging: rtl8712: removed unused wrapper structs

2015-07-27 Thread Joshua Clayton
Remove wrapper structs that just wrap struct ndis_wlan_bssid_ex, and are unused. Signed-off-by: Joshua Clayton stillcompil...@gmail.com --- drivers/staging/rtl8712/rtl871x_cmd.h | 18 -- 1 file changed, 18 deletions(-) diff --git a/drivers/staging/rtl8712/rtl871x_cmd.h b

[PATCH V3 0/8] clean up wlan_bssdef.h

2015-07-27 Thread Joshua Clayton
to the typedef Changes sinve V2: broke former patch 4, which was too big for git-send-email into 3 parts Joshua Clayton (8): staging: rtl8712: fix buggy size calculation staging: rtl8712: simplify size calculation staging: rtl8712: fix comment staging: rtl8712: removed unused wrapper structs

Re: [PATCH 3/5] staging: rtl8712: remove duplicate struct

2015-07-24 Thread Joshua Clayton
On Friday, July 24, 2015 02:02:56 PM Sudip Mukherjee wrote: On Thu, Jul 23, 2015 at 09:57:50PM -0700, Joshua Clayton wrote: struct ndis_wlan_bssid_ex is a dopelganger of struct wlan_bssid_ex, and is used about a third as often Switch all instances to wlan_bssid_ex This also gets rid

Re: [PATCH 5/5] staging: rtl8712: style fix:

2015-07-24 Thread Joshua Clayton
Dan, On Friday, July 24, 2015 01:52:27 PM Dan Carpenter wrote: Write a better subject line. On Thu, Jul 23, 2015 at 09:53:18PM -0700, Joshua Clayton wrote: change instances SupportedRates to compliant and sane rates This change in no way harms readability, and brings several lines under

[PATCH 2/5] staging: rtl8712: simplify size calculation

2015-07-23 Thread Joshua Clayton
replace item-by-item size calculation of a struct with the size of the struct. This gets rid of a use of typedef NDIS_802_11_RATES_EX Signed-off-by: Joshua Clayton stillcompil...@gmail.com --- drivers/staging/rtl8712/rtl871x_cmd.c | 11 +-- 1 file changed, 1 insertion(+), 10 deletions

[PATCH 1/5] staging: rtl8712: fix buggy size calculation

2015-07-23 Thread Joshua Clayton
r8712_get_ndis_wlan_bssid_ex_sz has a 6 * sizeof(unsigned long) where the underlying struct has a 6 * unsigned char. Simplify the calculation by just subtracting the variable part from the size of the struct. This also gets rid of a use of typedef NDIS_802_11_RATES_EX Signed-off-by: Joshua

[PATCH 5/5] staging: rtl8712: style fix:

2015-07-23 Thread Joshua Clayton
change instances SupportedRates to compliant and sane rates This change in no way harms readability, and brings several lines under the 80 character limit. Signed-off-by: Joshua Clayton stillcompil...@gmail.com --- drivers/staging/rtl8712/ieee80211.c | 22

[PATCH 4/5] staging: rtl8712: remove typedefs

2015-07-23 Thread Joshua Clayton
Coding style fix. Get rid of typedefs NDIS_802_11_RATES and NDIS_802_11_RATES_EX Signed-off-by: Joshua Clayton stillcompil...@gmail.com --- drivers/staging/rtl8712/rtl871x_ioctl_linux.c | 4 ++-- drivers/staging/rtl8712/wlan_bssdef.h | 7 +-- 2 files changed, 3 insertions(+), 8

[PATCH 0/5]

2015-07-23 Thread Joshua Clayton
could not bring myself to leave a variable called SupportedRates in the kernel with my name on it. I have tested this on amd64. cwthe module loads and doesn't explode Joshua Clayton (5): staging: rtl8712: fix buggy size calculation staging: rtl8712: simplify size calculation staging

[PATCH 3/5] staging: rtl8712: remove duplicate struct

2015-07-23 Thread Joshua Clayton
struct ndis_wlan_bssid_ex is a dopelganger of struct wlan_bssid_ex, and is used about a third as often Switch all instances to wlan_bssid_ex This also gets rid of a use of typedef NDIS_802_11_RATES_EX Signed-off-by: Joshua Clayton stillcompil...@gmail.com --- drivers/staging/rtl8712