How about this. To me it is more readable.
type
THtmlColorName = (
*hcnUnknown*, hcnWhite, hcnSilver, hcnGray, hcnBlack,
hcnRed, hcnMaroon, hcnYellow, hcnOlive,
hcnLime, hcnGreen, hcnAqua, hcnTeal, hcnBlue,
hcnNavy, hcnFuchsia, hcnPurple);
function TryStrToHtmlColorName(const S: St
Apparently, the FPC wiki uses the same software as Wikipedia; if so, the
following links may be useful.
https://en.wikipedia.org/wiki/Wikipedia:Manual_of_Style/Mathematics#Using_HTML
https://en.wikipedia.org/wiki/Wikipedia:Mathematical_symbols
https://en.wikipedia.org/wiki/List_of_mathematical_
On 2014-10-29 14:58, Sven Barth wrote:
Delphi introduced weak variable to break up cycling, I implemented
them similary in my branch (not using the attribute syntax though) and
in Florian's suggestions all object instance variables in legacy code
would be "weak" for backwards compatibility.
G
On 2014-10-27 09:39, Michael Van Canneyt wrote:
On Mon, 27 Oct 2014, ListMember wrote:
On 2014-10-27 00:00, Sven Barth wrote:
On 26.10.2014 12:17, Kostas Michalopoulos wrote:
On Sun, Oct 26, 2014 at 8:32 AM, Sven Barth
<mailto:pascaldra...@googlemail.
On 2014-10-27 00:00, Sven Barth wrote:
On 26.10.2014 12:17, Kostas Michalopoulos wrote:
On Sun, Oct 26, 2014 at 8:32 AM, Sven Barth mailto:pascaldra...@googlemail.com>> wrote:
Definitely not. We are in Pascal and there such directives are
placed afterwards.
how about these:
1) 'record
On 2014-02-10 00:02, Florian Klämpfl wrote:
The lazarus forum can be reached at
http://forum.lazarus.freepascal.org/index.php?action=forum
Shouldn't this link go directly to forum?
http://forum.lazarus.freepascal.org/
___
fpc-devel maillist - fpc-
On 2013-03-06 13:13, Alexander Klenin wrote:
On Wed, Mar 6, 2013 at 10:00 PM, Michael Schnell wrote:
On 03/05/2013 05:17 PM, Alexander Klenin wrote:
1) Make sure "is" and "as" work with generic types -- maybe they already
are?
"is" the generic type and/or "is" a certain specialization ?
Yes,
On 2013-03-05 12:37, Sven Barth wrote:
Thanks, I try my best :)
I know you do.
And, since generics has also been mentioned in this thread, here is
something I'd like to table/mention (or, rather, use you as a sounding
board, if I may).
Sometimes writing generic routines that are truly gene
On 2013-03-02 21:55, Sven Barth wrote:
- (in context with the above point) couple the support for the
anonymous functions to a new modeswitch (enabled by default in mode
delphi), but allow "reference to" procvars in non-Delphi modes (this
way you'd only be able to use nested functions, but late
On 2012-12-22 11:48, Michael Van Canneyt wrote:
On Sat, 22 Dec 2012, ListMember wrote:
On 2012-12-22 00:27, Sven Barth wrote:
Am 21.12.2012 22:20 schrieb "ListMember"
:
>
> Can you (or someone else, of course) think of a better search
string to locate it?
G
On 2012-12-22 00:27, Sven Barth wrote:
Am 21.12.2012 22:20 schrieb "ListMember" <mailto:listmem...@letterboxes.org>>:
>
> Can you (or someone else, of course) think of a better search string
to locate it?
Go to View Issues, click on the + before the search bix
On 2012-12-21 22:29, Michael Van Canneyt wrote:
On Fri, 21 Dec 2012, ListMember wrote:
On 2012-12-21 14:26, Michael Van Canneyt wrote:
- Inoussa has made a native unicode string manager. A large effort.
Is this code publicly available somewhere?
It's attached to a bugreport in M
On 2012-12-21 14:26, Michael Van Canneyt wrote:
- Inoussa has made a native unicode string manager. A large effort.
Is this code publicly available somewhere?
___
fpc-devel maillist - fpc-devel@lists.freepascal.org
http://lists.freepascal.org/mailma
I am sorry. I didn't mean to send it here.
But, now that I did: Does anyone know of Tor/Onion protocol
implementation in Pascal.
Cheers
On 2009-09-23 13:26, listmember wrote:
___
fpc-devel maillist - fpc-devel@lists.freepascal.org
___
fpc-devel maillist - fpc-devel@lists.freepascal.org
http://lists.freepascal.org/mailman/listinfo/fpc-devel
On 2009-08-17 01:20, Graeme Geldenhuys wrote:
An exact example would be very helpful. And the old "property mapping
to database field" doesn't could, because that's a design preference
and such mappings are not always appropriate or possible.
What I have in mind isn't quite an example but I'd l
On 2008-11-23 19:31, Graeme Geldenhuys wrote:
At least the good thing of UTF-8 is that you don't have to worry about
LE or BE byte orders. UTF-16 and UTF-32 have that nasty issue.
LE/BE only applies when streaming to/from file/device/network, otherwise
life is much simpler with UTF-32.
__
On 2008-11-23 15:10, Marco van de Voort wrote:
In our previous episode, listmember said:
[]..
I'd like to know this, in particular, for FPC ana Lazarus --to begin with.
And, the reason I'd like to know this is this: Whenever I suggest that
char size be increased to 4, the idea ge
On 2008-11-23 14:49, Daniël Mantione wrote:
Op Sun, 23 Nov 2008, schreef Jonas Maebe:
On 23 Nov 2008, at 13:31, Daniël Mantione wrote:
For an IDE, this is a little bit more complicated. I.e. searching for
a ç in a source file needs to find both the composed and the
decomposed variant, and in
On 2008-11-23 14:19, Mattias Gaertner wrote:
On Sun, 23 Nov 2008 13:35:07 +0200
listmember<[EMAIL PROTECTED]> wrote:
[...]
These dependencies are complex and require exclusive access. The
memory belongs to the program, the source files can be changed by
anyone.
Therefore the files ar
On 2008-11-23 14:34, Mattias Gaertner wrote:
On Sun, 23 Nov 2008 14:11:50 +0200
listmember<[EMAIL PROTECTED]> wrote:
That leaves me wondering how much do we lose performance-wise in
endlessly decompressing UTF-8 data, instead of using, say, UCS-4
strings.
I'm wondering what yo
On 2008-11-23 14:10, Daniël Mantione wrote:
Therefore, any other encoding is a waste of memory and does not gain you
any speed. For that reason, I don't see the compiler switch from 8-bit
processing either.
I nearly fully agree with you.
Except that, when a string constant needs to contain no
On 2008-11-23 13:49, Jonas Maebe wrote:
On 23 Nov 2008, at 12:35, listmember wrote:
But, isn't this a design-choice; caching all sources in memory for
speed reasons, as opposed to on-demand opening and closing each file.
For very large projects, that should probably be done anyway at
Do a 'find declaration' on an identifier, that does not exist. This
will explore all units of the uses section.
Now I see what you mean.
But, isn't this a design-choice; caching all sources in memory for speed
reasons, as opposed to on-demand opening and closing each file.
Still. If that is
However, you may hack into RTL at the NewAnsiString / NewWideString /
NewUnicodeString procedures and install hooks that will record the
number of bytes requested. That shouldn't be too difficult to do.
This is what I was looking for.
Thank you.
___
fp
On 2008-11-23 13:07, Graeme Geldenhuys wrote:
On Sun, Nov 23, 2008 at 12:29 PM, listmember<[EMAIL PROTECTED]> wrote:
What I am curious about is: 4 times of what?
RAM, Ramdom Access Memory, DIMMs those little green sticks you
shove into the mothe
On 2008-11-23 12:50, Jonas Maebe wrote:
On 23 Nov 2008, at 11:29, listmember wrote:
It is not hard to tell that an app that works with text files (such
as Lazarus) will consume 4 times more memory per file loaded.
But, how much memory does, say, Lazarus --itself-- consume
specifically for
I thought my example described just that. If strings use 4 bytes per
char then ASCII text will need 4 times more memory.
I am not disputing that.
What I am curious about is: 4 times of what?
It is not hard to tell that an app that works with text files (such as
Lazarus) will consume 4 times m
Actually, load times are not --does not seem to be-- linear at all.
4 times larger file seems to take only twice as long.
I did one very simple test using 2 text files:
File 1: 384 MB (403,248,710 bytes)
File 2: 120 MB (126,680,448 bytes)
with the code below:
procedure TForm1.Button1Click(Sen
I am only considering in memory representation being UTF-32 (or
UCS-4).
What do you mean with 'memory representation'?
That, each char in a string in memory would be 4-bytes (or more); yet,
when saved on disk (or transmitted across the net etc.) it would be
UTF-8 compressed. IOW, no compress
On 2008-11-23 10:19, Mattias Gaertner wrote:
On Sat, 22 Nov 2008 23:05:43 +0200
listmember<[EMAIL PROTECTED]> wrote:
Is there a way to determine how much memory is consumed by strings by
a running application?
I'd like to know this, in particular, for FPC ana Lazarus --to begin
Is there a way to determine how much memory is consumed by strings by a
running application?
I'd like to know this, in particular, for FPC ana Lazarus --to begin with.
And, the reason I'd like to know this is this: Whenever I suggest that
char size be increased to 4, the idea gets opposed on t
Ok, two questions for the example above:
- how do you maintain backward compatibility?
- how do you load a plain old ansi file?
You could alter the LoadFromFile(), LoadFromStream(), SaveToFile(),
SaveToStrwam() routines like below:
procedure TStringList.LoadFromFile(AFileName: TFilename; cons
What data could I be pushing to the server?
The state of your current copy of the repository; From this the server
can determine what data it should send and what not. If there are too
many files, this will amount to a big request, and that could cause such
an error response.
H.. That make
And the error is quite clear: you're pushing too much data to the server.
I don't have 'write' access. Not have I done any alterations to copy I
have so far managed to get.
What data could I be pushing to the server?
Try cutting up in several smaller chunks:
Browse the server repository, an
On 2008-11-07 19:12, Aleksa Todorovic wrote:
So, which action from right-click menu have you chosen? SVN Checkout?
First 'SVN Checkout'; then --after each failure-- 'SVN Update'
___
fpc-devel maillist - fpc-devel@lists.freepascal.org
http://lists.fr
You were trying to download trunk and all possible branches.
Of course I am. That was and is my intention.
My problem isn't disk space. Problem seems to be on the side of the
server --somehow.
It tells my side (client, i.e. TortoiseSVN) "413 Request Entity Too
Large" at exactly the same poi
I mean what command are you using. Something like:
svn co blablabla
Since this is a point-n-click GUI thing, there's no command line that I
know of.
But the URL I am using is this:
http://svn.freepascal.org/svn/fpc
___
fpc-devel maillist - fpc-d
On 2008-11-07 17:40, Felipe Monteiro de Carvalho wrote:
What svn command line are you using?
I am using the latest stable TortoiseSVN (Windows).
Maybe you are trying to download everything, including all tags, all
branches, all binary files, etc, etc.
Yes. I deliberately want to do that.
I was trying to get a copy of the whole FPC SVN, but at some point, I
get the following error:
"Server sent unexpected return value (413 Request Entity Too Large) in
response to REPORT request for '/svn/fpc/!svn/vcc/default'"
Does anyone have any idea why I get this "413 Request Entity Too La
On 2008-10-24 02:46, Felipe Monteiro de Carvalho wrote:
I agree with Daniël on this one. Simplify. ë --> Ë always
If you need something which takes into consideration the language then
build another routine with more parameters.
It's not that simple.
How would you uppercase this piece of str
> DM> Example: In Dutch uppercase characters generally do not get
> tremas: Daniël becomes DANIEL. Should an uppercase routine worry?
> No, this is a spelling convention, the correct uppercase of ë is
> Ë, we should not confuse spelling with uppercasing.
No. This is not a spelling convention. It
Sorry, but I meant comparing with collation. I did not mean comapring
within labguage context.
How can you do /proper/ collation while ignoring the language context?
1) 'sıkıcı' which means 'boring' in English (notice the dotless small
'i's)
2) 'sikici' which means 'fucker' in English
Depe
[Note that, here 'TCharacter' isn't necessarily an object; it might as
well be a simple record structure.]
AFAIK for most programmers this is not a common task. Most programs need less
(one language or codepage)
But, when you're talking unicode, codepage is rather meaningless --isn't it?
or
Actually for you example case doesn't matter. as you need to decide if
"ss" = "ß"
And, this is only valid in German. For all other, the result must either
be false, or undefined.
Is there, in Unicode, start-stop markes that denote 'language'?
I do not know, that was why I said "unused uni
Martin Friebe wrote:
Just to make sure, all of this discussion is based on various collation
No part of this discussion is based on collation.
I am going to leave out the object question for now. I said all I can
say in earlier mails.
That's good. Thank you.
And also from your comments it
So maybe the design is quite well thought?
Adding a flag field is easy enough --if all you're doing is to do some
sort of collation. In that sense, everything is well tought out.
But..
Life becomes very complicated when you begin to do things like FTS (full
text search) on a multilanguage t
IMHO You can't? But you could use a TStringList.
I don't think I could.
Because, in TStringList, you have no way of knowing what language each
item belogs to.
You could, of course, work around it by adding a fake object to each
item denoting the language, but that does mean a generalized so
Actually, UTF-8 can contain bidi info, it's indeed a matter of the
renderer.
And, how do you propose doing a case-insensitive search in a given text
that contains multiple languages?
___
fpc-devel maillist - fpc-devel@lists.freepascal.org
http://
>> procedure TLabel.Paint(...)
>> begin
>> if *Caption.IsRTL *then
>> DrawCaptionRTL(0,0,*Caption.AsUTF8*, flags)
>> else
>> DrawCaption(0,0,*Caption.AsUTF8*, flags);
>> end;
>>
>> Is not that enough?
>
> What is the gain as opposed to
>
> procedure TLabel.Paint(...)
> begin
>if
But it is far more readable when there is special and reserved type
for which we could have special operators and converters just like
those we have for strings and widestrings.
Oh, I thougbt people just complained in this thread that + isn't
appropriate for strings anyways ...
People are, o
compiler guys all the same} and ask, instead, to give us
reference-counted 4-byte (actually, preferably 6-bytes) per cell
arrays/strings.
What's wrong with an dyn. array of DWord?
Much like what's wrong with dynamic array of Word (as opposed to
Widestring) or with dynamic array of byte (as o
But, I could write a gigantic data mining application, a database application
or a myriad of such apps that uses the above class without doing a single
pixel of GUI stuff.
I'd like to see that: it will be guaranteed dog slow :(
Hmm.. may be, maybe not.
Last year I wrote a natural lang parser
Michael Van Canneyt wrote:
You are mixing 2 things:
- Texts (strings) at the compiler language level.
- (complex) GUI design that needs to handle a lot of text and a lot of extra
properties.
:)
If you draw the lines so red and thick, who am I to disagree...
But, I could write a gigantic d
Yes, but most proposals here about a TCharacter are a bit overkill. In
example languare reference for a given char is not very important from
a Unicode point of view, unicode focuses its power in the text, so
locale is important in context operations and collations.
See my other post above.
Michael Van Canneyt wrote:
You are mixing 2 things. There is the actual string content, and there is the
string metadata. The metadata is something that would apply for flyweight
pattern. There is nothing to be gained by putting the metadata in an object,
This is true --upto a point.
And, that
Graeme Geldenhuys wrote:
I have to say I agree with you The Object Pascal / Delphi language
already has way to many string types! At it's just getting worse.
I've always liked the Java style of everything being an object - even
the string type.
The more I look at this Unicode issue, the m
Michael Van Canneyt wrote:
Exactly. There are 4 converters:
Latex2html - a huge perl script which needs more time and memory than God
needed to create the earth, to convert the docs. We dumped it because
it simply takes too long. It's good for small documents (articles), but
I have read the text and I'd like to thank the author for the immense
effort (both in the past and in the future) put into it.
The only criticism I might have on it would be that it is a little too
US-centric.
I am referring to the stuff related to measurement systems, and other
various thin
I wonder if this might be a useful read to the architects here.
http://weblogs.mozillazine.org/roc/archives/2007/04/history_based_s.html
___
fpc-devel maillist - fpc-devel@lists.freepascal.org
http://lists.freepascal.org/mailman/listinfo/fpc-devel
As far as voting goes, personally, I prefer something like this: GList =
generic class(T)
And, are we going to have non-class rotines, such as event declarations; i.e.
TGenericCallback = generic function(AValue1: TGenericValue; AValue2:
TGenericValue): Integer;
TSomeGenericEvent = generic
Peter Vreman wrote:
Could someone give me some pointers to read about the
subject.
Ever heard Google? The second result with a search for 'linker' has
> a lot of information.
Peter,
That was harsh. I did of course google. But, from
the links, I did not get much digestable info.
The second
I know very little about Linker --just vaguely what it
does, and that's all. I googled for it, but could not
find much either.
Could someone give me some pointers to read about the
subject.
The reason why I was interested is, it seems a Linker
is more difficult to write than a compiler --after a
Florian Klaempfl wrote:
If you want to modernize the language you can take the current fpc
code and extend it yourself. If the extension is clear and we agree on
it it can eventually be put in the main fpc release.
Discussions are useful.
Discussions without proper basics are useless. If you
Marc Weustink wrote:
-- Class Contracts
I like the 'require/ensure' aproach.
It makes the code more robust and more debuggable, IMHO
I think the checks you can do there are to limited. I also wonder what
will happen if a require isn't met. Personally I don't want
exeption in my released app.
If you want to modernize the language you can take the current fpc code
and extend it yourself. If the extension is clear and we agree on it it
can eventually be put in the main fpc release.
Discussions are useful.
Before one starts coding away, a consensus would be nice to have.
I would not
First, with
strlist.create;
It is not clear whether strlist is already initialized or not;
there is no way it can now this.
Why not, what stops you from checking 'strlist <> Nil'.. ?
Second, with
strlist.create;
It is not clear from reading whether create is a constructor or not.
Create(
-- Class Contracts
I like the 'require/ensure' aproach.
It makes the code more robust and more debuggable, IMHO
I think the checks you can do there are to limited. I also wonder what
will happen if a require isn't met. Personally I don't want exeption in my
released app.
No, these are asserti
Marco van de Voort wrote:
Some of these target functionality (specially in the linking section) might
require restructures
related to
* introduction of an internal linker for some core platforms (no more LD)
* Rewrite of module (unit) handling
Yes, these would be great, IMHO.
For the
69 matches
Mail list logo