[gwt-contrib] Re: Code Review Request: Fix flaxy MessageTransport test

2010-03-16 Thread Rajeev Dayal
I'm testing that if you try to use MessageTransport.executeRequestAsync(..) and the server side of the network has closed its input stream, then an exception will be thrown (an ExecutionException with an underlying cause of IllegalStateException). I don't think shutdownInput(..) would work, becaus

[gwt-contrib] Add build.xml file with checkstyle target; pass checkstyle

2010-03-16 Thread rice
Reviewers: Ray Ryan, Description: Add build.xml file with checkstyle target; pass checkstyle Review by: rj...@google.com Please review this at http://gwt-code-reviews.appspot.com/218801 Affected files: M bikeshed/build.xml M bikeshed/src/com/google/gwt/bikeshed/cells/client/ProfitLossCell.

[gwt-contrib] Re: Don't ever set the "base" variable to null. It is supposed to be the empty string

2010-03-16 Thread spoon
I'm working on a test case for this tricky code, but it's going to take several hours to put together. Shall we put in the one-line fixes? The selection scripts as they are cause null pointer dereferences in some situations. http://gwt-code-reviews.appspot.com/219801 -- http://groups.google.co

[gwt-contrib] Don't ever set the "base" variable to null. It is supposed to be the empty string

2010-03-16 Thread spoon
Reviewers: jgw, Description: Don't ever set the "base" variable to null. It is supposed to be the empty string if it hasn't been set yet. Please review this at http://gwt-code-reviews.appspot.com/219801 Affected files: M dev/core/src/com/google/gwt/core/linker/IFrameTemplate.js M dev/core

[gwt-contrib] Issue 4720: PopupPanel#removeFromParent doesn't remove glass

2010-03-16 Thread jlabanca
Reviewers: jgw, Description: Calling PopupPanel#removeFromParent or RootPanel.get().remove(popupPanel) does not hide the glass. Fix: = onUnload now uses ResizeAnimation to complete the hide process if the PopupPanel isn't already hidden. While the fix seems trivial, this bug actually reveal

[gwt-contrib] Re: Don't ever set the "base" variable to null. It is supposed to be the empty string

2010-03-16 Thread jgw
On 2010/03/16 15:49:26, Lex wrote: I'm working on a test case for this tricky code, but it's going to take several hours to put together. Shall we put in the one-line fixes? The selection scripts as they are cause null pointer dereferences in some situations. That sounds fine to me for no

Re: [gwt-contrib] Support runAsync with the cross-site linker.

2010-03-16 Thread Lex Spoon
On Mon, Mar 15, 2010 at 8:34 PM, Joel Webber wrote: > That's great news, and will really help with efforts to make our linkers > more sane. Out of curiosity, what's the strategy for loading fragments into > the enclosing namespace (and yes, that's the sound of me being too lazy to > dig into the

[gwt-contrib] [google-web-toolkit] r7735 committed - Created wiki page through web user interface.

2010-03-16 Thread codesite-noreply
Revision: 7735 Author: sp...@google.com Date: Tue Mar 16 09:29:56 2010 Log: Created wiki page through web user interface. http://code.google.com/p/google-web-toolkit/source/detail?r=7735 Added: /wiki/CrossSiteRunAsync.wiki === --- /dev/null +++ /wiki/CrossSit

[gwt-contrib] Update currency data to Unicode CLDR 1.7.2.

2010-03-16 Thread jat
Reviewers: shanjian, Description: Update currency data to Unicode CLDR 1.7.2. Patch by: jat Review by: shanjian Please review this at http://gwt-code-reviews.appspot.com/221801 Affected files: M user/src/com/google/gwt/i18n/client/impl/cldr/CurrencyData.properties M user/src/com/google/gw

Re: [gwt-contrib] Support runAsync with the cross-site linker.

2010-03-16 Thread Eric Ayers
Something is screwy with riedvelt, and I can't leave a comment on XSTemplate.js My comment isn't really about your patch in particular, but the patterns we are using in the linker templates. I wish that stanzas of code common to many linkers, like the calling of __gwtStatsEvent() could be extract

[gwt-contrib] DOMImpl#eventGetTypeInt returns NULL for unknown event types

2010-03-16 Thread jlabanca
Reviewers: Dan Rice, Description: DOMImpl#eventGetTypeInt returns NULL for unknown event types instead of an int, resulting in an exception. Fix: === Added default case that returns -1 and updated JavaDoc. Testing: Added a unit test. Please review this at http://gwt-code-reviews.appsp

[gwt-contrib] Re: Update currency data to Unicode CLDR 1.7.2.

2010-03-16 Thread John Tamplin
On Tue, Mar 16, 2010 at 1:25 PM, Shanjian Li wrote: > Do you think that we should only include currency that is being used, not > those historical currency? Like following: > -ZWD = Zimbabwe Dollar|Z$ +ZWD = Zimbabwean Dollar|Z$|0|1 +ZWL = > Zimbabwean Dollar (2009) +ZWR = Zimbabwean Dollar (2008

[gwt-contrib] Re: DOMImpl#eventGetTypeInt returns NULL for unknown event types

2010-03-16 Thread rice
LGTM http://gwt-code-reviews.appspot.com/222801 -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

Re: [gwt-contrib] Support runAsync with the cross-site linker.

2010-03-16 Thread Lex Spoon
On Tue, Mar 16, 2010 at 11:54 AM, Eric Ayers wrote: > Something is screwy with riedvelt, and I can't leave a comment on > XSTemplate.js > > My comment isn't really about your patch in particular, but the patterns we > are using in the linker templates. I wish that stanzas of code common to > man

[gwt-contrib] Avira and HTML/CryptedGen (again)

2010-03-16 Thread Matt Mastracci
We started getting reports of the "HTML/Crypted.Gen" being detected in our Chrome extension again. I've managed to reproduce it - the signature seems to be the exact set of strings they use: .fromCharCode .charCodeAt nodeValue for 0,0,0,0,0,0 Math.min I kid you not - this is their sig

Re: [gwt-contrib] Avira and HTML/CryptedGen (again)

2010-03-16 Thread John Tamplin
On Tue, Mar 16, 2010 at 2:07 PM, Matt Mastracci wrote: > We started getting reports of the "HTML/Crypted.Gen" being detected in our > Chrome extension again. I've managed to reproduce it - the signature seems > to be the exact set of strings they use: > > > .fromCharCode > .charCodeAt > nodeV

Re: [gwt-contrib] Avira and HTML/CryptedGen (again)

2010-03-16 Thread Matt Mastracci
> I kid you not - this is their signature for an encrypted JS virus. I can't > seem to remove a single character from any of these tokens without turning it > from a dangerous virus to a harmless bit of JS. Order doesn't seem to be > important (although I haven't experimented with this that muc

[gwt-contrib] Re: One-line fix to SelectionScript's fallback logic for

2010-03-16 Thread spoon
http://gwt-code-reviews.appspot.com/183801 -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] [google-web-toolkit] r7736 committed - Don't ever set the "base" variable to null. It is supposed to be the ...

2010-03-16 Thread codesite-noreply
Revision: 7736 Author: sp...@google.com Date: Tue Mar 16 08:43:23 2010 Log: Don't ever set the "base" variable to null. It is supposed to be the empty string if it hasn't been set yet. Review at http://gwt-code-reviews.appspot.com/219801 Review by: j...@google.com http://code.google.com/p/go

[gwt-contrib] Re: Avira and HTML/CryptedGen (again)

2010-03-16 Thread Matt Mastracci
On Mar 16, 12:42 pm, Matt Mastracci wrote: > > Holy cow -- how do they think that is an acceptable measure?  Surely they > > could at least change the warning to say "potentially dangerous JS" or > > something rather than declaring it a virus. > This probably will likely affect a significant n

Re: [gwt-contrib] Support runAsync with the cross-site linker.

2010-03-16 Thread John Tamplin
On Tue, Mar 16, 2010 at 1:47 PM, Lex Spoon wrote: > Yes. Indeed, this fix originally went into the iframe linker and it was > overlooked for the cross-site linker. Using more templating should help us > not have to duplicate code so much. > > I was thinking in the short term to pull out compute

[gwt-contrib] Update bikeshed/eclipse.README based on feedback from Dan

2010-03-16 Thread rjrjr
Reviewers: Dan Rice, Description: Update bikeshed/eclipse.README based on feedback from Dan Review by: r...@google.com Please review this at http://gwt-code-reviews.appspot.com/224801 Affected files: M bikeshed/eclipse.README Index: bikeshed/eclipse.README ==

[gwt-contrib] [google-web-toolkit] r7737 committed - Adding a default return value to eventGetTypeInt....

2010-03-16 Thread codesite-noreply
Revision: 7737 Author: jlaba...@google.com Date: Tue Mar 16 08:57:25 2010 Log: Adding a default return value to eventGetTypeInt. http://gwt-code-reviews.appspot.com/222801 Review by: r...@google.com http://code.google.com/p/google-web-toolkit/source/detail?r=7737 Modified: /trunk/user/src/com/g

[gwt-contrib] Re: One-line fix to SelectionScript's fallback logic for

2010-03-16 Thread spoon
Here's a test case. Can either of you review it? http://gwt-code-reviews.appspot.com/183801 -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

Re: [gwt-contrib] Re: One-line fix to SelectionScript's fallback logic for

2010-03-16 Thread Miguel Méndez
Thanks Lex! 2010/3/12 Lex Spoon > 2010/3/11 Miguel Méndez > > +1 to Ray's question. I know that you were simply doing a fix Lex, but we >> need to think about how we test these "features". >> > > I agree. I'll work out a test. -Lex > > -- > http://groups.google.com/group/Google-Web-Toolkit-C

[gwt-contrib] Re: Comment on DefaultLocaleBinding in google-web-toolkit

2010-03-16 Thread codesite-noreply
Comment by d...@google.com: /*-FALLBACK*/ should be written as /*-FALLBACK-*/ since that's what's actually implemented For more information: http://code.google.com/p/google-web-toolkit/wiki/DefaultLocaleBinding -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] Re: Comment on DefaultLocaleBinding in google-web-toolkit

2010-03-16 Thread codesite-noreply
Comment by d...@google.com: {{{ /*-FALLBACK*/ }}} should be written as {{{ /*-FALLBACK-*/ }}} since that's what's actually implemented For more information: http://code.google.com/p/google-web-toolkit/wiki/DefaultLocaleBinding -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] Initial CL that sends an update across the wire and persists it.

2010-03-16 Thread amitmanjhi
Reviewers: Ray Ryan, Description: Initial CL that sends an update across the wire and persists it. Please review this at http://gwt-code-reviews.appspot.com/221802 Affected files: M bikeshed/src/com/google/gwt/sample/expenses/gen/ExpenseRequestFactoryImpl.java M bikeshed/src/com/google

[gwt-contrib] Re: DOMImpl#eventGetTypeInt returns NULL for unknown event types

2010-03-16 Thread jlabanca
committed as r7737 http://gwt-code-reviews.appspot.com/222801 -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] Give a better error message when RunAsyncCode.runAsyncCode is passed something

2010-03-16 Thread spoon
Reviewers: cromwellian, Description: Give a better error message when RunAsyncCode.runAsyncCode is passed something other than a class literal. Please review this at http://gwt-code-reviews.appspot.com/225801 Affected files: M dev/core/src/com/google/gwt/dev/jjs/impl/ReplaceRunAsyncs.java

[gwt-contrib] Re: Add build.xml file with checkstyle target; pass checkstyle

2010-03-16 Thread rjrjr
LGTM, presuming that you meant to include the symbols change in this patch http://gwt-code-reviews.appspot.com/218801 -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] [google-web-toolkit] r7739 committed - Initial patch that sends an update across the wire and persists it....

2010-03-16 Thread codesite-noreply
Revision: 7739 Author: amitman...@google.com Date: Tue Mar 16 10:02:10 2010 Log: Initial patch that sends an update across the wire and persists it. Review at http://gwt-code-reviews.appspot.com/221802 Patch by: amitmanjhi Review by: rjrjr http://code.google.com/p/google-web-toolkit/source/deta

[gwt-contrib] Re: Give a better error message when RunAsyncCode.runAsyncCode is passed something

2010-03-16 Thread scottb
LGTM. Just be sure to add the test class that you had in http://gwt-code-reviews.appspot.com/161802 http://gwt-code-reviews.appspot.com/225801 -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] Re: Give a better error message when RunAsyncCode.runAsyncCode is passed something

2010-03-16 Thread spoon
Rietveld really wants to create a new issue rather than adding a patch here. I'm not sure why. Anyway, the updated version of this patch is here: http://gwt-code-reviews.appspot.com/227801 http://gwt-code-reviews.appspot.com/161802 -- http://groups.google.com/group/Google-Web-Toolkit-Contrib

[gwt-contrib] Re: Update bikeshed/eclipse.README based on feedback from Dan

2010-03-16 Thread דניאל רייס
What is 'com.google.gwt.*' in the file/dir list referring to? Dan On Tue, Mar 16, 2010 at 3:00 PM, wrote: > Reviewers: Dan Rice, > > Description: > Update bikeshed/eclipse.README based on feedback from Dan > Review by: r...@google.com > > Please review this at http://gwt-code-reviews.appspot.

[gwt-contrib] Re: Add build.xml file with checkstyle target; pass checkstyle

2010-03-16 Thread דניאל רייס
I did, checkstyle runs out of memory on the old version! Dan On Tue, Mar 16, 2010 at 4:13 PM, wrote: > LGTM, presuming that you meant to include the symbols change in this > patch > > > http://gwt-code-reviews.appspot.com/218801 > -- http://groups.google.com/group/Google-Web-Toolkit-Contrib

[gwt-contrib] Re: Initial CL that sends an update across the wire and persists it.

2010-03-16 Thread rjrjr
LGTM http://gwt-code-reviews.appspot.com/221802 -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] Re: Update bikeshed/eclipse.README based on feedback from Dan

2010-03-16 Thread rjrjr
http://gwt-code-reviews.appspot.com/224801 -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] Explain com.google.gwt.*

2010-03-16 Thread rjrjr
Reviewers: Dan Rice, Description: Update bikeshed/eclipse.README based on feedback from Dan Review at http://gwt-code-reviews.appspot.com/224801 Review by: r...@google.com Please review this at http://gwt-code-reviews.appspot.com/227802 Affected files: M bikeshed/eclipse.README Index: bike

[gwt-contrib] Re: Update bikeshed/eclipse.README based on feedback from Dan

2010-03-16 Thread rjrjr
On 2010/03/16 19:00:38, Dan rice wrote: What is 'com.google.gwt.*' in the file/dir list referring to? The gwtc output directories in war, e.g. war/com.google.gwt.bikeshed.tree.Tree/ I'll add a comment to that effect. http://gwt-code-reviews.appspot.com/224801 -- http://groups.google.com/g

[gwt-contrib] Give a better error message when RunAsyncCode.runAsyncCode is passed something

2010-03-16 Thread spoon
Reviewers: cromwellian, Description: Give a better error message when RunAsyncCode.runAsyncCode is passed something other than a class literal. Review at http://gwt-code-reviews.appspot.com/161802 Please review this at http://gwt-code-reviews.appspot.com/227801 Affected files: M dev/core/sr

[gwt-contrib] Re: Explain com.google.gwt.*

2010-03-16 Thread rjrjr
Sorry, meant to be an update to the other issue. Please ignore. http://gwt-code-reviews.appspot.com/227802 -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] Re: Give a better error message when RunAsyncCode.runAsyncCode is passed something

2010-03-16 Thread spoon
Trying again: http://gwt-code-reviews.appspot.com/220802 http://gwt-code-reviews.appspot.com/161802 -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] Give a better error message when RunAsyncCode.runAsyncCode is passed something

2010-03-16 Thread spoon
Reviewers: cromwellian, Description: Give a better error message when RunAsyncCode.runAsyncCode is passed something other than a class literal. Review at http://gwt-code-reviews.appspot.com/227801 Please review this at http://gwt-code-reviews.appspot.com/220802 Affected files: M dev/core/sr

[gwt-contrib] Re: Give a better error message when RunAsyncCode.runAsyncCode is passed something

2010-03-16 Thread cromwellian
LGTM. I like the UnitTestTreeLogger, didn't even know it existed. http://gwt-code-reviews.appspot.com/220802 -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] additional predefined DateTimeFormat patterns

2010-03-16 Thread John Tamplin
DateTimeFormat now defines 4 date formats, 4 time formats, and 4 combined date/time formats (plus the ability to supply your own pattern, but then you are responsible for localizing it yourself). These formats don't cover all the possible use cases, such as a month/day or month/year format, or eve

[gwt-contrib] deRPC experiences

2010-03-16 Thread Matt Mastracci
I took the plunge and started moving our codebase over to deRPC. It's pretty simple to get bootstrapped, though there's some deployment work we needed to do to ensure that our .gwt.rpc files are made available to the backends. I'm storing our history of .gwt.rpc files in S3, since we're already

[gwt-contrib] Re: Update bikeshed/eclipse.README based on feedback from Dan

2010-03-16 Thread rjrjr
http://gwt-code-reviews.appspot.com/224801 -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] Re: Update bikeshed/eclipse.README based on feedback from Dan

2010-03-16 Thread rjrjr
Can you look again? I've made a few updates. http://gwt-code-reviews.appspot.com/224801 -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] Re: Unicode support for Character.is* methods

2010-03-16 Thread jat
A few issues: - the way this is divided, all of the code will get pulled into every app that calls any of these methods. - this is incomplete and doesn't have the other properties, such as getDirection, toLower, etc. I had written a full implementation a while ago (it is still available in svn a

[gwt-contrib] GWT-Query - needs forking?

2010-03-16 Thread Richard Vowles
Hi all, Not sure how to get a hold of the person responsible for GWT-Query, which was spoken of in terms of including it in GWT itself. This is my last ditch attempt - the project appears to have died in May, and I'd like to get committer access to the project. Ta! Richard -- http://groups.goog

Re: [gwt-contrib] GWT-Query - needs forking?

2010-03-16 Thread Miroslav Pokorny
Hi Richard, You do mean Ray Cromwell ? hes quite active here and should see your message. hth mP On Wed, Mar 17, 2010 at 2:18 PM, Richard Vowles wrote: > Hi all, > > Not sure how to get a hold of the person responsible for GWT-Query, > which was spoken of in terms of including it in GWT itself.