[gwt-contrib] Re: MutableArray and ImmutableArray JSNI implementation. (issue363801)

2010-04-22 Thread rchandia
Ping? On 2010/04/19 19:48:53, rchandia wrote: http://gwt-code-reviews.appspot.com/363801/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] Re: MutableArray and ImmutableArray JSNI implementation. (issue363801)

2010-04-22 Thread rice
LGTM http://gwt-code-reviews.appspot.com/363801/diff/1/3 File bikeshed/src/com/google/gwt/collections/MutableArray.java (right): http://gwt-code-reviews.appspot.com/363801/diff/1/3#newcode118 bikeshed/src/com/google/gwt/collections/MutableArray.java:118: int oldLen = elems.length; Why was the

[gwt-contrib] Fixes a bug in SplitLayoutPanel where calling setWidgetMinSize() on the center widget, the last ... (issue378802)

2010-04-22 Thread jlabanca
Reviewers: jgw, Description: Fixes a bug in SplitLayoutPanel where calling setWidgetMinSize() on the center widget, the last widget, or a widget that is not a child results in an NPE or IndexOutOfBoundsException. The occured because getAssocatedSplitter() had an off by one bug and didn't check

[gwt-contrib] Re: Fixes a bug in SplitLayoutPanel where calling setWidgetMinSize() on the center widget, the last ... (issue378802)

2010-04-22 Thread jlabanca
http://gwt-code-reviews.appspot.com/378802/diff/1/3 File user/src/com/google/gwt/user/client/ui/SplitLayoutPanel.java (right): http://gwt-code-reviews.appspot.com/378802/diff/1/3#newcode251 user/src/com/google/gwt/user/client/ui/SplitLayoutPanel.java:251: assertIsChild(child); This assertion is

[gwt-contrib] Re: Fixes a bug in SplitLayoutPanel where calling setWidgetMinSize() on the center widget, the last ... (issue378802)

2010-04-22 Thread jgw
LGTM http://gwt-code-reviews.appspot.com/378802/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] Reorganizes styles in bikeshed to use CssResource and ClientBundle. (issue388801)

2010-04-22 Thread jgw
Reviewers: jlabanca, Description: Reorganizes styles in bikeshed to use CssResource and ClientBundle. Moves all styles in stock and cookbook samples to one place. Removes the hovering boxes we stole from Wave for a slightly flatter look. Please review this at

[gwt-contrib] Re: MutableArray and ImmutableArray JSNI implementation. (issue363801)

2010-04-22 Thread rchandia
Also removed spaces in blank lines http://gwt-code-reviews.appspot.com/363801/diff/1/3 File bikeshed/src/com/google/gwt/collections/MutableArray.java (right): http://gwt-code-reviews.appspot.com/363801/diff/1/3#newcode118 bikeshed/src/com/google/gwt/collections/MutableArray.java:118: int

[gwt-contrib] Refactoring Tree code. SideBySideTreeView now uses SimpleCellList, which a protected method tha... (issue390801)

2010-04-22 Thread jlabanca
Reviewers: jgw, Description: Refactoring Tree code. SideBySideTreeView now uses SimpleCellList, which a protected method that allows users to use any ListView. SideBySideTreeNodeView shares a lot of code with SimpleCellList. Added animations to SideBySideTreeView. NodeInfo now includes a

[gwt-contrib] Re: Refactoring Tree code. SideBySideTreeView now uses SimpleCellList, which a protected method tha... (issue390801)

2010-04-22 Thread jgw
http://gwt-code-reviews.appspot.com/390801/diff/1/3 File bikeshed/src/com/google/gwt/bikeshed/cells/client/CompositeCell.java (right): http://gwt-code-reviews.appspot.com/390801/diff/1/3#newcode32 bikeshed/src/com/google/gwt/bikeshed/cells/client/CompositeCell.java:32: public class

[gwt-contrib] RR : Part 1 : UiBinder reports locations in errors (issue394801)

2010-04-22 Thread bobv
Reviewers: Ray Ryan, Message: Review requested. Description: This patch changes how UiBinder's compile-time DOM structure is generated so that we can provide accurate location information to the developer when logging errors. Instead of using a DOM parser, this patch builds a DOM using a SAX

[gwt-contrib] RR : Part 2 : Update sources of UiBinder error messages (issue395801)

2010-04-22 Thread bobv
Reviewers: Ray Ryan, Message: Review requested. Description: This patch builds on the first by reworking callers of MortalLogger to include a contextual XMLElement. Please review this at http://gwt-code-reviews.appspot.com/395801/show Affected files: M

[gwt-contrib] Re: RR : Part 1 : UiBinder reports locations in errors (issue394801)

2010-04-22 Thread rjrjr
Thank you! http://gwt-code-reviews.appspot.com/394801/diff/1/2 File user/src/com/google/gwt/uibinder/rebind/MortalLogger.java (right): http://gwt-code-reviews.appspot.com/394801/diff/1/2#newcode102 user/src/com/google/gwt/uibinder/rebind/MortalLogger.java:102: + location.getLineNumber() + ));

[gwt-contrib] Re: RR : Part 2 : Update sources of UiBinder error messages (issue395801)

2010-04-22 Thread rjrjr
Holy cow! Given this pass, and the fact that XMLElement#toString still sometimes reaches the error log, I think you should get the line number and (huge) file name out of XMLElement#toString http://gwt-code-reviews.appspot.com/395801/show --

[gwt-contrib] webAppCreator, create maven configuration file (pom.xml) (issue397801)

2010-04-22 Thread manuel . carrasco . m
Reviewers: jlabanca, Description: This patch - Adds to webAppCreator the ability to create maven configuration file: Issue_4878 - Fixes the Issue_4652 build.xml: compiles test classes in the same directory as the source - Adds tests to WebAppCreator Please review this at

[gwt-contrib] Re: webAppCreator, create maven configuration file (pom.xml) (issue397801)

2010-04-22 Thread jat
Mostly LGTM A couple of nits, and one more significant. http://gwt-code-reviews.appspot.com/397801/diff/1/3 File user/src/com/google/gwt/user/tools/README.txtsrc (right): http://gwt-code-reviews.appspot.com/397801/diff/1/3#newcode75 user/src/com/google/gwt/user/tools/README.txtsrc:75: have

[gwt-contrib] Re: Sync is for real now. Notes: (issue379802)

2010-04-22 Thread rjrjr
LGTM WOOO HOO http://gwt-code-reviews.appspot.com/379802/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors