Re: [PHP-DEV] Assign array with __get

2010-03-25 Thread Ionut Gabriel Stan
I guess you're gonna hate this :) So what you're saying is that it is *consistent* with regard to the implementation of methods/functions, i.e. __get behaves as an ordinary method. On Fri, Mar 26, 2010 at 1:49 AM, Stanislav Malyshev s...@zend.com wrote: Hi! So, what's the reasoning behind

Re: [PHP-DEV] [RFC] prototyping

2009-01-14 Thread Ionut Gabriel Stan
On 1/14/2009 01:15, Stanislav Malyshev wrote: Hi! Also, this adds very new thing to PHP - objects that change while being assigned. I am not sure it is a good thing. Well Closures are a brand new thing in PHP. So far we had nothing even remotely close to the closures we have right now.

Re: [PHP-DEV] [RFC] prototyping

2009-01-14 Thread Ionut Gabriel Stan
Hi, On 1/14/2009 18:29, Stanislav Malyshev wrote: Hi! That is one example of convoluted code that is already possible. If a developer creates such a mess is his fault. Convoluted? Mess? Are you kidding me? It's standard usage of access handlers. I don't understand how that could be

Re: [PHP-DEV] __invoke() weirdness

2008-12-28 Thread Ionut Gabriel Stan
PHP written in a JavaScript style is already possible with PHP 5.3. I started a little thread about this on a forum but didn't get that much feedback: http://www.sitepoint.com/forums/showthread.php?t=565576 It's not really what we're used to in JavaScript but it's very close. On 12/25/2008

Re: [PHP-DEV] Q on Primitives

2008-12-19 Thread Ionut Gabriel Stan
On 12/19/2008 17:39, Robin Burchell wrote: Ugh. Apparantly I forgot to CC the list on those last two mails.. Sorry. Pasted so others stay in on the conversation: On Fri, Dec 19, 2008 at 3:18 PM, troels knak-nielsentroel...@gmail.com wrote: snip That's an interesting mail, expresses a

Re: [PHP-DEV] json_encode()

2008-12-16 Thread Ionut Gabriel Stan
On 12/16/2008 14:23, Alexey Zakhlestin wrote: On Tue, Dec 16, 2008 at 3:20 PM, troels knak-nielsentroel...@gmail.com wrote: On Tue, Dec 16, 2008 at 12:57 PM, Scott MacVicarsc...@macvicar.net wrote: For now I'll be leaving it as is and adding a JSON_STRICT_ENCODE parameter to the options

Re: [PHP-DEV] [RFC] Iteration tools

2008-11-04 Thread Ionut Gabriel Stan
On 11/3/2008 17:41, Marcus Boerger wrote: Hello Ionut, some remarks about your proposal: 1) You can turn any array into a Traversable using (Recursive)ArrayIterator. Though this solution is still slow. The issue is that the c-level code needs to verify the current pointer every single time

[PHP-DEV] [RFC] Iteration tools

2008-11-03 Thread Ionut Gabriel Stan
Hello everybody, As a result of the advice given in the thread array_key_exists BC break, I have written an RFC concerning some higher order functions that, I believe, could a helpful addition to the language. Please note that I'm a userland developer and have no clue about PHP internals so

Re: [PHP-DEV] array_key_exists BC break

2008-10-28 Thread Ionut Gabriel Stan
While we're at this and considering the new lambdas that we now have in the language I must say I'd like some functions to support Traversables. Those would be: array_map(), array_reduce(), array_filter(), array_walk() and array_walk_recursive() Although I'd rather want a class (because the

Re: [PHP-DEV] array_key_exists BC break

2008-10-28 Thread Ionut Gabriel Stan
[EMAIL PROTECTED]wrote: Hi Ionut 2008/10/28 Ionut Gabriel Stan [EMAIL PROTECTED]: While we're at this and considering the new lambdas that we now have in the language I must say I'd like some functions to support Traversables. Those would be: array_map(), array_reduce(), array_filter

Re: [PHP-DEV] array_key_exists BC break

2008-10-24 Thread Ionut Gabriel Stan
But wouldn't be useful to at least accept objects implementing ArrayAccess? On 10/23/2008 23:40, Mark van der Velden wrote: Stanislav Malyshev wrote: Hi! I notice that 5.3 differs from 5.2 in how array_key_exists treats objects. In 5.2, if the second parameter (array) is allowed to be

Re: [PHP-DEV] php7- dropping the $ from the variable name - rfc

2008-09-18 Thread Ionut Gabriel Stan
Actually, I somehow understand what he wants, considering we'll soon have lambdas and closures. I mean, in case of javascript a variable can hold as well a function as it can hold anything else. Anyway, I don't think this is the case for PHP. I do find it ugly to write $function(), but I guess

Re: [PHP-DEV] Re: Namespaced function vs static method in global class

2008-09-18 Thread Ionut Gabriel Stan
Message From: Gregory Beaver [EMAIL PROTECTED] To: Ionut Gabriel Stan [EMAIL PROTECTED] Cc: internals@lists.php.net Sent: Wednesday, September 17, 2008 7:25:31 AM Subject: [PHP-DEV] Re: Namespaced function vs static method in global class Ionut Gabriel Stan wrote: snip echo Test::foo

[PHP-DEV] Namespaced function vs static method in global class

2008-09-16 Thread Ionut Gabriel Stan
Hi, I've decided to play a little with namespaces as some of you asked for feedback on this list or on your blogs. I'm just an userland developer and have no clue about PHP internals so forgive me if I say something stupid in this regard. Here's what I found on some simple test. It may be the

[PHP-DEV] SplFileObject with include_path

2008-05-13 Thread Ionut Gabriel Stan
Hi, I'm working on a SOAP project and as part of the checks I make are the existence and readability of the WSDL file. As far as I saw, SoapClient doesn't check include_path for the WSDL file, so I thought I could use fopen to check this and then find the real path which would be finally passed

Re: [PHP-DEV] SplFileObject with include_path

2008-05-13 Thread Ionut Gabriel Stan
Done, http://bugs.php.net/bug.php?id=44987 Thank you, Ionut --- Marcus Boerger [EMAIL PROTECTED] wrote: Hello Ionut, file as bug please. marcus Tuesday, May 13, 2008, 12:37:45 PM, you wrote: Hi, I'm working on a SOAP project and as part of the checks I make are the