Hi Jorn, I have a similar issue. But putting the custom rule on only
one of the fields means that the onkeyup/onblur validation will only
work when the user is in that field, which is not very clear for the
user if input in multiple fields affects validation.
Is there any solution to this?
On F
See the documentation for the rules option (http://docs.jquery.com/
Plugins/Validation/validate#options):
$(".selector").validate({
rules: {
// simple rule, converted to {required:true}
name: "required",
// compound rule
email: {
required: true,
email: true
I am dont see what metadata has to do with this(at far as i know metadata in
html is what you use inside the head tags, and also don't know what the
rules-option is.
Jörn Zaefferer wrote:
>
>
> Eridius schrieb:
>> um those is a little bit of an issue you you need you code to me valid.
>> For
Eridius schrieb:
um those is a little bit of an issue you you need you code to me valid. For
example required in not a valid attribute for an input so adding these
webform attribute will make my code invalid.
Just use metadata or the rules-option is you code for the w3c validator.
Jörn
um those is a little bit of an issue you you need you code to me valid. For
example required in not a valid attribute for an input so adding these
webform attribute will make my code invalid.
Jörn Zaefferer wrote:
>
>
> Eridius schrieb:
>> Another thing is there a reason why the class name a
Eridius schrieb:
Another thing is there a reason why the class name are very generic? This is
just an issue because a lot of those names are already used for other stuff
and is interfering with the current css. is there a reason you did not use
something like validate_required, validate_email,
Eridius schrieb:
I have a slight issue and maybe it is because I don't know enough about this
plugin but is seems like the validation is based off of the name of the form
field so if I wanted to have a email validation on 2 imputs I would have to
put 2 input both have the name "email" but that w
Another thing is there a reason why the class name are very generic? This is
just an issue because a lot of those names are already used for other stuff
and is interfering with the current css. is there a reason you did not use
something like validate_required, validate_email, etc...? it not a
8 matches
Mail list logo