[PATCH 2/6] mmc: sdhci: add a callback of tuning block setting

2015-09-14 Thread Yangbo Lu
Add a tuning block setting callback to let host set its tuning block before executing tuning procedure. Signed-off-by: Yangbo Lu --- drivers/mmc/host/sdhci.c | 3 +++ drivers/mmc/host/sdhci.h | 1 + 2 files changed, 4 insertions(+) diff --git a/drivers/mmc/host/sdhci.c

[PATCH] mmc: pwrseq: use gpiod_get() instead of index 0

2015-09-14 Thread Javier Martinez Canillas
The gpiod_get() function expands to gpiod_get_index() with index 0 so it's better to use it since is easier to read and more concise. Signed-off-by: Javier Martinez Canillas --- drivers/mmc/core/pwrseq_emmc.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff

Re: sdhci: runtime suspend/resume on card insert/removal

2015-09-14 Thread Vaibhav Hiremath
On Monday 14 September 2015 06:19 PM, Russell King - ARM Linux wrote: On Mon, Sep 14, 2015 at 06:03:40PM +0530, Vaibhav Hiremath wrote: On Monday 14 September 2015 04:20 PM, Russell King - ARM Linux wrote: On Mon, Sep 14, 2015 at 03:45:43PM +0530, Vaibhav Hiremath wrote: Came across below

[PATCH 6/6] mmc: sdhci-of-esdhc: add tuning cycles delay quirk for t2080/t1040

2015-09-14 Thread Yangbo Lu
Signed-off-by: Yangbo Lu --- drivers/mmc/host/sdhci-of-esdhc.c | 4 1 file changed, 4 insertions(+) diff --git a/drivers/mmc/host/sdhci-of-esdhc.c b/drivers/mmc/host/sdhci-of-esdhc.c index 57e1e8b..46efa05 100644 --- a/drivers/mmc/host/sdhci-of-esdhc.c +++

[PATCH 5/6] mmc: sdhci: add SDHCI_QUIRK2_DELAY_BETWEEN_TUNING_CYCLES quirk

2015-09-14 Thread Yangbo Lu
Although eMMC spec does not require a delay between tuning cycles, some hosts need it to avoid tuning failure. Signed-off-by: Yangbo Lu --- drivers/mmc/host/sdhci.c | 3 ++- drivers/mmc/host/sdhci.h | 2 ++ 2 files changed, 4 insertions(+), 1 deletion(-) diff --git

[PATCH 1/6] mmc: sdhci: add a callback of signal voltage switching

2015-09-14 Thread Yangbo Lu
Add a signal voltage switching callback to let host use its own switching process. Signed-off-by: Yangbo Lu --- drivers/mmc/host/sdhci.c | 5 + drivers/mmc/host/sdhci.h | 2 ++ 2 files changed, 7 insertions(+) diff --git a/drivers/mmc/host/sdhci.c

Re: sdhci: runtime suspend/resume on card insert/removal

2015-09-14 Thread Vaibhav Hiremath
On Monday 14 September 2015 04:20 PM, Russell King - ARM Linux wrote: On Mon, Sep 14, 2015 at 03:45:43PM +0530, Vaibhav Hiremath wrote: Came across below lines in the datasheet, = Copy-n-paste from datasheet All SDH interfaces share the same clock which is enabled when

Re: [RFC 2/3] mmc: sdhci: add host_ops->voltage_switch callback for all other voltages

2015-09-14 Thread Ulf Hansson
On 14 September 2015 at 11:42, Vaibhav Hiremath wrote: > > > On Monday 14 September 2015 03:00 PM, Ulf Hansson wrote: >> >> [...] >> >> >> Could this be implemented by regulator API? From patch set 3/3, the >> pxa1928 >> voltage_switch hook is to

Re: sdhci: runtime suspend/resume on card insert/removal

2015-09-14 Thread Russell King - ARM Linux
On Mon, Sep 14, 2015 at 03:45:43PM +0530, Vaibhav Hiremath wrote: > Came across below lines in the datasheet, > > = Copy-n-paste from datasheet > > All SDH interfaces share the same clock which is enabled when any of the SDH > clock enables are > set (from

Re: [RFC 2/3] mmc: sdhci: add host_ops->voltage_switch callback for all other voltages

2015-09-14 Thread Vaibhav Hiremath
On Monday 14 September 2015 04:04 PM, Ulf Hansson wrote: On 14 September 2015 at 11:42, Vaibhav Hiremath wrote: On Monday 14 September 2015 03:00 PM, Ulf Hansson wrote: [...] Could this be implemented by regulator API? From patch set 3/3, the pxa1928

Re: [RFC 2/3] mmc: sdhci: add host_ops->voltage_switch callback for all other voltages

2015-09-14 Thread Vaibhav Hiremath
On Monday 14 September 2015 06:11 PM, Vaibhav Hiremath wrote: On Monday 14 September 2015 04:04 PM, Ulf Hansson wrote: On 14 September 2015 at 11:42, Vaibhav Hiremath wrote: On Monday 14 September 2015 03:00 PM, Ulf Hansson wrote: [...] Could this be

Re: sdhci: runtime suspend/resume on card insert/removal

2015-09-14 Thread Russell King - ARM Linux
On Mon, Sep 14, 2015 at 11:50:14AM +0100, Russell King - ARM Linux wrote: > On Mon, Sep 14, 2015 at 03:45:43PM +0530, Vaibhav Hiremath wrote: > > Came across below lines in the datasheet, > > > > = Copy-n-paste from datasheet > > > > All SDH interfaces share the same clock

Re: sdhci: runtime suspend/resume on card insert/removal

2015-09-14 Thread Russell King - ARM Linux
On Mon, Sep 14, 2015 at 06:03:40PM +0530, Vaibhav Hiremath wrote: > On Monday 14 September 2015 04:20 PM, Russell King - ARM Linux wrote: > >On Mon, Sep 14, 2015 at 03:45:43PM +0530, Vaibhav Hiremath wrote: > >>Came across below lines in the datasheet, > >> > >>= Copy-n-paste from

Re: [PATCH v2 1/2] mmc: sdhci-of-arasan: add phy support for sdhci-of-arasan

2015-09-14 Thread Sören Brinkmann
Hi Shawn, overall, it looks good to me. I have some questions though. On Mon, 2015-09-14 at 02:29PM +0800, Shawn Lin wrote: > This patch adds Generic PHY access for sdhci-of-arasan. Driver > can get PHY handler from dt-binding, and power-on/init the PHY. > Also we add pm ops for PHY here if

Re: [PATCH v2 2/2] Documentation: bindings: add description of phy for sdhci-of-arasan

2015-09-14 Thread Sören Brinkmann
On Mon, 2015-09-14 at 02:29PM +0800, Shawn Lin wrote: > This patch adds phys and phy-names for sdhci-of-arasan as required > properties for arasan,sdhci-5.1, and details the example as well. > > Signed-off-by: Shawn Lin Acked-by: Sören Brinkmann

[PATCH V3] mmc: block: Add new ioctl to send multi commands

2015-09-14 Thread Jon Hunter
From: Seshagiri Holi Certain eMMC devices allow vendor specific device information to be read via a sequence of vendor commands. These vendor commands must be issued in sequence and an atomic fashion. One way to support this would be to add an ioctl function for sending a

Re: [PATCH V3] mmc: block: Add new ioctl to send multi commands

2015-09-14 Thread Grant Grundler
On Mon, Sep 14, 2015 at 8:00 AM, Jon Hunter wrote: > From: Seshagiri Holi > > Certain eMMC devices allow vendor specific device information to be read > via a sequence of vendor commands. These vendor commands must be issued > in sequence and an atomic

Re: [PATCH v3 0/2] regulator: Fix pbias regulator enable

2015-09-14 Thread Tony Lindgren
Hi, * Ulf Hansson [150904 05:48]: > > Okay, just to be clear on the way forward. I spoked with Mark Brown > offlist, and he will/has picked up the regulator patch and will send > it as fix for the 4.3 rc[n]. > > Regarding the ARM patch here, I guess Tony might as well

4.3-rc1 omap3 mmc boot warning + errors

2015-09-14 Thread Belisko Marek
Hi, after upgrading to 4.3-rc gta04 board during boot print following warning: [3.111206] omap_wdt: OMAP Watchdog Timer Rev 0x31: initial timeout 60 sec [3.131286] [ cut here ] [3.136138] WARNING: CPU: 0 PID: 1 at drivers/regulator/core.c:2105

Re: 4.3-rc1 omap3 mmc boot warning + errors

2015-09-14 Thread Belisko Marek
On Mon, Sep 14, 2015 at 10:15 PM, Belisko Marek wrote: > Hi, > > after upgrading to 4.3-rc gta04 board during boot print following warning: > > [3.111206] omap_wdt: OMAP Watchdog Timer Rev 0x31: initial timeout 60 sec > [3.131286] [ cut here

Re: [PATCH v2 1/2] mmc: sdhci-of-arasan: add phy support for sdhci-of-arasan

2015-09-14 Thread Shawn Lin
On 2015/9/14 23:07, Sören Brinkmann wrote: Hi Shawn, overall, it looks good to me. I have some questions though. On Mon, 2015-09-14 at 02:29PM +0800, Shawn Lin wrote: [...] +err_phy_exit: + phy_init(phy); Just to confirm, are these actions in the error path correct? E.g. if the

Re: [PATCH v3 0/2] regulator: Fix pbias regulator enable

2015-09-14 Thread Kishon Vijay Abraham I
Hi, On Tuesday 15 September 2015 01:52 AM, Tony Lindgren wrote: > Hi, > > * Ulf Hansson [150904 05:48]: >> >> Okay, just to be clear on the way forward. I spoked with Mark Brown >> offlist, and he will/has picked up the regulator patch and will send >> it as fix for the

Re: sdhci: runtime suspend/resume on card insert/removal

2015-09-14 Thread Vaibhav Hiremath
On Thursday 10 September 2015 01:34 PM, Jisheng Zhang wrote: Hi Russell, On Thu, 10 Sep 2015 09:02:33 +0100 Russell King - ARM Linux wrote: On Thu, Sep 10, 2015 at 03:31:29PM +0800, Jisheng Zhang wrote: Hi Vaibhav, On Thu, 10 Sep 2015 12:40:48 +0530 Vaibhav

[PATCH v2 1/2] mmc: sdhci-of-arasan: add phy support for sdhci-of-arasan

2015-09-14 Thread Shawn Lin
This patch adds Generic PHY access for sdhci-of-arasan. Driver can get PHY handler from dt-binding, and power-on/init the PHY. Also we add pm ops for PHY here if CONFIG_PM_SLEEP is enabled. Currently, it's just mandatory for arasan,sdhci-5.1. Signed-off-by: Shawn Lin

[PATCH v2 2/2] Documentation: bindings: add description of phy for sdhci-of-arasan

2015-09-14 Thread Shawn Lin
This patch adds phys and phy-names for sdhci-of-arasan as required properties for arasan,sdhci-5.1, and details the example as well. Signed-off-by: Shawn Lin --- Changes in v2: - Keep phy as a mandatory requirement for arasan,sdhci-5.1

[PATCH] mmc: core: Don't return an error for CD/WP GPIOs when GPIOLIB is unset

2015-09-14 Thread Ulf Hansson
When CONFIG_GPIOLIB is unset, its stubs will return -ENOSYS. That means when the mmc core parses DT for CD/WP GPIOs via mmc_of_parse(), -ENOSYS becomes propagated to the caller. Typically this means that the mmc host driver fails to probe. As the CD/WP GPIOs are already treated as optional, let's

Re: sdhci: runtime suspend/resume on card insert/removal

2015-09-14 Thread Vaibhav Hiremath
On Monday 14 September 2015 01:48 PM, Jisheng Zhang wrote: On Mon, 14 Sep 2015 13:43:32 +0530 Vaibhav Hiremath wrote: On Monday 14 September 2015 11:58 AM, Jisheng Zhang wrote: On Mon, 14 Sep 2015 11:55:56 +0530 Vaibhav Hiremath

Re: [RFC 2/3] mmc: sdhci: add host_ops->voltage_switch callback for all other voltages

2015-09-14 Thread Ulf Hansson
[...] Could this be implemented by regulator API? From patch set 3/3, the pxa1928 voltage_switch hook is to operate the IO pad registers, this seems not belong to the SDHC IP core. >>> >>> Not quite sure whether regulator would be right fit for this. >> >> >>

Re: [RFC 2/3] mmc: sdhci: add host_ops->voltage_switch callback for all other voltages

2015-09-14 Thread Vaibhav Hiremath
On Monday 14 September 2015 03:00 PM, Ulf Hansson wrote: [...] Could this be implemented by regulator API? From patch set 3/3, the pxa1928 voltage_switch hook is to operate the IO pad registers, this seems not belong to the SDHC IP core. Not quite sure whether regulator would be right

Re: sdhci: runtime suspend/resume on card insert/removal

2015-09-14 Thread Vaibhav Hiremath
On Monday 14 September 2015 11:58 AM, Jisheng Zhang wrote: On Mon, 14 Sep 2015 11:55:56 +0530 Vaibhav Hiremath wrote: On Thursday 10 September 2015 01:34 PM, Jisheng Zhang wrote: Hi Russell, On Thu, 10 Sep 2015 09:02:33 +0100 Russell King - ARM Linux

Re: sdhci: runtime suspend/resume on card insert/removal

2015-09-14 Thread Jisheng Zhang
On Mon, 14 Sep 2015 13:43:32 +0530 Vaibhav Hiremath wrote: > > > On Monday 14 September 2015 11:58 AM, Jisheng Zhang wrote: > > On Mon, 14 Sep 2015 11:55:56 +0530 > > Vaibhav Hiremath wrote: > > > >> > >> > >> On Thursday 10 September

RE: [PATCH] mmc: core: Don't return an error for CD/WP GPIOs when GPIOLIB is unset

2015-09-14 Thread Venu Byravarasu
> -Original Message- > From: linux-mmc-ow...@vger.kernel.org [mailto:linux-mmc- > ow...@vger.kernel.org] On Behalf Of Ulf Hansson > Sent: Monday, September 14, 2015 2:27 PM > To: linux-mmc@vger.kernel.org; Ulf Hansson > Cc: Michal Simek > Subject: [PATCH] mmc: core: Don't return an error

Re: sdhci: runtime suspend/resume on card insert/removal

2015-09-14 Thread Vaibhav Hiremath
On Monday 14 September 2015 02:49 PM, Vaibhav Hiremath wrote: On Monday 14 September 2015 01:48 PM, Jisheng Zhang wrote: On Mon, 14 Sep 2015 13:43:32 +0530 Vaibhav Hiremath wrote: On Monday 14 September 2015 11:58 AM, Jisheng Zhang wrote: On Mon, 14 Sep

Re: [PATCH] mmc: core: Don't return an error for CD/WP GPIOs when GPIOLIB is unset

2015-09-14 Thread Michal Simek
On 09/14/2015 11:53 AM, Venu Byravarasu wrote: > > >> -Original Message- >> From: linux-mmc-ow...@vger.kernel.org [mailto:linux-mmc- >> ow...@vger.kernel.org] On Behalf Of Ulf Hansson >> Sent: Monday, September 14, 2015 2:27 PM >> To: linux-mmc@vger.kernel.org; Ulf Hansson >> Cc: Michal

[PATCH V2] mmc: core: Don't return an error for CD/WP GPIOs when GPIOLIB is unset

2015-09-14 Thread Ulf Hansson
When CONFIG_GPIOLIB is unset, its stubs will return -ENOSYS. That means when the mmc core parses DT for CD/WP GPIOs via mmc_of_parse(), -ENOSYS becomes propagated to the caller. Typically this means that the mmc host driver fails to probe. As the CD/WP GPIOs are already treated as optional, let's

Re: [PATCH V2] mmc: core: Don't return an error for CD/WP GPIOs when GPIOLIB is unset

2015-09-14 Thread Michal Simek
On 09/14/2015 12:18 PM, Ulf Hansson wrote: > When CONFIG_GPIOLIB is unset, its stubs will return -ENOSYS. That means > when the mmc core parses DT for CD/WP GPIOs via mmc_of_parse(), -ENOSYS > becomes propagated to the caller. Typically this means that the mmc host > driver fails to probe. > > As

RE: [PATCH V2] mmc: core: Don't return an error for CD/WP GPIOs when GPIOLIB is unset

2015-09-14 Thread Venu Byravarasu
ACKed-by: Venu Byravarasu > -Original Message- > From: linux-mmc-ow...@vger.kernel.org [mailto:linux-mmc- > ow...@vger.kernel.org] On Behalf Of Ulf Hansson > Sent: Monday, September 14, 2015 3:49 PM > To: linux-mmc@vger.kernel.org; Ulf Hansson > Cc: Michal Simek;