Re: [PATCH WIP 01/43] IB: Modify ib_create_mr API

2015-07-26 Thread Sagi Grimberg
On 7/23/2015 10:08 PM, Jason Gunthorpe wrote: On Thu, Jul 23, 2015 at 01:07:56PM +0300, Sagi Grimberg wrote: On 7/22/2015 10:05 PM, Jason Gunthorpe wrote: The reason I named max_entries is because might might not be pages but real SG elements. It stands for maximum registration entries. Do you

Re: [PATCH WIP 01/43] IB: Modify ib_create_mr API

2015-07-23 Thread Jason Gunthorpe
On Thu, Jul 23, 2015 at 01:07:56PM +0300, Sagi Grimberg wrote: On 7/22/2015 10:05 PM, Jason Gunthorpe wrote: The reason I named max_entries is because might might not be pages but real SG elements. It stands for maximum registration entries. Do you have a better name? I wouldn't try and be

Re: [PATCH WIP 01/43] IB: Modify ib_create_mr API

2015-07-23 Thread Sagi Grimberg
On 7/22/2015 10:05 PM, Jason Gunthorpe wrote: On Wed, Jul 22, 2015 at 07:58:23PM +0300, Sagi Grimberg wrote: On 7/22/2015 7:44 PM, Christoph Hellwig wrote: On Wed, Jul 22, 2015 at 10:34:05AM -0600, Jason Gunthorpe wrote: +/** + * ib_alloc_mr() - Allocates a memory region + * @pd:

Re: [PATCH WIP 01/43] IB: Modify ib_create_mr API

2015-07-23 Thread Sagi Grimberg
On 7/23/2015 12:30 PM, Christoph Hellwig wrote: On Thu, Jul 23, 2015 at 12:57:34AM +, Hefty, Sean wrote: +enum ib_mr_type { + IB_MR_TYPE_FAST_REG, + IB_MR_TYPE_SIGNATURE, If we're going to go through the trouble of changing everything, I vote for dropping the word 'fast'. It's

Re: [PATCH WIP 01/43] IB: Modify ib_create_mr API

2015-07-23 Thread Christoph Hellwig
On Thu, Jul 23, 2015 at 12:57:34AM +, Hefty, Sean wrote: +enum ib_mr_type { + IB_MR_TYPE_FAST_REG, + IB_MR_TYPE_SIGNATURE, If we're going to go through the trouble of changing everything, I vote for dropping the word 'fast'. It's a marketing term. It's goofy. And the IB spec

Re: [PATCH WIP 01/43] IB: Modify ib_create_mr API

2015-07-22 Thread Jason Gunthorpe
+/** + * ib_alloc_mr() - Allocates a memory region + * @pd:protection domain associated with the region + * @mr_type: memory region type + * @max_entries: maximum registration entries available + * @flags: create flags + */ Can you update this comment to

Re: [PATCH WIP 01/43] IB: Modify ib_create_mr API

2015-07-22 Thread Christoph Hellwig
On Wed, Jul 22, 2015 at 10:34:05AM -0600, Jason Gunthorpe wrote: +/** + * ib_alloc_mr() - Allocates a memory region + * @pd:protection domain associated with the region + * @mr_type: memory region type + * @max_entries: maximum registration entries available + *

Re: [PATCH WIP 01/43] IB: Modify ib_create_mr API

2015-07-22 Thread Jason Gunthorpe
On Wed, Jul 22, 2015 at 07:59:16PM +0300, Sagi Grimberg wrote: Do we want to pull ib_get_dma_mr() here with type IB_MR_TYPE_DMA? I want to get rid of ib_get_dma_mr... My plan was to get rid of it as my last series shows for all lkey usages and then rename it to:

Re: [PATCH WIP 01/43] IB: Modify ib_create_mr API

2015-07-22 Thread Sagi Grimberg
On 7/22/2015 8:01 PM, Jason Gunthorpe wrote: On Wed, Jul 22, 2015 at 07:59:16PM +0300, Sagi Grimberg wrote: Do we want to pull ib_get_dma_mr() here with type IB_MR_TYPE_DMA? I want to get rid of ib_get_dma_mr... That's why I asked :) So I'll take it as a no... -- To unsubscribe from this

Re: [PATCH WIP 01/43] IB: Modify ib_create_mr API

2015-07-22 Thread Sagi Grimberg
On 7/22/2015 7:44 PM, Christoph Hellwig wrote: On Wed, Jul 22, 2015 at 10:34:05AM -0600, Jason Gunthorpe wrote: +/** + * ib_alloc_mr() - Allocates a memory region + * @pd:protection domain associated with the region + * @mr_type: memory region type + * @max_entries: maximum

Re: [PATCH WIP 01/43] IB: Modify ib_create_mr API

2015-07-22 Thread Jason Gunthorpe
On Wed, Jul 22, 2015 at 07:58:23PM +0300, Sagi Grimberg wrote: On 7/22/2015 7:44 PM, Christoph Hellwig wrote: On Wed, Jul 22, 2015 at 10:34:05AM -0600, Jason Gunthorpe wrote: +/** + * ib_alloc_mr() - Allocates a memory region + * @pd:protection domain associated with the region +

RE: [PATCH WIP 01/43] IB: Modify ib_create_mr API

2015-07-22 Thread Hefty, Sean
+enum ib_mr_type { + IB_MR_TYPE_FAST_REG, + IB_MR_TYPE_SIGNATURE, If we're going to go through the trouble of changing everything, I vote for dropping the word 'fast'. It's a marketing term. It's goofy. And the IB spec is goofy for using it. -- To unsubscribe from this list: send