sd_done and WRITE_SAME broken?

2015-09-24 Thread Grant Grundler
drivers/scsi/sd.c 1706 if (sshdr.asc == 0x20 || sshdr.asc == 0x24) { 1707 switch (op) { 1708 case UNMAP: 1709 sd_config_discard(sdkp, SD_LBP_DISABLE); 1710 break; 1711

Re: DMA mapping on SCSI device?

2008-01-28 Thread Grant Grundler
On Jan 29, 2008 11:08 AM, Robert Hancock <[EMAIL PROTECTED]> wrote: ... > The last solution I tried was to set the DMA mask on both ports to > 32-bit on slave_configure when an ATAPI device is connected. However, > this runs into complications as well. This is run on initialization and > when tryin

Re: [PATCH] Marvell 6440 SAS/SATA driver

2008-01-25 Thread Grant Grundler
On Jan 25, 2008 8:43 AM, Ke Wei <[EMAIL PROTECTED]> wrote: > The attached is Marvell 6440 SAS/SATA driver. I will try to send email > by git-send-email. > Sorry, just saw some more issues in +static void mvs_hba_interrupt_enable(struct mvs_info *mvi, int enable) Three comments here: 1) This routi

Re: [PATCH] Marvell 6440 SAS/SATA driver

2008-01-25 Thread Grant Grundler
On Jan 25, 2008 8:43 AM, Ke Wei <[EMAIL PROTECTED]> wrote: > The attached is Marvell 6440 SAS/SATA driver. I will try to send email > by git-send-email. I know this isn't part of this patch: #define mr32(reg) readl(regs + MVS_##reg) #define mw32(reg,val) writel((val), regs + MVS_##reg) Bu

Re: [PATCH] Marvell 6440 SAS/SATA driver

2008-01-23 Thread Grant Grundler
On Jan 22, 2008 7:58 PM, Jeff Garzik <[EMAIL PROTECTED]> wrote: > > +#define READ_PORT_CONFIG_DATA(i) \ > > + ((i > 3)?mr32(P4_CFG_DATA + (i - 4) * 8):mr32(P0_CFG_DATA + i * 8)) > > +#define WRITE_PORT_CONFIG_DATA(i,tmp) \ > > + {if (i > 3)mw32(P4_CFG_DATA + (i - 4) * 8, tmp); \ > > +

Re: [linux-usb-devel] [PATCH] [2.6.23.13] udev hangs USB-storage (HP r707 camera)

2008-01-22 Thread Grant Grundler
On Tue, Jan 22, 2008 at 11:55:56PM -0700, Grant Grundler wrote: ... > > http://www.phildev.net/linux/usb-unusualdevs-notes.html > > In general, a very helpful document! Thanks! ... I read the rest of the document and explains exactly my confusion. Can you please include that d

Re: [linux-usb-devel] [PATCH] [2.6.23.13] udev hangs USB-storage (HP r707 camera)

2008-01-22 Thread Grant Grundler
On Tue, Jan 22, 2008 at 09:27:09PM -0800, Phil Dibowitz wrote: ... > Patch looks fine to me. Let me get my tree in order (sorry, been really > swamped lately so I haven't updated in a while), make sure this diff's > nicely against the latest rc's, It's not. It's against 2.6.23. But I expect it to

[PATCH] [2.6.23.13] udev hangs USB-storage (HP r707 camera)

2008-01-19 Thread Grant Grundler
now reports 60800 sectors and udev is happy. email thread reference: http://marc.info/?t=12007648332&r=1&w=2 Signed-off-by: Grant Grundler <[EMAIL PROTECTED]> --- linux-2.6.23.13/drivers/usb/storage/unusual_devs.h 2008-01-19 19:59:15.0 -0800 +++ linux-2.6.23-GG

Re: udev hangs USB-storage (HP r707 camera)

2008-01-19 Thread Grant Grundler
On Sat, Jan 19, 2008 at 08:10:08PM -0700, Grant Grundler wrote: > [EMAIL PROTECTED]:~ # strace -o strace-dd-HPr707.out dd if=/dev/sda > of=/dev/null skip=60800 count=1 > dd: reading `/dev/sda': Input/output error > 0+0 records in > 0+0 records out > 0 bytes (0 B) copied, 55

Re: udev hangs USB-storage (HP r707 camera)

2008-01-19 Thread Grant Grundler
On Sat, Jan 19, 2008 at 08:56:31PM -0600, James Bottomley wrote: > > it's children a few days ago (probably with 2.6.22-14-generic (Ubuntu > > kernel). I've appended everything for PID 17972 (which is only 12k, full > > output is 559KB). Key bit is this: > > 17972 _llseek(3, 31129600, [3112960

Re: udev hangs USB-storage (HP r707 camera)

2008-01-19 Thread Grant Grundler
On Sat, Jan 19, 2008 at 07:28:29PM -0700, Grant Grundler wrote: ... > Thanks for reminding me...I had collected strace output of udev and all > it's children a few days ago (probably with 2.6.22-14-generic (Ubuntu > kernel). I've appended everything for PID 17972 (which is only

Re: udev hangs USB-storage (HP r707 camera)

2008-01-19 Thread Grant Grundler
On Sun, Jan 20, 2008 at 01:53:51AM +0100, Stefan Richter wrote: > Grant Grundler wrote: > > https://bugs.launchpad.net/ubuntu/+source/hal/+bug/180472 > ... > > I have a usbmon trace for 2.6.23.13 (appended) along with dmesg output. > > What I need is someone to inter

Re: MPT Fusion initialization in 2.6.23.12

2008-01-15 Thread Grant Grundler
will look into this more today and report back any useful information > I learn. Thanks very much for your help in understanding this. excellent - thanks, grant > > Thanks, > Karen > > On Mon, Jan 14, 2008 at 06:19:30PM -0700, Moore, Eric wrote: > > On Monday, January 14,

Re: MPT Fusion initialization in 2.6.23.12

2008-01-14 Thread Grant Grundler
On Jan 11, 2008 6:01 AM, Karen Shaeffer <[EMAIL PROTECTED]> wrote: > Hi, > > I have this server with an LSI Logic SAS1064 RAID > enabled Ultra320 SCSI controller on the system board. Karen, The above doesn't make sense to me. How is "SAS 1064 RAID" related to "Ultra320 SCSI"? This card has both tr

Re: [PATCH 1/3]: IO resource allocation using pci_request_selected_regions API

2008-01-11 Thread Grant Grundler
On Jan 11, 2008 1:28 AM, Christoph Hellwig <[EMAIL PROTECTED]> wrote: > On Fri, Jan 11, 2008 at 02:33:30PM +0530, Prakash, Sathya wrote: > > This patch modifies the IO resource allocation behavior of FUSION driver. > > By using the pci_select_bars and pci_request_selected_regions API > > The IORESO

Re: [PATCH 1/3] mpt fusion: IO resource allocation using pci_request_selected_regions API [Resent]

2008-01-11 Thread Grant Grundler
On Jan 11, 2008 1:07 AM, Prakash, Sathya <[EMAIL PROTECTED]> wrote: > This patch modifies the IO resource allocation behavior of FUSION driver. > By using the pci_select_bars and pci_request_selected_regions API > The IORESOURCE_IO will be requested only when the driver needs the IO > resource. T

Re: [PATCH 1/1] aacraid: big endian issues

2008-01-08 Thread Grant Grundler
not think this turns into a readability issue in either case > and view this as a simple cosmetic coding precaution much > like likely()/unlikely() offers hints to the compiler on code intent... Agreed - it's not a readability issue. thanks, grant > > Sincerely -- Mark Salyzyn &g

Re: [PATCH 1/1] aacraid: big endian issues

2008-01-08 Thread Grant Grundler
On Jan 8, 2008 12:48 PM, Salyzyn, Mark <[EMAIL PROTECTED]> wrote: > Big endian systems issues discovered in the aacraid driver. ... --- a/drivers/scsi/aacraid/comminit.c 2008-01-08 15:32:28.329810853 -0500 +++ b/drivers/scsi/aacraid/comminit.c 2008-01-08 15:37:35.633163607 -0500 @@ -301,10 +30

Re: [PATCH] add help to WAIT_SCAN option

2007-05-26 Thread Grant Grundler
it wasn't. > > Oh, right. Since Hugh's patch is the same as the one I sent in the > other fork of this thread, except for the contents of the comment, by > all means put in Hugh's version instead of mine. Include my signed-off > if you like. And you can add an "Acked

Re: [PATCH] add help to WAIT_SCAN option

2007-05-26 Thread Grant Grundler
On Sat, May 26, 2007 at 02:50:14PM -0500, James Bottomley wrote: > This solution is still as wrong as it was the last three times it was > submitted to linux-scsi: > > http://marc.info/?t=11790698961 > http://marc.info/?t=117926627700012 > http://marc.info/?t=11792306204 ugh...sorry. I s

[PATCH] add help to WAIT_SCAN option

2007-05-26 Thread Grant Grundler
initrd or initramfs. So no chance to load scsi_wait_scan module. This patch enables one to select "y" for WAIT_SCAN option and adds help text on how/when to use "m" vs "y". Signed-off-by: Grant Grundler <[EMAIL PROTECTED]> diff --git a/drivers/scsi/Kconfig b/

Re: [PATCH 2/5] fixing errors handling during pci_driver resume stage [ata]

2007-01-12 Thread Grant Grundler
On Tue, Jan 09, 2007 at 12:01:28PM +0300, Dmitriy Monakhov wrote: > ata pci drivers have to return correct error code during resume stage in > case of errors. ... > @@ -6246,8 +6253,10 @@ int ata_pci_device_suspend(struct pci_de > int ata_pci_device_resume(struct pci_dev *pdev) > { > struct

Re: [PATCH 1/5] Update Documentation/pci.txt

2006-12-17 Thread Grant Grundler
On Fri, Dec 15, 2006 at 09:02:07AM -0800, Greg KH wrote: > On Sun, Dec 10, 2006 at 12:25:08AM -0700, Grant Grundler wrote: ... [ re __devinit/__devexit ] > > o drivers should use __dev* exactly because HOTPLUG is defined. > > Yes, they should, but it is confusing as to why it sh

Re: [PATCH 1/5] Update Documentation/pci.txt

2006-12-06 Thread Grant Grundler
On Tue, Dec 05, 2006 at 11:26:51PM -0800, Greg KH wrote: > > If this looks good, I'll post a diff for gregkh. > > This looks very good, thanks for doing this work. welcome - feels like the most significant contribution I've made to kernel in a long time. > I do have a few minor comments: I'll f

Re: Symbios PCI error recovery [Was: Re: [PATCH/RFC] ppc64: EEH + SCSI recovery (IPR only)]

2005-03-31 Thread Grant Grundler
On Thu, Mar 31, 2005 at 02:14:09PM -0600, Linas Vepstas wrote: > > What config registers are you restoring? > > BAR's, grant, latency, interrupt, cacheline size. "grant" is PCI_COMMAND? If so, I think you have all of them. You may want to leave BUS_MASTER disabled until you think the driver is

Re: Symbios PCI error recovery [Was: Re: [PATCH/RFC] ppc64: EEH + SCSI recovery (IPR only)]

2005-03-31 Thread Grant Grundler
On Thu, Mar 31, 2005 at 02:06:22PM -0600, Linas Vepstas wrote: > > Does this process cause a SCSI bus reset? > > Don't get a chance to get that far. Have to bring up the PCI interfaces > first, before any scsi command can be issued. My point is you want the scsi bus to get reset so devices drop

Re: Symbios PCI error recovery [Was: Re: [PATCH/RFC] ppc64: EEH + SCSI recovery (IPR only)]

2005-03-22 Thread Grant Grundler
On Mon, Mar 21, 2005 at 05:10:28PM -0600, Linas Vepstas wrote: > My current hardware will halt all i/o to/from the symbios controller > upon detection of a PCI error. The recovery proceedure that I am > currently using is to call system firmware (aka 'bios') to raise > and then lower the #RST pci

Re: PATCH 2.6.11-rc4 rename IOMAPPED config option

2005-02-23 Thread Grant Grundler
On Sun, Feb 20, 2005 at 09:09:36PM -0500, Jeff Garzik wrote: > Irrelevant. It matters to automated patch snarfers, lkml.org users, etc. Jeff, I just cut the patch using standard cvs diff. I know SubmittingPatches wants -p0 but I also knew that willy doesn't mind -p1 and he's the maintainer. > In

PATCH 2.6.11-rc4 rename IOMAPPED config option

2005-02-20 Thread Grant Grundler
eed to read the config help to understand what this means. Signed-off-by: Grant Grundler <[EMAIL PROTECTED]> thanks, grant Index: drivers/scsi/Kconfig === RCS file: /var/cvs/linux-2.6/drivers/scsi/Kconfig,v retrieving revision 1.32 d