Re: [lng-odp] [API-NEXT PATCH 0/5] netmap pktio multi queue support

2015-11-20 Thread Elo, Matias (Nokia - FI/Espoo)
Did you first apply Petri’s '[API-NEXT PATCH v3 0/7] Multi-queue packet io APIs' patch set as noted in the cover letter? -Matias From: EXT Mike Holmes [mailto:mike.hol...@linaro.org] Sent: Thursday, November 19, 2015 9:47 PM To: Elo, Matias (Nokia - FI/Espoo) Cc: lng-odp Subject: Re: [lng-odp]

Re: [lng-odp] [API-NEXT PATCH v3 6/7] linux-generic: pktio: dummy multi-queue pktio

2015-11-20 Thread Savolainen, Petri (Nokia - FI/Espoo)
It build cleanly with ‘make’ and ‘make check’, but ‘make distcheck’ adds cast-qual warning level which catches the cast. The build system should be fixed to have same warning levels for all build targets! Cast is needed due to odp_queue_create() API definition. Additional cast to uintptr_t fixe

[lng-odp] [API-NEXT PATCH v4 0/7] Multi-queue packet io APIs

2015-11-20 Thread Petri Savolainen
This patch set adds APIs for multi-queue packet IO. It does not remove or modify existing API calls, so that multi-queue can be verified first with couple of apps and implementations. Single queue APIs (e.g. odp_pktio_inq_setdef()) and potentially plain _recv() and _send() should be removed once

[lng-odp] [API-NEXT PATCH v4 1/7] api: pktio: added pktio capability struct

2015-11-20 Thread Petri Savolainen
Added capability structure and a function to query it. Capability limits are used for advanced pktio configuration, like configuration of multiple input/output queues. Signed-off-by: Petri Savolainen --- include/odp/api/packet_io.h | 23 +++ 1 file changed, 23 insertions(+)

[lng-odp] [API-NEXT PATCH v4 3/7] api: pktio: added direct queue receive

2015-11-20 Thread Petri Savolainen
Added odp_pktio_recv_queue for direct packet receive from pktio input queues. Signed-off-by: Petri Savolainen --- include/odp/api/packet_io.h | 33 - 1 file changed, 28 insertions(+), 5 deletions(-) diff --git a/include/odp/api/packet_io.h b/include/odp/api/packe

[lng-odp] [API-NEXT PATCH v4 4/7] api: pktio: added multiple pktio output queues

2015-11-20 Thread Petri Savolainen
Added output queue configuration parameters and functions for setting up multiple output queues. Added also a function to query the number of output queues. Signed-off-by: Petri Savolainen --- include/odp/api/packet_io.h| 71 ++ .../include/odp/plat/pa

[lng-odp] [API-NEXT PATCH v4 5/7] api: pktio: added direct send to pktio output queue

2015-11-20 Thread Petri Savolainen
Added odp_pktio_send_queue for direct packet send to a pktio output queue. Signed-off-by: Petri Savolainen --- include/odp/api/packet_io.h | 39 +++ 1 file changed, 31 insertions(+), 8 deletions(-) diff --git a/include/odp/api/packet_io.h b/include/odp/api/pa

[lng-odp] [API-NEXT PATCH v4 6/7] linux-generic: pktio: dummy multi-queue pktio

2015-11-20 Thread Petri Savolainen
Implemented multi-queue API with dummy single queue support. Enables testing the API and provides stubbs for actual multi-queue implementations. Not optimized. Signed-off-by: Petri Savolainen --- .../include/odp/plat/packet_io_types.h | 14 +- .../linux-generic/include/odp_packet_io

[lng-odp] [API-NEXT PATCH v4 7/7] test: l2fwd: use multi-queue pktio in direct mode

2015-11-20 Thread Petri Savolainen
Modified the application to support for multiple queues per interface. Enabled inequal worker thread counts. Signed-off-by: Petri Savolainen --- test/performance/odp_l2fwd.c | 414 --- 1 file changed, 352 insertions(+), 62 deletions(-) diff --git a/test/p

[lng-odp] [API-NEXT PATCH v4 2/7] api: pktio: added multiple pktio input queues

2015-11-20 Thread Petri Savolainen
Added input queue configuration parameters and functions to setup multiple input queue and hashing. Added also functions to query the number of queues and queue handles. Direct receive does use new odp_pktin_queue_t handle type. Signed-off-by: Petri Savolainen --- include/odp/api/packet_io.h

[lng-odp] [PATCH] example/ipsec: Improper use of packet src_ip and dst_ip for LE platform

2015-11-20 Thread akhil.goyal
From: Akhil Goyal While decapsulation for tunnel, src_ip and dst_ip retreived from the packet shall be converted from network endianness to cpu endianness Signed-off-by: Akhil Goyal --- example/ipsec/odp_ipsec.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/example/ip

[lng-odp] [PATCH] pkg/rpm: different BuildRequires for CentOS

2015-11-20 Thread Anders Roxell
Reported-by: Riku Voipio Signed-off-by: Anders Roxell --- pkg/rpm/odp.spec | 6 ++ 1 file changed, 6 insertions(+) diff --git a/pkg/rpm/odp.spec b/pkg/rpm/odp.spec index 3c4c6f7..aa57476 100644 --- a/pkg/rpm/odp.spec +++ b/pkg/rpm/odp.spec @@ -19,8 +19,14 @@ BuildRequires: openssl-devel Bu

[lng-odp] [API-NEXT PATCH 1/3] api: thrmask: correct specification error

2015-11-20 Thread Petri Savolainen
odp_thread_count_max() returns the maximum number of threads, instead of odp_thrmask_count(). Signed-off-by: Petri Savolainen --- include/odp/api/thrmask.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/include/odp/api/thrmask.h b/include/odp/api/thrmask.h index ebc31f2..866

[lng-odp] [API-NEXT PATCH 3/3] linux-generic: thread: removed internal max threads define

2015-11-20 Thread Petri Savolainen
Replaced internal define with ODP_THREAD_COUNT_MAX. This fixes also the current make install issue. Signed-off-by: Petri Savolainen --- platform/linux-generic/Makefile.am | 1 - .../include/odp/plat/rwlock_recursive_types.h | 10 .../linux-generic/include/odp_buffe

[lng-odp] [API-NEXT PATCH 2/3] api: thread: added THREAD_COUNT_MAX define

2015-11-20 Thread Petri Savolainen
Added maximum thread count define to enable static memory allocation. The API call returns dynamic maximum. Static and dynamic may be different application is build for binary compatibility. Signed-off-by: Petri Savolainen --- include/odp/api/thread.h | 9 +- platf

Re: [lng-odp] [PATCH] pkg/rpm: different BuildRequires for CentOS

2015-11-20 Thread Maxim Uvarov
Merged, Maxim. On 11/20/2015 14:48, Anders Roxell wrote: Reported-by: Riku Voipio Signed-off-by: Anders Roxell --- pkg/rpm/odp.spec | 6 ++ 1 file changed, 6 insertions(+) diff --git a/pkg/rpm/odp.spec b/pkg/rpm/odp.spec index 3c4c6f7..aa57476 100644 --- a/pkg/rpm/odp.spec +++ b/pkg/rp

Re: [lng-odp] [API-NEXT PATCH 0/5] netmap pktio multi queue support

2015-11-20 Thread Mike Holmes
Ah no - see that now, I read the first line of your message and Petris got rejected but I did not think it though when yours failed. Thanks :) On 20 November 2015 at 03:06, Elo, Matias (Nokia - FI/Espoo) < matias@nokia.com> wrote: > Did you first apply Petri’s '[API-NEXT PATCH v3 0/7] Multi-

Re: [lng-odp] [API-NEXT PATCH v3 6/7] linux-generic: pktio: dummy multi-queue pktio

2015-11-20 Thread Anders Roxell
On 2015-11-20 08:38, Savolainen, Petri (Nokia - FI/Espoo) wrote: > It build cleanly with ‘make’ and ‘make check’, but ‘make distcheck’ adds > cast-qual warning level which catches the cast. The build system should be > fixed to have same warning levels for all build targets! if you do: ./bootstr

Re: [lng-odp] [API-NEXT PATCH v3 6/7] linux-generic: pktio: dummy multi-queue pktio

2015-11-20 Thread Savolainen, Petri (Nokia - FI/Espoo)
Did you try --with-netmap-path=xxx ? -Petri > -Original Message- > From: EXT Anders Roxell [mailto:anders.rox...@linaro.org] > Sent: Friday, November 20, 2015 3:29 PM > To: Savolainen, Petri (Nokia - FI/Espoo) > Cc: EXT Mike Holmes; lng-odp > Subject: Re: [lng-odp] [API-NEXT PATCH v3 6/7]

Re: [lng-odp] [PATCH 1/1] linux-generic: config: increase ODP_CONFIG_SCHED_GRPS to 256

2015-11-20 Thread Maxim Uvarov
Merged, Maxim. On 11/19/2015 17:30, Bill Fischofer wrote: That's a reasonable use case. The main issue is that the scheduler needs a rewrite to properly handle scheduler groups in cases like this. Basically, the scheduler should not be scanning queues that it can know aren't eligible for this

Re: [lng-odp] [API-NEXT PATCH 1/3] api: thrmask: correct specification error

2015-11-20 Thread Bill Fischofer
For this set: Reviewed-by: Bill Fischofer On Fri, Nov 20, 2015 at 6:32 AM, Petri Savolainen < petri.savolai...@nokia.com> wrote: > odp_thread_count_max() returns the maximum number of threads, > instead of odp_thrmask_count(). > > Signed-off-by: Petri Savolainen > --- > include/odp/api/thrmas

Re: [lng-odp] [API-NEXT PATCH v3 6/7] linux-generic: pktio: dummy multi-queue pktio

2015-11-20 Thread Anders Roxell
On 2015-11-20 13:40, Savolainen, Petri (Nokia - FI/Espoo) wrote: > Did you try --with-netmap-path=xxx ? No, didn't see that I had to do that... what will that give me? =) Cheers, Anders > > -Petri > > > -Original Message- > > From: EXT Anders Roxell [mailto:anders.rox...@linaro.org] >

Re: [lng-odp] [API-NEXT PATCH v3 6/7] linux-generic: pktio: dummy multi-queue pktio

2015-11-20 Thread Stuart Haslam
On Fri, Nov 20, 2015 at 02:40:29PM +0100, Anders Roxell wrote: > On 2015-11-20 13:40, Savolainen, Petri (Nokia - FI/Espoo) wrote: > > Did you try --with-netmap-path=xxx ? > > No, didn't see that I had to do that... > what will that give me? =) > When you build with netmap enabled it adds "-Wno-c

Re: [lng-odp] [PATCHv2] pkg/debian/control: add more packages to build-depends

2015-11-20 Thread Anders Roxell
On 2015-11-19 10:47, Anders Roxell wrote: > Reported-by: Riku Voipio > Signed-off-by: Anders Roxell > Reviewed-by: Riku Voipio Ping. > --- > pkg/debian/control | 4 +++- > 1 file changed, 3 insertions(+), 1 deletion(-) > > diff --git a/pkg/debian/control b/pkg/debian/control > index b4661cc.

Re: [lng-odp] [PATCHv2] pkg/debian/control: add more packages to build-depends

2015-11-20 Thread Maxim Uvarov
Merged, Maxim. On 11/19/2015 12:47, Anders Roxell wrote: Reported-by: Riku Voipio Signed-off-by: Anders Roxell Reviewed-by: Riku Voipio --- pkg/debian/control | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/pkg/debian/control b/pkg/debian/control index b4661cc..941e8

Re: [lng-odp] [API-NEXT PATCH v3 6/7] linux-generic: pktio: dummy multi-queue pktio

2015-11-20 Thread Anders Roxell
On 2015-11-20 13:52, Stuart Haslam wrote: > On Fri, Nov 20, 2015 at 02:40:29PM +0100, Anders Roxell wrote: > > On 2015-11-20 13:40, Savolainen, Petri (Nokia - FI/Espoo) wrote: > > > Did you try --with-netmap-path=xxx ? > > > > No, didn't see that I had to do that... > > what will that give me? =)

Re: [lng-odp] [PATCH] validation: remove strict dependency on CUnit 2.1-3

2015-11-20 Thread Maxim Uvarov
Merged, Maxim. On 11/19/2015 14:16, Ivan Khoronzhuk wrote: On 19.11.15 12:22, Stuart Haslam wrote: This makes it a bit easier to get a new system set up for running the unit tests. There has always been a dependency on using a version of CUnit >= 2.1-3, using an older version would result in

Re: [lng-odp] [PATCH] CONTRIBUTING: add user doc guidelines

2015-11-20 Thread Maxim Uvarov
Merged, Maxim. On 11/18/2015 19:15, Bill Fischofer wrote: On Wed, Nov 18, 2015 at 10:03 AM, Mike Holmes > wrote: Signed-off-by: Mike Holmes mailto:mike.hol...@linaro.org>> Reviewed-by: Bill Fischofer > --- CONT

Re: [lng-odp] [PATCH] scripts/builddeb: add support for source only generation

2015-11-20 Thread Maxim Uvarov
Merged, Maxim. On 11/19/2015 09:35, Riku Voipio wrote: For CI loop, we have separate job to build binaries (build-package). To make it possible to build source package without first installing all build-deps, add a new optional parameter "source" to build only source package. Signed-off-by: Rik

Re: [lng-odp] [PATCH] scripts/builddeb: add support for source only generation

2015-11-20 Thread Mike Holmes
Do we have a review for this ? On 20 November 2015 at 09:39, Maxim Uvarov wrote: > Merged, > Maxim. > > > On 11/19/2015 09:35, Riku Voipio wrote: > >> For CI loop, we have separate job to build binaries (build-package). >> To make it possible to build source package without first installing >> a

[lng-odp] ODP power management requirement?

2015-11-20 Thread Hongbo Zhang
Hi guys, https://projects.linaro.org/browse/ODP-242 I'd like to discuss with you about this issue, hope you can make it clear about the real requirement, give suggestions and make a coincident conclusion before we go further on a wrong way. First question is what is the original requirement? "core

Re: [lng-odp] [API-NEXT PATCH v4 1/3] api: pool: add packet user area initializer for pool creation parameters

2015-11-20 Thread Zoltan Kiss
This patch fell off the radar, Bill and Bala acked it. On 14/08/15 19:55, Zoltan Kiss wrote: Applications can preset certain parts of the packet user area, so when that memory will be allocated it starts from a known state. If the platform allocates the memory during pool creation, it's enough t

Re: [lng-odp] [PATCH] scripts/builddeb: add support for source only generation

2015-11-20 Thread Anders Roxell
On 20 November 2015 at 15:45, Mike Holmes wrote: > Do we have a review for this ? No because it didn't work due to we always depends on libssl-dev (debian) or openssl-devel (fedora). This is the output if we have a buildserver that doesn't have any pre-installed packages except for the standard,

[lng-odp] [Bug 1698] No support for CoS drop policies

2015-11-20 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=1698 --- Comment #2 from Bala Manoharan --- v1 patch submitted: https://patches.linaro.org/56865/ -- You are receiving this mail because: You are on the CC list for the bug.___ lng-odp mailing list lng-odp@lists

Re: [lng-odp] [PATCH] scripts/builddeb: add support for source only generation

2015-11-20 Thread Maxim Uvarov
On 11/20/2015 20:07, Anders Roxell wrote: On 20 November 2015 at 15:45, Mike Holmes wrote: Do we have a review for this ? No because it didn't work due to we always depends on libssl-dev (debian) or openssl-devel (fedora). This is the output if we have a buildserver that doesn't have any pre-

Re: [lng-odp] [PATCH] scripts/builddeb: add support for source only generation

2015-11-20 Thread Anders Roxell
On 20 November 2015 at 19:23, Maxim Uvarov wrote: > On 11/20/2015 20:07, Anders Roxell wrote: >> >> On 20 November 2015 at 15:45, Mike Holmes wrote: >>> >>> Do we have a review for this ? >> >> No because it didn't work due to we always depends on libssl-dev >> (debian) or openssl-devel (fedora).

[lng-odp] [PATCHv15 0/9] IPC (pktio)

2015-11-20 Thread Maxim Uvarov
v15: - rebase on the latest master - fix checkpatch errors on move odp ring (Mikes comment) v14: - rebase on the latest master - move odp pause to installed helper to make out of tree builds happen. v13: - added ipc.README with description and limitations notes. v12: - size size for ri

[lng-odp] [PATCHv15 2/9] linux-generic: create internal pool create function with shm flags

2015-11-20 Thread Maxim Uvarov
On init odp creates odp_sched_pool. We can not modify API to add new parameter to odp_pool_param_t and this pool should not be shared between different processes. To do that implemented internal linux-generic function with parameters to created shm. Note: create shm before and then provide it to th

[lng-odp] [PATCHv15 1/9] helper: ring: update ring with shm proc argument

2015-11-20 Thread Maxim Uvarov
Signed-off-by: Maxim Uvarov --- helper/include/odp/helper/ring.h | 2 ++ helper/ring.c| 9 - 2 files changed, 10 insertions(+), 1 deletion(-) diff --git a/helper/include/odp/helper/ring.h b/helper/include/odp/helper/ring.h index 65c32ad..5e640a7 100644 --- a/helper/in

[lng-odp] [PATCHv15 3/9] helper: flag to not link ring to linked list

2015-11-20 Thread Maxim Uvarov
Add flag ODPH_RING_NO_LIST to ring to not link it to linked list. Signed-off-by: Maxim Uvarov --- helper/include/odp/helper/ring.h | 21 + helper/ring.c| 3 ++- 2 files changed, 15 insertions(+), 9 deletions(-) diff --git a/helper/include/odp/helper/ring

[lng-odp] [PATCHv15 4/9] helpers: remove odp_ prefix for tests source files

2015-11-20 Thread Maxim Uvarov
Prefixed were removed for validation test suite and to be consistent we need to do the same for helpers. Signed-off-by: Maxim Uvarov --- helper/test/.gitignore | 11 ++- helper/test/Makefile.am | 25 - helper/test/{odp_chksum.c =

[lng-odp] [PATCHv15 6/9] linix-generic: return error for unsupported pktio calls

2015-11-20 Thread Maxim Uvarov
For some pktios like loop and ipc functions like mtu, promisc, and mac addr are not applicable. Instead of crash on deference null pointer just return error if functions are not defined. Signed-off-by: Maxim Uvarov --- platform/linux-generic/odp_packet_io.c | 24 1 file c

[lng-odp] [PATCHv15 7/9] helper: move odp pause to installed helper

2015-11-20 Thread Maxim Uvarov
ipc pktio depends on ring which depends on pause. Move pause to installed helpers to support out of tree builds. Signed-off-by: Maxim Uvarov --- helper/Makefile.am | 4 ++-- helper/{odph_pause.h => include/odp/helper/pause.h} | 0 helper/ring.c

[lng-odp] [PATCHv15 5/9] helper: move ring test to helper

2015-11-20 Thread Maxim Uvarov
Move ring test to helper and kill not needed api_test directory. Unfortunately odp_ring_test.c had some old dirty code so I had to clean up it to to use cunit and latest helper apis. Signed-off-by: Maxim Uvarov --- configure.ac | 1 - helper/test/Makefile.

[lng-odp] [PATCHv15 8/9] linux-generic: add ipc pktio support

2015-11-20 Thread Maxim Uvarov
Signed-off-by: Maxim Uvarov --- platform/linux-generic/Makefile.am | 4 + .../linux-generic/include/odp_buffer_internal.h| 3 + .../linux-generic/include/odp_packet_io_internal.h | 38 ++ .../include/odp_packet_io_ipc_internal.h | 47 ++ platform/linux-generic/

[lng-odp] [PATCHv15 9/9] linux-generic: internal ipc_pktio test

2015-11-20 Thread Maxim Uvarov
2 example ipc pktio applications create ipc pktio to each other and do packet transfer, validation magic numbers and packets sequence counters inside it. Signed-off-by: Maxim Uvarov --- platform/linux-generic/Makefile.am | 1 + platform/linux-generic/m4/configure.m4

Re: [lng-odp] [PATCH] scripts/builddeb: add support for source only generation

2015-11-20 Thread Mike Holmes
I checked with Anders, my summary of the case. Riku intended this patch would allow ODP to build on a plain vanilla build server and that goal is not met by this patch. On 20 November 2015 at 13:29, Anders Roxell wrote: > On 20 November 2015 at 19:23, Maxim Uvarov > wrote: > > On 11/20/2015 20

Re: [lng-odp] [PATCH] scripts/builddeb: add support for source only generation

2015-11-20 Thread Maxim Uvarov
CC Riku if he is not in the list. On 11/20/2015 22:16, Mike Holmes wrote: I checked with Anders, my summary of the case. Riku intended this patch would allow ODP to build on a plain vanilla build server and that goal is not met by this patch. My understanding was that he wanted to just pre

Re: [lng-odp] ODP power management requirement?

2015-11-20 Thread Bill Fischofer
>From an ODP application standpoint there are several factors to consider. First, power management if fundamentally a concern of the ODP implementation more than then application. The main way a data plane application should manage its workload is by creating and terminating worker threads (probab

Re: [lng-odp] [PATCHv15 8/9] linux-generic: add ipc pktio support

2015-11-20 Thread Mike Holmes
On 20 November 2015 at 13:41, Maxim Uvarov wrote: > Signed-off-by: Maxim Uvarov > --- > platform/linux-generic/Makefile.am | 4 + > .../linux-generic/include/odp_buffer_internal.h| 3 + > .../linux-generic/include/odp_packet_io_internal.h | 38 ++ > .../include/odp_pack