Re: Patch: reduce skb input dev on 64 bit machines

2005-07-24 Thread Ben Greear
David S. Miller wrote: From: Thomas Graf <[EMAIL PROTECTED]> Date: Sat, 23 Jul 2005 16:29:42 +0200 I think we should head for a 16bit ifindex at some point or is there any reason why 65K interfaces wouldn't be sufficient? I think we are locked into using "s32" for this. I can definitely im

Re: [PATCH] add netlink module refcounting

2005-07-24 Thread David S. Miller
From: Harald Welte <[EMAIL PROTECTED]> Date: Sat, 23 Jul 2005 16:15:52 -0400 > The attached patch adds support for refcounting of modules implementing > netlink protocols. The idea is that you prevent the module from > disappearing as long as someone in userspace has still a socket talking > to y

Re: [PATCH RFC]: Killing skb->real_dev

2005-07-24 Thread David S. Miller
Ok, here is the final patch I came up with, it's on it's way to the net-2.6.14 GIT tree right now as well. The orig_dev argument to ptype->func() is never ever NULL. BTW, I lied during my netconf2005 talk. On 64-bit we started with a 272 byte sk_buff with everything enabled, not a 256 byte one

Re: [PATCH] [IPV4] fib_trie cleanups

2005-07-24 Thread Olof Johansson
On Fri, Jul 22, 2005 at 11:38:38AM -0700, David S. Miller wrote: > > A lot of the spacing and tabbing has been cleaned up by > Stephen Hemminger, so you might want to patch against > the copy in my 2.6.14 networking it tree at: > > rsync://rsync.kernel.org/pub/scm/linux/kernel/git/davem/net-2

Re: [NET]: Reduce tc_index/tc_verd to u16

2005-07-24 Thread Jamal Hadi Salim
On Sun, 2005-24-07 at 20:16 -0700, David S. Miller wrote: > From: Jamal Hadi Salim <[EMAIL PROTECTED]> > Date: Sun, 24 Jul 2005 23:11:22 -0400 > > > ->cb could be used or made to grow dynamically ? > > Yes, and back to the whole SKB extensions idea and how tricky > that is to get right and effici

Re: Patch: reduce skb input dev on 64 bit machines

2005-07-24 Thread Jamal Hadi Salim
On Sun, 2005-24-07 at 20:14 -0700, David S. Miller wrote: > I see one place where input_dev could be something different, > the mirred stuff. And in fact this ends up being the one > place where an input_dev reference can escape the singular > execution of the input packet path in softirq context

Re: [NET]: Reduce tc_index/tc_verd to u16

2005-07-24 Thread David S. Miller
From: Jamal Hadi Salim <[EMAIL PROTECTED]> Date: Sun, 24 Jul 2005 23:11:22 -0400 > ->cb could be used or made to grow dynamically ? Yes, and back to the whole SKB extensions idea and how tricky that is to get right and efficient at the same time. It is also a good time to remember what I said ab

Re: Patch: reduce skb input dev on 64 bit machines

2005-07-24 Thread David S. Miller
From: Jamal Hadi Salim <[EMAIL PROTECTED]> Date: Sun, 24 Jul 2005 23:02:14 -0400 > On Sun, 2005-24-07 at 22:58 -0400, Jamal Hadi Salim wrote: > > On Sun, 2005-24-07 at 19:02 -0700, David S. Miller wrote: > > > > I agree they will mean the same thing. > > I meant to say they will mean the same t

Re: [NET]: Reduce tc_index/tc_verd to u16

2005-07-24 Thread Jamal Hadi Salim
On Sun, 2005-24-07 at 19:07 -0700, David S. Miller wrote: > From: Thomas Graf <[EMAIL PROTECTED]> > Date: Mon, 25 Jul 2005 03:31:18 +0200 > > > Anyways, tc_verd needs a serious cleanup, not just for the > > macros which we might want to replace with bitfields or > > at least have generic macros to

Re: Patch: reduce skb input dev on 64 bit machines

2005-07-24 Thread Jamal Hadi Salim
On Sun, 2005-24-07 at 22:58 -0400, Jamal Hadi Salim wrote: > On Sun, 2005-24-07 at 19:02 -0700, David S. Miller wrote: > > I agree they will mean the same thing. I meant to say they will mean the same thing in the simple case. And this line below extrapolates that statement further > The example

Re: Patch: reduce skb input dev on 64 bit machines

2005-07-24 Thread Jamal Hadi Salim
On Sun, 2005-24-07 at 19:02 -0700, David S. Miller wrote: I agree they will mean the same thing. The example i gave was to show where one meaning contradicts the other. > And the current specific settings of input_dev has the following > problems: > > 1) you cannot ingress classify on tunneling

Re: [NET]: Reduce tc_index/tc_verd to u16

2005-07-24 Thread David S. Miller
From: Patrick McHardy <[EMAIL PROTECTED]> Date: Sat, 23 Jul 2005 07:03:08 +0200 > [NET]: Reduce tc_index/tc_verd to u16 > > Signed-off-by: Patrick McHardy <[EMAIL PROTECTED]> Applied, thanks Patrick. - To unsubscribe from this list: send the line "unsubscribe netdev" in the body of a message to

Re: Patch: reduce skb input dev on 64 bit machines

2005-07-24 Thread David S. Miller
From: Thomas Graf <[EMAIL PROTECTED]> Date: Sat, 23 Jul 2005 16:29:42 +0200 > I think we should head for a 16bit ifindex at some point > or is there any reason why 65K interfaces wouldn't be > sufficient? I think we are locked into using "s32" for this. I can definitely imagine virtual interface

Re: [NET]: Reduce tc_index/tc_verd to u16

2005-07-24 Thread Jamal Hadi Salim
On Mon, 2005-25-07 at 03:31 +0200, Thomas Graf wrote: > Anyways, tc_verd needs a serious cleanup, not just for the > macros which we might want to replace with bitfields or > at least have generic macros to generate the masks. Right - and as we discussed: -> recall that the use of bit operations

Re: [PATCH] reduce netfilte sk_buff enlargement

2005-07-24 Thread David S. Miller
From: Marcel Holtmann <[EMAIL PROTECTED]> Date: Sat, 23 Jul 2005 03:36:20 +0200 > If you are serious with the shrinking of the sk_buff, I can send you > the final patch along with my pending patches for 2.6.13. Please do. The pkt_type change would get queued for 2.6.14, and please only send real

Re: SKB tutorial, Blog, and NET TODO

2005-07-24 Thread Jamal Hadi Salim
On Sun, 2005-24-07 at 18:04 -0700, David S. Miller wrote: > But this simply doesn't work by itself, that's why we need the > per-queue "stopped" states. > > We need something that properly synchronizes the queue "full" > state transitions, so that the queue does not deadlock and when > one priori

Re: SKB tutorial, Blog, and NET TODO

2005-07-24 Thread David S. Miller
From: Thomas Graf <[EMAIL PROTECTED]> Date: Mon, 25 Jul 2005 03:24:37 +0200 > * David S. Miller <[EMAIL PROTECTED]> 2005-07-24 18:08 > > The next issue is how to demultiplex from the number of prios > > we want, to what the hardware actually supports if the latter > > is smaller. > > That's what

Re: [NET]: Reduce tc_index/tc_verd to u16

2005-07-24 Thread David S. Miller
From: Thomas Graf <[EMAIL PROTECTED]> Date: Mon, 25 Jul 2005 03:31:18 +0200 > Anyways, tc_verd needs a serious cleanup, not just for the > macros which we might want to replace with bitfields or > at least have generic macros to generate the masks. I'll > look into this once I'm back. I think tc_

Re: Patch: reduce skb input dev on 64 bit machines

2005-07-24 Thread David S. Miller
From: Jamal Hadi Salim <[EMAIL PROTECTED]> Date: Sun, 24 Jul 2005 21:49:34 -0400 > The semantics of the two are very different. real_dev is in regards to > stacked interfaces and input_dev is in reference to track what the last > ingress interface was. So it is ambigous to have them to be the same

Re: [PATCH] net drivers: make some driver families subordinate

2005-07-24 Thread David S. Miller
From: randy_dunlap <[EMAIL PROTECTED]> Date: Sat, 23 Jul 2005 19:05:20 -0700 > This patch improves the presentation of several networking driver families. > It causes them to be displayed aligned with ARCnet and Ethernet > (immediately under them in menuconfig/xconfig/gconfig) instead of > not bei

Re: [PATCH] net/ipv6/ip6_tunnel.c: implicit declaration of function `xfrm6_tunnel_unregister'

2005-07-24 Thread David S. Miller
From: Cal Peake <[EMAIL PROTECTED]> Date: Sat, 23 Jul 2005 20:50:48 -0400 (EDT) > This patch seems correct: > > Signed-off-by: Cal Peake <[EMAIL PROTECTED]> Applied, thanks Cal. - To unsubscribe from this list: send the line "unsubscribe netdev" in the body of a message to [EMAIL PROTECTED] More

Re: Patch: reduce skb input dev on 64 bit machines

2005-07-24 Thread Jamal Hadi Salim
On Sun, 2005-24-07 at 18:00 -0700, David S. Miller wrote: > > Signed-off-by: Jamal Hadi Salim <[EMAIL PROTECTED]> > > I have a better change in the wings that totally eliminates > real_dev _AND_ input_dev completely, and passes them as > parameters into pt->func() and ->enqueue() as it should hav

Re: [NET]: Reduce tc_index/tc_verd to u16

2005-07-24 Thread Thomas Graf
* Thomas Graf <[EMAIL PROTECTED]> 2005-07-23 18:23 > Hold on, I'm working on a patch to introduce TC_CB() so we can > move some of the fields of tc_verd into the control buffer so > I can do the cleanup at the same time. I tried but none of the bits can be moved into cb as-is except for TC_MUNGED

Re: SKB tutorial, Blog, and NET TODO

2005-07-24 Thread Thomas Graf
* David S. Miller <[EMAIL PROTECTED]> 2005-07-24 18:08 > The key is what should happen when the ring for prio X fills > up? netif_stop_queue() in it's current form is the wrong > thing to do, because it prevents lower priority packets from > being queued which is exactly what we want to do if thos

Re: Patch: reduce skb input dev on 64 bit machines

2005-07-24 Thread David S. Miller
From: Patrick McHardy <[EMAIL PROTECTED]> Date: Sat, 23 Jul 2005 18:54:13 +0200 > Let me propose again to just set it here for all cases. So far there > hasn't been a single exception where indev is not the input device > as seen by netif_rx(), and I don't expect any to come up. In any case > you

Re: SKB tutorial, Blog, and NET TODO

2005-07-24 Thread David S. Miller
From: Thomas Graf <[EMAIL PROTECTED]> Date: Sat, 23 Jul 2005 18:14:58 +0200 > The simplest case is if the hardware does strict prio and does > the queueing itself based on skb->priority or similiar. We don't > need to change anything in this case except for adding the > interface to transfer the c

Re: SKB tutorial, Blog, and NET TODO

2005-07-24 Thread David S. Miller
From: Jamal Hadi Salim <[EMAIL PROTECTED]> Date: Sat, 23 Jul 2005 10:14:52 -0400 > Setting the skb->prio to be used by the driver sounds reasonable. > Another alternative would be what was already mentioned to change the > call to hardware_start_transmit() to take a prio option. > The driver shoul

Re: Patch: reduce skb input dev on 64 bit machines

2005-07-24 Thread David S. Miller
From: Jamal Hadi Salim <[EMAIL PROTECTED]> Date: Sat, 23 Jul 2005 09:32:07 -0400 > This is part of mission skb diet. > Against git/davem/2.6.14 that was on vger 30 minutes back: It changes > input_dev to be an ifindex so we dont bother holding devices. > Would only cut a 4 byte fat on 64 bit ma

Re: net-2.6.14 GIT rebased

2005-07-24 Thread David S. Miller
From: Harald Welte <[EMAIL PROTECTED]> Date: Sat, 23 Jul 2005 01:11:08 -0400 > so there now is > rsync://rsync.kernel.org/pub/scm/linux/kernel/git/davem/net-2.6.14.git/ > and > rsync://rsync.kernel.org/pub/scm/linux/kernel/git/davem/net-2.6.14.git/new-net-2.6.14.git > > I don't think this is thi

[PATCH] net drivers: make all driver famiies aligned

2005-07-24 Thread randy_dunlap
From: Randy Dunlap <[EMAIL PROTECTED]> Suggestion from Sam Ravnborg <[EMAIL PROTECTED]> (This replaces yesterday's patch.) This patch improves the presentation of several networking driver families. It causes all driver families to be displayed aligned immediately under the main network drivers h

Re: [stable] Re: [05/11] SMP fix for 6pack driver

2005-07-24 Thread Adrian Bunk
On Sun, Jul 17, 2005 at 05:09:39PM -0400, Ralf Baechle wrote: > On Fri, Jul 15, 2005 at 09:35:56PM +0200, Adrian Bunk wrote: > > > I do agree with Francois regarding this issue: > > > > AFAIR, there has been not one 2.6 kernel where this driver was available > > for SMP kernels. > > Eh... That

Re: linux networking manpages

2005-07-24 Thread Andi Kleen
On Sat, Jul 23, 2005 at 08:11:59PM -0400, Harald Welte wrote: > Hi Dave & Andi! > > Since we're introducing some changes to the network stack > (SO_RCVBUFFORCE, ...), I would like to update the respective man pages. > > I think Andi wrote most of the current ones, but said they're > unmaintained

linux networking manpages

2005-07-24 Thread Harald Welte
Hi Dave & Andi! Since we're introducing some changes to the network stack (SO_RCVBUFFORCE, ...), I would like to update the respective man pages. I think Andi wrote most of the current ones, but said they're unmaintained by now. If this is still the case, can someone please send me the latest ve

Re: [PATCH RFC]: PHY Abstraction Layer III

2005-07-24 Thread Kumar Gala
Because the patch is all new code. drivers/net/phy/phy.c doesn't exist in any kernel tree. The patch is adding it. - kumar On Jul 23, 2005, at 4:59 PM, Francois Romieu wrote: Andy Fleming <[EMAIL PROTECTED]> : Here's the latest version of the patch, done against a cogito linux-2.6 branch

[PATCH] ieee80211 branch: ipw2100 open fix

2005-07-24 Thread Imre Deak
I had a problem where doing an open after a close left the device unusable. netif_carrier_on should be called whenever we go to the associated state, but this is not so in case of a close->open sequence. The following fixes this: diff --git a/drivers/net/wireless/ipw2100.c b/drivers/net/wireless/i