Need help

2000-01-11 Thread Houman Nazarnia
Hi, I have installed openssl-0.9.4 on my linux machine. I need to generate the ssl certification request to setup with verisign. I have tryied ./openssl req and I get Using configuration from /apps/openssl-0.9.4/ssl/openssl.cnf I don't get any answers after that! could you please tell me

Problem with RSA routines

2000-01-11 Thread Simon Edwards
Hi, I was wondering if somebody could help me or point me to the right place the get help. I'm having problems using the RSA routines from openssl 0.9.4. I've got a very simple C program which generates and RSA key (I'm not worried about the randomness of the key at this stage) and then

Re: Windows NT installation

2000-01-11 Thread Yuriy Stul
Title: Windows NT installation Hello Alex, try to do next: In Visual Studio open Tools/Options and choose Directories property. Add path G:\OpenSSL-0.9.4\inc32 (in my settings it is first line!) In source I use include like next: #include openssl/pem RegardsYuriy Stulmailto:[EMAIL

Re: Function naming convention.

2000-01-11 Thread Goetz Babin-Ebell
At 08:00 11.01.00 +0200, Arne Ansper wrote: So any preferences or alternative suggestions? peek for iget and copy for rget peek is OK. copy is bad, suggesting you get a independent copy you can modify. link(ed) ? By Goetz -- Goetz Babin-Ebell, TC TrustCenter GmbH,

Re: Function naming convention.

2000-01-11 Thread Dj Browne
On Tue, 11 Jan 2000, Richard Levitte - VMS Whacker wrote: [edit] - -Otherwise, I must say that I personally would like things to Become -Right rather than keeping Bug Compatibility, if one has to choose. So -I'd choose to put correctly updated and used reference counters -everywhere (or at

Re: Function naming convention.

2000-01-11 Thread Jeffrey Altman
On Tue, 11 Jan 2000, Richard Levitte - VMS Whacker wrote: [edit] - -Otherwise, I must say that I personally would like things to Become -Right rather than keeping Bug Compatibility, if one has to choose. So -I'd choose to put correctly updated and used reference counters -everywhere

Re: Function naming convention.

2000-01-11 Thread Dr Stephen Henson
Dj Browne wrote: On Tue, 11 Jan 2000, Richard Levitte - VMS Whacker wrote: [edit] - -Otherwise, I must say that I personally would like things to Become -Right rather than keeping Bug Compatibility, if one has to choose. So -I'd choose to put correctly updated and used reference

Re: Function naming convention.

2000-01-11 Thread Jeffrey Altman
The problem here is what is right? Its not that clear cut. If we decide that all the get/set/add functions should up reference counts then you have to add reference counts to all manner of things or Malloc() copies. Any code that relies on the old behaviour will end up leaking memory

Re: Function naming convention.

2000-01-11 Thread Dr Stephen Henson
Jeffrey Altman wrote: So in other words you plan to implement two versions of every single function? And then leave it up to the caller to determine what the behavior should be? This is going to be a nightmare. I'm not sure what you mean by that. What we could have is one "official"

Re: Function naming convention.

2000-01-11 Thread Bodo Moeller
So any preferences or alternative suggestions? peek for iget and copy for rget I like the peek thing, but "copy" is not a perfect choice of words: [...] Also note that we need a convention not just for "get" functions, there are also "set" functions. SSL_CTX_set_tmp_dh and

Re: Problem with RSA routines

2000-01-11 Thread Bodo Moeller
Simon Edwards [EMAIL PROTECTED]: I'm having problems using the RSA routines from openssl 0.9.4. I've got a very simple C program which generates and RSA key (I'm not worried about the randomness of the key at this stage) and then proceeds to read data from a file encrypting the data and

Re: Function naming convention.

2000-01-11 Thread Bodo Moeller
Arne Ansper [EMAIL PROTECTED]: So any preferences or alternative suggestions? peek for iget and copy for rget I like the peek thing, but "copy" is not a perfect choice of words: There's a difference between really copying a structure on the one hand and just providing another pointer and a

Re: make fails

2000-01-11 Thread Andy Polyakov
I have Red Hat Linux 6.0 (kernel 2.2.5-15). ... cryptlib.c:59: stdio.h: No such file or directory I fail to understand why you mail openssl-bugs as it sounds like you can't compile any program at all. Please, make sure you have glibc-devel and kernel-headers rpm installed. Andy.

Re: Function naming convention.

2000-01-11 Thread Richard Levitte - VMS Whacker
jaltman I would rather you just break the code outright. Forget the separate jaltman names. If you need to provide a method for determining whether or not jaltman the returned value should be considered persistent then add a jaltman parameter to the function specification which will determine

Re: Function naming convention.

2000-01-11 Thread Dj Browne
[edit] - -Old code shouldn't be compiled with newer versions under the blind -assumption that nothing has changed (the behaviour has been changing in -lots of various subtle and other ways). Perhaps a version change is -required to keep people happy - its easy to see people getting stroppy

Re: Function naming convention.

2000-01-11 Thread Richard Levitte - VMS Whacker
From: Geoff Thorpe [EMAIL PROTECTED] geoff plenty of *_copy() functions to deal with that ('twould seem that a copy geoff ups the reference count on the new structure by definition so copy geoff functions needn't have any form of switch between "r" and/or "i"). I'm not sure if that parenthesis

Re: Function naming convention.

2000-01-11 Thread Richard Levitte - VMS Whacker
From: Geoff Thorpe [EMAIL PROTECTED] geoff On Tue, 11 Jan 2000, Richard Levitte - VMS Whacker wrote: geoff geoff From: Geoff Thorpe [EMAIL PROTECTED] geoff geoff geoff plenty of *_copy() functions to deal with that ('twould seem that a copy geoff geoff ups the reference count on the new

Re: cvs commit: openssl/doc/crypto RSA_blinding_on.pod RSA_check_key.pod RSA_generate_key.pod RSA_get_ex_new_index.pod RSA_new.pod RSA_padding_add_PKCS1_type_1.pod RSA_print.pod RSA_private_encrypt.pod RSA_public_encrypt.pod RSA_set_method.pod RSA_sign.pod RSA_sign_ASN1_OCTET_STRING.pod RSA_size.pod crypto.pod d2i_RSAPublicKey.pod rsa.pod

2000-01-11 Thread Dr Stephen Henson
Ulf Möller wrote: On Tue, Jan 11, 2000 at 11:25:44PM +, Dr Stephen Henson wrote: Erm do we really want one manpage per function call or pair of calls? I think it's more readable this way (just like there's not just one man page for fopen/fprintf/fclose/fseek etc). Of course when

Re: cvs commit: openssl/doc/crypto RSA_blinding_on.pod RSA_check_key.pod RSA_generate_key.pod RSA_get_ex_new_index.pod RSA_new.pod RSA_padding_add_PKCS1_type_1.pod RSA_print.pod RSA_private_encrypt.pod RSA_public_encrypt.pod RSA_set_method.pod RSA_sign.pod RSA_sign_ASN1_OCTET_STRING.pod RSA_size.pod crypto.pod d2i_RSAPublicKey.pod rsa.pod

2000-01-11 Thread Dr Stephen Henson
Dr Stephen Henson wrote: On a related issue IMHO we shouldn't document every function in the library. Certain ones should be "internal only" paricularly if they are of little use to the outside user or which users shouldn't be calling anyway. Which ones don't get documented is largely a

Re: cvs commit: openssl/doc/crypto RSA_blinding_on.pod RSA_check_key.pod RSA_generate_key.pod RSA_get_ex_new_index.pod RSA_new.pod RSA_padding_add_PKCS1_type_1.pod RSA_print.pod RSA_private_encrypt.pod RSA_public_encrypt.pod RSA_set_method.pod RSA_sign.pod RSA_sign_ASN1_OCTET_STRING.pod RSA_size.pod crypto.pod d2i_RSAPublicKey.pod rsa.pod

2000-01-11 Thread Jeffrey Altman
but I'd place RSA_padding_add_PKCS1_type_1() into this category. On reflection maybe not undocumented but at least with some note that it wont normally be used or may change or something like that. I would suggest that private functions that should not be called be prefaced by

RE: Function naming convention.

2000-01-11 Thread Ramsay, Ron
I agree. It's not as if developers HAVE to take the latest release. If 0.9.5 were a maintenance release (and 0.9.6, etc), then developers using the 0.9.X branch will not be disadvantaged. At the same time, I see real advantages to starting 1.0.0 with a new API. The functions could behave

Re: cvs commit: openssl/doc/crypto RSA_blinding_on.pod RSA_check_key.pod RSA_generate_key.pod RSA_get_ex_new_index.pod RSA_new.pod RSA_padding_add_PKCS1_type_1.pod RSA_print.pod RSA_private_encrypt.pod RSA_public_encrypt.pod RSA_set_method.pod RSA_sign.pod RSA_sign_ASN1_OCTET_STRING.pod RSA_size.pod crypto.pod d2i_RSAPublicKey.pod rsa.pod

2000-01-11 Thread Rich Salz
I would prefer to see a "reasonable" set of related functions put on a single page. Deciding what's reasonable, of course, is why you get the big salary. :) They can be hardlinked to have multiple names. Better versions of "man" special-case if the first line is ".so xxx" and will turn "man

Doubt about OPENSSL config file

2000-01-11 Thread Raul Gutierrez Rodriguez
HI: What is the meanig of field RANDFILE = $ENV::HOME/.rnd oid_file = $ENV::HOME/.oid in the openssl config file? If i have the OpenSSL on a MS NT 4 PC, what value can i assign to it? Slds Raul Gutierrez __ OpenSSL

Re: Doubt about OPENSSL config file

2000-01-11 Thread Richard Levitte - VMS Whacker
raulg What is the meanig of field raulg raulg RANDFILE = $ENV::HOME/.rnd raulg oid_file = $ENV::HOME/.oid raulg raulg in the openssl config file? raulg raulg If i have the OpenSSL on a MS NT 4 PC, what value can i assign to it? If you make sure that each user has a HOME environment