[Puppet-dev] [PATCH/puppet 3/4] (#2128) Get facts before retrieving catalog

2011-06-06 Thread Nick Lewis
Retrieving a catalog and getting the facts to submit with the catalog request are distinct operations, and should be done separately. This is also to prepare for adding the ability to determine the node name based on a fact, in which case the node name needs to be determined before it is used for e

[Puppet-dev] [PATCH/puppet 4/4] (#2128) Add support for setting node name based on a fact

2011-06-06 Thread Nick Lewis
This adds the node_name_fact setting, which specifies a fact to use to determine the node name. This allows dynamically determining the node name without having to modify puppet.conf or command line options. Using this setting requires modifying auth.conf to allow nodes to request catalogs not mat

[Puppet-dev] [PATCH/puppet 2/4] (#2128) Add the ability to specify a node name

2011-06-06 Thread Nick Lewis
The setting node_name_value may now be used for 'puppet apply' or 'puppet agent' to specify the name for the node. This will not affect the certificate used by the node, and the node will still be authenticated based on its certname. The default value for node_name_value is the certname. This is u

[Puppet-dev] [PATCH/puppet 1/4] maint: Refactor specs in preparation for making node name more flexible

2011-06-06 Thread Nick Lewis
These tests were stubbing when it was unnecessary, so replace much of it with actual objects and files. Paired-With: Jacob Helwig Signed-off-by: Nick Lewis --- spec/unit/application/apply_spec.rb | 95 ++--- spec/unit/configurer/fact_handler_spec.rb | 61 +-- spec/unit/configurer_spec

Re: [Puppet-dev] [PATCH/puppet 1/1] (#7788) Allow gem directories to be searched while autoloading

2011-06-06 Thread Nigel Kersten
On Mon, Jun 6, 2011 at 4:35 PM, R.I.Pienaar wrote: > > The ruby world wants gem extendible tools, I am not a huge fan but it is > convenient and it will make us look a bit less like a wart to a certain type > of hacker who might want to contribute so I thought going the gem route > while more wor

Re: [Puppet-dev] [PATCH/puppet 1/1] (#7788) Allow gem directories to be searched while autoloading

2011-06-06 Thread R.I.Pienaar
On 7 Jun 2011, at 00:27, Daniel Pittman wrote: > On Mon, Jun 6, 2011 at 16:24, R.I.Pienaar wrote: >> On 7 Jun 2011, at 00:12, Daniel Pittman wrote: >>> On Mon, Jun 6, 2011 at 15:43, Daniel Pittman wrote: On Mon, Jun 6, 2011 at 13:57, R.I.Pienaar wrote: > >>> We have a cluster of other

Re: [Puppet-dev] [PATCH/puppet 1/1] (#7788) Allow gem directories to be searched while autoloading

2011-06-06 Thread James Turnbull
Daniel Pittman wrote: > One, we are concerned that there might be cases where this adds the > gem path, but not everything on the Ruby $LOAD_PATH, to the locations > our autoloader (or one of the other open-coded implementations of the > same) hunt for things on disk. That should be easy enough to

Re: [Puppet-dev] [PATCH/puppet 1/1] (#7788) Allow gem directories to be searched while autoloading

2011-06-06 Thread Daniel Pittman
On Mon, Jun 6, 2011 at 16:24, R.I.Pienaar wrote: > On 7 Jun 2011, at 00:12, Daniel Pittman wrote: >> On Mon, Jun 6, 2011 at 15:43, Daniel Pittman wrote: >>> On Mon, Jun 6, 2011 at 13:57, R.I.Pienaar wrote: >> We have a cluster of other issues in the area, though: we need to be >> able to plugi

Re: [Puppet-dev] [PATCH/puppet 1/1] (#7788) Allow gem directories to be searched while autoloading

2011-06-06 Thread R.I.Pienaar
On 7 Jun 2011, at 00:12, Daniel Pittman wrote: > On Mon, Jun 6, 2011 at 15:43, Daniel Pittman wrote: >> On Mon, Jun 6, 2011 at 13:57, R.I.Pienaar wrote: >> So, add that comment and I am happy to see this go in. Throw my reviewed-by on the change and you can go ahead and merge it in

Re: [Puppet-dev] [PATCH/puppet 1/1] (#7788) Allow gem directories to be searched while autoloading

2011-06-06 Thread R.I.Pienaar
On 7 Jun 2011, at 00:12, Daniel Pittman wrote: > On Mon, Jun 6, 2011 at 15:43, Daniel Pittman wrote: >> On Mon, Jun 6, 2011 at 13:57, R.I.Pienaar wrote: >> So, add that comment and I am happy to see this go in. Throw my reviewed-by on the change and you can go ahead and merge it i

Re: [Puppet-dev] [PATCH/puppet 1/1] (#7788) Allow gem directories to be searched while autoloading

2011-06-06 Thread Daniel Pittman
On Mon, Jun 6, 2011 at 15:43, Daniel Pittman wrote: > On Mon, Jun 6, 2011 at 13:57, R.I.Pienaar wrote: > >>> So, add that comment and I am happy to see this go in.  Throw my >>> reviewed-by on the change and you can go ahead and merge it into >>> master.  (I think you have the commit rights alrea

Re: [Puppet-dev] [PATCH/puppet 4/5] Fix apparent bug in URI::FTP merge method

2011-06-06 Thread Jacob Helwig
This definitely looks like a bug in URI::FTP, but rather than monkey-patching URI::FTP (which really should go under ./lib/puppet/util/monkey_patches.rb, so all of the monkey-patching is in the same place) it looks like we could just use the + method instead of merge. It looks like it just Does Th

Re: [Puppet-dev] [PATCH/puppet 1/5] Rewrite freebsd package provider

2011-06-06 Thread Jacob Helwig
So, I've got a couple of comments on this patch series. It really looks like all of this should be one commit, except for moving "defaultfor :operatingsystem => :freebsd" from ports.rb to freebsd.rb (which should be in its own commit). Not a killer, but would certainly make it easier to review si

Re: [Puppet-dev] [PATCH/puppet 1/1] (#7788) Allow gem directories to be searched while autoloading

2011-06-06 Thread Daniel Pittman
On Mon, Jun 6, 2011 at 13:57, R.I.Pienaar wrote: >> So, add that comment and I am happy to see this go in.  Throw my >> reviewed-by on the change and you can go ahead and merge it into >> master.  (I think you have the commit rights already, but if not I >> will chase Zach to get them for you.) >

[Puppet-dev] Re: Should we move "generate" off the certificate face?

2011-06-06 Thread Nick Fagerlund
On Jun 3, 5:52 pm, Daniel Pittman wrote: > I think we should build an entirely new Face for interacting with the > certificate subsystem, which is a higher level abstraction over the > concepts that the user is going to be familiar with.  Something more > akin to the "legacy" application than the

Re: [Puppet-dev] [PATCH/puppet 1/1] (#7788) Allow gem directories to be searched while autoloading

2011-06-06 Thread R.I.Pienaar
- Original Message - > > So, add that comment and I am happy to see this go in. Throw my > reviewed-by on the change and you can go ahead and merge it into > master. (I think you have the commit rights already, but if not I > will chase Zach to get them for you.) > > Thanks for writin

[Puppet-dev] [PATCH/puppet 1/1] (#7632) Make secret_agent application compatible with secret_agent face

2011-06-06 Thread nfagerlund
Running `puppet secret_agent` was failing with an error in validate_args (in interface/action.rb), because the application was trying to pass the certname as an argument to the synchronize action. Also, it was trying to submit the report a second time. Reviewing the code with Nick0, we found tha

Re: [Puppet-dev] [PATCH/puppet 1/1] (#7788) Allow gem directories to be searched while autoloading

2011-06-06 Thread Daniel Pittman
On Mon, Jun 6, 2011 at 12:25, R.I.Pienaar wrote: > - Original Message - >> > >> > diff --git a/lib/puppet/configurer.rb b/lib/puppet/configurer.rb >> > index cfeb73a..00c3b18 100644 >> > --- a/lib/puppet/configurer.rb >> > +++ b/lib/puppet/configurer.rb >> > @@ -156,9 +156,10 @@ class Pupp

Re: [Puppet-dev] [PATCH/puppet 1/1] (#7788) Allow gem directories to be searched while autoloading

2011-06-06 Thread markus
> > - # The list of directories to search through for loadable plugins. > > + # features uses the autoloader which causes a loop so avoid trying to > > + # ask Gem for its path during feature loading. > > + # > > + # We're using a per-thread cache based on the code in > > #module_directories

Re: [Puppet-dev] [PATCH/puppet 1/1] (#7788) Allow gem directories to be searched while autoloading

2011-06-06 Thread R.I.Pienaar
- Original Message - > > > > diff --git a/lib/puppet/configurer.rb b/lib/puppet/configurer.rb > > index cfeb73a..00c3b18 100644 > > --- a/lib/puppet/configurer.rb > > +++ b/lib/puppet/configurer.rb > > @@ -156,9 +156,10 @@ class Puppet::Configurer > >       return > >     end > >   ensure

Re: [Puppet-dev] [PATCH/facter 1/2] (#7038) Added utility module for prtdiag

2011-06-06 Thread Jacob Helwig
On Mon, 06 Jun 2011 11:00:32 -0700, Jacob Helwig wrote: > > Adrien, > > The updated manufacturer_spec.rb looks good, but there should be some > testing around the new utility module. We should really have some tests > that show that it's returning the "System Configuration" line from that > outp

Re: [Puppet-dev] [PATCH/puppet 1/1] (#7788) Allow gem directories to be searched while autoloading

2011-06-06 Thread Daniel Pittman
On Sun, Jun 5, 2011 at 01:12, R.I.Pienaar wrote: Hey, cool code. I have some questions that really deserve answers in the code, though, since I don't want to count on remembering the "why" in six months time: > This allows rubygems to be used to extend or override puppet behavior. > > Unfortuna

Re: [Puppet-dev] [PATCH/facter 1/2] (#7038) Added utility module for prtdiag

2011-06-06 Thread Jacob Helwig
Adrien, The updated manufacturer_spec.rb looks good, but there should be some testing around the new utility module. We should really have some tests that show that it's returning the "System Configuration" line from that output (and only that line), and that it doesn't return anything if that li

Re: [Puppet-dev] Should we move "generate" off the certificate face?

2011-06-06 Thread Daniel Pittman
On Sun, Jun 5, 2011 at 22:05, Luke Kanies wrote: > On Jun 3, 2011, at 5:52 PM, Daniel Pittman wrote: >> On Fri, Jun 3, 2011 at 16:18, Nick Fagerlund >> wrote: >>> (For reference: https://projects.puppetlabs.com/issues/7783) >>> >>> In 2.7, we have both a "cert" application and a new "certificate"