Re: [Qemu-devel] [PATCH 17/19] qtest/ahci: Add a macro bootup routine

2015-02-03 Thread Paolo Bonzini
On 02/02/2015 22:12, John Snow wrote: It comes in handy later for testing migration so I don't have to do a lot of boilerplate for each instance, though it is just a convenience subroutine with no logic of its own. I like to cut down on boilerplate as much as possible to expose the

Re: [Qemu-devel] [PATCH 17/19] qtest/ahci: Add a macro bootup routine

2015-02-02 Thread John Snow
On 02/02/2015 05:37 AM, Paolo Bonzini wrote: On 30/01/2015 19:42, John Snow wrote: +/** + * Boot and fully enable the HBA device. + * @see ahci_boot, ahci_pci_enable and ahci_hba_enable. + */ +static AHCIQState *ahci_macro_bootup(void) Ugly name... I would just leave out this patch.

Re: [Qemu-devel] [PATCH 17/19] qtest/ahci: Add a macro bootup routine

2015-02-02 Thread Paolo Bonzini
On 30/01/2015 19:42, John Snow wrote: +/** + * Boot and fully enable the HBA device. + * @see ahci_boot, ahci_pci_enable and ahci_hba_enable. + */ +static AHCIQState *ahci_macro_bootup(void) Ugly name... I would just leave out this patch. Paolo +{ +AHCIQState *ahci; +ahci =

[Qemu-devel] [PATCH 17/19] qtest/ahci: Add a macro bootup routine

2015-01-30 Thread John Snow
Add a routine that can be used to engage the AHCI device at a not-granular level so that bringing up the functionality of the HBA is easy in future tests that are not concerned with testing the bring-up process. Signed-off-by: John Snow js...@redhat.com --- tests/ahci-test.c | 19