Re: Review Request 56152: Implemented the 'fetchManifest()' method of prefix puller.

2017-04-03 Thread Qian Zhang
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/56152/ --- (Updated April 4, 2017, 11:07 a.m.) Review request for mesos, Gilbert Song and

Re: Review Request 57818: Added unit tests to verify offers are suppressed based on registration.

2017-04-03 Thread Mesos Reviewbot
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/57818/#review170952 --- Patch looks great! Reviews applied: [57815, 57816, 57817, 57818]

Re: Review Request 58126: Windows: Stout: Reimplemented `stringify_args`.

2017-04-03 Thread Joseph Wu
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58126/#review170947 --- Ship it! I dislike the fact we need to do this sort of

Re: Review Request 57974: Windows: Replaced WindowsLauncher with SubprocessLauncher.

2017-04-03 Thread Joseph Wu
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/57974/#review170929 --- Ship it! LGTM. I can fix the below before committing.

Re: Review Request 57975: Windows: Use Subprocess in default executor.

2017-04-03 Thread Joseph Wu
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/57975/#review170930 --- Ship it! Important thing to note, this changes the "command

Re: Review Request 57976: Refactored default executor for `launchTaskSubprocess`.

2017-04-03 Thread Joseph Wu
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/57976/#review170938 --- Ship it! src/launcher/executor.cpp Lines 201-203 (patched)

Re: Review Request 57973: Windows: Added `JobObjectManager` actor.

2017-04-03 Thread Joseph Wu
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/57973/#review170916 --- Ship it! LGTM. I can fix the below before committing.

Re: Review Request 58161: Fixed HealthyTaskNonShell test on Windows.

2017-04-03 Thread Andrew Schwartzmeyer
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58161/ --- (Updated April 3, 2017, 11:35 p.m.) Review request for mesos, Jeff Coffler,

Re: Review Request 58161: Fixed HealthyTaskNonShell test on Windows.

2017-04-03 Thread Mesos Reviewbot
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58161/#review170944 --- Patch looks great! Reviews applied: [56364, 56367, 57973, 57974,

Re: Review Request 56367: Windows: Stout: Adapted `os::killtree` to terminate job objects.

2017-04-03 Thread Andrew Schwartzmeyer
> On April 3, 2017, 10:20 p.m., Joseph Wu wrote: > > 3rdparty/stout/include/stout/os/windows/killtree.hpp > > Lines 54 (patched) > > > > > > s/it/return type/ Thanks! - Andrew

Re: Review Request 57818: Added unit tests to verify offers are suppressed based on registration.

2017-04-03 Thread Anindya Sinha
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/57818/ --- (Updated April 3, 2017, 10:35 p.m.) Review request for mesos, James Peach,

Re: Review Request 57817: Suppress offers for frameworks on registration.

2017-04-03 Thread Anindya Sinha
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/57817/ --- (Updated April 3, 2017, 10:35 p.m.) Review request for mesos, James Peach,

Re: Review Request 57816: Add a scheduler flag `offers_suppressed_on_register`.

2017-04-03 Thread Anindya Sinha
> On March 31, 2017, 8:47 p.m., James Peach wrote: > > src/sched/flags.hpp > > Lines 127 (patched) > > > > > > Recommend you rename this to `subscribe_suppressed` or something > > similar. The flag is for

Re: Review Request 57816: Add a scheduler flag `offers_suppressed_on_register`.

2017-04-03 Thread Anindya Sinha
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/57816/ --- (Updated April 3, 2017, 10:34 p.m.) Review request for mesos, James Peach,

Re: Review Request 56367: Windows: Stout: Adapted `os::killtree` to terminate job objects.

2017-04-03 Thread Joseph Wu
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/56367/#review170915 --- Ship it! LGTM. I can fix the below before committing.

Review Request 58161: Fixed HealthyTaskNonShell test on Windows.

2017-04-03 Thread Andrew Schwartzmeyer
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58161/ --- Review request for mesos, Jeff Coffler, John Kordich, Joseph Wu, Li Li, and

Review Request 58160: Stout: Removed `TRUE_COMMAND`.

2017-04-03 Thread Andrew Schwartzmeyer
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58160/ --- Review request for mesos, Jeff Coffler, John Kordich, Joseph Wu, Li Li, and

Re: Review Request 58133: Added resource provider API protobuf template.

2017-04-03 Thread Vinod Kone
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58133/#review170917 --- Ship it! Ship It! - Vinod Kone On April 2, 2017, 11:59

Re: Review Request 58040: Avoid various redundant copies.

2017-04-03 Thread Benjamin Bannier
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58040/#review170913 --- Ship it! Let's get these in as they are strictly improvements.

Re: Review Request 58043: Cleaned up usage of namespace-qualified identifiers.

2017-04-03 Thread Benjamin Bannier
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58043/#review170912 --- Ship it! Let's get these in as they are strictly improvements.

Re: Review Request 58084: Adjust `using` style in a few places.

2017-04-03 Thread Benjamin Bannier
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58084/#review170910 --- Ship it! Let's get these in as they are strictly improvements.

Re: Review Request 58128: Windows: Updated use of UTF-16 `getSystemEnvironment`.

2017-04-03 Thread Andrew Schwartzmeyer
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58128/ --- (Updated April 3, 2017, 5:54 p.m.) Review request for mesos, Jeff Coffler,

Re: Review Request 58128: Windows: Updated use of UTF-16 `getSystemEnvironment`.

2017-04-03 Thread Andrew Schwartzmeyer
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58128/ --- (Updated April 3, 2017, 5:35 p.m.) Review request for mesos, Jeff Coffler,

Re: Review Request 58043: Cleaned up usage of namespace-qualified identifiers.

2017-04-03 Thread Neil Conway
> On April 3, 2017, 9:07 a.m., Benjamin Bannier wrote: > > This patch needs a rebase. Done. - Neil --- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58043/#review170829

Re: Review Request 58043: Cleaned up usage of namespace-qualified identifiers.

2017-04-03 Thread Neil Conway
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58043/ --- (Updated April 3, 2017, 5:26 p.m.) Review request for mesos and Benjamin

Re: Review Request 57816: Add a scheduler flag `offers_suppressed`.

2017-04-03 Thread James Peach
> On March 31, 2017, 8:47 p.m., James Peach wrote: > > src/sched/flags.hpp > > Lines 127 (patched) > > > > > > Recommend you rename this to `subscribe_suppressed` or something > > similar. The flag is for

Re: Review Request 58125: Stout: Added stringify for std::wstring.

2017-04-03 Thread Andrew Schwartzmeyer
> On April 1, 2017, 12:01 a.m., Jeff Coffler wrote: > > 3rdparty/stout/include/stout/stringify.hpp > > Lines 42 (patched) > > > > > > We've learned, from other projects, that converting from string to/from > >

Re: Review Request 57816: Add a scheduler flag `offers_suppressed`.

2017-04-03 Thread Anindya Sinha
> On March 31, 2017, 8:47 p.m., James Peach wrote: > > src/sched/flags.hpp > > Lines 127 (patched) > > > > > > Recommend you rename this to `subscribe_suppressed` or something > > similar. The flag is for

Re: Review Request 58150: Removed an old comment from 'v1/mesos.proto'.

2017-04-03 Thread Mesos Reviewbot
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58150/#review170886 --- Patch looks great! Reviews applied: [58150] Passed command:

Re: Review Request 58150: Removed an old comment from 'v1/mesos.proto'.

2017-04-03 Thread Neil Conway
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58150/#review170881 --- Ship it! Ship It! - Neil Conway On April 3, 2017, 3:05

Review Request 58150: Removed an old comment from 'v1/mesos.proto'.

2017-04-03 Thread Greg Mann
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58150/ --- Review request for mesos and Neil Conway. Repository: mesos Description

Re: Review Request 58071: Updated test helpers to support changed disk types.

2017-04-03 Thread Benjamin Bannier
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58071/#review170845 --- src/tests/mesos.hpp Line 1166 (original), 1194-1205 (patched)

Re: Review Request 58146: Added infrastructure for unit tests in the new python-based CLI.

2017-04-03 Thread Mesos Reviewbot
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58146/#review170871 --- Patch looks great! Reviews applied: [58146] Passed command:

Review Request 58146: Added infrastructure for unit tests in the new python-based CLI.

2017-04-03 Thread Armand Grillet
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58146/ --- Review request for mesos and Kevin Klues. Bugs: MESOS-6032

Re: Review Request 58071: Updated test helpers to support changed disk types.

2017-04-03 Thread Jan Schlicht
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58071/ --- (Updated April 3, 2017, 1:36 p.m.) Review request for mesos, Benjamin Bannier

Re: Review Request 58137: Added `mesos config show` command to display the config file.

2017-04-03 Thread Mesos Reviewbot
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58137/#review170849 --- Patch looks great! Reviews applied: [57896, 57951, 57952, 58137]

Re: Review Request 58071: Updated test helpers to support changed disk types.

2017-04-03 Thread Jan Schlicht
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58071/ --- (Updated April 3, 2017, 12:26 p.m.) Review request for mesos, Benjamin Bannier

Re: Review Request 58021: Added storage-related offer operations.

2017-04-03 Thread Jan Schlicht
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58021/ --- (Updated April 3, 2017, 12:25 p.m.) Review request for mesos, Benjamin Bannier

Re: Review Request 58136: Cleaned up pattern matching in Resource operator==.

2017-04-03 Thread Mesos Reviewbot
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58136/#review170843 --- Patch looks great! Reviews applied: [58136] Passed command:

Re: Review Request 57999: Made Path and Mount root optional in Resource.DiskInfo.Source.

2017-04-03 Thread Jan Schlicht
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/57999/#review170840 --- Ship it! Ship It! - Jan Schlicht On April 3, 2017, 11:31

Re: Review Request 57999: Made Path and Mount root optional in Resource.DiskInfo.Source.

2017-04-03 Thread Benjamin Bannier
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/57999/ --- (Updated April 3, 2017, 11:31 a.m.) Review request for mesos, Jie Yu and Jan

Re: Review Request 58048: Added id to Resource.DiskInfo.

2017-04-03 Thread Jan Schlicht
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58048/#review170832 --- Fix it, then Ship it! src/tests/mesos.hpp Line 1356

Re: Review Request 57999: Made Path and Mount root optional in Resource.DiskInfo.Source.

2017-04-03 Thread Jan Schlicht
> On April 3, 2017, 10:58 a.m., Jan Schlicht wrote: > > src/common/resources.cpp > > Lines 119 (patched) > > > > > > RHS also needs to be checked for `root`. > > `left.has_root() && right.has_root() &&

Re: Review Request 57999: Made Path and Mount root optional in Resource.DiskInfo.Source.

2017-04-03 Thread Benjamin Bannier
> On March 30, 2017, 3:02 p.m., Jan Schlicht wrote: > > There's also some validation in `resources.cpp` (`validate` in line 739) > > that needs to be updated to support missing paths. Good point. Fixed in both v0 and v1 now. - Benjamin

Re: Review Request 58047: Introduce BLOCK and RAW disk types.

2017-04-03 Thread Jan Schlicht
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58047/#review170836 --- Ship it! Ship It! - Jan Schlicht On April 3, 2017, 9:55

Re: Review Request 58043: Cleanup usage of namespace-qualified identifiers.

2017-04-03 Thread Benjamin Bannier
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58043/#review170829 --- This patch needs a rebase. - Benjamin Bannier On March 29,

Re: Review Request 58043: Cleanup usage of namespace-qualified identifiers.

2017-04-03 Thread Benjamin Bannier
> On March 30, 2017, 10:36 a.m., Benjamin Bannier wrote: > > src/checks/checker.cpp > > Line 1 (original), 1 (patched) > > > > > > Since you focus on `std::string` and `testing::WithParamInterface` in > > this patch,

Re: Review Request 58040: Avoid various redundant copies.

2017-04-03 Thread Benjamin Bannier
> On March 30, 2017, 10:36 a.m., Benjamin Bannier wrote: > > The changes here look good to me, but running > > > > % CHECKS='-*,performance-unnecessary-copy-initialization' > > ./support/mesos-tidy.sh > > > > still emits a lot of unneeded copy warnings. Could you have a look what > >

Re: Review Request 58084: Adjust `using` style in a few places.

2017-04-03 Thread Benjamin Bannier
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58084/#review170831 --- See my comment at https://reviews.apache.org/r/58043/. -

Re: Review Request 57999: Made Path and Mount root optional in Resource.DiskInfo.Source.

2017-04-03 Thread Jan Schlicht
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/57999/#review170827 --- src/common/resources.cpp Lines 119 (patched)

Re: Review Request 58021: Added storage-related offer operations.

2017-04-03 Thread Jan Schlicht
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58021/ --- (Updated April 3, 2017, 10:41 a.m.) Review request for mesos, Benjamin Bannier

Re: Review Request 58021: Added storage-related offer operations.

2017-04-03 Thread Jan Schlicht
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58021/ --- (Updated April 3, 2017, 10:41 a.m.) Review request for mesos, Benjamin Bannier

Re: Review Request 57998: Added ResourceProviderID to Resource protos.

2017-04-03 Thread Jan Schlicht
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/57998/#review170826 --- Ship it! Ship It! - Jan Schlicht On March 31, 2017, 11:38

Review Request 58137: Added `mesos config show` command to display the config file.

2017-04-03 Thread Armand Grillet
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58137/ --- Review request for mesos and Kevin Klues. Repository: mesos Description

Review Request 58136: Cleaned up pattern matching in Resource operator==.

2017-04-03 Thread Benjamin Bannier
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58136/ --- Review request for mesos and Jie Yu. Repository: mesos Description ---

Re: Review Request 58047: Introduce BLOCK and RAW disk types.

2017-04-03 Thread Benjamin Bannier
> On March 30, 2017, 11:32 a.m., Jan Schlicht wrote: > > include/mesos/v1/mesos.proto > > Lines 1017-1018 (original), 1018-1019 (patched) > > > > > > Do we also need similar `Block` and `Raw` types/fields here?

Re: Review Request 58047: Introduce BLOCK and RAW disk types.

2017-04-03 Thread Benjamin Bannier
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/58047/ --- (Updated April 3, 2017, 9:55 a.m.) Review request for mesos, Jie Yu and Jan