Re: RFR: 8331557: Serial: Refactor SerialHeap::do_collection [v7]

2024-05-17 Thread Albert Mingkun Yang
On Fri, 17 May 2024 07:44:29 GMT, Albert Mingkun Yang wrote: >> It's probably easier to read the new code directly. The two classes in >> `serialVMOperations` serve as entrance points to invoke young/full GCs. Some >> previously hidden decisions are made more obvious, e.g. if a young-gc fails

Re: RFR: 8331557: Serial: Refactor SerialHeap::do_collection [v7]

2024-05-17 Thread Ivan Walulya
On Fri, 17 May 2024 07:44:29 GMT, Albert Mingkun Yang wrote: >> It's probably easier to read the new code directly. The two classes in >> `serialVMOperations` serve as entrance points to invoke young/full GCs. Some >> previously hidden decisions are made more obvious, e.g. if a young-gc fails

Re: RFR: 8331557: Serial: Refactor SerialHeap::do_collection [v6]

2024-05-17 Thread Ivan Walulya
On Fri, 17 May 2024 07:39:39 GMT, Albert Mingkun Yang wrote: >> I prefer that to the "no_gc_locker" emphasizing names > > I can do that for `try_collect_at_safepoint`, but > `SerialHeap::do_full_collection` is an API from `CollectedHeap`. yeah, i only meant change those that are not "override"

Re: RFR: 8331557: Serial: Refactor SerialHeap::do_collection [v7]

2024-05-17 Thread Albert Mingkun Yang
> It's probably easier to read the new code directly. The two classes in > `serialVMOperations` serve as entrance points to invoke young/full GCs. Some > previously hidden decisions are made more obvious, e.g. if a young-gc fails > (or will probablly fail), fallback to full-gc. > >

Re: RFR: 8331557: Serial: Refactor SerialHeap::do_collection [v6]

2024-05-17 Thread Albert Mingkun Yang
On Fri, 17 May 2024 07:22:36 GMT, Ivan Walulya wrote: >> How about calling them `try_x` and `x` for the public and private API, >> respectively, e.g. `try_do_full_collection` and `do_full_collection`? > > I prefer that to the "no_gc_locker" emphasizing names I can do that for

Re: RFR: 8331557: Serial: Refactor SerialHeap::do_collection [v6]

2024-05-17 Thread Ivan Walulya
On Fri, 17 May 2024 07:17:13 GMT, Albert Mingkun Yang wrote: >> src/hotspot/share/gc/serial/serialHeap.cpp line 907: >> >>> 905: >>> 906: void SerialHeap::print_tracing_info() const { >>> 907: // Nothing >> >> What is the `Nothing` supposed to convey here? > > To emphasize that this empty

Re: RFR: 8331557: Serial: Refactor SerialHeap::do_collection [v6]

2024-05-17 Thread Albert Mingkun Yang
On Fri, 17 May 2024 06:02:31 GMT, Ivan Walulya wrote: >> Albert Mingkun Yang has updated the pull request with a new target base due >> to a merge or a rebase. The pull request now contains seven commits: >> >> - Merge branch 'master' into s1-do-collect >> - review >> - Merge branch

Re: RFR: 8331557: Serial: Refactor SerialHeap::do_collection [v6]

2024-05-17 Thread Ivan Walulya
On Fri, 10 May 2024 08:55:36 GMT, Albert Mingkun Yang wrote: >> It's probably easier to read the new code directly. The two classes in >> `serialVMOperations` serve as entrance points to invoke young/full GCs. Some >> previously hidden decisions are made more obvious, e.g. if a young-gc fails

Re: RFR: 8331557: Serial: Refactor SerialHeap::do_collection [v6]

2024-05-10 Thread Albert Mingkun Yang
> It's probably easier to read the new code directly. The two classes in > `serialVMOperations` serve as entrance points to invoke young/full GCs. Some > previously hidden decisions are made more obvious, e.g. if a young-gc fails > (or will probablly fail), fallback to full-gc. > >

Re: RFR: 8331557: Serial: Refactor SerialHeap::do_collection [v5]

2024-05-10 Thread Guoxiong Li
On Wed, 8 May 2024 10:04:15 GMT, Albert Mingkun Yang wrote: >> It's probably easier to read the new code directly. The two classes in >> `serialVMOperations` serve as entrance points to invoke young/full GCs. Some >> previously hidden decisions are made more obvious, e.g. if a young-gc fails

Re: RFR: 8331557: Serial: Refactor SerialHeap::do_collection [v5]

2024-05-08 Thread Albert Mingkun Yang
> It's probably easier to read the new code directly. The two classes in > `serialVMOperations` serve as entrance points to invoke young/full GCs. Some > previously hidden decisions are made more obvious, e.g. if a young-gc fails > (or will probablly fail), fallback to full-gc. > >

Re: RFR: 8331557: Serial: Refactor SerialHeap::do_collection [v2]

2024-05-06 Thread Guoxiong Li
On Mon, 6 May 2024 09:12:47 GMT, Albert Mingkun Yang wrote: >> src/hotspot/share/gc/serial/serialHeap.cpp line 461: >> >>> 459: if (should_verify && VerifyBeforeGC) { >>> 460: prepare_for_verify(); >>> 461: Universe::verify("Before GC"); >> >> May the prefix of the verification log

Re: RFR: 8331557: Serial: Refactor SerialHeap::do_collection [v4]

2024-05-06 Thread Albert Mingkun Yang
> It's probably easier to read the new code directly. The two classes in > `serialVMOperations` serve as entrance points to invoke young/full GCs. Some > previously hidden decisions are made more obvious, e.g. if a young-gc fails > (or will probablly fail), fallback to full-gc. > >

Re: RFR: 8331557: Serial: Refactor SerialHeap::do_collection [v3]

2024-05-06 Thread Albert Mingkun Yang
> It's probably easier to read the new code directly. The two classes in > `serialVMOperations` serve as entrance points to invoke young/full GCs. Some > previously hidden decisions are made more obvious, e.g. if a young-gc fails > (or will probablly fail), fallback to full-gc. > >

Re: RFR: 8331557: Serial: Refactor SerialHeap::do_collection [v2]

2024-05-06 Thread Albert Mingkun Yang
On Sat, 4 May 2024 02:39:38 GMT, Guoxiong Li wrote: >> Albert Mingkun Yang has updated the pull request with a new target base due >> to a merge or a rebase. The pull request now contains one commit: >> >> s1-do-collect > > src/hotspot/share/gc/serial/serialHeap.cpp line 461: > >> 459: if

Re: RFR: 8331557: Serial: Refactor SerialHeap::do_collection [v2]

2024-05-03 Thread Guoxiong Li
On Fri, 3 May 2024 12:49:03 GMT, Albert Mingkun Yang wrote: >> It's probably easier to read the new code directly. The two classes in >> `serialVMOperations` serve as entrance points to invoke young/full GCs. Some >> previously hidden decisions are made more obvious, e.g. if a young-gc fails

Re: RFR: 8331557: Serial: Refactor SerialHeap::do_collection [v2]

2024-05-03 Thread Albert Mingkun Yang
> It's probably easier to read the new code directly. The two classes in > `serialVMOperations` serve as entrance points to invoke young/full GCs. Some > previously hidden decisions are made more obvious, e.g. if a young-gc fails > (or will probablly fail), fallback to full-gc. > >

RFR: 8331557: Serial: Refactor SerialHeap::do_collection

2024-05-02 Thread Albert Mingkun Yang
It's probably easier to read the new code directly. The two classes in `serialVMOperations` serve as entrance points to invoke young/full GCs. Some previously hidden decisions are made more obvious, e.g. if a young-gc fails (or will probablly fail), fallback to full-gc. Additionally,