[SSSD] Using patchwork for tracking SSSD patch status

2012-10-31 Thread Simo Sorce
Hi all, a few days ago I installed patchwork and an instance is tracking the SSSD project here: https://patchwork.acksyn.org/project/SSSD/list/ Although patchwork is not a full cycle review system it seem to work really well for tacking patches and patchsets and their status. The only limitation

Re: [SSSD] [PATCH] sss_cache: Remove fastcache even if sssd is not running.

2012-10-31 Thread Simo Sorce
On Wed, 2012-10-31 at 12:43 +0100, Michal Židek wrote: > On 10/30/2012 02:25 PM, Simo Sorce wrote: > > On Tue, 2012-10-30 at 10:39 +0100, Michal Židek wrote: > >> On 10/29/2012 03:53 PM, Simo Sorce wrote: > >>> > >>> Codewise looks ok, but I still see duplication of the code used to lock > >>> the

[SSSD] [PATCH 1/4] Code can only check for cached passwords

2012-10-31 Thread Simo Sorce
Make it clear to the API users that we can not take arbitrary auth tokens. We can only take a password for now so simplify and clarify the interface. --- src/db/sysdb.h |3 +-- src/db/sysdb_ops.c | 12 +--- src/providers/krb5/krb5_auth.c | 23 +++

[SSSD] [PATCH 3/4] Add authtok utility functions.

2012-10-31 Thread Simo Sorce
These functions allow handling of auth tokens in a completely opaque way, with clear semantics and accessor fucntions that guarantee consistency, proper access to data and error conditions. --- Makefile.am|2 + src/util/authtok.c | 195 +

[SSSD] [PATCH 0/4] Create and use an auth token object

2012-10-31 Thread Simo Sorce
The current way we handle with auth token is manual and very error prone. The semanthics are also confusing and do not make clear how tokens are stored such that manipulating them is difficult. For example it was unclar in the code whether password tokens where 0 terminated and whether the length w

[SSSD] [PATCH 2/4] Add function to safely wipe memory.

2012-10-31 Thread Simo Sorce
This is useful for wiping passwords, as it prevents the compiler from optimizing out a memset to zero before a free() --- src/util/util.c |9 + src/util/util.h | 10 ++ 2 files changed, 19 insertions(+), 0 deletions(-) diff --git a/src/util/util.c b/src/util/util.c index b8

[SSSD] [PATCH 5/5] Use an entry type mask macro to filter entry types

2012-10-31 Thread Simo Sorce
Avoids hardcodinf magic numbers everywhere and selfdocuments why a mask is being applied. --- src/providers/data_provider.h |1 + src/providers/ipa/ipa_id.c|2 +- src/providers/ipa/ipa_subdomains_id.c |2 +- src/providers/ldap/ldap_id.c |2 +- src/provi

[SSSD] [PATCH 1/5] Fix tevent_req style for krb5_auth

2012-10-31 Thread Simo Sorce
No functionality changes, just make the code respect the tevent_req style and naming conventions and enhance readability by adding some helper functions. --- src/providers/krb5/krb5_access.c |6 +- src/providers/krb5/krb5_auth.c | 556 -- src/provider

[SSSD] [PATCH 3/5] Fix tevent_req style for get_netgroup in ipa_id

2012-10-31 Thread Simo Sorce
Also do not intermix two tevent_req sequences --- src/providers/ipa/ipa_id.c | 151 +--- 1 files changed, 71 insertions(+), 80 deletions(-) diff --git a/src/providers/ipa/ipa_id.c b/src/providers/ipa/ipa_id.c index f61236b965b77ca1058a14cb7e425ac2ff65723e

[SSSD] [PATCH 4/5] Streamline ipa_account_info handler

2012-10-31 Thread Simo Sorce
--- src/providers/ipa/ipa_id.c | 128 1 files changed, 69 insertions(+), 59 deletions(-) diff --git a/src/providers/ipa/ipa_id.c b/src/providers/ipa/ipa_id.c index ab0d8924013941943babb32a96f03560aea8c7f3..7afa6df6fbd841309d33866caf080be12eac170f 10

[SSSD] [PATCH 2/5] Fix ipa_subdomain_id names and tevent_req style

2012-10-31 Thread Simo Sorce
--- src/providers/ipa/ipa_id.c|5 +- src/providers/ipa/ipa_id.h| 10 ++-- src/providers/ipa/ipa_subdomains_id.c | 73 + 3 files changed, 36 insertions(+), 52 deletions(-) diff --git a/src/providers/ipa/ipa_id.c b/src/providers/ipa/ip

[SSSD] [PATCH 0/5] Fix various tevent_req style and naming issues

2012-10-31 Thread Simo Sorce
While I was working on an unrelated patchset I couldn't help fixing some of the code to properly use tevent_req style and naming conventions. This will bring this code in line with our tevent_req coding style and hopefully make it more readable to eyes used to the tevent_req style. It also fixes u

Re: [SSSD] [INI] Remove code that allows duplicate sections

2012-10-31 Thread Dmitri Pal
On 10/31/2012 08:35 AM, Ondrej Kos wrote: > On 10/18/2012 05:02 AM, Dmitri Pal wrote: >> Hello, >> >> After previous set of patches have been committed I started working on >> the last remaining piece - the merge functionality. >> >> Re-reading the code I started some time ago I realized that at th

Re: [SSSD] [PATCH 1/1] LDAP: Better debug logging when saving groups

2012-10-31 Thread Stephen Gallagher
On Wed 31 Oct 2012 02:16:02 PM EDT, Simo Sorce wrote: On Wed, 2012-10-31 at 13:18 -0400, Stephen Gallagher wrote: fail: -DEBUG(2, ("Failed to save group [%s]\n", - name ? name : "Unknown")); +DEBUG(SSSDBG_MINOR_FAILURE, + ("Failed to save group [%s]: [%s]\n", +

Re: [SSSD] [PATCH 1/1] LDAP: Better debug logging when saving groups

2012-10-31 Thread Simo Sorce
On Wed, 2012-10-31 at 14:36 -0400, Stephen Gallagher wrote: > On Wed 31 Oct 2012 02:16:02 PM EDT, Simo Sorce wrote: > > On Wed, 2012-10-31 at 13:18 -0400, Stephen Gallagher wrote: > >> fail: > >> -DEBUG(2, ("Failed to save group [%s]\n", > >> - name ? name : "Unknown")); > >> +

Re: [SSSD] [PATCH 1/1] LDAP: Better debug logging when saving groups

2012-10-31 Thread Simo Sorce
On Wed, 2012-10-31 at 13:18 -0400, Stephen Gallagher wrote: > fail: > -DEBUG(2, ("Failed to save group [%s]\n", > - name ? name : "Unknown")); > +DEBUG(SSSDBG_MINOR_FAILURE, > + ("Failed to save group [%s]: [%s]\n", > + name ? name : "Unknown", > +

Re: [SSSD] [PATCH] LDAP: Fix off-by-one error when saving ghost user

2012-10-31 Thread Simo Sorce
On Wed, 2012-10-31 at 18:30 +0100, Jakub Hrozek wrote: > https://fedorahosted.org/sssd/ticket/1612 ACK. Simo. -- Simo Sorce * Red Hat, Inc * New York ___ sssd-devel mailing list sssd-devel@lists.fedorahosted.org https://lists.fedorahosted.org/mailman

[SSSD] [PATCH] LDAP: Fix off-by-one error when saving ghost user

2012-10-31 Thread Jakub Hrozek
https://fedorahosted.org/sssd/ticket/1612 >From de3c880f4c59b24a5515f3ade0fedc49ebe9 Mon Sep 17 00:00:00 2001 From: Jakub Hrozek Date: Wed, 31 Oct 2012 17:58:22 +0100 Subject: [PATCH] LDAP: Fix off-by-one error when saving ghost users The ldb_val's length parameter should not include the term

[SSSD] [PATCH 1/1] LDAP: Better debug logging when saving groups

2012-10-31 Thread Stephen Gallagher
--- src/providers/ldap/sdap_async_groups.c | 86 +- 1 file changed, 75 insertions(+), 11 deletions(-) diff --git a/src/providers/ldap/sdap_async_groups.c b/src/providers/ldap/sdap_async_groups.c index 60cbcea7727f5d7e614f339acf979e513b114efd..cb372d2cf38a85298066

[SSSD] [PATCH 0/1] Better debug logging when saving groups

2012-10-31 Thread Stephen Gallagher
There are many places in the sdap_save_group() routine where we could exit due to failure without logging a detailed message. This patch adds more log messages in error conditions. Stephen Gallagher (1): LDAP: Better debug logging when saving groups src/providers/ldap/sdap_async_groups.c | 86

Re: [SSSD] [INI] Remove code that allows duplicate sections

2012-10-31 Thread Ondrej Kos
On 10/18/2012 05:02 AM, Dmitri Pal wrote: Hello, After previous set of patches have been committed I started working on the last remaining piece - the merge functionality. Re-reading the code I started some time ago I realized that at the time I left the question of whether the config object sh

Re: [SSSD] [PATCH] sss_cache: Remove fastcache even if sssd is not running.

2012-10-31 Thread Michal Židek
On 10/30/2012 02:25 PM, Simo Sorce wrote: On Tue, 2012-10-30 at 10:39 +0100, Michal Židek wrote: On 10/29/2012 03:53 PM, Simo Sorce wrote: Codewise looks ok, but I still see duplication of the code used to lock the file. I was wondering, would it make sense to split this patch in 2 and put th