[v8-dev] Daylight savings intervals caching. There're two caches: small one for 6 inte... (issue2099013)

2010-05-21 Thread oleg
Reviewers: Mads Ager, William Hesse, Description: Daylight savings intervals caching. There're two caches: small one for 6 intervals, and bigger one which is allocated only when needed. This is the new version of http://codereview.chromium.org/1758013/show Sorry for not making changes there. I c

[v8-dev] Re: Rewrite the functions checking for DST in C++ and also cache all the DST intervals. (issue1758013)

2010-05-17 Thread Oleg Eterevsky
Of the other benchmarks, closure-datetime spends about half of its time in DST calculations. And judging from the results of JSC, they do cache DST intensively. I'll upload a new version of my change later today. It will cache less aggressively, then it does now. On Mon, May 17, 2010 at 11:29,

Re: [v8-dev] Re: Force Windows and Mac OS platforms to notice when the system time zone has ch... (issue2012008)

2010-05-13 Thread Oleg Eterevsky
Sorry for not answering this right away. I was on vacations. I investigated some date tests and found that in some of them (http://compute1.aar:9013/golem/date-parse.html) more then 80% of time is taken by determining the DST offset. I'm working right now to eliminate system call to check DST off

[v8-dev] Rewrite the functions checking for DST in C++ and also cache all the DST intervals. (issue1758013)

2010-04-28 Thread oleg
Reviewers: Mads Ager, Description: Rewrite the functions determining DST in C++ and also cache all the DST intervals. Please review this at http://codereview.chromium.org/1758013/show Affected files: M src/date.js M src/platform-posix.cc M src/runtime.h M src/runtime.cc -- v8-dev mail

[v8-dev] Re: Simplify double to number convertion. (issue1694004)

2010-04-28 Thread oleg
I've changed the return value to newly allocated HeapNumber. http://codereview.chromium.org/1694004/show -- v8-dev mailing list v8-dev@googlegroups.com http://groups.google.com/group/v8-dev

[v8-dev] Re: Simplify double to number convertion. (issue1694004)

2010-04-26 Thread oleg
The current code used NewNumberFromDouble only in a couple of places and NumberFromDouble in 20 or so places. http://codereview.chromium.org/1694004/diff/10001/11001 File src/heap.cc (right): http://codereview.chromium.org/1694004/diff/10001/11001#newcode1832 src/heap.cc:1832: if (rep.bits == p

[v8-dev] Simplify double to number convertion. (issue1694004)

2010-04-26 Thread oleg
Reviewers: Mads Ager, Description: Simplify double to number convertion. Please review this at http://codereview.chromium.org/1694004/show SVN Base: http://v8.googlecode.com/svn/branches/bleeding_edge/ Affected files: M src/heap.h M src/heap.cc M src/runtime.cc -- v8-dev m

[v8-dev] Re: Fixing Windows build. (issue1563002)

2010-03-29 Thread oleg
LGTM http://codereview.chromium.org/1563002 -- v8-dev mailing list v8-dev@googlegroups.com http://groups.google.com/group/v8-dev To unsubscribe from this group, send email to v8-dev+unsubscribegooglegroups.com or reply to this email with the words "REMOVE ME" as the subject.

[v8-dev] Fix bug http://code.google.com/p/v8/issues/detail?id=659. Move the limits che... (issue1075016)

2010-03-23 Thread oleg
Reviewers: Mads Ager, Description: Fix bug http://code.google.com/p/v8/issues/detail?id=659. Move the limits check for date before the time zone offset is applied. Please review this at http://codereview.chromium.org/1075016 SVN Base: http://v8.googlecode.com/svn/branches/bleeding_edge/ Af

[v8-dev] Modify FastD2I to use static_cast instead of lrint(). Benchmarks show that it... (issue1128010)

2010-03-22 Thread oleg
Reviewers: Mads Ager, Description: Modify FastD2I to use static_cast instead of lrint(). Benchmarks show that it's much faster this way. Please review this at http://codereview.chromium.org/1128010 SVN Base: http://v8.googlecode.com/svn/branches/bleeding_edge/ Affected files: M src/c

[v8-dev] Re: Add parens to DateYMDFromTimeSlow to clearify. (issue1132002)

2010-03-19 Thread Oleg Eterevsky
Definitely LGTM then. On Fri, Mar 19, 2010 at 16:01, Mads Sig Ager wrote: > This one was not purely about readability.  GCC gave warnings on this > one because there were combinations of && and || with no parenthesis > to clearify precedence. > > -- Mads > > On Fri,

[v8-dev] Re: Add parens to DateYMDFromTimeSlow to clearify. (issue1132002)

2010-03-19 Thread Oleg Eterevsky
To me extra parentheses make the code less readable, but obviously you know the project style guidelines better than myself. On Fri, Mar 19, 2010 at 10:52, wrote: > LMRTM (Looks More Readable To Me) > > http://codereview.chromium.org/1132002 > -- v8-dev mailing list v8-dev@googlegroups.com htt

[v8-dev] Re: Improve Math.round(). Fix the bug in r4146. Further improve performance by ch... (issue1008004)

2010-03-18 Thread oleg
On 2010/03/18 08:21:22, Erik Corry wrote: I think Rico's objection could be solved with a rename eg to Runtime_RoundNumber() so that it is clear that the input must be a number. Done. http://codereview.chromium.org/1008004 -- v8-dev mailing list v8-dev@googlegroups.com http://groups.google.co

[v8-dev] Re: Improve Math.round(). Fix the bug in r4146. Further improve performance by ch... (issue1008004)

2010-03-18 Thread oleg
http://codereview.chromium.org/1008004/diff/5001/6002 File src/runtime.cc (right): http://codereview.chromium.org/1008004/diff/5001/6002#newcode5330 src/runtime.cc:5330: // Must be SMI. Return the argument unchanged for all the other types On 2010/03/17 23:29:19, fschneider wrote: SMI -> smi

[v8-dev] Improve Math.round(). Fix the bug in r4146. Further improve performance by ch... (issue1008004)

2010-03-17 Thread oleg
Reviewers: Mads Ager, fschneider, Vladislav Kaznacheev, Description: Improve Math.round(). Fix the bug in r4146. Further improve performance by checking the exponent instead of comparing doubles. Add several tests for numbers near the limits of SMI and several tests from WebKit. Please review t

Re: [v8-dev] Re: Add a special case in Math.round for a SMI result. Also change the implementa... (issue981002)

2010-03-16 Thread Oleg Eterevsky
On Tue, Mar 16, 2010 at 16:58, Oleg Eterevsky wrote: >>> > Drive-by comment:  Is it worth doing some of the work in math.js like we >>> > do for floor? >>> You mean, check for SMI in math.js rather then in runtime.cc? What >>> difference does it make?

Re: [v8-dev] Re: Add a special case in Math.round for a SMI result. Also change the implementa... (issue981002)

2010-03-16 Thread Oleg Eterevsky
>> > Drive-by comment:  Is it worth doing some of the work in math.js like we >> > do for floor? >> >> You mean, check for SMI in math.js rather then in runtime.cc? What >> difference does it make? We'll still have to call C++ function, so >> there'll be an overhead of CEntryStub. > > No, you can c

[v8-dev] Re: Add a special case in Math.round for a SMI result. Also change the implementa... (issue981002)

2010-03-16 Thread Oleg Eterevsky
Ok, I'll do it like that. I was not sure about reference counting and such things, so I decided to play safe. Sorry, I still do not understand V8 internals well enough. On Mon, Mar 15, 2010 at 23:11, wrote: > > http://codereview.chromium.org/981002/diff/1/2 > File src/runtime.cc (right): > > htt

[v8-dev] Re: Add a special case in Math.round for a SMI result. Also change the implementa... (issue981002)

2010-03-16 Thread Oleg Eterevsky
You mean, check for SMI in math.js rather then in runtime.cc? What difference does it make? We'll still have to call C++ function, so there'll be an overhead of CEntryStub. On Mon, Mar 15, 2010 at 23:07, wrote: > Drive-by comment:  Is it worth doing some of the work in math.js like we do > for >

[v8-dev] Add a special case in Math.round for a SMI result. Also change the implementa... (issue981002)

2010-03-15 Thread oleg
Reviewers: Mads Ager, Vladislav Kaznacheev, Description: Add a special case in Math.round for a SMI result. Also change the implementation for non-SMI case. http://compute3.aar:9013/golem/r4138-v8-olege-round-vs-4138-v8.html Expect gain on http://compute3.aar:9013/golem/pinto-random.html Pleas

[v8-dev] Re: Remove unneeded date table from JS code. This table was moved to runtime.cc. (issue968001)

2010-03-15 Thread oleg
http://codereview.chromium.org/968001 -- v8-dev mailing list v8-dev@googlegroups.com http://groups.google.com/group/v8-dev

[v8-dev] Remove unneeded date table from JS code. This table was moved to runtime.cc. (issue968001)

2010-03-15 Thread oleg
Reviewers: Mads Ager, Please review this at http://codereview.chromium.org/968001 SVN Base: http://v8.googlecode.com/svn/branches/bleeding_edge/ Affected files: M src/date-delay.js Index: src/date-delay.js === --- src/dat

[v8-dev] Re: Rewrite the function that converts timestamp to year, month and day in C++. (issue811006)

2010-03-11 Thread oleg
http://codereview.chromium.org/811006/diff/8001/9003 File src/runtime.cc (right): http://codereview.chromium.org/811006/diff/8001/9003#newcode5150 src/runtime.cc:5150: class YearMonthDate { On 2010/03/11 13:48:53, Mads Ager wrote: Instead of having a class that does all the work in it's constru

[v8-dev] Rewrite the function that converts timestamp to year, month and day in C++. (issue811006)

2010-03-10 Thread oleg
Reviewers: Mads Ager, Vladislav Kaznacheev, Message: I'm not sure about the style details: whether it's ok to create a class in runtime.cc to return the triplet (year, month, day), is it ok to insert the tables of dates directly into C++ file, or should I put it in some separate place... Descrip

[v8-dev] Re: Fix broken test in WebKit test suite and add the test in question to V8 tests... (issue661466)

2010-03-03 Thread oleg
http://codereview.chromium.org/661466/diff/5/6 File src/runtime.cc (right): http://codereview.chromium.org/661466/diff/5/6#newcode4981 src/runtime.cc:4981: static const int base_day = 365*(1970 + year_delta) + (1970 + year_delta)/4 - On 2010/03/03 14:09:37, Mads Ager wrote: Please add space aro

[v8-dev] Fix broken test in WebKit test suite and add the test in question to V8 tests... (issue661466)

2010-03-03 Thread oleg
Reviewers: Mads Ager, antonm, Description: Fix broken test in WebKit test suite and add the test in question to V8 tests. Please review this at http://codereview.chromium.org/661466 SVN Base: http://v8.googlecode.com/svn/branches/bleeding_edge/ Affected files: M src/runtime.cc M

[v8-dev] Prevent "control reaches end of non-void function" warning from gcc on Mac. (issue660379)

2010-03-02 Thread oleg
Reviewers: Vitaly, Mads Ager, Description: Prevent "control reaches end of non-void function" warning from gcc on Mac. Please review this at http://codereview.chromium.org/660379 SVN Base: http://v8.googlecode.com/svn/branches/bleeding_edge/ Affected files: M src/runtime.cc Index: src

[v8-dev] Fix minor syntax error which broke the compilation. (issue660377)

2010-03-02 Thread oleg
Reviewers: William Hesse, Description: Fix minor syntax error which broke the compilation. tbr=whe...@chromium.org Please review this at http://codereview.chromium.org/660377 SVN Base: http://v8.googlecode.com/svn/branches/bleeding_edge/ Affected files: M src/rewriter.cc Index: src/r

[v8-dev] Re: Revert change to EquivalentTime in date.js. The checks that I've removed in t... (issue660375)

2010-03-02 Thread oleg
http://codereview.chromium.org/660375/diff/7/1002 File src/runtime.cc (right): http://codereview.chromium.org/660375/diff/7/1002#newcode4947 src/runtime.cc:4947: ASSERT(args[0]->IsSmi()); On 2010/03/02 14:07:53, antonm wrote: I think we should either have ASSERTs and use Smi::cast or CONVERT_S

[v8-dev] Revert change to EquivalentTime in date.js. The checks that I've removed in t... (issue660375)

2010-03-02 Thread oleg
Reviewers: Mads Ager, antonm, Description: Revert change to EquivalentTime in date.js. The checks that I've removed in the last changed were essential after all. Please review this at http://codereview.chromium.org/660375 SVN Base: http://v8.googlecode.com/svn/branches/bleeding_edge/ Affec

[v8-dev] Re: Rewrite MakeDay function from JS to C++. (issue661366)

2010-03-02 Thread oleg
http://codereview.chromium.org/661366/diff/1/3 File src/date-delay.js (right): http://codereview.chromium.org/661366/diff/1/3#newcode368 src/date-delay.js:368: // Now we presume that year, month and date are actually SMIs. On 2010/03/02 13:04:08, Mads Ager wrote: Since the runtime function prob

[v8-dev] Re: Optimize 3 Number2Integer functions in runtime.cc: remove the check that was ... (issue660084)

2010-02-25 Thread oleg
http://codereview.chromium.org/660084/diff/1/2 File src/runtime.cc (right): http://codereview.chromium.org/660084/diff/1/2#newcode4157 src/runtime.cc:4157: // We do not include 0 so that we didn't have to treat +0 / -0 cases. On 2010/02/25 15:11:03, Mads Ager wrote: didn't -> don't Done. htt

[v8-dev] Optimize 3 Number2Integer functions in runtime.cc: remove the check that was ... (issue660084)

2010-02-25 Thread oleg
Reviewers: Mads Ager, Vladislav Kaznacheev, Vitaly, Description: Optimize three Number2Integer functions in runtime.cc: remove the check that was already done in JavaScript, add simpler code in case we are getting a SMI result. Please review this at http://codereview.chromium.org/660084 SVN

[v8-dev] Change the implementation of lastIndexOf method of String. Convert the string... (issue646010)

2010-02-19 Thread oleg
Reviewers: Mads Ager, Vitaly, Description: Change the implementation of lastIndexOf method of String. Convert the strings in question to Vector or Vector and execute simple search algorithm on them. The difference in speed on 500k character string is about 10x. Please review this at http:/