On Fri, 17 Oct 2025 12:13:23 GMT, Mikhail Yankelevich <[email protected]> wrote:
>> Also, `KeyMgr:` string can be removed, the logger will prepend the message >> with the full class name and line number. > > I agree with logging this as warning. However I think keeping `KeyMgr:` would > be better, as this format is used in the existing code in the class. What do > you think? Oh, I see. Let's remove the `KeyMgr: ` prefix throughout the whole file, it was left here from the initial version of this file when logging was done by a simple debug logger. So such prefix was useful then, but not now. Also let's make the log message more informative: `"Exception thrown while getting an alias " + alias + ": " + e` ------------- PR Review Comment: https://git.openjdk.org/jdk/pull/27851#discussion_r2440241654
