On Wed, 25 Jan 2023 11:45:47 GMT, Johan Sjölen <jsjo...@openjdk.org> wrote:

> Do the conversion in the share/memory/ sub-directory and all of its files.

Metaspace changes are good.

src/hotspot/share/memory/metaspace/blockTree.hpp line 228:

> 226:       DEBUG_ONLY(check_node(insertion_point);)
> 227:       if (n->_word_size == insertion_point->_word_size) {
> 228:         add_to_list(n, insertion_point); // parent stays null in this 
> case.

Small nit. Do we have a unified naming scheme for comments?
 
"null" reads like a java null. I prefer keeping NULL in comments.

-------------

Marked as reviewed by stuefe (Reviewer).

PR: https://git.openjdk.org/jdk/pull/12185

Reply via email to