On Tue, 8 Sep 2026 09:26:20 GMT, Stefan Karlsson <[email protected]> wrote:
> [JDK-8391728](https://bugs.openjdk.org/browse/JDK-8391728) replaced the word > inline with value for value objects and types. That change deferred the > update of names using the word "inlined", because it should likely be named > "flattened", and I wanted that part to be easier to review. > > Note: > * The second summary of the CDS test needs to verified that it says the > correct thing > * I wasn't sure about what to do with > test/hotspot/jtreg/runtime/cds/appcds/test-classes/WithInlinedField.java. Is > it meant to be named WithValueField.java, WithFlattenableField.java, or > WithFlattenedField.java. I left it untouched. > > --------- > - [x] I confirm that I make this contribution in accordance with the [OpenJDK > Interim AI Policy](https://openjdk.org/legal/ai). We also have about 200 instances of `flat_field` in the source code. E.g., https://github.com/openjdk/jdk/blob/2b5edfe1b6f5571e9878dcb08b67cdec3487b666/src/hotspot/share/oops/valuePayload.hpp#L127 And ~40 cases of `FlatField` https://github.com/openjdk/jdk/blob/2b5edfe1b6f5571e9878dcb08b67cdec3487b666/src/hotspot/share/oops/valuePayload.hpp#L215 Those should also be changed to `flattened_field` and `FlattenedField` for consistency. ------------- PR Comment: https://git.openjdk.org/jdk/pull/32756#issuecomment-5588207681
