On Tue, 8 Sep 2026 16:09:01 GMT, Ioi Lam <[email protected]> wrote: > We also have about 200 instances of `flat_field` in the source code. E.g., > > https://github.com/openjdk/jdk/blob/2b5edfe1b6f5571e9878dcb08b67cdec3487b666/src/hotspot/share/oops/valuePayload.hpp#L127 > > And ~40 cases of `FlatField` > > https://github.com/openjdk/jdk/blob/2b5edfe1b6f5571e9878dcb08b67cdec3487b666/src/hotspot/share/oops/valuePayload.hpp#L215 > > Those should also be changed to `flattened_field` and `FlattenedField` for > consistency.
Or is "flattened" the wrong word and `has_inlined_fields` should be changed to `has_flat_fields`? ------------- PR Comment: https://git.openjdk.org/jdk/pull/32756#issuecomment-5589271173
