> But tacking a factory method onto a regular Python list is much
> simpler with a separation of concerns:
>
> class FactoryCollection(list):
>    def create(self, options, **kw):
eh sorry, i want it the hard way.. 
now as i think of it, its just me being lazy and fancy - preferring 
implicitness and less method names to remember.

> For a while there was a "no-op" decorator that did the same job as
> @internally_instrumented in the first example, just a different
> name for clarity.  It could easily come back if this pattern
> becomes common- I yanked it after working with the collections for
> a while and finding the second form much more common in my work.
@do_not_instrument might a be better name -- but regardless the name, 
if the opting-out concept is not not advertised, one does not know 
what to look for..


--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"sqlalchemy" group.
To post to this group, send email to sqlalchemy@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/sqlalchemy?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to