> Why is it important to highlight word boundaries in so many other conventions 
> in Swift but not in this one? What would be lost with this alternative?
> 
> public
> module_private
> file_private
> private
> 
> Is it just the extra (chorded, on US keyboards) keystroke? I think the 
> readability benefits of clear word boundaries far outweigh the keystroke cost 
> (especially with good editor auto-complete).

The keywords, unlike identifiers, are always the same. You don't need to parse 
them every time; ‘on an infinite timescale’, you get used to them and recognize 
them at a glance. So the value of adding an underscore (or, heaven forbid, 
camel case style) to a keyword is a lot less than with identifiers.

My personal completely subjective opinion is that the underscored ones look 
gross and pull too much attention onto themselves, rather than helping to focus 
on the identifiers. To me, this actually detracts from the overall readability 
of the entire line.

In other words: nothing says “nothing to see here, move along” quite like 
abunchofgibberishthrowntogether.

A.
_______________________________________________
swift-evolution mailing list
swift-evolution@swift.org
https://lists.swift.org/mailman/listinfo/swift-evolution

Reply via email to