On Fri, 15 Feb 2002, GOMEZ Henri wrote:

> What about renaming native2 (jk2) in JTC to mod_jk2
> and jk2_module ?

+1 if you talk about the binary. -0 if you talk about directory/file
names. 

In mod_jk2 we already removed a lot of 'public' symbols that could
conflict if both modules are loaded. Instead of doing a mechanical
replace, I would do it gradually, and maybe finish the 'virtualization'
of jk2.

I think the effects are very good, it improves code readability and
extensibility. What I'm talking about is using JNI-style ( or
module style ), with structures and funcion pointer. 
( ok, that's kind-of OO programming in C, but OO is not that bad :-)

> It will allow us to install both modules at the same 
> times and test original mod_jk and new mod_jk.

That's a very good idea, it allows us to ship both
and have a 'backup' plan if something doesn't work.


> It will be need to rename all non static references,
> variables functions, but I could do that, by suffixing
> with jk2_ :

If you want, you can go ahead with that ( but in time I would
still like to continue to organize the code with fewer
globals and more objects )


> And to be consistent, it could be nice to suffix the native,
> original mod_jk, with jk_ 
 
> If you agree, I could do this quickly, but JTC developpers
> shouldn't do updates for 1-3 hours...

I agree with changing the names of non-statics in native2,
but need more time to think about changing dir names. There
are build files, cvs history, habbits that will change as well.


Costin


--
To unsubscribe, e-mail:   <mailto:[EMAIL PROTECTED]>
For additional commands, e-mail: <mailto:[EMAIL PROTECTED]>

Reply via email to