Howard,

Just in case that was an invitation for proposals :), how about:
contributeSomethingToSomeService(), where 'Something' is optional?

Allows for a little more specificity while still being an easily
parsed convention.  And for those that don't care - its only two more
characters :)

In any case, +1 for not leaving it as is.

Cheers,
lasitha

Oh, p.s - immeasurable thanks for T5!

On 10/14/07, Howard Lewis Ship <[EMAIL PROTECTED]> wrote:
> Where I dropped the ball here, in a minor way, is that it should be
> "contributeTo" as a prefix, or perhaps "configure".  It's a prefix on the
> *service* being configured or contributed to.  So I would choose option #2
> or #3.
>
> I wonder if there's some value in something like:
>
> @Contribute(FooBar.class)
> public void whatWouldYouCallThis(Configuration<FooBarDatum> configuration) {
> ... }
>
> This is heading a bit backwards from my initial goals, of naming conventions
> over annotations, and raises the question of the convention for naming such
> methods, but it would allow for more pleasing names such as
> "contributeLoggingFilter" (with the annotation) vs.
> "contributeRequestHandler" (which gives no indication what is being
> contributed).
>
>
> On 10/12/07, Dan Adams <[EMAIL PROTECTED]> wrote:
> >
> > Let's say you have a service that allows multiple contributions. One of
> > the contributions is simply a list of other objects (say an ordered
> > configuration). What is the naming convention for the configuration
> > point for that list of objects? For instance, lets say you want to have
> > a list of FooBars contributed. Which of the following is recommended:
> >
> > contributeFooBars()
> >
> > contributeFooBarManager()
> >
> > contributeMasterFooBar()
> >
> > or would you recommend something else entirely? I think I like the first
> > one simply because it more readable in the modules that are
> > contributing.
> >
> > --
> > Dan Adams
> > Senior Software Engineer
> > Interactive Factory
> > 617.235.5857
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [EMAIL PROTECTED]
> > For additional commands, e-mail: [EMAIL PROTECTED]
> >
> >
>
>
> --
> Howard M. Lewis Ship
> Partner and Senior Architect at Feature50
>
> Creator Apache Tapestry and Apache HiveMind
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to