Sending half-done review, now to look at rebase. Overall looks pretty swell but
one question below.

https://codereview.chromium.org/1189743003/diff/60001/src/preparser.h
File src/preparser.h (right):

https://codereview.chromium.org/1189743003/diff/60001/src/preparser.h#newcode3522
src/preparser.h:3522: //   BindingElement[?Yield, ?GeneratorParameter]
if is_rest is true then we are parsing BindingRestElement, which is only
an identifier.  That is, this is an error AFAIU:

  function foo(...{a,b}) {}

Probably here is the right place to signal an error if is_rest but not
Traits::IsIdentifier(pattern).  We need to do a similar thing in
Parser::ParseArrowFunctionFormalParameters I think.

https://codereview.chromium.org/1189743003/diff/60001/src/preparser.h#newcode3660
src/preparser.h:3660: NULL, Token::INIT_VAR, kArrowFunction, CHECK_OK);
Nit: const Variable *name = nullptr, pass by name?  As you like.

https://codereview.chromium.org/1189743003/

--
--
v8-dev mailing list
v8-dev@googlegroups.com
http://groups.google.com/group/v8-dev
--- You received this message because you are subscribed to the Google Groups "v8-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to v8-dev+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to