-1 on the streamline. I'm not going to go through and rewrite my
chapters of the book yet *again*.
Can we just agree to keep the API stable?
Martijn
On 6/18/07, Johan Compagner <[EMAIL PROTECTED]> wrote:
because wicket is so flexible that you can do almost everything with just
one component!
for the html below i would use button.. But that is because it is visual a
button.
The differences are i guess that button has the submit() method and link the
onClick()
and because of those silly behaviours we have suddenly a Button can also
'have' an onclick.
and Link could be a form submitting component when it implements the
interface....
So how to streamline all this? i don't know
lets just make Button and Link pretty much behave the same.
johan
On 6/18/07, Igor Vaynberg <[EMAIL PROTECTED]> wrote:
>
> since everyone is talking about this can i add some more flames? why is
> Link
> called link? cause really its not just a link.
>
> you can do:
> add(new Link("foo") {});
>
> and in markup have
>
> <a wicket:id="foo"></a>
> <input type="button" wicket:id="foo"/>
> <button wicket:id="foo"/>
>
> so its not just a link.
>
> -igor
>
>
> On 6/18/07, Johan Compagner <[EMAIL PROTECTED]> wrote:
> >
> > i agree more with Frank,
> >
> > i don't like that Button would be come SubmitButton
> >
> > For me Button doesn't say what it does. no it tells me how it looks
> > And many buttons don't submit but they are link (onclick)
> >
> > So having a SubmitButton is mostly not true for me because it doesn't so
> a
> > submit!
> > its a <button type="button" onclick="">
> >
> > johan
> >
> >
> > On 6/18/07, Frank Bille <[EMAIL PROTECTED]> wrote:
> > >
> > > Hey
> > >
> > > We could also rename AjaxSubmitButton into AjaxButton.
> > >
> > > Then we have:
> > > Button, ImageButton and AjaxButton (and AjaxFallbackButton)
> > >
> > > and
> > >
> > > SubmitLink and AjaxSubmitLink
> > >
> > > I don't know whats best, yet. It's just a surgestion now that we play
> > with
> > > names :)
> > >
> > > Frank
> > >
> > >
> > > On 6/18/07, Al Maw <[EMAIL PROTECTED]> wrote:
> > > >
> > > > Hello,
> > > >
> > > > I know we're in a feature freeze, and I'm aware this one is likely
> to
> > be
> > > > somewhat controversial, but I think we should rename a couple of the
> > > > submit components, leaving behind @deprecated classes which extend
> the
> > > > renamed ones.
> > > >
> > > > We currently have:
> > > >
> > > > Button, ImageButton, SubmitLink, AjaxSubmitButton, AjaxSubmitLink.
> > > >
> > > > We're about to have an AjaxFallbackSubmitButton, too. [1]
> > > >
> > > > It would make sense for me for everything to be based on the word
> > > > "Submit", so I think we should rename:
> > > >
> > > > Button -> SubmitButton (highly controversial, obviously)
> > > > ImageButton -> SubmitImage
> > > >
> > > > This may well need to wait 'til 1.4.x.
> > > >
> > > > WDYT?
> > > >
> > > >
> > > > Al
> > > >
> > > > --
> > > > Alastair Maw
> > > > Wicket-biased blog at http://herebebeasties.com
> > > >
> > > > [1] WICKET-634
> > > > [Ajax[Fallback]]Submit[Image|Button|Link]
> > > > If we support all combinations (which we probably should)
> that's
> > > > nine(!) components. I wish Java supported mix-ins. :-(
> > > >
> > >
> >
>
--
Join the wicket community at irc.freenode.net: ##wicket
Wicket 1.2.6 contains a very important fix. Download Wicket now!
http://wicketframework.org