[ 
https://issues.apache.org/jira/browse/YARN-6202?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15951887#comment-15951887
 ] 

Yufei Gu commented on YARN-6202:
--------------------------------

You are right. No matter what default value is, this shouldn't be a 
configuration item at all. I saw people actually configure it, and thought the 
items could work! The reality is the daemons should always be true, and some 
tests need it to be false no matter what configuration is.
I think make the default to be true should be better since it should be true 
for daemons. The only downside is we need to explicitly set it to false in some 
test cases, which is mitigated by following cases:
# All unit tests using dispatcher in MockRM is fine since we set it to false in 
MockRM.
# All unit tests using DrainDispatcher is fine since we set it false in 
DrainDispatcher as well.


> Configuration item Dispatcher.DISPATCHER_EXIT_ON_ERROR_KEY is disregarded
> -------------------------------------------------------------------------
>
>                 Key: YARN-6202
>                 URL: https://issues.apache.org/jira/browse/YARN-6202
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: nodemanager, resourcemanager
>    Affects Versions: 2.9.0, 3.0.0-alpha2
>            Reporter: Yufei Gu
>            Assignee: Yufei Gu
>         Attachments: YARN-6202.001.patch, YARN-6202.002.patch
>
>
> Dispatcher.DISPATCHER_EXIT_ON_ERROR_KEY (yarn.dispatcher.exit-on-error) 
> always be true no matter what value in configuration files. This misleads 
> users. Two solutions: 
> # Remove the configuration item and provide a method to allow 
> {{exitOnDispatchException}}/{{shouldExitOnError}} to be false to enable 
> related unit tests. There is no need for false value in a real daemon since 
> daemons should crash if its dispatcher quit.
> # Make it default true instead of false, so that we don't need to hard code 
> it to be true in RM and NM, it is still configurable, and also provide method 
> to enable related unit tests.
> Other than that, the code around it needs to refactor. {{public static 
> final}} for a variable of interface isn't necessary, and YARN related 
> configure item should be in class YarnConfiguration. 



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to