[ 
https://issues.apache.org/jira/browse/YARN-6672?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16525275#comment-16525275
 ] 

Íñigo Goiri commented on YARN-6672:
-----------------------------------

Thanks [~haibochen] for tackling the comments.
For the logger, yes, that's what I meant.
Regarding  [^YARN-6672-YARN-1011.04.patch], a couple more comments:
* ContainerScheduler#233, no need to use toString(); logger should already do 
that for you and do it only if needed.
* In the javadoc for SnapshotBasedOverAllocationPreemptionPolicy, we can use 
link too for NMAllocationPreemptionPolicy. In addition, I think the text should 
be "determine how many resources need to be reclaimed".
* Not sure DrainableContainerManager is the best name as it also checks 
utilization.
* In TestContainerSchedulerQueuing#363, I would extract the container id into 
containerId0.
* In all the tests, we have fixed values (0.75 and 0.8 thresholds, 1024 and 512 
memory sizes,..), it would be good to have general comments explaining the 
setup. For example, a comment in 
testPreemptOpportunisticContainersUponHighMemoryUtilization would be to explain 
why 1024, 512, 1024 and 300. If random say random with certain properties.
* We seem to set the memory utilization to 2048 when we only have 512 in some 
cases.
* This was done before but for readability, I would tweak 
createStartContainerRequest() to take OPPORTUNISTIC/GUARANTEED as a param. The 
boolean works but it's hard to read.
* In TestSnapshotBasedOverAllocationPreemptionPolicy, we should have comments 
explaining the numbers. For example, testMemoryOverPreemptionThreshold should 
say that we have an allocation of 2048, then when the utilization is 200, we 
need to remove 464 (I actually don't follow how 464 shows up here).
* Use Time.now() instead of System.currentTimeMillis()?

> Add NM preemption of opportunistic containers when utilization goes high
> ------------------------------------------------------------------------
>
>                 Key: YARN-6672
>                 URL: https://issues.apache.org/jira/browse/YARN-6672
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>    Affects Versions: 3.0.0-alpha3
>            Reporter: Haibo Chen
>            Assignee: Haibo Chen
>            Priority: Major
>         Attachments: YARN-6672-YARN-1011.00.patch, 
> YARN-6672-YARN-1011.01.patch, YARN-6672-YARN-1011.02.patch, 
> YARN-6672-YARN-1011.03.patch, YARN-6672-YARN-1011.04.patch
>
>




--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to